#openstack-meeting-4: kuryr
Meeting started by apuimedo at 15:01:50 UTC
(full logs).
Meeting summary
-
- gsagie, tfukushima, diga, banix, daneyon and
apuimedo present (apuimedo,
15:03:23)
- topic: vif-binding-unbinding (apuimedo,
15:04:27)
- https://blueprints.launchpad.net/kuryr/+spec/vif-binding-and-unbinding-mechanism
(diga,
15:05:08)
- vif-binding-unbinding (apuimedo, 15:05:29)
- https://blueprints.launchpad.net/kuryr/+spec/vif-binding-and-unbinding-mechanism
(apuimedo,
15:06:05)
- https://etherpad.openstack.org/p/Kuryr_vif_binding_unbinding
(tfukushima,
15:06:12)
- https://github.com/midonet/midonet/blob/master/tools/docker/mm-docker.sh#L28-L39
(tfukushima,
15:08:59)
- https://github.com/openstack/kuryr/blob/master/doc/source/design.rst#user-workflow
(tfukushima,
15:10:44)
- : NetworkDriver.Join gives Kuryr the Network
Namespace location to put the veth (apuimedo,
15:11:49)
- ACTION: diga to
update on the executable calling via gerrit ;-) (apuimedo,
15:12:51)
- libnetwork <-> docker network mapping (apuimedo, 15:15:03)
- https://github.com/docker/libnetwork/issues/139
(apuimedo,
15:16:52)
- https://github.com/docker/libnetwork/issues/414
(tfukushima,
15:17:19)
- https://github.com/docker/libnetwork/issues/414
(apuimedo,
15:19:19)
- ACTION: tfukushima to
find out about the label persistence or libnetwork abuse
(apuimedo,
15:26:32)
- ACTION: gsagie to
look at putting hte network resource info in neutron as a last
resort option (apuimedo,
15:28:59)
- feature mapping (apuimedo, 15:29:19)
- https://review.openstack.org/#/c/213490/
(gsagie,
15:30:16)
- ACTION: all to review
the spec (apuimedo,
15:32:03)
- we'll be adding cluster/orchestration engines
sections in the kuryr spec (apuimedo,
15:36:04)
- it is important to discuss about the
expectations/assumptions those engines have and how they are
affected by Kuryr (apuimedo,
15:36:51)
- configuration management (apuimedo, 15:38:40)
- https://wiki.openstack.org/wiki/Meetings/Containers#Container_Networking_Subteam_Meeting
(daneyon,
15:38:54)
- ACTION: banix to
update on configuration management for the next meeting (apuimedo,
15:42:59)
- sprint proposal (apuimedo, 15:43:16)
- irenab proposed a virtual/semi-virtual
sprint (apuimedo,
15:43:52)
- ACTION: irenab gsagie
to propose dates and format (apuimedo,
15:44:15)
- VM container networking (apuimedo, 15:44:52)
- kuryr drivers will have a brainstorming session
about VM container networking for Milestone 2 on Wednesday
(apuimedo,
15:45:45)
- ACTION: apuimedo to
bring diagrams of two proposals to spark discussion (apuimedo,
15:46:17)
- https://plus.google.com/hangouts/_/midokura.com/kuryr
(apuimedo,
15:47:58)
- the goal of the meeting is to come out of it
with an agreement of a plan A and B for the VM container use
case (apuimedo,
15:49:07)
- August 19th 15UTC (apuimedo,
15:50:05)
- Open floor (apuimedo, 15:50:36)
- https://review.openstack.org/#/q/status:open+project:openstack/kuryr,n,z
(tfukushima,
15:52:04)
- ACTION: apuimedo to
finally review and W+1 the patches that have reviews (apuimedo,
15:53:15)
Meeting ended at 15:54:50 UTC
(full logs).
Action items
- diga to update on the executable calling via gerrit ;-)
- tfukushima to find out about the label persistence or libnetwork abuse
- gsagie to look at putting hte network resource info in neutron as a last resort option
- all to review the spec
- banix to update on configuration management for the next meeting
- irenab gsagie to propose dates and format
- apuimedo to bring diagrams of two proposals to spark discussion
- apuimedo to finally review and W+1 the patches that have reviews
Action items, by person
- apuimedo
- apuimedo to bring diagrams of two proposals to spark discussion
- apuimedo to finally review and W+1 the patches that have reviews
- banix
- banix to update on configuration management for the next meeting
- diga
- diga to update on the executable calling via gerrit ;-)
- gsagie
- gsagie to look at putting hte network resource info in neutron as a last resort option
- irenab gsagie to propose dates and format
- tfukushima
- tfukushima to find out about the label persistence or libnetwork abuse
People present (lines said)
- apuimedo (106)
- gsagie (50)
- tfukushima (21)
- daneyon (19)
- banix (18)
- diga (14)
- openstack (3)
- dane_leblanc_ (2)
Generated by MeetBot 0.1.4.