15:13:27 <apuimedo_> #startmeeting kuryr
15:13:27 <openstack> Meeting started Mon Sep 7 15:13:27 2015 UTC and is due to finish in 60 minutes. The chair is apuimedo_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:13:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:13:30 <openstack> The meeting name has been set to 'kuryr'
15:13:41 <apuimedo_> Hi everybody, sorry for the delay
15:14:00 <apuimedo_> Is there still somebody for the meeting?
15:14:10 <diga> apuimedo_: hi
15:14:12 <tfukushima> o/
15:14:12 <apuimedo_> I know gsagie and irenab could not make it today
15:14:56 <apuimedo_> it seems banix couldn't make it either
15:14:59 <diga> ohh..k
15:15:15 <apuimedo_> I know some are traveling
15:15:26 <apuimedo_> let's get started
15:15:37 <apuimedo_> #topic vif-binding
15:15:47 <VikasC> 0/
15:16:00 <apuimedo_> Hi VikasC!, welcome
15:16:13 <apuimedo_> #info diga tfukushima diga apuimedo present
15:16:19 <VikasC> Thanks apuimedo_
15:16:31 <apuimedo_> diga: I reviewed your code and pointed out some issues with it
15:16:46 <apuimedo_> did you get too see the latest comments?
15:16:50 <diga> apuimedo_: as per the comment & suggestion I got from you, here is the patch I have updated today
15:16:51 <diga> https://review.openstack.org/#/c/214002/
15:17:11 <apuimedo_> diga: I reviewed it again ;-)
15:17:15 <apuimedo_> I'm fast today
15:17:16 <apuimedo_> :P
15:17:56 <diga> apuimedo_: sorry I never looked at your comments, looking at it now
15:18:01 <apuimedo_> diga: check it out later ;-)
15:18:06 <diga> sure
15:18:07 <apuimedo_> let's talk about the sprint
15:18:20 <apuimedo_> #action diga to check the reviews on https://review.openstack.org/#/c/214002/
15:18:39 <apuimedo_> #topic ipam
15:18:49 <apuimedo_> tfukushima: any updates on IPAM?
15:18:54 <diga> I will address all of your comments in next patch, but ovs.sh code is fine ?
15:19:17 <apuimedo_> diga: it seems fine, but I have to check it more carefully. I'll do so tonight
15:19:23 <tfukushima> I has uploaded my new patch although it lacks some test patterns.
15:19:33 <apuimedo_> tfukushima: like?
15:19:34 <diga> thanks apuimedo_
15:19:38 <tfukushima> #link Implement /NetworkDriver.CreateEndpoint https://review.openstack.org/#/c/210052/
15:20:08 <tfukushima> Like the case listing the existing networks returns the multiple network and so on.
15:20:35 <tfukushima> I just covered the major scenario.
15:20:47 <tfukushima> If I add more tests, the patch is going to be very big.
15:20:59 <tfukushima> It's already 571 lines of code.
15:20:59 <apuimedo_> #action tfukushima to increase test coverage in follow-up patches
15:21:33 <apuimedo_> tfukushima: that's quite enough
15:21:51 <apuimedo_> 571, I'll get a headache reviewing it :P
15:22:01 <tfukushima> And I haven't touched the config part. I just used the env vars default to what are in the blueprint.
15:22:07 <apuimedo_> #action apuimedo to review the lastest versions tonight
15:22:31 <tfukushima> Actually it's sort of verbose and I need to make it short somehow.
15:22:39 <apuimedo_> #info: diga is introducing some part of oslo config in his patch
15:22:43 <apuimedo_> tfukushima: ^^
15:23:06 <apuimedo_> #topic virtual sprint
15:23:23 <apuimedo_> #link https://etherpad.openstack.org/p/kuryr-virtual-sprint
15:23:25 <tfukushima> Ah, Ok. I'll take a look at it but I wouldn't change my code to avoid the conflict of our works.
15:23:36 <apuimedo_> please, look at the task breakdown
15:23:55 <diga> tfukushima: if you need help on oslo.config, let me know
15:24:16 <apuimedo_> I believe the easiest thing is that you two talk it out to who creates a patch that only introduces the basic conf file and module for it
15:24:30 <tfukushima> diga: Ok, thanks.
15:25:36 <apuimedo_> note that I added my name next to something I want to work on
15:26:10 <apuimedo_> I see diga did too
15:26:19 <apuimedo_> tfukushima: try to do the same
15:26:50 <apuimedo_> diga: tfukushima you are the first shift of the sprint
15:26:59 <apuimedo_> at what time utc will you be starting?
15:27:11 <apuimedo_> you should try to start at a similar time
15:27:23 <apuimedo_> and try to talk with each other the issues
15:27:37 <apuimedo_> then we could sync up at 06:00 utc
15:27:43 <diga> apuimedo_: I am 2 hrs ahead of Gal
15:27:51 <apuimedo_> or maybe 07:00 utc
15:29:16 <apuimedo_> diga: it's 21:00 where you are at, is it?
15:29:20 <VikasC> seems so stupid asking..what is virtual sprint?
15:29:53 <apuimedo_> VikasC: it's three days where we put goals and we sync up and talk over the conference line to solve those goals
15:29:53 <VikasC> will apreciate any document link
15:30:02 <VikasC> ohh
15:30:10 <diga> 1500UTC = 8:30 PM my time
15:30:13 <apuimedo_> a poor mans' sprint when you can't afford to travel
15:30:53 <VikasC> when is next sprint starting?
15:31:05 <apuimedo_> September 8th
15:31:13 <apuimedo_> VikasC: you are welcome to join
15:31:24 <VikasC> how to join?
15:31:34 <apuimedo_> https://etherpad.openstack.org/p/kuryr-virtual-sprint
15:31:43 <apuimedo_> there's the conference call number there
15:31:55 <apuimedo_> #info: participants in the sprint should be on the line
15:32:16 <VikasC> thanks
15:32:24 <apuimedo_> VikasC: see the tasks and goals that we defined for the virtual sprint
15:32:37 <diga> apuimedo_: these will be free dialup number ??
15:32:38 <VikasC> i will go through after meeting
15:32:53 <apuimedo_> I hope so :P
15:33:13 <apuimedo_> diga: send an email if it's not toll free from where you are at
15:33:22 <diga> sure
15:33:24 <apuimedo_> and we can try to change to something else
15:33:27 <diga> I will
15:33:58 <diga> can someone from us arrange webex conference ?
15:34:05 <apuimedo_> #info: if more than one person take a task from the etherpad, and it is something I recommend, try to make sure that you will be on the line in similar hours to discuss
15:34:42 <apuimedo_> you can ask banix, but it seems he finally opted for phone
15:34:52 <diga> okay
15:35:28 <apuimedo_> #info 1st and 2nd shifts to sync up at 07:00utc
15:36:03 <apuimedo_> #info 2nd and 3rd shifts to sync up at 17:00 utc
15:36:22 <apuimedo_> any more questions about the sprint?
15:36:22 <diga> ok
15:37:21 <apuimedo_> #topic open floor
15:37:39 <apuimedo_> Does anybody have any other thing to bring up?
15:38:22 <VikasC> i want to get involved
15:38:31 <diga> apuimedo_: I am working midonet, can we consider tap0 will be default device for create_tap ?
15:38:41 <VikasC> please give some tips
15:38:44 <apuimedo_> VikasC: glad to reat that
15:38:52 <apuimedo_> VikasC: what tz are you on?
15:39:06 <apuimedo_> diga: we shouldn't need any tap device
15:39:07 <VikasC> digambar
15:39:13 <diga> ok
15:39:29 <apuimedo_> you should only need to call mm-ctl on the tap device
15:39:34 <apuimedo_> fsck
15:39:36 <diga> apuimedo_: I will help VikasC, he is from my tz
15:39:38 <apuimedo_> veth peer
15:39:48 <apuimedo_> diga: VikasC: very well
15:40:00 <VikasC> Thanks diga
15:40:12 <apuimedo_> VikasC: and ping me after the 1st and 2nd team shifts syncup
15:40:25 <VikasC> sure
15:40:29 <apuimedo_> Thank you all for joining!
15:40:38 <apuimedo_> have a nice rest of day
15:40:42 <apuimedo_> #endmeeting