03:00:19 <tfukushima> #startmeeting kuryr
03:00:20 <openstack> Meeting started Tue Feb 23 03:00:19 2016 UTC and is due to finish in 60 minutes.  The chair is tfukushima. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:23 <openstack> The meeting name has been set to 'kuryr'
03:00:57 <tfukushima> Who's up for the Kuryr regular meeting except for me?
03:01:06 <baohua> hi
03:01:08 <fawadkhaliq> hi tfukushima
03:01:10 <baohua> im here
03:01:31 <tfukushima> Hi baohua and fawadkhaliq.
03:01:42 <baohua> morning tfukushima
03:02:03 <tfukushima> Good morning (and possibly evening) guys.
03:02:11 <baohua> not see today's agenda, anyone can share?
03:02:34 <tfukushima> #info baohua,fawadkhaliq and tfukushima present
03:02:59 <tfukushima> #link Today's agenda https://wiki.openstack.org/wiki/Meetings/Kuryr#Meeting_February_23.2C_2016
03:03:05 <baohua> thanks!~
03:03:46 <tfukushima> Ok, let's start with a topic, which is ...
03:03:49 <tfukushima> #topic Deployment
03:04:43 <tfukushima> Ok, apuimedo submitted a patch for systemd patch.
03:05:23 <tfukushima> #link systemd patch https://review.openstack.org/#/c/280939/
03:05:44 <tfukushima> #link dockerization patch: https://review.openstack.org/#/c/279320/
03:05:56 <tfukushima> And dockerfile patch.
03:06:36 <tfukushima> Nice. Please review them when you have some time.
03:06:52 <fawadkhaliq> sure will do
03:07:16 <tfukushima> #topic Existing Networks
03:07:45 <tfukushima> It seems banix posted a WIP patch for that.
03:07:58 <tfukushima> #link banix's existing network patch https://review.openstack.org/#/c/280948/
03:08:42 <tfukushima> I haven't updated my devref and need to talk to him to coordinate the patch and the doc.
03:09:00 <tfukushima> #action tfukushima talks to banix to coordinate the patch and the doc.
03:09:56 <tfukushima> And someone is trying to add "description" field for all Neutron resources.
03:10:10 <tfukushima> #link description field patch for Neutron https://review.openstack.org/#/c/269887/
03:10:46 <tfukushima> This could help to hold the Docker ID of the libnetwork resources beside the readable name.
03:11:02 <tfukushima> #topic Nested Containers and Magnum Integration
03:11:33 <tfukushima> #link nested container spec https://review.openstack.org/#/c/269039/
03:11:56 <tfukushima> fawadkhaliq: What has been updated since the last time?
03:12:37 <fawadkhaliq> tfukushima: we discussed that the use-case of supporting native tools instead of magnum would be considered later
03:12:47 <fawadkhaliq> however, we decided otherwise in the last IRC meeting
03:12:58 <fawadkhaliq> and going ahead with supporting native tools as well
03:13:05 <fawadkhaliq> so to cater for that use-case
03:13:10 <fawadkhaliq> I have updated the spec
03:13:17 <fawadkhaliq> it's out for review
03:13:27 <fawadkhaliq> please review so we can converge on this soon
03:13:38 <tfukushima> fawadkhaliq: I see. Thanks.
03:13:38 <baohua> done today :)
03:13:48 <fawadkhaliq> baohua: thanks
03:13:57 <tfukushima> #action tfukushima reviews the nested container spec
03:14:31 <tfukushima> #topic Kubernetes Integration
03:15:05 <tfukushima> irenab submitted a patch for k8s integration spec.
03:15:16 <tfukushima> #link k8s integration spec proposal https://review.openstack.org/#/c/281132/
03:16:09 <tfukushima> fawadkhaliq: "Using K8 Python client from Magnum" Is this what you were talking about?
03:16:53 <fawadkhaliq> yes, that's like one of the native tools I suppose.
03:18:00 <tfukushima> Ok, if it's networking-backend agnostic, it'd be fine but I'm a bit concerned they're still strongly assuming flannel.
03:18:19 <tfukushima> Anyways we'll see.
03:18:25 <fawadkhaliq> flannel, kuryr will be different options
03:18:37 <fawadkhaliq> and kuryr will potentially be the default once its there
03:19:32 <tfukushima> So regarding "Syncing the binding part and the watcher part", we, for instance I and gsagie had the discussion about it.
03:20:19 <tfukushima> How to arrange the timing of these two parts. We're still figuring it out though.
03:21:37 <tfukushima> The idea is that there'd be a watcher along side of the k8s apiserver and watches the events related to pods and services.
03:22:13 <tfukushima> And create Neutron resources mapping k8s resources to Neutron's ones.
03:22:32 <fawadkhaliq> I see
03:22:51 <tfukushima> Then the agent-ish component on each worker binds the veth endpoint to the virtual port, Neutron port.
03:23:05 <fawadkhaliq> btw, is there a document which captures all this information?
03:24:19 <tfukushima> I thought ireanb's spec contained it but it didn't really.
03:25:04 <fawadkhaliq> maybe it will be added later
03:25:08 <fawadkhaliq> since its a wip
03:26:09 <tfukushima> Some discussions have the mention about it.
03:26:11 <tfukushima> http://eavesdrop.openstack.org/irclogs/%23openstack-kuryr/%23openstack-kuryr.2016-02-03.log.html
03:26:16 <tfukushima> http://eavesdrop.openstack.org/meetings/kuryr/2016/kuryr.2016-01-26-15.03.log.html
03:26:35 <tfukushima> But not in the legitimate doc.
03:27:09 <tfukushima> #action apuimedo, gsagie and irenab describe about the details of the watcher and port binder in the sepc.
03:27:27 <tfukushima> #topic Fullstack / Rally tests
03:27:54 <tfukushima> baohua: Do you have anything to say on this topic?
03:28:07 <baohua> yes,
03:28:20 <baohua> done a framework and the patch got merged recently.
03:28:35 <baohua> i will add more scenarios, and welcome for review and code patches :)
03:28:47 <tfukushima> Nice.
03:28:51 <baohua> https://review.openstack.org/274014
03:28:54 <baohua> merged patch here
03:29:08 <baohua> sure tfukushima
03:29:30 <baohua> i will work will gal on more fullstack testing and rally testing
03:29:44 <baohua> 2nd will --> with
03:30:04 <tfukushima> Now I can see "gate-kuryr-dsvm-fullstack-nv" and "gate-kuryr-dsvm-rally-nv" on patch pages.
03:30:19 <tfukushima> That's very nice to see.
03:30:27 <baohua> :)
03:30:28 <fawadkhaliq> baohua: nice, will review
03:30:47 <baohua> thanks tfukushima fawadkhaliq
03:31:16 <tfukushima> #topic Open Discussions
03:32:03 <tfukushima> Does anyone have any topic to be shared ant want to talk about it?
03:32:17 <fawadkhaliq> tfukushima: nothing from my side today
03:32:41 <baohua> nothing for me
03:32:53 <tfukushima> Good.
03:33:05 <tfukushima> Oh, I forgot to add an action.
03:33:36 <tfukushima> #action baohua and gsagie add few more fullstack and rally tests
03:33:49 <baohua> ok
03:33:58 <tfukushima> Ok, guys. Let's finish the meeting earlier today.
03:34:08 <baohua> sure, thanks everyone ~
03:34:18 <fawadkhaliq> thanks, bye
03:34:23 <tfukushima> Thank you for your participations, folks.
03:34:32 <tfukushima> #endmeeting