03:01:30 <tfukushima> #startmeeting Kuryr
03:01:31 <openstack> Meeting started Tue Mar  8 03:01:30 2016 UTC and is due to finish in 60 minutes.  The chair is tfukushima. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:01:34 <openstack> The meeting name has been set to 'kuryr'
03:02:08 <tfukushima> Who's up for Kuryr IRC meeting today?
03:02:16 <baohua> morning&evening, everyone~
03:02:22 <baohua> hi tfukushima
03:02:22 <banix> o/
03:02:24 <fawadkhaliq> evening
03:02:31 <fawadkhaliq> o/
03:03:02 <tfukushima> #info baohua, banix, fawadkhaliq and tfukushima are present
03:03:36 <tfukushima> #link Today's agenda https://wiki.openstack.org/wiki/Meetings/Kuryr#Meeting_March_8.2C_2016
03:04:01 <tfukushima> Ok, let's get started.
03:04:29 <tfukushima> #topic Kubernetes Integration
03:04:49 <tfukushima> #link Spec proposal by irenab https://review.openstack.org/#/c/281132/
03:06:07 <tfukushima> #action Everyone reviews irenab's spec proposal
03:06:34 <fawadkhaliq> tfukushima: thanks, will do. I did a quick review early on, Will do again on the latest patch
03:06:53 <baohua> +1, will do it
03:07:18 <tfukushima> Yeah, it seems to be updated recently and it'd be again, I guess.
03:07:31 <banix> sure will do too
03:08:30 <tfukushima> It has the descriptions about the API watcher and the CNI driver.
03:08:50 <banix> tfukushima: taku i hear you have a prototupe working
03:09:02 <banix> is it along the lines being described in the spec?
03:09:33 <tfukushima> I think I have to write the devref rather than the higher level spec.
03:10:16 <tfukushima> I'm playing with the apiserver of K8s.
03:10:46 <banix> cool
03:11:27 <tfukushima> The API allows you to get a line of JSON data when you call GET against the certain endpoint with the query string, i.e., /api/v1/pods?watch=true
03:12:02 <tfukushima> You can see what's happening with curl.
03:12:16 <baohua> tfukushima is your prototype a multi-node env?
03:12:44 <tfukushima> At this point one master and two worker nodes. Small cluster.
03:13:04 <banix> sounds multi-node to me :)
03:13:04 <baohua> thanks
03:13:31 <tfukushima> And I'm doing the api watcher-ish stuff, so only the master is my concern so far.
03:14:08 <tfukushima> I'll push back to Kuryr updatream when it gets some shape.
03:14:40 <tfukushima> Oh, I have a question about that.
03:14:51 <banix> great thanks. Mike Spreitzer who dont seem to be around now is also working on a prototype
03:15:45 <tfukushima> Nice. We might need to coordinate our tasks not to be conflicted.
03:16:26 <banix> i think he is doing the OTHER approach discussed for a quick short term solution but should leave it to him to describe what he has
03:16:41 <banix> any of you going to KubeCon?
03:16:45 <banix> in Europe?
03:16:51 <banix> London I believe
03:17:47 <baohua> banix possible not for me, will u go?
03:17:53 <tfukushima> I hope I could. We'd love to see that proposal but yes, it's up to him.
03:18:45 <banix> I am not going. Mike is going. Should let us know how things are in our next meeting hopefully
03:19:24 <baohua> yes, that will be a nice sharing
03:20:02 <tfukushima> Anyways, here's my question: To get a line of JSON data, I'd like to use asyncio, the async I/O library introduced in Python 3.4 not to be blocked for the next event propagation. Does it make sense to drop Python 2.6 support for that?
03:21:16 <banix> 2.7 you mean?
03:21:28 <baohua> to support curl-based api querying?
03:21:30 <tfukushima> Yes. Python 2.x.
03:22:09 <tfukushima> To support better async I/O mechanisms and more features introduced only in Python 3.x.
03:22:30 <tfukushima> curl is blocking actually, I believe.
03:23:29 <banix> i understand what you are saying. is the rest of kuryr ok with 3.4?
03:23:54 <tfukushima> There's Trollius for the equivalent but it's saying it's deprecated and recommending to move Python 3.x.
03:24:00 <tfukushima> http://trollius.readthedocs.org/deprecated.html
03:24:02 <banix> i know we test at gate but beyond that
03:24:45 <baohua> a little worried not full tested yet.
03:25:25 <tfukushima> Maybe we can separate the API watcher from the rest but it'd be a bit bothering.
03:26:45 <tfukushima> Anyways, I'll submit the patch or something and propose this in another way as well but I wanted to know how you would feel about that.
03:27:29 <tfukushima> #link Python3 support in OpenStack https://wiki.openstack.org/wiki/Python3
03:28:15 <tfukushima> Sorry, I took time. Let's move on to the next topic.
03:28:31 <tfukushima> #topic Nested Containers and Magnum Integration
03:28:52 <tfukushima> fawadkhaliq: Any update?
03:29:44 <fawadkhaliq> tfukushima: yes, the spec is in good shape
03:29:52 <fawadkhaliq> have several +1s and a +2
03:30:01 <fawadkhaliq> I am hoping we merge it soon
03:30:23 <fawadkhaliq> And in parallel, we are planning to kick off the discussion on Kuryr Agent
03:30:28 <fawadkhaliq> there is a separate spec for that
03:30:38 <fawadkhaliq> that's the current update and plan moving forward.
03:30:45 <tfukushima> Nice. I seriously should look at the spec! It's my shame.
03:31:05 <fawadkhaliq> tfukushima: thanks
03:31:48 <tfukushima> fawadkhaliq: BTW, have you tried Magnum?
03:32:09 <fawadkhaliq> tfukushima: yes, I have in general usage sense
03:32:20 <fawadkhaliq> are you referring to some specific?
03:32:28 <fawadkhaliq> s/some/something/
03:32:50 <tfukushima> fawadkhaliq: My friend tried it but he told me he got stuck in the middle of creating a bay.
03:33:18 <fawadkhaliq> tfukushima: okay, maybe he can drop an email
03:33:54 <tfukushima> Yeah, he'd but I was just wondering how stable Magnum is now.
03:34:29 <fawadkhaliq> tfukushima: its reasonable, the base infra has to be perfect to make it work
03:34:55 <fawadkhaliq> tfukushima: sine Heat is invovled and sometimes Heat stacks are just stuck forever
03:35:12 <fawadkhaliq> and thats normally tied to the base infra
03:35:46 <tfukushima> fawadkhaliq: I see. That makes sense. Thanks.
03:35:55 <fawadkhaliq> tfukushima: npp
03:36:05 <fawadkhaliq> so thats all on the nested container topic for today
03:36:14 <tfukushima> #action Everyone review fawadkhaliq's spec again.
03:36:28 <tfukushima> Good.
03:36:30 <fawadkhaliq> thanks, hoping to get it merged soon.
03:37:09 <tfukushima> #topic Existing Networks
03:37:36 <tfukushima> banix: You might want to share something about that.
03:37:46 <banix> yes sure
03:37:59 <banix> so the Neutron tags got merged for neutron networks
03:38:24 <tfukushima> Yay!
03:38:30 <banix> in that light, we can get rid of the use of neutron network names
03:38:30 <tfukushima> Finally.
03:38:34 <banix> yes
03:38:52 <banix> so i have a patchset to do that. Will update it based on the comments
03:38:58 <tfukushima> I heard you tried it and it worked?
03:39:08 <banix> this will just change the kuryr to use tags
03:39:19 <banix> yes it works
03:39:39 <banix> Then I am going to update your existing network spec Taku
03:39:54 <banix> I had made changes based on our stop-gap planning
03:40:01 <tfukushima> banix: Yes, please. I left it forever. :-(
03:40:07 <banix> but now, I can uodate it to use tags
03:40:24 <tfukushima> That's sweet.
03:40:34 <banix> tfukushima: no worries. Gal and Toni mentioned you are busy
03:41:06 <banix> So that will get rid of the using name ugliness and add the support for existing networks in a clean way
03:41:41 <banix> That’s all for me unless there are questions
03:42:19 <tfukushima> Cool.
03:43:01 <tfukushima> Ok, we shall go to the next topic.
03:43:14 <tfukushima> #topic Packaging
03:43:50 <tfukushima> Actually I have no idea about the situation of the packaging.
03:44:24 <banix> We shall leave this for next week then :) We need Toni to get the status
03:44:57 <tfukushima> Yeah, he should know better and I saw hi submitted a few patches.
03:45:16 <tfukushima> #topic Fullstack and Rally integration
03:45:48 <tfukushima> baohua: Would you like to share something?
03:45:53 <baohua> yes
03:46:01 <baohua> two patches under review, welcome anyone's comments, thanks!
03:46:03 <baohua> https://review.openstack.org/#/c/265105/
03:46:08 <baohua> https://review.openstack.org/#/c/286531/
03:46:17 <baohua> that's it :)
03:47:13 <baohua> tfukushima, pls go ahead :)
03:47:23 <tfukushima> baohua: Thanks. I have to review them.
03:47:30 <tfukushima> #action Everyone reviews haohua's Rally tests.
03:48:16 <tfukushima> baohua: The patch looks well documented and I like it.
03:48:25 <baohua> thanks :)
03:49:02 <tfukushima> Ok, let's wrap up the meeting.
03:49:09 <tfukushima> #topic Open Discussion
03:49:29 <tfukushima> Does anyone have anything else to discuss?
03:50:04 <tfukushima> banix; Oh, I submitted a patch. https://review.openstack.org/#/c/289147/
03:50:32 <tfukushima> I'm sadly a OSX user and I wanted to run unit tests. :-p
03:50:44 <banix> cool
03:51:20 <banix> will have a look
03:51:53 <tfukushima> Good. I think we can finish today's meeting.
03:51:58 <fawadkhaliq> nothing else from my side
03:52:07 <fawadkhaliq> yay! we save 9 min :-)
03:52:09 <fawadkhaliq> :P
03:52:14 <banix> thanks taku
03:52:18 <baohua> great! thanks everyone~
03:52:21 <banix> and everybody :)
03:52:37 <tfukushima> Thanks for attending, guys.
03:52:42 <baohua> :)
03:52:44 <fawadkhaliq> thankjs
03:52:46 <fawadkhaliq> bye
03:52:50 <baohua> bye
03:52:56 <tfukushima> #endmeeting