03:01:22 <tfukushima> #startmeeting kuryr
03:01:22 <openstack> Meeting started Tue Mar 22 03:01:22 2016 UTC and is due to finish in 60 minutes. The chair is tfukushima. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:01:25 <openstack> The meeting name has been set to 'kuryr'
03:01:52 <tfukushima> Who's up for Kuryr weekly meeting?
03:02:16 <fawadkhaliq> o/
03:02:57 <tfukushima> mspreitz: Are you joining us as well?
03:03:06 <mspreitz> yes
03:03:36 <tfukushima> #info fawadkhaliq, mspreitz and tfukushima are present.
03:03:52 <tfukushima> So it seems we don't have the agenda today. https://wiki.openstack.org/wiki/Meetings/Kuryr#Meeting_March_14.2C_2016
03:04:16 <tfukushima> But we can inherit the previous one.
03:04:55 <tfukushima> We can go quick.
03:05:18 <tfukushima> #topic Kubernetes Integration
03:05:53 <tfukushima> So we had the k8s meeting as you know.
03:06:02 <mspreitz> not sure I do
03:06:05 <mspreitz> which meeting?
03:06:31 <tfukushima> mspreitz: You led the meeting actually :-)
03:06:50 <mspreitz> I suppose that narrows it down a bit
03:07:00 <mspreitz> I probably remember most of it
03:07:33 <mspreitz> I updated my devref with examples, as discussed.
03:08:01 <mspreitz> IIRC there was also a request for finer details on the implementation, but I have not had time to write that yet.
03:09:04 <mspreitz> Baohua Yang also raised an interesting point in review: the policy agent looks like it is not really specific to the translate approach, could be used for the direct approach too.
03:10:02 <mspreitz> He also carried on about linux bridges, but I think he is still misguided about that. But he is not here now.
03:10:03 <tfukushima> mspreitz: Ok, we need to take a look at it.
03:11:18 <mspreitz> That's all the news I have for now.
03:11:27 <tfukushima> #action baohua gives us more details about the linux bridge stuff and the policy agent.
03:12:05 <tfukushima> #action Everyone reviews mspreitz's spec, which introduces the CNM-CNI translation.
03:12:35 <tfukushima> #action Everyone reviews irenab's spec, which introduces the direct translation with the agent and the CNI plugin.
03:12:43 <tfukushima> mspreitz: Thanks.
03:12:47 <mspreitz> yw
03:13:10 <mspreitz> Regarding Irena's spec...
03:13:37 <mspreitz> I think it might be good to split out the part about replacing the kube-proxy
03:14:09 <mspreitz> That, and the MT part, open lots of issues. We might want to factor the spec into two or three.
03:14:40 <tfukushima> mspreitz: Sorry, what is "MT" here?
03:14:45 <mspreitz> Multi-Tenancy
03:14:49 <tfukushima> Oh, multi tenancy.
03:15:38 <tfukushima> #action irenab thinks about to split her spec into a few pieces, like kube-proxy part and multi-tenancy part.
03:16:05 <tfukushima> Yeah, kube-proxy replacement plan can be optional.
03:16:07 <mspreitz> Oh, and I remembered one other thing...
03:16:23 <mspreitz> What's up with making Neutron routers share routing information?
03:16:48 <mspreitz> I saw some stuff on the mailing list that suggests there is some work under way for that.
03:17:18 <tfukushima> mspreitz: Could you elaborate it more?
03:17:35 * mspreitz looks through email inbox...
03:18:19 <mspreitz> Subject line is "[openstack-dev] [neutron] BGP Dynamic Routing Development Going Forward"
03:18:37 <mspreitz> I haven't tried to digest it yet myself.
03:18:37 <tfukushima> #link mspreitz 's CNM-CNI spec: https://review.openstack.org/#/c/290172/
03:18:57 <tfukushima> #link irenab's direct translation spec: https://review.openstack.org/#/c/281132/
03:19:02 <mspreitz> I just wondered if anybody here has a TL;DR
03:19:44 <tfukushima> I don't unfortunately. How about you, fawadkhaliq?
03:20:25 <fawadkhaliq> tfukushima: same
03:20:44 <tfukushima> Ok.
03:22:02 <tfukushima> mspreitz: I might be wrong but I thought we could just use a Neutron router for connecting subnets under the same network, which could be translated into the namespace.
03:22:38 <mspreitz> For level 1 ambition that's fine. For level 2, introducing multi-tenancy, I suggested a router per tenant. Now we get to think about routing between tenants.
03:23:05 <tfukushima> Uh, I see.
03:23:48 <tfukushima> #action K8s guys check the thread "[openstack-dev] [neutron] BGP Dynamic Routing Development Going Forward" on ML
03:25:13 <tfukushima> So for the direct translation side, I'm working on the devref of the API watcher agent now. I'll submit it once it gets nice shape.
03:25:38 <tfukushima> #action tfukushima write the devref of the API watcher agent
03:26:20 <tfukushima> The agent idea could be used for other things such as the translation of the policy and so on, I believe.
03:27:19 <tfukushima> I hope I could finish it before "Hanami" season in Tokyo, which is the random party where you see cherry blossoms and drink sake.
03:27:36 <tfukushima> Let's move on.
03:27:48 <tfukushima> #topic Nested Containers and Magnum Integration
03:28:03 <tfukushima> fawadkhaliq: Congrats for you patch merged.
03:28:11 <tfukushima> s/you/your/
03:28:20 <fawadkhaliq> tfukushima: thanks
03:29:02 <fawadkhaliq> so gsagie introduced oanson to me, who will be helping with the next steps
03:29:21 <tfukushima> fawadkhaliq: Good. What'd be the next step?
03:29:46 <fawadkhaliq> I am hoping to make some progress on the kuryr agent details. Need to find some time to get to that and then implementation.
03:30:23 <fawadkhaliq> there's not much other than this on this topic today
03:31:23 <tfukushima> #fawadkhaliq takes the next step to give the details of the kuryr agent and the implementation with the help from oanson
03:31:36 <tfukushima> #action fawadkhaliq takes the next step to give the details of the kuryr agent and the implementation with the help from oanson
03:31:43 <tfukushima> Ooops, excuse me.
03:31:54 <tfukushima> fawadkhaliq: Ok, thanks.
03:32:26 <tfukushima> #topic Existing Networks
03:32:43 <tfukushima> banix is not here but he's working on this already.
03:32:45 <fawadkhaliq> yw
03:33:14 <tfukushima> #link banix's patch with Neuron tag https://review.openstack.org/#/c/288737/
03:34:21 <tfukushima> He's leveraging the newly introduced "tag" field for the Neutron resources to track the Docker IDs.
03:35:31 <tfukushima> #link banix's patch for "-o neutron.net.uuid=d98d1259-03d1-4b45-9b86-b039cba1d90d" capability https://review.openstack.org/#/c/280948/
03:35:52 <tfukushima> #topic Fullstack and Rally integration
03:36:41 <tfukushima> It seems baohua is not here today but he's in charge of this.
03:37:06 <tfukushima> #link baohua's patches https://review.openstack.org/#/q/owner:baohua%2540linux.vnet.ibm.com+status:open
03:37:31 <tfukushima> fawadkhaliq: Thanks for your reviews.
03:38:05 <tfukushima> I think we can finish early today.
03:38:13 <tfukushima> #topic open discussion
03:38:42 <tfukushima> mspreitz , fawadkhaliq: Do you have anything you want to talk specifically?
03:38:53 <mspreitz> I have nothing to add now.
03:38:56 <fawadkhaliq> tfukushima: nothing from my side.
03:39:10 <tfukushima> Alright, let's wrap the meeting up.
03:39:31 <tfukushima> Thanks for joining and let's keep eyes on patches.
03:39:47 <tfukushima> #endmeeting