14:10:48 <apuimedo> #startmeeting kuryr
14:10:50 <openstack> Meeting started Mon Jun  6 14:10:48 2016 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:10:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:10:53 <openstack> The meeting name has been set to 'kuryr'
14:11:04 <apuimedo> hongbin: fawadkhaliq banix are here
14:11:12 <apuimedo> who else is here?
14:11:28 <salv-orl_> apuimedo: aloha
14:11:30 * apuimedo was having a final boss battle with a load balancer
14:12:20 <apuimedo> #info hongbin, fawadkhaliq, banix, salv-orl_ and apuimedo present
14:12:44 <apuimedo> #topic libnetwork
14:13:15 <apuimedo> Liping Mao has been sending some patches to fix some issues we had in devstack and in libnetwork general
14:13:23 <apuimedo> today we merged two of them
14:13:50 <apuimedo> #link https://review.openstack.org/#/c/323453/
14:14:03 <apuimedo> this one just moved the problem around but bought us some time
14:14:24 <apuimedo> I think that we should be lazier
14:14:54 <apuimedo> we should probably delay talking to neutron to set up stuff and detect capabilities until the first usage
14:15:19 <apuimedo> thoughts?
14:15:50 <salv-orl_> nope sounds good to me
14:16:00 <banix> on “we should be lazier”, I don’t think it is possible, on “detecting capabilities with the first usage” sounds good
14:17:02 <apuimedo> banix: do not underestimate southern europe laziness
14:17:08 <apuimedo> good
14:17:42 <apuimedo> #action we are to move to lazy neutron capability detection
14:17:59 <apuimedo> if somebody has time for that this week, let me know
14:18:45 <apuimedo> #info There is https://github.com/openstack/kuryr-libnetwork. We should move there As soon as we have the fullstack tests fixed
14:19:39 <apuimedo> do we all agree to move before the first release?
14:20:05 <banix> sure
14:20:11 <apuimedo> very well
14:20:19 <fawadkhaliq> apuimedo: makes sense. better to make such changes before it.
14:20:40 <apuimedo> #info the priority is to fix the fullstack test that is currently red, then move to kuryr-libnetwork repo
14:20:58 <apuimedo> Anybody has anything else on libnetwork?
14:21:15 <banix> apuimedo: who is working on that?
14:21:32 <banix> the fullstack test i mean
14:23:05 <apuimedo> I think baohua was on some fullstack test
14:23:09 <apuimedo> but a separate one iirc
14:23:35 <apuimedo> and liping error fixing was probably working towards the current one
14:23:42 <apuimedo> but I don't know his irc
14:23:44 <apuimedo> nick
14:24:07 <apuimedo> limao apparently
14:24:15 <banix> ok thanks
14:24:31 <apuimedo> #action apuimedo to message the mailing list about the failed fullstack test
14:25:07 <apuimedo> banix: any news on the "wait for the ports to become active" ?
14:26:23 <banix> apuimedo: I think the two options remain polling neutron server or monitoring the message queue
14:26:56 <apuimedo> banix: what about you take this to the ML and we finally all take a decision on this then?
14:27:06 <banix> sounds good
14:27:18 <apuimedo> thanks
14:27:37 <apuimedo> #action banix to go to the ML about waiting for ports to become active
14:28:08 <apuimedo> #topic kubernetes
14:28:49 <apuimedo> #link https://review.openstack.org/#/c/320545/
14:29:04 <apuimedo> there is a first WIP of the CNI driver for the kubernetes integration
14:29:12 <apuimedo> salv-orl_: maybe you can cast criticism on it
14:29:34 <apuimedo> everybody is welcome to that
14:29:36 <salv-orl_> apuimedo: why I may post my appraisal of it instead
14:29:51 * salv-orl_ feels very positive this week ;)
14:30:16 <apuimedo> salv-orl_: ok, but at least include one or two puns
14:30:59 <apuimedo> #action apuimedo to get the API watcher first commits to kuryr-kubernetes watcher this week
14:31:35 <apuimedo> we have a bit of a discussion with tfukushima these days about what to do when events are missed
14:31:49 <apuimedo> and keeping track of resource indexes
14:32:14 <apuimedo> I'll try to give it shape before I bring to ML though
14:32:30 <apuimedo> so far, I'm still convinced that different watchers should be able to work independently
14:33:03 <apuimedo> questions about the k8s integration? (Why is it still not there yet is a valid question)
14:33:58 <salv-orl_> did you try the networkpolicy API translation already?
14:35:12 <apuimedo> salv-orl_: not yet. I've been mostly stabilizing and trying to break tfukushima's code when things are missing
14:35:22 <salv-orl_> apuimedo: cool thanks
14:35:34 <apuimedo> I don't think I'll get to it before the end of the month
14:35:40 <apuimedo> unless somebody sends a policy spec
14:35:46 <apuimedo> I can get to reviewing earlier :P
14:36:06 <apuimedo> #topic containers-in-VMs
14:36:15 <apuimedo> hongbin: fawadkhaliq: any updates?
14:36:54 <fawadkhaliq> yes, I am splitting the work items into smaller items as we will have  collaboration between different members
14:37:30 <fawadkhaliq> I might have another person helping me here. And Omer (from gsagie's team) might also be there
14:37:42 <fawadkhaliq> Will share the plan and we kick off the work
14:37:54 <apuimedo> great to hear that!
14:38:09 <hongbin> I wonder roughly what will be the work items
14:38:20 <fawadkhaliq> Also need to have clear information for Magnum folks
14:38:22 <apuimedo> fawadkhaliq: where will you put those items on bluprints?
14:38:48 <fawadkhaliq> I think we can update the spec
14:38:51 <fawadkhaliq> does that work?
14:39:12 <hongbin> From Magnum side, Ton Ngo is the liaison. I can serve as a backend
14:39:13 <apuimedo> fawadkhaliq: works for me
14:39:24 <apuimedo> good
14:39:29 <fawadkhaliq> thanks hongbin, thats great
14:39:41 <apuimedo> fawadkhaliq: is there anything else we can help with towards the task split?
14:39:51 <fawadkhaliq> apuimedo: thanks, will let you know
14:39:59 <apuimedo> (else apart from reviews :P )
14:40:12 <apuimedo> very well
14:40:17 <apuimedo> #topic general
14:40:18 <fawadkhaliq> thanks, will definitely need help ;)
14:40:39 <apuimedo> hongbin: you started the higgins project, right?
14:40:45 <hongbin> yes
14:41:01 <hongbin> apuimedo: anything specific you want to know?
14:41:40 <apuimedo> I wanted to know if you plan to interface with Kuryr to get the libnetwork/cni driver work to consume the neutron networks
14:42:12 <hongbin> It is under discussion. I think we will use Kuryr for libnetwork
14:42:26 <hongbin> For cni, not sure yet, since k8s integration is not the priority
14:42:41 <apuimedo> hongbin: I meant for rkt
14:43:18 <hongbin> apuimedo: the initial focus is docker. rkt is under discussion, maybe it willl be the second driver
14:43:34 <apuimedo> hongbin: very well. Thanks!
14:43:46 <hongbin> np
14:43:53 <apuimedo> be sure to come to us if there is any help we can bring
14:44:06 <hongbin> ack. thx
14:44:26 <apuimedo> #info higgins is tentatively studying going with kuryr for libnetwork
14:44:35 <apuimedo> I want to ask now about config
14:44:58 <apuimedo> are you all fine if we move all the neutron/keystone config to a separate client section like nova has
14:45:00 <apuimedo> ?
14:45:16 <apuimedo> fawadkhaliq: banix salv-orlando devvesa ?
14:45:30 <salv-orlando> no opposition from me
14:45:38 <fawadkhaliq> +!
14:45:39 <fawadkhaliq> +1
14:45:41 <banix> sure
14:45:47 <banix> ok with me
14:46:06 <apuimedo> thanks
14:46:30 <apuimedo> #action apuimedo to send a patch changing the config to move keystone/neutron to its own client section like in nova
14:46:37 <apuimedo> #topic open discussion
14:46:44 <apuimedo> Anything else from anybody?
14:47:15 <apuimedo> BTW, I've been informed that Raven (the name I proposed for the Kubernetes API watcher) kinda sucks
14:47:17 <apuimedo> :P
14:47:33 <apuimedo> so I'm open to suggestions before we start sending code for it :P
14:49:32 <apuimedo> going once
14:49:35 <apuimedo> going twice
14:49:37 <apuimedo> gone!
14:49:46 <apuimedo> thank you all for joining!
14:49:51 <apuimedo> #endmeeting