#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:00:57 UTC (full logs).

Meeting summary

    1. tango, vikasc, hongbin, irenab, limao devvesa and apuimedo present for the meeting (apuimedo, 14:05:32)

  1. kuryr-libnetwork (apuimedo, 14:05:51)
    1. flask 0.11 caused some fullstack breakages (apuimedo, 14:07:52)
    2. https://review.openstack.org/#/c/323895/12/ (apuimedo, 14:08:17)
    3. pyroute2 0.3.x caused some breakages on trusty kernels (apuimedo, 14:08:47)
    4. https://review.openstack.org/#/c/331333/ (apuimedo, 14:09:00)
    5. ACTION: apuimedo to nag the infra team so that the change is merged and the bot sends an update to our repo (apuimedo, 14:09:37)
    6. https://hub.docker.com/r/kuryr/libnetwork/ is the official upstream image (apuimedo, 14:11:56)
    7. the container is built from contrib/docker/libnetwork/Dockerfile (apuimedo, 14:14:41)
    8. infra is planning on a generic build system for project's containers that will then be able to push images (apuimedo, 14:16:27)
    9. apuimedo proposes to move the Dockerfile to /Dockerfile as soon as we move to the kuryr-libnetwork repository (apuimedo, 14:19:34)
    10. ACTION: vikasc to rebase https://review.openstack.org/#/c/331050/ (apuimedo, 14:23:33)
    11. https://review.openstack.org/#/c/331050/ (apuimedo, 14:24:52)
    12. https://review.openstack.org/#/c/331050/ (apuimedo, 14:24:57)
    13. ACTION: apuimedo irenab to try to get https://review.openstack.org/#/c/331050/ merged (apuimedo, 14:27:18)
    14. https://review.openstack.org/#/c/326303/ (vikasc, 14:27:36)
    15. ACTION: apuimedo to review https://review.openstack.org/#/c/326303/ (apuimedo, 14:27:41)
    16. ACTION: irenab to file a bug about reconnection and extension re-checking (apuimedo, 14:32:59)

  2. kuryr-kubernetes (apuimedo, 14:35:26)
    1. there's been work in the kubernetes devref (apuimedo, 14:38:45)
    2. https://review.openstack.org/#/c/328106/ (apuimedo, 14:39:01)
    3. further detail into the watcher and translator https://review.openstack.org/#/c/330282/ (apuimedo, 14:39:43)
    4. ACTION: apuimedo to address the final comments to the patch (apuimedo, 14:42:06)
    5. once we have these two specs I think we can start bringing the code to kuryr-kubernetes repository (apuimedo, 14:43:37)
    6. ACTION: gsagie to work on splitting kuryr into kuryr (having the common library and binding) and kuryr-libnetwork (apuimedo, 14:45:17)

  3. containers-in-vms (apuimedo, 14:46:08)
  4. open discussion (apuimedo, 14:50:38)


Meeting ended at 14:56:56 UTC (full logs).

Action items

  1. apuimedo to nag the infra team so that the change is merged and the bot sends an update to our repo
  2. vikasc to rebase https://review.openstack.org/#/c/331050/
  3. apuimedo irenab to try to get https://review.openstack.org/#/c/331050/ merged
  4. apuimedo to review https://review.openstack.org/#/c/326303/
  5. irenab to file a bug about reconnection and extension re-checking
  6. apuimedo to address the final comments to the patch
  7. gsagie to work on splitting kuryr into kuryr (having the common library and binding) and kuryr-libnetwork


Action items, by person

  1. apuimedo
    1. apuimedo to nag the infra team so that the change is merged and the bot sends an update to our repo
    2. apuimedo irenab to try to get https://review.openstack.org/#/c/331050/ merged
    3. apuimedo to review https://review.openstack.org/#/c/326303/
    4. apuimedo to address the final comments to the patch
  2. gsagie
    1. gsagie to work on splitting kuryr into kuryr (having the common library and binding) and kuryr-libnetwork
  3. irenab
    1. apuimedo irenab to try to get https://review.openstack.org/#/c/331050/ merged
    2. irenab to file a bug about reconnection and extension re-checking
  4. openstack
    1. vikasc to rebase https://review.openstack.org/#/c/331050/
    2. apuimedo irenab to try to get https://review.openstack.org/#/c/331050/ merged
    3. apuimedo to review https://review.openstack.org/#/c/326303/
  5. vikasc
    1. vikasc to rebase https://review.openstack.org/#/c/331050/


People present (lines said)

  1. apuimedo (160)
  2. irenab (32)
  3. gsagie (28)
  4. vikasc (24)
  5. tango (11)
  6. hongbin (10)
  7. diga (9)
  8. openstack (5)
  9. limao_ (2)
  10. devvesa (1)


Generated by MeetBot 0.1.4.