14:00:38 <apuimedo> #startmeeting kuryr
14:00:39 <openstack> Meeting started Mon Jul  4 14:00:38 2016 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:42 <openstack> The meeting name has been set to 'kuryr'
14:00:59 <apuimedo> Hello and welcome to another weekly kuryr meeting
14:01:08 <apuimedo> who is here for it?
14:01:12 <vikasc> o/
14:01:14 <icoughla> hello
14:01:19 <irenab> hi
14:01:38 <irenab> will have to drop soon
14:01:51 <tango> o/
14:01:54 <devvesa> o/
14:01:58 <apuimedo> :-)
14:02:14 <apuimedo> #info vikasc icoughla irenab tango devvesa and apuimedo are present
14:02:19 <apuimedo> Thank you all for joining
14:02:44 <apuimedo> #topic repository organization
14:03:15 <apuimedo> #info openstack/kuryr has been cloned to openstack/kuryr-libnetwork by mordred at our request
14:04:03 <apuimedo> #info openstack/kuryr should now start dropping the code that is specific to kuryr-libnetwork and become home of the specs and the kuryr-libnetwork python package
14:04:08 <apuimedo> crap
14:04:17 <apuimedo> #info openstack/kuryr should now start dropping the code that is specific to kuryr-libnetwork and become home of the specs and the kuryr_lib python package
14:04:27 <apuimedo> second time's the charm...
14:04:29 <apuimedo> xD
14:04:51 <apuimedo> #info openstack/libnetwork should drop the common code and add kuryr_lib to its requirements
14:05:06 <vikasc> https://review.openstack.org/#/c/336661/
14:05:12 <vikasc> apuimedo, done in this patch
14:05:16 <apuimedo> #link https://review.openstack.org/#/c/336661/
14:05:33 <apuimedo> we should soon release kuryr_lib and, after putting it as a requirement, we should move on release kuryr-libnetwork
14:06:17 <vikasc> apuimedo, relevant ml link, http://lists.openstack.org/pipermail/openstack-dev/2016-July/098692.html
14:06:28 <apuimedo> #link http://lists.openstack.org/pipermail/openstack-dev/2016-July/098692.html
14:06:41 <apuimedo> vikasc: I think the commit message in your wip patch should be updated
14:06:49 <vikasc> apuimedo, will do
14:06:50 <apuimedo> as I understand that it is not the RPC one anymore
14:07:07 <apuimedo> it is only dropping code and adding the dependency on kuryr_lib
14:07:25 <vikasc> apuimedo, it has rpc apis also plus namespace support
14:07:45 <irenab> vikasc: any reason to have both in one patch?
14:07:49 <apuimedo> vikasc: I'd rather have a separate patch that only drops the common code and adds the requirement
14:08:05 <irenab> I agree with apuimedo
14:08:10 <diga> o/
14:08:15 <diga> sorry, got late
14:08:44 <vikasc> apuimedo, will do. and will add remaining in another patch linked with dependencies
14:08:54 <apuimedo> #link http://lists.openstack.org/pipermail/openstack-dev/2016-July/098652.html
14:09:02 <apuimedo> thanks vikasc
14:09:13 <vikasc> apuimedo, welcome!!
14:09:34 <apuimedo> any questions on the repo organization part?
14:10:07 <apuimedo> vikasc: (note the link I just posted that says that we should not use the namespaces, we should have kuryr_lib kuryr_libnetwork and kuryr_kubernetes as separated packages)
14:10:33 <diga> apuimedo: +1
14:10:40 <vikasc> apuimedo, i too noted that discussion. was expecting discussion here
14:11:38 <apuimedo> does everybody agree to drop the namespace idea as per dhellmann's recommendation?
14:11:55 <apuimedo> I seem to remember vikasc also preferred not using the namespaces originally
14:12:17 <apuimedo> and it was me pushing for namespaces because they looked elegant and I'm getting too cozy with python3
14:12:28 <vikasc> apuimedo,  yes.. I too feel its more clear with seperate package names
14:12:34 <apuimedo> very well
14:13:00 <vikasc> apuimedo,  I am happy to remove namespaces :)
14:13:17 <apuimedo> #info as per dhellmann's recommendation, the split into repos will not use python namespaces, instead, we'll have three python packages kuryr_lib, kuryr_libnetwork, kuryr_kubernetes
14:13:25 <apuimedo> vikasc: sorry for the extra work I caused you
14:13:55 <vikasc> apuimedo, no probs.. i learned namespaces
14:14:18 <vikasc> apuimedo, might be helpful in some future activity
14:14:43 <vikasc> apuimedo, I too was planning to ask pros of namespaces
14:14:49 <apuimedo> vikasc: if we decide to drop python2 in the future we can revisit it
14:14:59 <apuimedo> vikasc: it's just much cleaner :P
14:15:03 <apuimedo> (when it works
14:15:08 <vikasc> apuimedo, sure :)
14:15:39 <apuimedo> alright, let's move on to other topics
14:16:04 <vikasc> apuimedo,  one query here
14:16:17 <apuimedo> sure, go ahread vikasc
14:16:53 <vikasc> apuimedo, along with dropping common code and adding dependency in first patchset, I will have to drop many testcases also
14:17:15 <apuimedo> vikasc: drop them?
14:17:44 <apuimedo> you mean dropping them on kuryr_libnetwork and keep them on kuryr_lib and viceversa?
14:17:53 <vikasc> apuimedo, yes
14:18:00 <apuimedo> that's fine
14:18:14 <apuimedo> as long as they still exist either in kuryr_lib or kuryr_libnetwork
14:18:20 <vikasc> apuimedo, but finally these have to be on kuryr-libnetwork repo only, along with fullstack tests
14:19:02 <apuimedo> the fullstack tests thing worries me a bit
14:19:39 <apuimedo> probably we should have changes in kuryr_lib run the same gates as the changes in kuryr_libnetwork
14:19:55 <vikasc> apuimedo, in current patches I dropped test cases from kuryr and kept in kuryr-libnetwork..
14:20:07 <apuimedo> vikasc: yes, that's the logical course of action
14:20:25 <apuimedo> I just want to make sure that changes to kuryr_lib that would break kuryr_libnetwork will be caught in time
14:20:44 <apuimedo> #action apuimedo to check how we can run dependent project's gates in kuryr_lib gates
14:20:59 <apuimedo> #topic container_in_vm (nested)
14:21:32 <apuimedo> #info vikasc has been added as an assignee for the spec https://review.openstack.org/#/c/334354/1
14:22:42 <vikasc> apuimedo, cant we have kuryr-libnetwork working from my forked kuryr-lib repo, until actual kuryr-lib becomes working
14:22:49 <apuimedo> vikasc: It would be nice if you could describe a bit the plans that you have to move the spec forward, probably in the ml
14:23:30 <apuimedo> vikasc: well, I think that the changes to kuryr_lib are the top priority ones
14:23:35 <apuimedo> so that we can make a release
14:23:46 <apuimedo> so if you could send the patches to it, that would be great
14:24:06 <vikasc> apuimedo, already submitted
14:24:07 <apuimedo> I'd rather we make a release this week or the next one of kuryr_lib and we can start using it from kuryr_libnetwork
14:24:11 <vikasc> apuimedo, working parallely
14:24:17 <apuimedo> great
14:24:26 <vikasc> apuimedo, https://review.openstack.org/#/c/336784/
14:25:07 <apuimedo> vikasc: it needs the updates on commit message
14:25:08 <vikasc> apuimedo, these same changes i have on my forked repo to satisfy kuryr-libnetwork gate testing dependencies
14:25:17 <apuimedo> ;-)
14:25:18 <vikasc> apuimedo, will done.
14:25:37 <vikasc> *do
14:25:37 <apuimedo> #action apuimedo, banix and irenab to review https://review.openstack.org/#/c/336784/
14:25:49 <apuimedo> vikasc: make sure to remove the [WIP] tag when it is ready
14:26:18 <vikasc> apuimedo, sure..
14:26:23 <apuimedo> vikasc: about the nested thing, I specially would appreciate more info about the RPC thing
14:26:36 <apuimedo> do you think you could maybe expand on that on the nested spec?
14:26:53 <vikasc> apuimedo, that is already in my todo list
14:26:58 <apuimedo> cool!
14:27:00 <apuimedo> thanks vikasc!
14:27:09 <apuimedo> #topic kubernetes
14:27:10 <vikasc> apuimedo, first i was trying to make kuryr-libnetwork ready..
14:27:23 <apuimedo> vikasc: you have the priorities absolutely right ;-)
14:27:32 <apuimedo> I just give updates on the different fronts ;-)
14:27:51 <vikasc> apuimedo,  thanks !!!
14:28:04 <apuimedo> #action apuimedo to update the spec patch https://review.openstack.org/330282
14:28:21 <apuimedo> I should also add the section about High availability
14:28:43 <apuimedo> the idea is that we'll re-use the etcd deployment that kubernetes uses (or we can be pointed to another one)
14:28:51 <apuimedo> to run leader election
14:29:04 <apuimedo> and have all the API watchers look for the events
14:29:38 <apuimedo> but only do actions with side-effects to neutron and kubernetes when the API watcher has the leadership
14:29:46 <apuimedo> so an active-passive setup
14:30:03 <apuimedo> #action apuimedo to check the leader election primitives in etcdv3 that was just released
14:30:11 <apuimedo> questions?
14:31:16 <apuimedo> #topic open discussion
14:31:40 <apuimedo> icoughla: tango: irenab: devvesa: vikasc: do you have some topic to bring up?
14:32:01 <devvesa> Not from me
14:32:02 <tango> None from me at this time
14:32:51 <apuimedo> very well
14:33:16 <apuimedo> let's wait one minute more, and we can close the meeting if nobody comes up with another topic
14:33:55 <apuimedo> oh yes, I was forgetting #link https://review.openstack.org/#/c/307946/
14:34:08 <apuimedo> #action irenab apuimedo to review https://review.openstack.org/#/c/307946/
14:34:28 <apuimedo> it's not a WIP anymore
14:34:37 <apuimedo> thanks to all of you for joining!
14:34:45 <vikasc> thanks
14:34:49 <tango> Thanks!
14:34:49 <devvesa> Thanks apuimedo
14:34:52 <apuimedo> let's keep chatting on #openstack-kuryr
14:34:57 <apuimedo> #endmeeting