#openstack-meeting-4: kuryr
Meeting started by apuimedo at 14:05:29 UTC
(full logs).
Meeting summary
-
- vikasc limao_ tango irenab and apuimedo
present (apuimedo,
14:07:54)
- kuryr-libnetwork (apuimedo, 14:08:21)
- Docker expose support was added backed by
Security groups https://review.openstack.org/337746 (apuimedo,
14:09:29)
- limao corrected the test paths after the repo
split https://review.openstack.org/342885 (apuimedo,
14:10:09)
- limao moved the remaining port references to
our new port, 23750 https://review.openstack.org/340627 (apuimedo,
14:10:43)
- banix added support for taking hold of
pre-existing unbound neutron ports
https://review.openstack.org/337882 (apuimedo,
14:11:14)
- Usage of pre-existing unbound neutron ports
would allow users to pre-allocate ports for deployments (apuimedo,
14:12:22)
- https://review.openstack.org/#/c/340212/1
should be ready for merge (apuimedo,
14:13:32)
- vikasc is working on the code
refactoring (apuimedo,
14:15:07)
- https://github.com/vikaschoudhary16/kuryr
(apuimedo,
14:15:35)
- https://review.openstack.org/#/c/336784/
(vikasc,
14:18:54)
- ACTION: apuimedo to
move gate-install-dsvm-kuryr/gate-kuryr-dsvm-fullstack-nv, and
gate-kuryr-dsvm-rally-nv to kuryr-libnetwork only (apuimedo,
14:21:21)
- kuryr-lib pypi package will have the code
importable from kuryr.lib (apuimedo,
14:28:38)
- https://review.openstack.org/#/c/341891/
(limao,
14:30:33)
- https://review.openstack.org/#/c/341891/
(apuimedo,
14:31:15)
- ACTION: enable
python34 and python35 as voting in kuryr and kuryr-libnetwork
(apuimedo,
14:32:03)
- kuryr-kubernetes (apuimedo,
14:35:00)
- kuryr-kubernetes (apuimedo, 14:35:26)
- no big news on this yet. Patches to come once
kuryr-lib is merged (apuimedo,
14:35:54)
- https://github.com/midonet/kuryr/tree/k8s/doc/source
(irenab,
14:39:35)
- : it is important to note that it uses lbaasv1.
It is a question whether we'll upstream with only v2 or we'll make
it configurable (apuimedo,
14:39:42)
- :
https://github.com/midonet/kuryr/tree/k8s (irenab,
14:39:57)
- open discussion (apuimedo, 14:41:16)
- https://github.com/midonet/kuryr/tree/k8s
(irenab,
14:52:59)
Meeting ended at 14:57:15 UTC
(full logs).
Action items
- apuimedo to move gate-install-dsvm-kuryr/gate-kuryr-dsvm-fullstack-nv, and gate-kuryr-dsvm-rally-nv to kuryr-libnetwork only
- enable python34 and python35 as voting in kuryr and kuryr-libnetwork
Action items, by person
- apuimedo
- apuimedo to move gate-install-dsvm-kuryr/gate-kuryr-dsvm-fullstack-nv, and gate-kuryr-dsvm-rally-nv to kuryr-libnetwork only
People present (lines said)
- apuimedo (105)
- irenab (30)
- vikasc (28)
- limao (18)
- portdirect (8)
- tango (5)
- openstack (3)
- limao_ (1)
Generated by MeetBot 0.1.4.