14:02:46 <irenab> #startmeeting kuryr
14:02:47 <openstack> Meeting started Mon Aug 1 14:02:46 2016 UTC and is due to finish in 60 minutes. The chair is irenab. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:51 <openstack> The meeting name has been set to 'kuryr'
14:03:00 <limao> o/
14:03:02 <irenab> apuimedo: will be late a bit, he asked me to start the meeting
14:03:59 <irenab> banix tonanhngo limao irenab are here for the meeting
14:05:19 <irenab> I do not see published agenda so we cango based on the items you have to discuss
14:06:22 <irenab> who has some topic to discuss, please raise it
14:06:38 <tonanhngo> I have a question about the image on docker hub: kuryr/libnetwork
14:06:50 <tonanhngo> it seems to be broken right now
14:06:54 <banix> what is the status of the split?
14:07:11 <tonanhngo> I guess it's getting built from the current repo?
14:07:27 <banix> have been out of office for a few days
14:07:40 <irenab> tonanhngo: who is the owner of the image?
14:08:17 <irenab> banix: vikas was working on the split, it seems to be close to be completed
14:08:31 <tonanhngo> The owner is "kuryr"
14:08:59 <limao> I think apuimedo worked out the first version
14:09:33 <limao> It may broken because of the split of repo
14:09:49 <tonanhngo> I wonder if we can tag a stable version
14:10:00 <tonanhngo> like last working version
14:10:11 <irenab> banix: according to the gerrit, all vikas patches seems to be merged
14:10:30 <irenab> tonanhngo: this sounds reasonable
14:11:26 <tonanhngo> For now I can build my own copy from the old repo before the split, but as we implement the integration in Magnum, we will be downloading the image on demand.
14:12:00 <tonanhngo> I mean users will be downloading the image.
14:12:17 <banix> irenab: ok thx will try testing the repos today
14:12:49 <irenab> #info: need to tag kuryr images
14:13:32 <irenab> apuimedo wasplanning to tag a release of kuryr-lib
14:13:54 <irenab> given the repository reorg is done, Mido team can start upstreaming the k8s integration
14:14:54 <irenab> tonanhngo: do you have any other requests/dependencies required by Magnum?
14:16:15 <irenab> any patches need review or be discussed here?
14:16:37 <tonanhngo> I was also trying to get logging from the image, but could not get it to work. Not sure if I am not doing something correctly.
14:17:02 <tonanhngo> Let me debug some more to see if it's me.
14:17:27 <irenab> tonanhngo: please, open bug for any issue you run into
14:17:34 <tonanhngo> ok thanks
14:18:13 <irenab> limao: do you know if there is any work to be done to complete the split?
14:19:48 <limao__> https://github.com/openstack/kuryr-libnetwork/blob/master/requirements.txt
14:20:18 <irenab> vikas was working on adding RPC driver to communicate with neutron instread of neutron client, please review https://review.openstack.org/#/c/340147/
14:20:19 <limao__> I see we are using "-e git+https://github.com/vikaschoudhary16/kuryr.git@drop_libnet_specific_code#egg=kuryr-lib" in requirements.txt till now
14:21:45 <irenab> limao__: indeed, need to be fixed to point to the main repo
14:21:52 <apuimedo> I'm here
14:22:07 <irenab> apuimedo: made it safely :-)
14:22:20 <apuimedo> yup
14:22:55 <apuimedo> tonanhngo: I will update the build point for the kuryr/libnetwork image
14:23:15 <apuimedo> banix: irenab: we should tag the release
14:23:16 <tonanhngo> apuimedo: Thanks
14:23:34 <apuimedo> the only thing I wanted to get to kuryr-lib before that is the keystone v3
14:23:36 <irenab> apuimedo: when we declare the release?
14:23:51 <apuimedo> so we need that fixed
14:24:00 <apuimedo> I can get on it next week if nobody can do it earlier
14:24:04 <apuimedo> then we merge it
14:24:06 <apuimedo> then we push
14:24:12 <banix> fawad was working on it
14:24:28 <banix> i think he had a patch up
14:24:29 <irenab> there is also requirements update, see limao__ comment
14:24:45 <apuimedo> irenab: the requirement is in kuryr-libnetwork
14:24:51 <apuimedo> I hope it wasn't me who merged that
14:25:17 <apuimedo> cause I wanted to wait until we had the kuryr-lib, before merging the patch, so we didn't require anything from out of the openstack/ namespace
14:25:47 <irenab> apuimedo: please mark such patches with -2 so we know the intention
14:26:03 <apuimedo> that's a very good point
14:26:08 <apuimedo> I will make sure to do so :P
14:27:11 <apuimedo> did I miss anything else?
14:27:24 <irenab> apuimedo: do you have any update on the RPC driver vikas was working on?
14:27:35 <irenab> I think it was required for the nested case
14:27:45 <apuimedo> I was holding it off until we had kuryr-lib
14:27:54 <apuimedo> but I was probably not being explicit enough
14:28:05 <limao__> Do we have plan for the scope of first release?
14:28:23 <apuimedo> kuryr-lib is only missing the keystone v3
14:28:34 <apuimedo> kuryr-libnetwork is meant to have the nested support (so RPC)
14:28:56 <apuimedo> limao__: so the wait was for kuryr-lib, not for kuryr-libnetwork
14:29:09 <limao__> yeah
14:29:48 <apuimedo> #action apuimedo to get v3 in a mergeable state by next week
14:30:01 <irenab> apuimedo: kuryr-libnetwork will have configurable RPC/REST driver based on the deployment case, correct?
14:30:46 <apuimedo> yes. That's the idea
14:31:10 <apuimedo> to limit the surface that is accessible from VMs
14:31:41 <limao__> for rpc, not very clear about how it deploy. How to process multi tenant in kuryr-server side?
14:32:56 <limao__> Do we have spec or doc or discuss to discribe how it will process multi tenant? :-)
14:33:30 <apuimedo> limao__: the discussion was not finalized
14:33:53 <apuimedo> there are two options, in admin owned VMs or as processes started by Magnum
14:34:03 <apuimedo> (like the haproxy LBaaS)
14:34:32 <irenab> apuimedo: limao__ multi tenancy on the same cluster?
14:34:48 <irenab> or two distinct deployments per tenant?
14:34:59 <apuimedo> distinct deployments per tenant should be possible
14:35:25 <irenab> limao__: Iwould suggest to drive use cases discussion before we dive into implementation details
14:38:48 <irenab> there was request about the alternating meeting
14:39:22 <apuimedo> #no times were proposed
14:39:28 <apuimedo> s/#//
14:39:30 <apuimedo> yet
14:39:55 <apuimedo> so I think for now we could have every week in this timezone until there is enough demand and time proposals
14:40:21 <irenab> +1
14:40:36 <banix> +1
14:40:38 <limao_> apuimedo, sorry, I disconnected from irc just now, I will check log
14:40:43 <apuimedo> ok
14:40:57 <tonanhngo> +1
14:42:30 <irenab> anything else to discuss?
14:42:43 <apuimedo> not on my side
14:42:52 <apuimedo> anybody else has some topic to bring up?
14:43:35 <irenab> not from me
14:44:04 <limao_> not from me
14:44:18 <tonanhngo> I am good
14:44:35 <banix> im good too
14:45:02 <irenab> great, thank you all for attending. Have a nice day
14:45:08 <irenab> #endmeeting