14:02:08 <apuimedo> #startmeeting kuryr
14:02:10 <openstack> Meeting started Mon Nov 21 14:02:08 2016 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:13 <openstack> The meeting name has been set to 'kuryr'
14:02:31 <apuimedo> Welcome to Kuryr's weekly meeting!
14:02:35 <apuimedo> Who's here?
14:02:41 <garyloug> o/
14:02:46 <vikasc> o/
14:02:49 <limao_> o/
14:02:54 <alraddarla_> o/
14:02:56 <yedongcan> o/
14:03:12 <irenab> hi
14:03:16 <ivc_> o/
14:03:29 <apuimedo> :-)
14:03:32 <hongbin> o/
14:03:38 <apuimedo> Welcome everybody!
14:03:40 <mchiappero> o/
14:03:48 <apuimedo> #topic kuryr-libnetwork
14:03:51 <ltomasbo> o/
14:03:52 <apuimedo> crap
14:03:57 <apuimedo> #topic kuryr-lib
14:04:08 <apuimedo> my hand autocompletes lib to libnetwork sometimes
14:04:11 <apuimedo> xD
14:04:13 <apuimedo> anyway
14:04:28 <apuimedo> We have to cut a release so that we can move kuryr-libnetwork to depend on it
14:04:41 <lmdaly> o/
14:05:35 <mchiappero> it would be great!
14:05:46 <apuimedo> indeed
14:06:05 <apuimedo> I would like it if anybody that has something that should make it to this release brings it up :-)
14:06:53 <alraddarla_> I found a few easy documentation bugs that I'm willing to fix. Added one patch set here: https://review.openstack.org/#/c/397790/
14:07:02 <apuimedo> vikasc: irenab: we should merge the simpler ones now, so they don't wait a whole release
14:07:05 <apuimedo> like https://review.openstack.org/#/c/394819/4
14:07:13 <apuimedo> alraddarla_: good!
14:07:25 <irenab> apuimedo, will take a look
14:07:34 <alraddarla_> i plan to fix the other one as soon as this one gets merged
14:07:38 <vikasc> apuimedo, sure
14:07:45 <apuimedo> good
14:07:57 <janonymous> o/
14:08:22 <apuimedo> alraddarla_: make sure to add more reviewers to your patches :-)
14:08:35 <apuimedo> otherwise sometimes I miss patches
14:08:49 <alraddarla_> okay, will do! Since I'm newer to the project I wasn't sure how you all like to handle these
14:09:00 <alraddarla_> Anyone else besides you that I should normall add?
14:09:29 <apuimedo> alraddarla_: limao vikasc and irenab are doing a lot of reviews
14:09:38 <apuimedo> yedongcan and janonymous too :-)
14:09:45 <apuimedo> we have a healthy reviewing population
14:09:58 <apuimedo> vikasc: ltomasbo: I'd like https://review.openstack.org/#/c/361993/ to be part of the release
14:09:58 <alraddarla_> Awesome, sounds great! Thanks
14:10:13 <apuimedo> alraddarla_: welcome to the project :-)
14:10:20 <ltomasbo> with both modes?
14:10:30 <ltomasbo> or just one subport per container?
14:10:35 <alraddarla_> Thank you, apuimedo :) I'm excited to jump in
14:10:36 <vikasc> apuimedo, i am working on vlan-per-containe mod
14:11:01 <vikasc> apuimedo, i am trying trunk port support
14:11:04 <apuimedo> ltomasbo: we can start with one and make a further release for the second mode
14:11:11 <apuimedo> no need to to everything at once
14:11:33 <ltomasbo> great, so I will sync with vikasc for the vlan-per-container
14:11:41 <vikasc> able to see trunk bridge etc getting created, not sure where ping packets are getting stuck
14:11:48 <apuimedo> #info before release we must have CNI driver (apuimedo) and one vlan binding mode (vikasc + ltomasbo)
14:12:06 <ivc_> apuimedo, do we really need CNI in release?
14:12:13 <ltomasbo> vikasc: do you need some help?
14:12:17 <vikasc> ltomasbo, we might debug together
14:12:22 <apuimedo> ivc_: we don't, but I hope I get it before they do :P
14:12:23 <vikasc> ltomasbo, :)
14:12:29 <irenab> apuimedo, CNI is in kuryr-lib?
14:12:36 <ivc_> apuimedo, i had a suggestion regarding CNI and the drivers
14:12:39 <apuimedo> I am hoping I don't need to visit a hospital in at least 10 days
14:12:42 <apuimedo> xD
14:12:50 <apuimedo> irenab: the base driver is
14:13:00 <ltomasbo> sure, happy to help! are you working on kuryr-libnetwork too? or just the binding so far?
14:13:03 <apuimedo> ivc_: where did you send it? IRC or ml?
14:13:06 <vikasc> ltomasbo,i will ping you just after meeting
14:13:12 <ivc_> wdyt if we use kuryr-kubernetes as a sandbox/playground for CNI and os-vif - based drivers
14:13:13 * apuimedo just binding
14:13:17 <ltomasbo> vikasc: ok, great!
14:13:27 <ivc_> apuimedo, i did not :) i'm just sharing it now
14:13:45 <apuimedo> ivc_: you mean that we submit it there and then we have it graduate to kuryr-lib?
14:13:56 <ivc_> my thinking was that kuryr-k8s is not bound by release-restrictions
14:13:59 <ivc_> yet
14:14:01 <apuimedo> I don't know what irenab and vikasc think, but it makes a lot of sense to it
14:14:12 <apuimedo> s/to it/to do it/
14:14:22 <irenab> I was already convinced by ivc_
14:14:30 <apuimedo> alright then
14:14:46 <ivc_> right now i'm planning to implement the [experimental] cni driver by using just os-vif (and some parts of kuryr-lib maybe or just IPDB)
14:15:00 <apuimedo> #action apuimedo to move CNI patch to kuryr-kubernetes and make it work with the pod handler and have a devstack test
14:15:16 <ivc_> so we can eventually mature it enough to get rid of the bash scripts and replace it with os-vif :)
14:15:18 <apuimedo> #info kuryr-lib release drops CNI driver
14:15:23 <apuimedo> ivc_: agreed
14:15:41 <ivc_> apuimedo, cool
14:15:42 <apuimedo> altough that will probably mean to have to send patches to os-vif
14:15:54 <ivc_> not necessary
14:16:05 <apuimedo> hopefully not
14:16:06 <ivc_> they use stevedore too :)
14:16:11 <apuimedo> ah, good
14:16:18 <apuimedo> anything more on kuryr-lib?
14:16:20 <ivc_> there's one thing i'm mising is the Subnet.id
14:16:32 <ivc_> ^ in os-vif
14:17:03 <irenab> I guess possible to start just by posting a bug for os_vif
14:17:34 <apuimedo> irenab: first we try to make it work
14:17:44 <apuimedo> ivc_: I started a patch for subnet.id to os-vif
14:17:46 <ivc_> irenab, we have a workaround for now, we'll fix it later
14:17:57 <apuimedo> when we get to it I'll continue it
14:18:06 <ivc_> cool
14:18:48 <apuimedo> #topic kuryr-libnetwork
14:19:31 <apuimedo> vikasc: please, look at this patch from yedongcan https://review.openstack.org/#/c/400078/1
14:19:40 <vikasc> apuimedo, sure
14:19:51 <apuimedo> and the patches he sent for credentials
14:20:05 <apuimedo> he took over gal's bp of not using admin credentials IIRC
14:20:51 <vikasc> apuimedo, i will go through
14:21:01 <apuimedo> thanks
14:21:55 <vikasc> yedongcan, please add me to the review list
14:22:28 <apuimedo> lmdaly: once we make the release, we should be able to merge https://review.openstack.org/#/c/394547/ right?
14:22:35 <apuimedo> *kuryr-lib
14:22:52 <mchiappero> yes
14:23:11 <mchiappero> well, I'm not sure there is a need for rebasing
14:23:21 <mchiappero> but tests should pass
14:23:39 <apuimedo> #info The refactoring of where the devices are created and deleted to better comply with libnetwork and also to make nested flow work is pending kuryr-lib release
14:23:48 <apuimedo> very well
14:24:01 <apuimedo> anything else on kuryr-libnetwork?
14:24:20 <mchiappero> lmdaly
14:24:33 <apuimedo> lmdaly: mchiappero: Did you send a patch after this one for using the nested drivers already?
14:24:48 <lmdaly> We have the libnetwork driver very nearly ready
14:25:14 <mchiappero> there are a few opens to discuss about but should be there
14:25:43 <mchiappero> one open is how to guarantee the driver-to-driver coherency
14:26:22 <apuimedo> mchiappero: we did have some discussion on that in the channel last week
14:26:30 <mchiappero> I was wondering whether we can make bindings.drivers.__init__ store a binding driver?
14:26:51 <apuimedo> what do you mean with 'store'?
14:27:00 <apuimedo> you mean to cache it during runtime?
14:27:06 <mchiappero> apuimedo: yes, I like your idea, I'm still not too sure on how to adapt the kuryr-lib side
14:27:09 <mchiappero> yes
14:27:29 <apuimedo> can't we do that on the controller side?
14:27:41 <apuimedo> to have a kuryr-libnetwork driver loading method
14:27:47 <apuimedo> that returns you the cached one?
14:28:02 <mchiappero> yes, but currently kuryr-lib is reading straight from the config file
14:28:34 <mchiappero> ok ok, I wasn't sure there was a clear agreement yet
14:29:12 <apuimedo> I see no issue with kuryr-libnetwork caching binding drivers
14:29:15 <mchiappero> let's anyway continue on gerrit once the first patchset is up
14:29:24 <apuimedo> if anybody sees issues with it, please bring it up
14:29:33 <mchiappero> neither I, it was more on how to adapt kuryr-lib
14:30:18 <mchiappero> apuimedo: good, will do!
14:30:37 <apuimedo> mchiappero: if there is changes we need to kuryr-lib, let's bring it up before we release :P
14:30:42 <apuimedo> #topic kuryr-kubernetes
14:31:10 <mchiappero> apuimedo: there is a dependency cycle
14:31:11 <apuimedo> #info we move CNI and os-vif binding to kuryr-kubernetes first. From here it will bubble up to kuryr-lib
14:31:34 <apuimedo> another important thing. Or even more
14:31:57 <apuimedo> We need to start adding functional tests to kuryr-kubernetes using devstack
14:32:03 <mchiappero> the dependency on kuryr-libnetwork won't merge until we release kuryr-lib
14:32:52 <apuimedo> mchiappero: let's detail the dependency cycle on #openstack-kuryr just after the meeting
14:32:57 <apuimedo> and see how we go about it
14:33:03 <apuimedo> #chair ivc_
14:33:04 <openstack> Current chairs: apuimedo ivc_
14:33:17 <apuimedo> ivc_: please, update on the latest of your work
14:34:05 <ivc_> well, there's one huge problem about kuryr-k8s is that i probably poorly communicate plans with community :)
14:34:20 <vikasc> +1 :)
14:34:24 <ivc_> xD
14:34:28 <vikasc> :D
14:34:33 <irenab> ivc_, hoppe that https://docs.google.com/document/d/1hExm0TNp_OMWY_XMVRYpSvg5G8kFrL5hcrT9M_NDCwo/edit?usp=sharing will help on this
14:34:42 <ivc_> but thankfully irenab started working on a devref :)
14:34:44 <ivc_> ^
14:34:58 <ivc_> so thanks a lot, irenab <3
14:35:02 <apuimedo> you can't just drop a link irenab!
14:35:04 <apuimedo> you have to put
14:35:09 <apuimedo> #link https://docs.google.com/document/d/1hExm0TNp_OMWY_XMVRYpSvg5G8kFrL5hcrT9M_NDCwo/edit?usp=sharing
14:35:12 <apuimedo> :-)
14:35:15 <vikasc> irenab, superb +100
14:35:18 <apuimedo> thanks a lot on this effort irenab!
14:35:19 <irenab> ivc_, thanks a lot for your time and review of the docs
14:35:45 <irenab> its still WIP, but supposed to help to see the full picture of the design ivc_ has in mind
14:35:57 <apuimedo> that's a great initiative
14:36:04 <ivc_> i hope the confusion about that drivers chain should be fixed once i rebase VIFHandler patch on that chain
14:36:17 <apuimedo> good
14:36:29 <irenab> once convereged on code, we will post it in rst devref in kuryr-k8s
14:36:37 <apuimedo> agreed
14:36:56 <ivc_> so the current state is that i need to update VIFHandler and then another patch with experimental cni
14:37:03 <apuimedo> #action get https://docs.google.com/document/d/1hExm0TNp_OMWY_XMVRYpSvg5G8kFrL5hcrT9M_NDCwo/edit?usp=sharing in sync with the code and post it as devref
14:37:13 <ivc_> and then the pods should work
14:37:18 <apuimedo> very well
14:37:39 <ivc_> actually i've already tested os-vif based binding with current patches, just need to add veth-pairing
14:37:46 <irenab> ivc_, pods on single network per k8s cluster, correct?
14:37:50 <apuimedo> ivc_: pairing?
14:38:07 <apuimedo> irenab: yes, that's the current default handler
14:38:08 <ivc_> apuimedo, s/pairing/plugging/
14:38:13 <apuimedo> ah
14:38:16 <ivc_> irenab, yes
14:38:44 <ivc_> apuimedo, the hybrid bridge and ovs and port activation is working already thanks to os-vif
14:38:57 <ivc_> so just need to expose it to the container
14:39:15 <apuimedo> cool
14:39:35 <ivc_> but then we'll have to extend the drivers and there'll be lots of work
14:40:08 <apuimedo> ivc_: extend which drivers? You mean the kuryr-lib binding drivers?
14:40:15 <ivc_> one part is extending os-vif translators to support linux-bridge and native ovs
14:40:36 <irenab> ivc_, apuimedo any MPV goal for Ocata?
14:40:48 <apuimedo> irenab: MPV?
14:40:54 <ivc_> ^+1?
14:41:06 <irenab> minimal product value
14:41:08 * apuimedo is bad at acronymcs
14:41:11 <apuimedo> xD
14:41:27 <apuimedo> kuryr-lib should have the vlan binding drivers
14:41:33 <apuimedo> kuryr-libnetwork should work in nested
14:41:54 <irenab> k8s?
14:41:54 <apuimedo> kuryr-kubernetes should have default drivers for all the resources and cni binding using os-vif
14:42:03 <apuimedo> so far I'm not counting on policy
14:42:09 <irenab> flat network mode?
14:42:23 <irenab> or also net per namespace?
14:42:30 <mchiappero> sorry, I'm not sure I understand the work needed to extend the drivers
14:42:50 <apuimedo> well, I was hoping we can use the code ivc_ made to load the mapping of port to subnet
14:42:54 <apuimedo> and have it for this release
14:43:07 <apuimedo> so that means you can easily have flat, net per namespace
14:43:19 <apuimedo> it's quite moddable
14:43:24 <ivc_> :P
14:43:39 <ivc_> you can tune anything
14:43:42 <ivc_> almost :)
14:44:19 <irenab> So plans to have drivers for flat and per namespace + tests?
14:44:29 <ivc_> also we'll need to extend GenericVIFDriver and subclass it into a Recycling one that will reuse/recycle ports
14:44:52 <apuimedo> something like http://i743.photobucket.com/albums/xx72/Tripmyster/weird-car-3.jpg
14:44:55 <apuimedo> xD
14:45:14 <apuimedo> ivc_: the recycling part is definitely not MPV though
14:45:18 <irenab> :-)
14:45:44 <ivc_> apuimedo, maybe not, but it should allow us to show really cool performance numbers
14:46:00 <mchiappero> LOL
14:46:00 <apuimedo> ivc_: it's important work indeed
14:46:02 <irenab> ivc_, apuimedo will be helpful to set miniml goal for ocata
14:46:07 <ivc_> as right now the word 'performance' does not have a place in the current codebase
14:46:43 <apuimedo> minimum goal is to have the base drivers down in a way that they can be replaced with stevedore as ivc_ is doing
14:46:47 <ivc_> irenab, well are we talking about (public) goals or (internal) ones?
14:46:48 <irenab> apuimedo, do not give ideas to ivc_ he has a lot already :-)
14:46:52 <apuimedo> and to have a sensible default with devstack test coverage
14:47:05 <irenab> ivc_, both I think
14:47:27 <apuimedo> that's the minimum goal for sure
14:47:54 <apuimedo> I'd like that we can get there with support and tests for nested (probably lmdaly and mchiappero continuing their nested work onto kuryr-kubernetes)
14:48:22 <mchiappero> let us know how we can help there
14:48:22 <apuimedo> that's my first extension goal if we get any extra time
14:48:23 <ivc_> apuimedo, there we might have a problem
14:48:36 <irenab> need to drop from the meeting, sorry
14:48:42 <apuimedo> irenab: thanks for joining!
14:48:42 <ivc_> i'm not certain how much of kuryr-lib drivers i can salvage atm
14:48:53 <ivc_> thnx, irenab
14:49:13 <apuimedo> ivc_: no worries. Just do the os-vif prototype and we'll work it back in
14:49:23 <apuimedo> and add tests for it
14:49:35 <ivc_> i'm aiming at 100% coverage
14:49:44 <apuimedo> ivc_: you don't need to ;-)
14:49:50 <ivc_> but i want!
14:49:55 <ivc_> :P
14:50:22 <apuimedo> ivc_: better to concentrate on the service and other resource drivers
14:50:26 <apuimedo> and then on the reusing
14:50:38 <apuimedo> than spend time on 100% binding coverage
14:50:51 <apuimedo> which is something we already have on kuryr-lib binding and is a matter of porting
14:51:00 <ivc_> well its already 100% for most of the modules
14:51:21 <ivc_> just those pesky opts.py and config.py and some other minor things missing :)
14:51:29 <hongbin> apuimedo: hey, i wonder if i can take 1 - 2 minutes in this meeting. i would like to give a general status update of the fuxi project
14:51:42 <apuimedo> sure
14:51:46 <apuimedo> that's great!
14:51:50 <apuimedo> #topic fuxi
14:52:02 <apuimedo> #info hongbin is our new fuxi contact
14:52:09 <hongbin> hey everyone
14:52:09 <apuimedo> #chair hongbin
14:52:10 <openstack> Current chairs: apuimedo hongbin ivc_
14:52:12 <apuimedo> please, go ahead
14:52:29 <hongbin> as apuimedo said, i will start to pick up fuxi from now
14:52:44 <hongbin> and i would like to work with you to define the future plan
14:52:57 <hongbin> right now, i am still try to pick up the codebase
14:53:10 <hongbin> just want to show up and collect any feedback if there is any
14:53:21 <hongbin> ^^
14:53:23 <apuimedo> hongbin: did you manage to reach out to jgriffith?
14:53:38 <hongbin> apuimedo: no, i don't have connection to him
14:53:40 <apuimedo> he had some feedback on things that were apparently not working well with fuxi
14:53:48 <apuimedo> hongbin: he's at #openstack-kuryr
14:54:01 <apuimedo> it would be good if we can have discusion in the channel about it
14:54:08 <apuimedo> I'm not sure about his timezone though
14:54:09 <ivc_> apuimedo, hongbin, do we have plans about fuxi for kuryr-k8s?
14:54:21 <hongbin> apuimedo: ok, i will ping him later
14:54:52 <hongbin> ivc_: yes, k8s support is what we want to support in fuxi
14:55:08 <apuimedo> ivc_: it depends on the state of kubernetes openstack providers. So first we have to check what's the state, see if we can get the people working on that together
14:55:12 <apuimedo> and make a plan for ocata
14:55:14 <hongbin> ivc_: we can discuss it further if anyone want to work on this feature
14:55:37 <hongbin> sure
14:56:09 <hongbin> the last thing i would need you guys to help
14:56:13 <hongbin> is the review queue: https://review.openstack.org/#/q/project:openstack/fuxi
14:56:36 <hongbin> it would be great if we can move the old patches there forward :)
14:56:40 <hongbin> that is all from me
14:56:49 <ivc_> hongbin, apuimedo, i'm just trying to figure out if we'll need to add something to the current watcher/handlers landscape
14:56:56 <ivc_> for fuxi i mean
14:57:04 <apuimedo> #action apuimedo, vikasc irenab to review https://review.openstack.org/#/q/project:openstack/fuxi
14:57:15 <hongbin> apuimedo: thx
14:57:25 <apuimedo> ivc_: I think it would be very good to get vikasc feedback on that
14:57:44 <apuimedo> IIRC openshift already does something of a storage/volume annotations on k8s
14:57:59 <apuimedo> so we can see if that is something we can take from
14:58:09 <ivc_> cool
14:58:17 <apuimedo> apart from the normal storage providers in k8s
14:58:48 <hongbin> ok
14:59:28 <apuimedo> very well
14:59:33 <apuimedo> that's all for today
14:59:40 <apuimedo> thank you all for joining
14:59:42 <apuimedo> #endmeeting