14:04:44 <apuimedo> #startmeeting kuryr
14:04:45 <openstack> Meeting started Mon Mar 27 14:04:44 2017 UTC and is due to finish in 60 minutes. The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:49 <openstack> The meeting name has been set to 'kuryr'
14:05:00 <apuimedo> Welcome to another weekly irc meeting
14:05:05 <apuimedo> Who's here for it?
14:05:08 <hongbin> o/
14:05:09 <alraddarla> o/
14:05:19 <janonymous> o/
14:05:22 <yedongcan> o/
14:05:59 <apuimedo> limao: still here?
14:06:24 <limao_> o/
14:07:36 <apuimedo> :-)
14:07:55 <apuimedo> Thank you all for joining. And sorry for the confusion an hour ago. DST should be abolished
14:07:59 <apuimedo> #topic kuryr-lib
14:08:14 <apuimedo> Last week kuryr-lib 0.4.0 was released
14:09:22 <apuimedo> #info Kuryr-lib 0.4.0 was released last week and the global requirements for other openstack projects was bumped to 0.4.0
14:09:59 <apuimedo> I also finished today its packaging for RDO git@gitlab.com:celebdor/kuryr-lib-distgit.git
14:10:25 <apuimedo> It would be nice if somebody would package for debian/ubuntu if there's demand
14:12:25 <apuimedo> Any questions on kuryr-lib release?
14:12:31 <apuimedo> or kuryr-lib in general?
14:13:50 <apuimedo> very well. Moving on!
14:13:54 <apuimedo> #topic kuryr-libnetwork
14:15:24 <apuimedo> #info kuryr-libnetwork 0.1.0 was released last week
14:16:51 <kzaitsev_ws> late o/
14:17:23 <apuimedo> :-)
14:17:27 <apuimedo> welcome kzaitsev_ws
14:17:41 <apuimedo> Oh, I see there's some post release patches to kuryr-libnetwork
14:18:13 <apuimedo> limao_: I think we can merge https://review.openstack.org/#/c/449377/ . What do you think?
14:18:34 <apuimedo> oh right
14:18:41 <apuimedo> it should be changed to 3.5
14:18:48 <limao_> apuimedo: yes, if it changed to 3.5 will be better
14:18:51 <apuimedo> limao_: In these cases, better -1 the patch
14:18:53 <apuimedo> :-)
14:19:04 <apuimedo> so the owner is prompted that something is not right
14:19:35 <limao_> apuimedo: yeah, thanks, I will change
14:19:50 <apuimedo> limao_: thanks for the fix in https://review.openstack.org/#/c/449002/
14:20:13 <apuimedo> did you get around to trying it with green threads?
14:21:04 <limao_> apuimedo: that would be a work around , when I try it in green threads , looks like current uwsgi version do not support, I will try more in next week
14:21:19 <apuimedo> excellent
14:21:22 <apuimedo> thanks a lot
14:21:34 <apuimedo> The last item on kuryr-libnetwork is
14:22:03 <apuimedo> discussion on whether its release model should be cycle-with-intermediary
14:22:22 <apuimedo> i.e., we make releases when we want, but also a release when Pike, Queens, etc come around
14:23:21 <hongbin> i think that is a good idea for libnetwork
14:23:41 <apuimedo> limao_: janonymous: yedongcan: thoughts?
14:23:54 <hongbin> another option is cycle-with-milestone, there are people complaining that this model makes releases that are not needed
14:24:13 <hongbin> (since it needs to make the milestone 1/2/3 release by date)
14:24:30 <janonymous> cycle with intermediary looks good to me
14:24:33 <limao_> +1 cycle-with-intermediary
14:24:48 <yedongcan> +1
14:25:05 <kzaitsev_ws> hongbin: the argument release team has for milestone releases is that it executes the release machinery often
14:25:27 <kzaitsev_ws> so if something is not right — they find out early and not at the day of the actual release
14:25:27 <hongbin> kzaitsev_ws: that is true
14:25:30 <apuimedo> kzaitsev_ws: right now we are on "independent"
14:25:45 <apuimedo> so intermediary is already an improvement :P
14:26:05 <kzaitsev_ws> but yeah I don't know anyone, who would actually use these 'intermediary' releases )
14:26:45 <apuimedo> I think kuryr-kubernetes will probably get more traction and benefit from milestones (although I submitted it with intermediary for now). kuryr-libnetwork may, but not yet
14:28:05 <apuimedo> #info majority of the meeting participants vote for cycle-with-intermediary for kuryr-libnetwork. We'll confirm with missing cores and propose
14:28:31 <apuimedo> Also, please, file blueprints for things you want for the pike cycle relase for kuryr-libnetwork
14:29:07 <apuimedo> anything else on kuryr-libnetwork?
14:29:19 <limao_> apuimedo: thanks, one more is about the docker swarm mode
14:29:56 <limao_> The background is from docker 1.12, it support swarm mode
14:30:00 <apuimedo> right
14:30:07 <janonymous> yeah, i will get involved too
14:30:08 <apuimedo> does it new to support some new api?
14:30:24 <limao_> No, it do not need some new api
14:30:42 <limao_> the problem is when we use docker swarm mode in 1.13
14:31:24 <limao_> it do not support legacy plugin
14:31:42 <limao_> It only support docker managed plugin in swarm mode
14:31:46 <limao_> https://docs.docker.com/engine/extend/
14:32:29 <limao_> That means kuryr-libnetwork docker plugin need be managed by "docker plugin system"
14:32:45 <apuimedo> limao_: what does that mean for us. What kind of change it involves
14:33:24 <limao_> The change is we need to support v2plugin : https://review.openstack.org/#/c/449038/
14:34:07 <apuimedo> Oh! there is a WIP
14:34:10 <apuimedo> great limao_
14:34:19 <limao_> I upload a kuryr-libnetwork v2plugin in my docker hub
14:34:20 <apuimedo> that's definitely a must for Pike
14:34:27 <yedongcan> limao_: anything changed in controller side?
14:35:11 <limao_> yedongcan: nothing changed in controller, you need to listen to a local socket
14:35:38 <apuimedo> that's easy enough
14:35:40 <apuimedo> cool
14:35:43 <limao_> docker plugin install --alias kuryr limao/kuryr-libnetwork-v2plugin
14:35:46 <apuimedo> I add myself as reviewer
14:36:00 <yedongcan> limao_: ok, thanks
14:36:01 <limao_> You can try the plugin from my docker hub
14:36:14 <apuimedo> ah, so it needs to be containerized then
14:36:23 <apuimedo> limao_: please, file a blueprint for that too
14:36:26 <limao_> I packaged one with master code
14:36:39 <limao_> apuimedo: OK, will do it
14:36:44 <apuimedo> thanks limao_!
14:36:49 <apuimedo> #topic fuxi
14:36:53 <apuimedo> hongbin_: the floor is yours
14:36:57 <hongbin_> hi
14:36:57 <apuimedo> #chair hongbin_
14:36:58 <openstack> Current chairs: apuimedo hongbin_
14:37:13 <hongbin_> at last week, i tried to setup the ci for manila provider
14:37:26 <hongbin_> #link https://review.openstack.org/#/c/449833/
14:37:52 <hongbin_> there is some bugs from manila side. now it is resolved
14:38:13 <apuimedo> hongbin_: only that on the depends on?
14:38:17 <hongbin_> there is a bug from manilaclient that failed the py35 gate, and the fix was proposed
14:38:31 <apuimedo> ah good
14:38:34 <hongbin_> apuimedo: yes
14:38:51 <apuimedo> hongbin_: any news on fuxi-kubernetes side?
14:39:13 <hongbin_> apuimedo: i still didn't receive any information about this, will ping them this week again
14:39:33 <hongbin_> apuimedo: sorry about that
14:39:41 <apuimedo> very well. No worries! Thanks hongbin_
14:39:48 <apuimedo> #topic kuryr-kubernetes
14:41:44 <apuimedo> We moved to require kuryr-lib 0.4.0
14:41:57 <apuimedo> Once we get the last services patch merged
14:42:04 <apuimedo> I think we'll make an intermediary
14:42:23 <kzaitsev_ws> yay!
14:42:28 <apuimedo> #info We were formally added to the Pike release: https://review.openstack.org/#/c/448521/
14:43:16 <apuimedo> #info Vagrant support was added for vbox, libvirt and parallels providers
14:44:09 <apuimedo> ruijing cleaned up devstack from remains :-)
14:45:17 <apuimedo> #action irenab vikas ivc_ review https://review.openstack.org/#/c/446492/
14:46:01 <apuimedo> #action apuimedo ivc_ vikas to review https://review.openstack.org/#/c/450113/
14:46:40 <apuimedo> janonymous: did you see yedongcan's comments on https://review.openstack.org/#/c/447942/ ?
14:47:36 <janonymous> apuimedo:yeah, will update shortly
14:47:42 <apuimedo> thanks janonymous!
14:47:48 <apuimedo> It's a very good idea this blueprint
14:48:07 <janonymous> :)
14:48:20 <kzaitsev_ws> apuimedo: regarding the services patch — I actually wanted to write an email to Ilya about his patch to ask if he would be ok If I'll help him out with it.
14:48:37 <apuimedo> kzaitsev_ws: I think that would be great. Please, put me in copy
14:48:56 <kzaitsev_ws> looks like he's busy and the patch seems mostly implemented
14:49:05 <apuimedo> kzaitsev_ws: IIRC it only misses unit tests, so as long as they are up to the standard of the rest of tests. It would easily go in
14:49:23 <apuimedo> allow us to realease 0.1.0 and move on to the rest of blueprints
14:49:32 <kzaitsev_ws> yep, feels like we should only do a final push there
14:49:32 <apuimedo> (and possibly add octavia support later on)
14:49:37 <apuimedo> agreed
14:49:41 <apuimedo> thanks kzaitsev_ws
14:49:49 <apuimedo> Anything else about kuryr-kubernetes?
14:50:17 <yedongcan> apuimedo: https://review.openstack.org/#/c/443748/
14:50:20 <apuimedo> oh, btw. I'm also finishing kuryr-kubernetes rdo package. It already builds
14:50:30 <apuimedo> I'll share the link later if anybody wants it
14:50:47 <yedongcan> I think it related to you patch: https://review.openstack.org/#/c/447073/
14:50:58 <apuimedo> Yay!
14:51:02 <apuimedo> thanks yedongcan
14:51:11 <apuimedo> I can't wait for os-vif to use it too
14:51:25 <apuimedo> I don't like breaking out into ovs-vsctl
14:51:42 <apuimedo> I will submit the new version shortly
14:51:45 <yedongcan> u're welcome.
14:51:48 <apuimedo> anything else?
14:53:19 <apuimedo> alright
14:53:26 <apuimedo> #topic general
14:53:39 <apuimedo> Does anybody else want to bring up some other topic?
14:54:38 <apuimedo> very well then!
14:54:46 <apuimedo> Thank you all for joining today!
14:54:53 <apuimedo> #endmeeting