14:00:04 <apuimedo> #startmeeting kuryr
14:00:04 <openstack> Meeting started Mon Jul 3 14:00:04 2017 UTC and is due to finish in 60 minutes. The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'kuryr'
14:00:16 <kzaitsev_ws> o/
14:00:22 <apuimedo> Welcome to Kuryr's weekly meeting
14:00:31 <apuimedo> who's here for the show
14:00:34 <garyloug> o/
14:01:32 <apuimedo> alright
14:01:34 <apuimedo> let's get started
14:01:40 <apuimedo> #topic kuryr-libnetwork
14:02:09 <apuimedo> #info Support for tagging subnetpool is being merged today
14:02:58 <janonymous> o/
14:03:02 <apuimedo> #info Documentation (sphinx) theme is being changed to match the rest of OpenStack project
14:03:19 <apuimedo> Anybody has anything else on kuryr-libnetwork?
14:03:23 <kzaitsev_ws> yeah, those docs are part of a larger doc-migration
14:03:30 <kural> o/
14:03:51 <kzaitsev_ws> I had some free time on my hands last week, so I updated all the kuryr projects.
14:04:03 <kzaitsev_ws> would do the same for fuxi sometime this week )
14:04:04 <apuimedo> kzaitsev_ws: you're doing God's work with the doc improvements :-)
14:04:09 <apuimedo> perfect
14:04:26 <kzaitsev_ws> #link https://etherpad.openstack.org/p/doc-migration-tracking
14:04:56 <apuimedo> #topic kuryr-kubernetes
14:05:30 <apuimedo> kzaitsev_ws: I sent you a message last week to see if we could have a bluejeans meeting to discuss the sriov patches and the multinetworks effort this week
14:05:38 <apuimedo> how does that sound?
14:05:49 <kzaitsev_ws> oh, sorry I believe I missed that
14:05:54 <apuimedo> it seems it could make us all converge faster
14:05:55 <kzaitsev_ws> but I'm in
14:06:07 <apuimedo> kzaitsev_ws: I sent it at a very late hour
14:06:25 <apuimedo> (was in east coast US)
14:06:48 <apuimedo> kzaitsev_ws: I'll check with the other folks tomorrow. Maybe we could do wednesday or thursday
14:06:49 <kural> Hi, This is kural from Intel, working with Marco and Gary..
14:07:03 <janonymous> o/
14:07:04 <apuimedo> kural: Hi! Nice to meet you
14:07:06 <kzaitsev_ws> apuimedo: btw my sriov patches are based on multi-vif patch https://review.openstack.org/#/c/471012/
14:07:07 <apuimedo> ;-)
14:07:15 <kzaitsev_ws> so I would appreciate some reviews on it
14:07:18 <mchiappe1o> o/
14:07:27 <kzaitsev_ws> or we can include it in the bluejeans agenda
14:07:28 <apuimedo> kzaitsev_ws: I've been looking at them. just didn't post comments
14:07:29 <kural> We are working in Multi network PoC work in K8s as well.. We developed Multus CNI, to address these issue
14:07:48 <apuimedo> it was actually the first item in the bjn's meeting I had in mind
14:07:49 <janonymous> great!
14:08:18 <apuimedo> kural: yes. I heard. I thought multus was kinda stopped but I somebody reported it grew a controller as well
14:09:32 <apuimedo> #info merging sphinx theme change to adequate to the rest of OpenStack docs
14:09:33 <kural> <apuimedo> yes kinda.. We released latest code to select the network in pod spec using TPR and pod spec annotation
14:09:39 <kzaitsev_ws> oh, yeah looks like it got some traction lately =) https://github.com/Intel-Corp/multus-cni/commits/master
14:09:53 <kural> we planning to extend it in kuryr CNI as well
14:09:56 <kzaitsev_ws> kural: I've been using it in my first kuryr-sriov poc =)
14:10:08 <apuimedo> kural: I'm curious. Do you assume all the networks can be on all the worker nodes? Or you made some scheduler extender?
14:11:20 <kural> <apuimedo> <kzaitsev_ws> We currently assume it on worker node
14:11:27 <apuimedo> ok
14:11:50 <kural> <apuimedo> Scheduler extender is a long way to go
14:11:56 <apuimedo> ;-)
14:11:57 <kzaitsev_ws> and how do you want to extend kuryr-cni? I mean you can use kuryr-cni with multus just fine
14:11:59 <vikasc> o/
14:12:05 <kzaitsev_ws> at least I used to use it
14:12:12 <apuimedo> kural: do you have some document about how you did the tpr + annotations?
14:12:34 <apuimedo> I'm currently trying to gather the ovn-k8s, kuryr-k8s and odl-k8s controller integrations
14:12:39 <kural> <kzaitsev_ws> yes, exactly that :)
14:12:40 <apuimedo> to see if we can find common ground
14:13:23 <apuimedo> try to standardize the approach to annotations and (if necessary) net custom resources in the k8s api
14:13:23 <kural> <apuimedo> https://github.com/Intel-Corp/multus-cni/#usage-with-kubernetes-tpr-based-network-objects
14:13:35 <apuimedo> #link
14:13:39 <apuimedo> #link https://github.com/Intel-Corp/multus-cni/#usage-with-kubernetes-tpr-based-network-objects
14:14:14 <apuimedo> thanks kural !
14:14:16 <kzaitsev_ws> kural: exactly what? =) I think I just asked how you want to extend kuryr-cni
14:14:19 <apuimedo> very well written
14:14:42 <apuimedo> kzaitsev_ws: I understood it as them wanting to make sure that kuryr continues to be usable under multus
14:14:54 <kzaitsev_ws> ah
14:15:44 <garyloug> kzaitsev_ws yes, what apuimedo said :)
14:15:44 <kural> We planned to development DPDK net plugin for Kuryr, which uses Multus CNI along with it
14:15:49 <kzaitsev_ws> well, I did encounter a bunch of wierd error messages in logs, however kuryr-cni worked fine (at least as master-cni)
14:16:22 <apuimedo> kural: we'd like to keep interoperability if possible
14:17:14 <apuimedo> vikasc: regarding https://review.openstack.org/#/c/466675/
14:17:21 <kural> <apuimedo> ok cool..
14:17:22 <apuimedo> is the latest patch set confirmed to be working?
14:17:31 <vikasc> apuimedo, yes
14:17:53 <apuimedo> vikasc: also, it feels like the py3 encoding standalone patch may be something we want to add to the normal codebase
14:18:14 <apuimedo> adding an if py3: this, else: that
14:18:32 <apuimedo> vikasc: I'll try to test it and approve it this week then
14:18:37 <apuimedo> it's looking quite good already
14:18:41 <vikasc> apuimedo, thanks!
14:18:57 <vikasc> apuimedo, on py3 encoding, sure
14:19:36 <vikasc> apuimedo, py3 encoding in normal code and cleanup handling using pre-delete lifecycle hooks
14:19:38 <apuimedo> (I'm fine with merging with separate patch and then on a subsequent patch that fixes it in a generic way, drop the patch)
14:20:08 <vikasc> apuimedo, make sense
14:21:18 <apuimedo> vikasc: kzaitsev_ws: https://review.openstack.org/#/c/476424/
14:21:24 <apuimedo> garyloug: did you get my email?
14:21:37 <apuimedo> (regarding services)
14:21:54 <apuimedo> it was about which k8s services are supported on kuryr-k8s (if at all)
14:21:59 <garyloug> apuimedo, I did, thank you, explained everything
14:22:10 <apuimedo> I wanted to assign load balancer service type support to my new colleague yboaron
14:22:22 <apuimedo> but if somebody wants to add it earlier, I can accept
14:23:00 <apuimedo> and be happy for it :-)
14:23:09 <apuimedo> janonymous: did you start on the cni split?
14:23:18 <kzaitsev_ws> apuimedo: i don't like these kind of mass-commits (hence I appologise for the docs commits, I know those are annoying), but I see no real harm in https://review.openstack.org/#/c/476424 too
14:23:18 <janonymous> apuimedo: yea
14:23:19 <apuimedo> I saw some message from you from last week
14:23:22 <apuimedo> cool
14:23:27 <garyloug> apuimedo, for now I was just wondering what's supported at the moment, no plans to add
14:23:29 <janonymous> apuimdeo: i will push draft versison by this week
14:23:31 <apuimedo> let me know if I can help somehow
14:23:45 <janonymous> thanks!
14:24:05 <apuimedo> garyloug: what I would really like to have is macvlan be added as a segmentation type
14:24:14 <apuimedo> in neutron
14:24:21 <apuimedo> so the macvlan support gets simplified
14:24:22 <janonymous> i will add for review :)
14:24:39 <apuimedo> janonymous: very well
14:24:41 <apuimedo> :-)
14:24:52 <apuimedo> I'll ask my neutron colleagues if they see it possible
14:25:17 <apuimedo> also oanson if he thinks that dragonflow/ml2ovs/ovn could potentially do the split based on mac
14:26:17 <apuimedo> janonymous: regarding moving to python official client
14:26:33 <apuimedo> I had some reports of malfunction last week from the kubernetes-ovn folks
14:26:57 <apuimedo> so I want to know more about what the problems were, since they drastically rewrote in golang to workaround
14:27:07 <janonymous> apuimedo: ohh.. i would like to see errors and make changes
14:27:22 <apuimedo> janonymous: yes. I'd like to know about those errors too
14:27:43 <apuimedo> sorry I don't have the specifics yet
14:28:04 <janonymous> no problem i will test more in all aspects
14:28:20 <janonymous> thanks for feedback
14:28:42 <apuimedo> thanks!
14:28:49 <apuimedo> anything else on kuryr-kubernetes?
14:29:11 <garyloug> yes, just quickly
14:29:25 <apuimedo> btw, we should start speccing network poliyc
14:29:27 <apuimedo> *policy
14:29:31 <apuimedo> garyloug: please, go ahead
14:29:55 <garyloug> I was to have a blueprint ready on DPDK support for nested containers but I'm afraid I have been very busy. i will try for next week's meeting
14:30:26 <apuimedo> oh!
14:30:39 <apuimedo> garyloug: I'm very interested in hearing more about that
14:30:43 <apuimedo> I'm sure vikasc is too
14:30:57 <garyloug> yes :)
14:31:00 <apuimedo> how does it work? from virtio? or you passthrough the device to VM?
14:31:05 <kzaitsev_ws> +1
14:31:45 <garyloug> so from last week the guys suggested I show it at the meeting and take discussion to the #openstack-kuryr chat following
14:32:06 <kural> Multus will call Kuryr twice to get Virtio
14:32:31 <garyloug> We are currently working on a PoC
14:33:27 <apuimedo> kural: call how?
14:33:37 <garyloug> apuimedo, passthrough might be a follow up option, but for now we are focusing on virtio
14:33:45 <apuimedo> kuryr-k8s doesn't have an API at the moment
14:33:48 <apuimedo> or you mean kuryr-cni?
14:34:06 <garyloug> yes, kuryr-cni
14:34:20 <apuimedo> garyloug: well. if there's DPDK at the host with ovs-dpdk and dpdk virtio at the VM, I suppose the perf will be good
14:34:52 <garyloug> yes, that's exactly the plan :)
14:34:57 <kzaitsev_ws> apuimedo: garyloug: so you're talking about containers in VM, right?
14:34:58 <apuimedo> garyloug: feel free to bring it up next week, or even to call for a bluejeans to present and discuss "in person"
14:35:07 <apuimedo> kzaitsev_ws: that's right
14:35:23 <kzaitsev_ws> oh, ok sounds right then
14:35:23 <garyloug> yes, bluejeans meeting might be useful also
14:35:31 <kural> +1
14:35:58 <vikasc> interesting :)
14:36:16 <apuimedo> garyloug: kural: so let me know when it would work for you and I'll try to schedule
14:36:23 <vikasc> +1 for bj
14:36:32 <garyloug> ok, thanks guys!
14:36:35 <apuimedo> which reminds me that I should probably get started on planning the vtg
14:36:47 <apuimedo> garyloug: thanks to you for bringing it up
14:36:50 <garyloug> I'll follow up after
14:36:53 <apuimedo> #topic general discussion
14:36:59 <apuimedo> Any other topic?
14:37:16 <apuimedo> Is there fuxi folks? (I didn't see hongbin connected)
14:37:23 <zengchen1> yes
14:37:33 <zengchen1> i am waiting here
14:37:37 <apuimedo> oh, great zengchen1!
14:37:41 <apuimedo> Sorry I missed you
14:38:23 <apuimedo> #topic fuxi
14:38:23 <apuimedo> #chair zengchen1
14:38:26 <openstack> Current chairs: apuimedo zengchen1
14:38:28 <zengchen1> last week, i finished the flexvolume driver of cinder, and i have done some tests.
14:38:59 <zengchen1> i also submit a patch to deploy flexvolume driver by devstack.
14:39:10 <apuimedo> #info The flexvolume documentation patches got merged
14:39:19 <apuimedo> zengchen1: awesome
14:39:31 <zengchen1> oh, it is a good news to me.
14:39:36 <apuimedo> I saw there was some patch to import the watcher framework too
14:40:12 <zengchen1> i don't see the patches about wather.
14:40:21 <zengchen1> s/wather/watcher
14:40:49 <apuimedo> zengchen1: you're right
14:40:58 <apuimedo> I misread the topic msg of the patch
14:41:06 <apuimedo> it was flexvolume framework
14:41:09 <apuimedo> ;P
14:41:11 <apuimedo> sorry about that
14:41:43 <apuimedo> #action apuimedo irenab to review the flexvolume patches
14:41:44 <zengchen1> this week, i will start the work of watching PVC to create PV
14:41:54 <apuimedo> perfect
14:42:04 <apuimedo> can't wait to try it
14:42:08 <apuimedo> I'm sick of the nfs pvs
14:42:13 <apuimedo> :-)
14:42:31 <apuimedo> zengchen1: anything else on fuxi this week?
14:42:34 <zengchen1> we need more reviews.
14:42:51 <apuimedo> zengchen1: I agree
14:43:05 <zengchen1> no, keep on design and coding
14:43:13 <apuimedo> zengchen1: we need irenab and possibly cinder people to review
14:43:17 <apuimedo> I'll see what I can do
14:43:42 <apuimedo> zengchen1: sorry it's a bit slow for now in terms of reviews
14:43:43 <zengchen1> yes, irenab give more reviews
14:43:52 <apuimedo> hopefully it will start to pick up pace
14:44:03 <apuimedo> #topic general
14:44:17 <apuimedo> Anything else related to kuryr or fuxi that we did not cover?
14:46:17 <apuimedo> alright. Thank you all for joining today. Let's keep talking during the week in #openstack-kuryr!
14:46:18 <apuimedo> #endmeeting