14:01:47 <apuimedo> #startmeeting kuryr
14:01:48 <openstack> Meeting started Mon Aug 28 14:01:47 2017 UTC and is due to finish in 60 minutes. The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:52 <openstack> The meeting name has been set to 'kuryr'
14:01:59 <apuimedo> Welcome to yet another weekly IRC Kuryr meeting
14:02:05 <ltomasbo> o/
14:02:09 <ivc> o/
14:02:58 <apuimedo> dmellado: irenab: hongbin: here?
14:03:10 <dmellado> hey apuimedo
14:03:13 <dmellado> yep, got distracted
14:03:16 <dmellado> by triple things
14:03:18 <dmellado> xD
14:03:43 <apuimedo> dmellado: #triplejoy
14:03:54 <dmellado> totally
14:03:55 <apuimedo> alright, let's get started
14:04:01 <apuimedo> #topic kuryr-lib
14:04:17 <hongbin> o/
14:04:22 <apuimedo> #info Last week we released kuryr-lib 0.6.0. It is an independent release
14:04:42 <apuimedo> The only changes from 0.5.0 is that it points to pike cycle keystonauth
14:05:00 <apuimedo> anythin else about kuryr-lib?
14:07:29 <irenab> hi
14:07:51 <apuimedo> alright moving on
14:07:57 <apuimedo> #topic kuryr-libnetwork
14:09:09 <apuimedo> #info only requirements updates https://review.openstack.org/#/c/495184/3
14:09:18 <apuimedo> anything else on kuryr-libnetwork?
14:10:52 <hongbin> no stable branch for libnetwork?
14:11:32 <apuimedo> hongbin: IIRC it is release independent
14:12:10 <hongbin> apuimedo: ok, i think it is better to change the release model :)
14:12:19 <apuimedo> hongbin: I'm for
14:12:36 <hongbin> apuimedo: ack
14:12:36 <apuimedo> what do the other people think?
14:14:19 <apuimedo> irenab: ltomasbo: ivc: dmellado: ?
14:14:19 <hongbin> apuimedo: we can discuss it with limao after
14:14:28 <apuimedo> hongbin: I think that's a good idea
14:14:36 <apuimedo> hongbin: ping me when you do
14:14:36 * dmellado backreading
14:14:39 <apuimedo> ;-)
14:14:44 <ltomasbo> sounds good to me
14:14:48 <dmellado> yep
14:14:50 <dmellado> +1
14:15:24 <ivc> +1
14:16:28 <apuimedo> thanks for chiming in :-)
14:16:54 <apuimedo> #action kuryr-libnetwork to be changed to cycle with intermediaries
14:17:09 <apuimedo> #topic fuxi
14:17:12 <apuimedo> #chair hongbin
14:17:13 <openstack> Current chairs: apuimedo hongbin
14:17:19 <hongbin> hi all
14:17:44 <hongbin> in last week, zengchen uploads several revisionis on fuxi-kubernetes
14:17:57 <hongbin> here is the review queue
14:17:59 <hongbin> #link https://review.openstack.org/#/q/project:openstack/fuxi-kubernetes+and+status:open
14:18:29 <hongbin> i saw several outstanding comments are addresses in his new patchset
14:19:05 <hongbin> i think those patches are ready for another iteration of reviews :)
14:19:08 <apuimedo> hongbin: it's a very busy week, but I'll try to look over them
14:19:12 <apuimedo> thanks!
14:19:20 <hongbin> apuimedo: thank you. that is all from my side
14:19:50 <apuimedo> good, thanks
14:19:54 <janonymous> o/ sry got late :D
14:19:56 <apuimedo> #topic kuryr-kubernetes
14:20:24 <apuimedo> #info ltomasbo got in a couple of port pool fixes that help with non ml2/ovs
14:21:11 <apuimedo> #info OpenDaylight LB is confirmed to work with kuryr-kubernetes
14:21:19 <ltomasbo> working in a new one to enable adding/removing subports from the pools (for the nested case)
14:21:32 <apuimedo> ltomasbo: you mean the kuryr-manage?
14:21:37 <ltomasbo> apuimedo, that info is not right (if you got it from me)
14:21:43 <ltomasbo> the lbaas one I mean
14:21:58 <ltomasbo> ODL works with lbaasv2, but not with ODL-lbaas
14:22:27 <apuimedo> oops
14:22:28 <ltomasbo> and I'm planning to add support at kuryr for Octavia L2 (so that it will work too with ODL)
14:22:38 <apuimedo> ltomasbo: and with octavia?
14:22:41 <apuimedo> ah, right
14:22:46 <apuimedo> ok, ok. I fix it
14:23:10 <ltomasbo> great!
14:23:33 <apuimedo> #info Kuryr-kubernetes + legacy neutron-lbaasv2 works. Octavia lbaas will need layer2 support in kuryr-kubernetes. Native ODL lbaas needs more work as well
14:24:22 <apuimedo> janonymous: I saw that you updated the kubernetes-incubator/python-client patch
14:24:26 <apuimedo> any news on that?
14:24:40 <janonymous> yup, just query from zenchen
14:25:08 <janonymous> in starting of next cycle we can work to merge 2 patch
14:25:22 <janonymous> cni and client, till then i will test my best
14:25:48 <janonymous> any reviews are appreciated! :)
14:25:59 <apuimedo> perfect, thanks
14:26:03 <apuimedo> :-)
14:26:37 <apuimedo> #info I've started work on OpenShift support in devstack. The idea is to then gate with both k8s and devstack
14:26:44 <apuimedo> darn!!!
14:26:51 <apuimedo> I screw up all the #info today
14:27:02 <apuimedo> #info I've started work on OpenShift support in devstack. The idea is to then gate with both k8s and openshift
14:27:29 <apuimedo> so our matrix will be increased to cover k8s, openshift, octavia and lbaasv2
14:28:05 <apuimedo> #info yboaron posted a patch for loadbalancer service type support https://review.openstack.org/#/c/498253/
14:28:11 <apuimedo> I have to finish reviewing it
14:28:19 <apuimedo> ivc: it would be great if you can review it too
14:28:31 <ivc> apuimedo ack
14:29:23 <apuimedo> thanks
14:29:29 <apuimedo> anything else on kuryr-kubernetes?
14:36:13 <apuimedo> #topic generalalright
14:36:16 <apuimedo> crap
14:36:21 <apuimedo> #topic general
14:36:23 <dmellado> lol
14:36:24 <apuimedo> Alright
14:36:33 <apuimedo> anything else before we close the meeting
14:36:48 <apuimedo> and I go punch the keyboard with my head for lack of coordination?
14:37:08 <dmellado> I'd rather pass on and watch you punching the keyboard with your head
14:37:50 <apuimedo> dmellado: it's pay per view
14:39:27 <apuimedo> Thank you all for joining!
14:39:30 <apuimedo> #endmeeting