14:07:23 <apuimedo> #startmeeting kuryr
14:07:23 <openstack> Meeting started Mon Apr 30 14:07:23 2018 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:07:26 <openstack> The meeting name has been set to 'kuryr'
14:07:36 <apuimedo> Hi everybody and welcome to the weekly kuryr meeting
14:07:44 <apuimedo> #topic kuryr-kubernetes
14:08:35 <apuimedo> #info today we released 0.4.3 that includes an important bugfix for service deletion when using octavia
14:08:49 <apuimedo> yboaron_: I still think that we should catch the exception you proposed
14:09:02 <apuimedo> yboaron_: ltomasbo: thoughts on that?
14:09:47 <yboaron_> apuimedo, I don't think we need,  after we have the cascading delete merged
14:10:29 <ltomasbo> I don't have a strong opinion there, but catching the exception will not hurt
14:10:34 <apuimedo> yboaron_: cause this can't happen with neutron-lbaas, can it?\
14:10:49 <yboaron_> apuimedo, that's correct
14:12:26 <yboaron_> apuimedo, it can't happen in LBaaSV2
14:12:47 <apuimedo> yboaron_: ok. So it that case, let's abandon it
14:12:53 <ltomasbo> ok!
14:13:04 <apuimedo> #action yboaron_ to abandon the lbaas badrequest exception catching bug
14:13:19 <yboaron_> apuimedo, will do it
14:13:42 <apuimedo> yboaron_: talk to us a bit about the ingress controller effort
14:14:02 <yboaron_> apuimedo,  before reaching the ingress controller ,we have another issue with Octavia LB ,
14:14:12 <yboaron_> #link https://bugs.launchpad.net/kuryr-kubernetes/+bug/1768009
14:14:13 <openstack> Launchpad bug 1768009 in kuryr-kubernetes "Service edit (scale out number of members) - cause exception" [Undecided,New]
14:14:45 <yboaron_> all the Get list + fields are not supported at Octavia
14:15:03 <yboaron_> there's an open patch for that in Octavia
14:15:19 <yboaron_> #link https://review.openstack.org/#/c/559842/
14:15:45 <apuimedo> nice, new bugs
14:15:48 <apuimedo> let's see
14:16:24 <yboaron_> so, from Kuryr perspective, all the _find_xx functions in Lbaasv2.py file will cause an exception
14:16:57 <apuimedo> yboaron_: I see it is a backport candidate
14:17:06 <yboaron_> Yes
14:17:32 <yboaron_> I"ll open a bug for that in Octavia and mark that it affects Kuryr
14:17:32 <apuimedo> #action yboaron_ to talk to Octavia folks to see whether it is likely to be backported and see how we can help it get in quickly
14:17:55 <apuimedo> also, please test that the bug solves it and comment on the patch if it does
14:18:13 <yboaron_> OK
14:19:00 <yboaron_> now I can elaborate about the Ingress controller ..
14:19:09 <ltomasbo> :)
14:19:19 <yboaron_> so, I have decided to split the work into two phases
14:19:44 <yboaron_> 1. just add the Ingress controller
14:19:58 <yboaron_> 2. add the ocp-route and service handlers
14:20:16 <yboaron_> I have sent 4 patches that covers phase 1
14:20:49 <apuimedo> yboaron_: can you argue about the split
14:20:59 <apuimedo> vs just having handlers
14:21:06 <apuimedo> loaded as the other handlers are loaded
14:22:02 <yboaron_> we"ll still have the handlers (ocp-route and  service) loaded using the pluggable feature
14:22:09 <yboaron_> but in phase '2'
14:22:43 <yboaron_> in first phase, we just have the Ingress controller LB creation and Devstack related stuff
14:22:52 <apuimedo> oh, I understand now
14:22:58 <apuimedo> phase 1 is dpeloyment
14:23:07 <apuimedo> phase 2 happens in the kuryr-controller instead
14:23:09 <apuimedo> is that right?
14:23:10 <yboaron_> correct
14:23:52 <yboaron_> also prt of phase '1', as the LB created manually and controller just need to sync with it
14:24:14 <yboaron_> but in general most of phase '1' about deployment
14:24:36 <yboaron_> also added two zuul gates for ingress controller in K8S and Openshift
14:24:59 <yboaron_> as one of the patches of phase '1'
14:25:02 <apuimedo> yboaron_: wouldn't openshift gate be with Routes handler instead?
14:25:48 <yboaron_> you mean to enable Ingress controller by default in openshift?
14:26:54 <yboaron_> I thought that route handlers should be tested by tempest tests (e.g: create service+route and try to curl the name)
14:27:51 <apuimedo> yboaron_: sure
14:30:48 <apuimedo> alright, let's move to the next work in progress
14:31:18 <apuimedo> ltomasbo: how's the work on the namespace handling for subnet per namespace effort?
14:31:53 <ltomasbo> apuimedo, it is working and I addressed some of the comments
14:32:02 <ltomasbo> apuimedo, I need to find some time to add the unittesting
14:32:32 <apuimedo> ltomasbo: yboaron_: and I'm expecting tempest tests for the service deletion and for the namespace handlers
14:32:35 <apuimedo> :-)
14:32:40 <ltomasbo> xD
14:32:56 <yboaron_> it in my list ..
14:33:01 <ltomasbo> yes yes, first the unit tests, and then I'll add some tempest too
14:33:27 <apuimedo> :-)
14:33:30 <ltomasbo> and I reply to some of the comments that yossi made, and I have a todo from it!
14:33:41 <apuimedo> perfect
14:33:45 <apuimedo> thanks
14:33:53 <ltomasbo> so, probably on thursday I'll spin a new version, but the current ones are testable
14:33:58 <apuimedo> does anybody have anything else on kuryr-kubernetes
14:33:59 <ltomasbo> so, feel free to give it a try!
14:34:06 <apuimedo> ltomasbo: let me know when you do so I make sure to review them
14:34:24 <ltomasbo> I have a few backports, that we may merge or abandon
14:34:29 <ltomasbo> (probably the second)
14:35:01 <ltomasbo> apuimedo, https://review.openstack.org/#/c/563079/
14:35:10 * apuimedo looking
14:35:20 <apuimedo> ltomasbo: let's abandon this one
14:35:25 <apuimedo> what else?
14:35:41 <ltomasbo> and similar for these two: https://review.openstack.org/#/c/563078/ https://review.openstack.org/#/c/564113/
14:37:14 <apuimedo> I think we should take the first
14:37:29 <apuimedo> check what's wrong with the gates with it
14:37:40 <apuimedo> the second as well
14:37:58 <ltomasbo> ok!
14:38:34 <ltomasbo> second one passes the gate, it is just a matter if we want to merge it now or later
14:38:51 <apuimedo> we're not waiting for any urgent backport
14:38:52 <ltomasbo> following yossi's comments
14:39:02 <apuimedo> I'll check his comment again later
14:39:09 <ltomasbo> ok! that's all
14:39:12 <apuimedo> anything else?
14:39:51 <ltomasbo> nope
14:39:55 <yboaron_> Not from my side
14:41:37 <apuimedo> very well
14:41:42 <apuimedo> #topic kuryr general
14:41:49 <apuimedo> Does anybody have any other topic?
14:43:31 <apuimedo> alright. Let's close it early today
14:43:36 <apuimedo> Thank you all for joining!
14:43:39 <apuimedo> #endmeeting