14:00:18 <ltomasbo> #startmeeting kuryr
14:00:19 <openstack> Meeting started Mon Jun 18 14:00:18 2018 UTC and is due to finish in 60 minutes.  The chair is ltomasbo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:22 <openstack> The meeting name has been set to 'kuryr'
14:00:34 <ltomasbo> hi folks! who is around for the meeting?
14:00:49 <ltomasbo> irenab, dulek, dmellado, ...
14:01:09 <dulek> o/
14:01:50 <ltomasbo> seems not so many people... lets waits a couple of minutes...
14:03:10 <ltomasbo> dulek, do you have anything you want to discuss about?
14:04:06 <dulek> ltomasbo: We've merged Ingress and HA stuff at Friday!
14:04:18 <dulek> I guess it's time to focus on adding tempest for that.
14:04:25 <ltomasbo> I saw that! great!
14:04:29 <ltomasbo> yes, I fully agree!
14:04:35 <ltomasbo> and documentation
14:04:54 <dulek> :)
14:04:55 <ltomasbo> #action add tempest tests for OCP-Route and Kuryr-controller HA
14:05:30 <dulek> Besides that I don't think there's a lot of news. I plan to have a few bugfixes up for review soon.
14:05:36 <ltomasbo> well as toni is not here, I'll do the split...
14:05:48 <ltomasbo> #action dulek add kuryr-controller HA tempest coverage
14:06:11 <ltomasbo> great!
14:06:26 <ltomasbo> I re-spin the devref irenab started on Kuryr Port CRDs
14:06:35 <dulek> This is waiting for the multinode, at first I'll probably just add 2 replicas there.
14:06:45 <dulek> ltomasbo: Great!
14:06:47 <ltomasbo> dulek, it will be great if you could take a look https://review.openstack.org/#/c/556181/
14:07:05 <ltomasbo> and once we agreed upon, I'll start working on it
14:07:13 <dulek> ltomasbo: Okay, cool.
14:07:31 <dulek> ltomasbo: I have a draft of that CRD in my daemon-side vif choice patch.
14:07:57 <ltomasbo> dulek, nice, should we try to split it out from the daemon-side vif?
14:07:57 <dulek> ltomasbo: You can take a look as well - https://review.openstack.org/#/c/527243/
14:08:12 <dulek> ltomasbo: Might be a good idea - that patch is already huge.
14:08:42 <ltomasbo> ok, once we agree on the KuryrPort CRD, I'll take a look at your patch, and try to move everything to KuryrPort CRDs
14:09:17 <ltomasbo> that way it will be simpler in you patch to handle the vif management on the cni
14:09:31 <dulek> ltomasbo: What's everything in this context? You mean annotations? We'll need to care about upgrade path there.
14:09:41 <ltomasbo> I'm planning to later extended to the pools, but perhaps you also addressed that on your patch?
14:10:00 <dulek> ltomasbo: I don't really have pools CRDs there.
14:10:26 <ltomasbo> I mean moving to KuryrPort CRDs for annotations for the general case, not just the daemon-side vif driver
14:11:10 <ltomasbo> ok!
14:11:20 <dulek> Okay, cool. Some of that is done on my patch, so it's  a good starting point, I guess.
14:11:30 <ltomasbo> great!
14:11:33 <ltomasbo> on a different matter, I took a look at your HA patch
14:11:40 <ltomasbo> I have a question though
14:11:53 <dulek> ltomasbo: Yeah>
14:11:53 <ltomasbo> I see you only enable the HA if the number of replicas is greating than 1
14:12:05 <dulek> ltomasbo: Yes, at least in DevStack.
14:12:12 <ltomasbo> will it be possible to have it enabled by default even if you have 1 replica?
14:12:25 <dulek> ltomasbo: Sure thing, why do you want it though?
14:12:29 <ltomasbo> so that if at any point in time you want to increase the number of replicas, you can do so
14:12:57 <ltomasbo> I believe we will want to have HA by default
14:13:06 <dulek> ltomasbo: Ah, probably a good idea. Basing condition on replicas was apuimedo's idea.
14:13:19 <ltomasbo> but it will be nice for some testing/cases to have just 1 replica when you are not interested about it
14:13:49 <dulek> ltomasbo: All normal tempest will have just a single replica. I'm unable to run 2 on single-node due to port conflicts.
14:13:52 <ltomasbo> I understand it is better to see how it works (and have tempest) before making it the default I guess
14:14:08 <ltomasbo> I was just wondering if there was any problem with the election mechanism when the number of replicas is just 1
14:14:34 <dulek> ltomasbo: Shouldn't be, I've tested that.
14:14:35 <ltomasbo> dulek, yes, that is the reason why I'm interested to have HA enabled, even with just 1 replica
14:14:43 <ltomasbo> great!
14:15:10 <dulek> ltomasbo: You want me to write a patch doing that? It won't be today though.
14:15:35 <ltomasbo> no hurry, just wanted to understand if there was a limitation of having HA enabled with just 1 replica
14:15:55 <ltomasbo> I guess that is just a devstack deployment issue, so, we can add it when we need it!
14:16:17 <dulek> ltomasbo: Yup, okay!
14:16:22 <ltomasbo> (and 'if' we need it)
14:16:37 <dulek> I guess that's all we have to share? :)
14:17:10 <ltomasbo> yep, I guess we can finish soon today! (or talk at kuryr channel)
14:17:18 <ltomasbo> I don't have anythin else
14:17:49 <ltomasbo> just pointing that it will be nice if you give your input to the kuryrCRD devref, as you already may have some requirements for the patch you worked on
14:17:51 <ltomasbo> dulek, ^^
14:18:02 <dulek> ltomasbo: Sure thing, I'll review it.
14:18:14 <ltomasbo> thanks!
14:18:30 <ltomasbo> #endmeeting