13:59:36 <celebdor1> #startmeeting kuryr
13:59:37 <openstack> Meeting started Mon Jul  2 13:59:36 2018 UTC and is due to finish in 60 minutes.  The chair is celebdor1. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:40 <openstack> The meeting name has been set to 'kuryr'
13:59:45 <celebdor1> Hello everybody
13:59:53 <celebdor1> and welcome to Kuryr's weekly meeting
13:59:58 <celebdor1> who's here today?
14:00:46 <ltomasbo_> o/
14:00:54 <dulek_> o/
14:02:05 <dmellado> o/ (After a *rushed* lunch)
14:02:20 <garyloug_> o/
14:02:30 <celebdor1> dmellado: I didn't even have lunch
14:02:33 <celebdor1> nor breakfast
14:02:38 <celebdor1> anyway
14:02:44 <celebdor1> let's get the party started
14:02:47 <dmellado> celebdor1: really? have you become a cyborg in the end?
14:02:49 <celebdor1> #topic kuryr-kubernetes
14:02:59 <celebdor1> dmellado: I turn to fasting until Octavia is fast
14:03:39 <dmellado> celebdor1: have you ever head about Sokushinbutsu
14:03:41 <dmellado> ?
14:03:43 <celebdor1> #info we had a flask related regression. dmellado spotted it and fixed it
14:03:43 <dmellado> take care
14:03:55 <dulek_> celebdor1: Hey, it was me who fixed it! :P
14:04:05 <dmellado> with the help of dulek_ and yboaron
14:04:10 <dmellado> it was a terrible CI incident
14:04:11 <celebdor1> oh
14:04:12 <dmellado> xD
14:04:15 <celebdor1> I thought it was dmellado
14:04:16 <dmellado> a collaborative effort
14:04:20 <celebdor1> well, both start with d
14:04:22 <dulek_> celebdor1: ltomasbo_ was working on that as well! :)
14:04:27 <celebdor1> and it was 2:30 in the morning when I saw it
14:04:29 <celebdor1> xD
14:04:32 <dmellado> dulek_: ltomasbo_ too? xD
14:04:33 <celebdor1> sorry dulek_
14:04:44 <dmellado> I thought all he did was patchwork
14:04:50 <dulek_> Talking about gate stability - this should help with LBaaS v2 occasional failures: https://review.openstack.org/#/c/579533/
14:05:00 <dmellado> dulek_: yep
14:05:03 <dmellado> in any case, regarding that
14:05:05 <celebdor1> #info multinode is finally working
14:05:06 <dulek_> And we should be fairly stable at the moment.
14:05:14 <dulek_> So I expect something breaks again soon. :)
14:05:21 <dmellado> let's move those to queens/stable branch
14:05:22 <dulek_> So use this time wisely!
14:05:24 <dmellado> when we realease r
14:05:29 <celebdor1> duldulgood point
14:05:32 <dmellado> dulek_: you mean drinking beers?
14:05:35 <dmellado> duldul xD
14:05:38 <celebdor1> damned keyboard
14:05:51 <dulek_> dmellado: No need. stable/queens is still on Zuul v2.
14:06:01 <dulek_> dmellado: And flask version there is fixed.
14:06:02 <celebdor1> #info we were not fully configuring neutron-lbaasv2 in gates
14:06:06 <dulek_> So no need for backports IMO.
14:06:09 <celebdor1> thanks for the fix dulek
14:06:25 <dmellado> dulek_: let's keep it for now and check if they move to zuulv3 at some point
14:06:38 <dmellado> it'd be fairly simple to move that to that branch if needed
14:06:48 <celebdor1> #info snapiri split zuul into smaller files
14:06:56 <dmellado> thanks snapiri !
14:07:01 <dulek_> dmellado: Agreed, I'm pretty sure no one will want to move .zuul.yaml to V3 in stable/queens. ;)
14:07:04 <dmellado> \o/
14:07:10 <celebdor1> #info lv jiawei fixed cgroups settings
14:07:44 <celebdor1> #info neutron's lbaasv2 implementation is officially deprecated
14:08:16 <dmellado> we'll keep those lbaas gates in master until next release
14:08:19 <celebdor1> #info yossi and ltomasbo_ have worked on stabilizing octavia's driver
14:08:21 <dmellado> then deprecate as well
14:08:30 <celebdor1> dmellado: until current release
14:08:37 <dmellado> celebdor1: that's what I meant
14:08:47 <dmellado> just different wording
14:08:48 <dmellado> xD
14:08:52 <ltomasbo_> celebdor1, we still have something to fix: https://review.openstack.org/#/c/579144
14:09:04 <ltomasbo_> dulek_, left a comment on: https://review.openstack.org/#/c/579144/5/kuryr_kubernetes/controller/drivers/lbaasv2.py
14:09:09 <celebdor1> #info dulek_ fixed the health binding address after flask behavior change
14:09:20 <dmellado> ltomasbo_: saw it
14:09:24 <ltomasbo_> dulek_, I'm not sure if that could affect other side effects
14:09:27 <celebdor1> ltomasbo_: I know. that's why I didn't say "fixed"
14:09:29 <celebdor1> xD
14:09:29 <dmellado> I'll give it a try on my env and review
14:09:42 <ltomasbo_> but I'm pretty much doing what it was already done when the id or provider was missing
14:10:01 <celebdor1> ok
14:10:10 <celebdor1> I think we covered most of what happened last week
14:10:12 <yboaron> ltomasbo_, will review it after the meeting
14:10:18 <celebdor1> What do we have on the plate for this week?
14:10:27 <dmellado> ltomasbo_: celebdor1 any info on the progress on the namespace SG thing?
14:10:34 <dulek_> ltomasbo_: Can't see it, you probably haven't submitted the comment.
14:10:34 <celebdor1> there is!
14:10:41 <celebdor1> ltomasbo_: has a prototype
14:10:43 <ltomasbo_> thanks yboaron! that I tested locally and it is working, but not sure if other cases are affected
14:10:44 <dmellado> I'll resume my NPS job and would like to take that into consideration
14:10:53 <dmellado> ltomasbo_: and you kept it for yourself
14:10:54 <dmellado> you greedy
14:10:57 <celebdor1> #info apuimedo sent a patch to enable openshift's DNS
14:11:03 <celebdor1> (on devstack
14:11:07 <ltomasbo_> celebdor1, dmellado: yes, I was about to test my PoC regarding that (but lost connection with the server...)
14:11:08 <celebdor1> the same should be done for kubernetes
14:11:18 <dmellado> celebdor1: I'm waiting on your tempest patch
14:11:21 <ltomasbo_> celebdor1, I found out some flakiness on devstack plugin though
14:11:23 <celebdor1> #info ltomasbo sent a PoC for openshift project isolation
14:11:32 <celebdor1> dmellado: I have it on the VM
14:11:34 <celebdor1> I'll push later
14:11:42 <celebdor1> how do I skip unless it is openshift?
14:11:52 <dmellado> you'd need to create a flag
14:11:54 <celebdor1> ltomasbo_: which flakiness?
14:11:58 <dmellado> just like we did last time
14:11:58 <celebdor1> dmellado: we don't have any?!
14:12:03 <dmellado> let me check if I can find it
14:12:05 <dmellado> we have a regex
14:12:07 <dmellado> on the gate
14:12:10 <dmellado> you can just define it there
14:12:13 <dmellado> or a flag
14:12:26 <celebdor1> #info peng liu is pushing forward with the standard multi vif effort
14:12:30 <ltomasbo_> security groups are awk-ed by 'default', so if any other sg has the string 'default' in it, it fails (as it happened to me on my PoC)
14:12:44 <ltomasbo_> so, I'll modify it as part of my patch to 'Default'
14:12:46 <dmellado> celebdor1: example
14:12:46 <celebdor1> ltomasbo_: that's funny
14:12:48 <dmellado> https://review.openstack.org/#/c/578062/
14:12:58 <celebdor1> thanks dmellado
14:13:00 <dmellado> ltomasbo_: can't you try to use id?
14:13:25 <dmellado> I mean, I'd try to avoid relying on names if possible
14:13:34 <celebdor1> #info dulek_ is improving devstack with octavia timeouts and API IPs
14:13:58 <dulek_> Yup, I have an issue there, hopefully it was related to https://review.openstack.org/#/c/579533/
14:14:09 <celebdor1> ok
14:14:14 <ltomasbo_> it is for deploying, and as it was relying on name, it was taking the wrong id when using my modification taht create a couple of extra SGs
14:14:49 <dmellado> ltomasbo_: huh, yeah, I've seen things like that in the past
14:14:51 <dmellado> blame devstack
14:15:02 <dmellado> I saw a tshirt on vancouver that it said
14:15:06 <dmellado> 'It fails on devstack'
14:15:08 <dmellado> xD
14:15:12 <ltomasbo_> cF
14:15:14 <ltomasbo_> xD
14:15:14 <dmellado> sadly I couldn't get to get a hold of it
14:15:16 <celebdor1> #info yboaron sent further documenation and tests for Openshift's routes
14:15:22 <celebdor1> folks... Review!
14:15:37 <dmellado> celebdor1: I will do that when it's documentation
14:15:44 <dmellado> you need a new keyboard! xD
14:16:20 <celebdor1> dmellado: I'm hungry
14:16:21 <dmellado> https://review.openstack.org/#/c/578806/
14:16:23 <celebdor1> I eat letters too
14:16:26 <dmellado> FYI folks
14:16:40 <dmellado> as long as you don't do like gabert and eat my chocolates I'm fine
14:17:01 <celebdor1> dmellado: what's with the ovn gate?
14:17:10 <dmellado> celebdor1: it was broken due to their devstack plugin
14:17:21 <dmellado> we'd need to rebase the make-it-voting patch and that'd be it
14:17:33 <celebdor1> also, please review danil's sriov patches
14:17:37 <dulek_> dmellado: I see it's performing better now, so I'm all for it.
14:17:37 <dmellado> but I'd keep it as n-v until it stabilyzes
14:18:07 <dmellado> dulek_: well, we can always make it nv anytime
14:18:10 <dmellado> so we SHOULD be
14:18:14 <dmellado> done with infra for a while
14:18:23 <celebdor1> dmellado: merge https://review.openstack.org/#/c/576853/1
14:18:24 <dulek_> :)
14:18:25 <dmellado> (now is when dulek_ tells me we have three issues at the same time)
14:18:55 <dulek_> dmellado: Nah, not yet. But no worries, I'm on PTO for Thursday and Friday, so I expect I'll find something on Wednesday.
14:19:07 <dmellado> dulek_: lol
14:19:19 <dmellado> no worries, I'll just make a change so it breaks there
14:19:21 <dmellado> xD
14:19:34 <dmellado> in any case congrats everyone who was involved into this
14:19:39 <dmellado> we made it work and multinode already
14:19:43 <celebdor1> xD
14:19:43 <dmellado> hoorray \o/
14:19:58 <celebdor1> openshift multinode is going to be a PITA
14:20:23 <celebdor1> anything else folks?
14:20:27 <celebdor1> I have nothing else for the meeting
14:20:36 <dmellado> https://toufayan-cdn.sirv.com/WP_SirvMediaLibrary/2014/12/napa_chicken_pita_salad.png
14:20:38 <dmellado> yeah
14:20:43 <dmellado> I've got another topic!
14:21:07 <dmellado> so, folks, next week's Mon I'd like to have a BJ
14:21:17 <dmellado> so we can further discuss topics for the Berlin summit
14:21:20 <dmellado> irenab: snapiri
14:21:30 <dmellado> I'll add to you and also some dell folks who are interested
14:21:47 <dmellado> danil might be too so I'll send the invite over the ML
14:22:11 <celebdor1> true
14:22:13 <celebdor1> :P
14:22:16 <celebdor1> ok, ok
14:22:22 <dmellado> and I guess that's it for now
14:22:27 <dmellado> thanks everyone for attending!
14:22:29 <AlexeyPerevalov> o/ hello
14:22:30 <celebdor1> #action dmellado to write abstracts
14:22:30 <dmellado> celebdor1: go for lunch!
14:22:32 <dmellado> xD
14:22:40 <celebdor1> #chair dmellado
14:22:41 <openstack> Current chairs: celebdor1 dmellado
14:22:51 <celebdor1> dmellado: unfortunately now I have to go pick up the kids
14:22:58 <celebdor1> and then join the meeting
14:22:58 <dmellado> celebdor1: ttyl in the meeting then
14:23:00 <dmellado> enjoy!
14:23:04 <celebdor1> I don't know when I'll be able to eat
14:23:12 <celebdor1> AlexeyPerevalov: hi
14:23:19 <AlexeyPerevalov> I still have to say something regarding vhostuser on baremetal installation.
14:23:26 <dmellado> AlexeyPerevalov: go for it
14:23:34 <AlexeyPerevalov> I already implemented PoC patche, now it's on internal code review. But I faced with issue on Kubernetes side.
14:23:47 <AlexeyPerevalov> It doesn't obtain ip from CNI output, it gets it from container's eth0 (
14:23:54 <AlexeyPerevalov> so I fixed it,
14:24:06 <AlexeyPerevalov> there    https://github.com/AlexeyPerevalov/kubernetes/commit/ba863551448b8f4fc92953097a589359dbf1a58c
14:24:17 <AlexeyPerevalov> need to discuss with Kubernetes community.
14:24:49 <AlexeyPerevalov> So I'll update spec, as soon it will be clear with kubernetes behaviour in case when we don't have eth0 inside container.
14:25:03 <dmellado> AlexeyPerevalov: but do you mean using kuryr as CNI with kubernetes?
14:25:20 <dulek_> AlexeyPerevalov: Hey, that's surprising that K8s doesn't follow the CNI spec.
14:25:24 <ltomasbo> btw, yboaron: seems a different modification in octavia was needed: https://review.openstack.org/#/c/579559/
14:25:28 <dmellado> totally
14:25:32 <dmellado> #chair dulek_ ltomasbo
14:25:33 <openstack> Current chairs: celebdor1 dmellado dulek_ ltomasbo
14:25:42 <dmellado> folks, I'll need to drop for a moment too
14:25:52 <dmellado> pls close the meeting when all is done
14:26:36 <AlexeyPerevalov> dulek_: for me too ) kubernetes unittests rely on eth0 as well
14:27:35 <AlexeyPerevalov> dmellado: kuryr-kubernetes, but not kuryr )
14:27:50 <dulek_> AlexeyPerevalov: Anything else to share? Do you have an action item for us?
14:28:15 <AlexeyPerevalov> dmelado: why you think about kuryr?
14:28:45 <AlexeyPerevalov> dulek_: yes, btw your CNI output is little bit out dated, kuryr-kubernetes tells 0.3.0 version, but format is in previous version (0.2.0), ;)
14:29:28 <AlexeyPerevalov> so I'm going to fix it too, now I'm working it around.
14:29:33 <dulek_> AlexeyPerevalov: Oh, this is totally a bug. Can you file it? bugs. https://bugs.launchpad.net/kuryr-kubernetes
14:29:39 <dulek_> AlexeyPerevalov: Awesome, thanks!
14:30:10 <AlexeyPerevalov> dulek_: ok, I'll file it.
14:31:09 <AlexeyPerevalov> that's all from my side.
14:32:06 <dulek_> Anyone else has something to share before we close the meeting?
14:32:11 <pliu> With regarding to the Multi-VIF driver, currently 2 approaches are proposed, however neither of it got enough comments.
14:32:52 <pliu> https://review.openstack.org/575629 and https://review.openstack.org/#/c/577070
14:34:36 <dulek_> Yeah, I need to walk through them as well. I guess dmellado and celebdor aka apuimedo should too.
14:35:14 <dulek_> Patches are now sitting in the limbo of my opened browser tabs. Hopefully that'll help them get my review. :)
14:36:05 <pliu> :) I am thinking that people can take a look at both patch and give comments. and help to find a way forward.
14:36:30 <dulek_> Sure!
14:36:58 <dulek_> So, anything else, anyone? :)
14:37:48 <pliu> BTW, https://review.openstack.org/#/c/578009/ is a reference implementation of https://review.openstack.org/575629
14:38:18 <dulek_> pliu: Okay, noted!
14:40:36 <dulek_> Okay, I guess this is the moment to close this. Thanks everyone!
14:41:01 <dulek_> #endmeeting