14:00:09 <dmellado> #startmeeting kuryr
14:00:10 <openstack> Meeting started Mon Jul 30 14:00:09 2018 UTC and is due to finish in 60 minutes.  The chair is dmellado. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <openstack> The meeting name has been set to 'kuryr'
14:00:23 <dmellado> Hi fellow kuryrs, who's here today and not on PTO? xD
14:01:03 <ltomasbo> o/
14:01:57 <AlexeyPerevalov_> o/
14:01:59 <dmellado> #chair ltomasbo
14:02:00 <openstack> Current chairs: dmellado ltomasbo
14:02:07 <garyloug> o/
14:02:08 <dulek> o/
14:02:15 <dmellado> #chair dulek
14:02:16 <openstack> Current chairs: dmellado dulek ltomasbo
14:02:45 <dmellado> a-ha, so we have quite a lot of usual suspects around, good!
14:03:02 <dmellado> I thought I'd be the only one back to 40ÂșC in the city, bummer!
14:03:22 <dmellado> #topic kuryr-kubernetes
14:04:03 <dmellado> All right, so, anyone has anything to share on this? I just arrived today and I've quite the backlog on reviews
14:04:15 <apuimedo> ~~
14:04:23 <dmellado> so if you're having any patch you'd like reviewed either wait or shout out to me
14:04:29 <dmellado> #chair apuimedo
14:04:29 <openstack> Current chairs: apuimedo dmellado dulek ltomasbo
14:04:35 <apuimedo> I'm no chair today
14:04:37 <apuimedo> :-)
14:04:43 <dmellado> apuimedo, you're table
14:04:45 <dmellado> xD
14:05:06 <dmellado> so, mimicking one colleague, who's ready for the EXCITEMENT? xD
14:05:15 <apuimedo> I'd rather be https://vignette.wikia.nocookie.net/dragonball/images/e/e0/MajinBuuChocolate.png/revision/latest/scale-to-width-down/640?cb=20110911111416
14:05:30 <apuimedo> the most burning issues as I see it are:
14:05:34 <apuimedo> - Multi vif reviews
14:05:49 <apuimedo> - Getting dulek's tempest test fix in
14:05:57 <apuimedo> merging all the eternally rebased tests
14:06:12 <apuimedo> asking ltomasbo what needs for his isolation stuff
14:06:39 <dmellado> apuimedo: all right, so that was what happened those past days?
14:06:47 <dmellado> dulek: what tempest tests apuimedo refers to?
14:07:00 <apuimedo> Round robin crap
14:07:13 <ltomasbo> xD
14:07:14 <dmellado> https://review.openstack.org/#/c/575629/
14:07:21 <dmellado> this is multi vif
14:07:27 <dulek> dmellado: https://review.openstack.org/#/c/583200/ ?
14:07:31 <dmellado> #link https://review.openstack.org/#/c/575629/ multi-vif
14:07:55 <dmellado> #link  https://review.openstack.org/#/c/583200/
14:08:00 <dmellado> dulek: oh, still the cmp? xD
14:09:04 <dmellado> yboaron, could you clarify those sleeps around there?
14:09:08 <dulek> dmellado: Yeah, yboaron had some remarks there.
14:09:18 <dmellado> dulek: yep, that's what I was checking
14:09:20 <dulek> I haven't looked at them too closely yet. :P
14:09:32 <dmellado> well, I'll take a look and review it again
14:09:45 <dmellado> today I feel like I haven't ever typed in a computer's keyboard
14:09:50 <dmellado> it kinda feels like my dad xD
14:10:21 <garyloug> dmellado, I've been doing some testing of nested DPDK against Pengs multi vif patch linked above. Just got it working in past few moments, need to test more but looks good :)
14:10:57 <dmellado> garyloug: awesome, IIRC before I went out peng mentioned that you had a meeting and synced on the implementation, wasn't it?
14:11:15 <garyloug> yea, we've been keeping in sync
14:11:56 <dmellado> awesome, please keep me in the loop for any future meetings that you'd have
14:12:03 <garyloug> will do
14:12:20 <ltomasbo> in my case (namespace isolation) I'm going to reshuffle a bit the drivers so that SGs get created on the sg driver instead of the subnet driver (as dulek suggested)
14:12:26 <ltomasbo> apuimedo, ^^
14:12:49 <dmellado> garyloug: btw, I'll assign you this blueprint
14:13:01 <ltomasbo> it was already working before my 2 weeks vacations, but missing unittesting and such, and now I'll do the polishing
14:13:04 <dmellado> seems apuimedo is still marked as a responsible for it
14:13:13 <apuimedo> ltomasbo: sounds good
14:13:29 <apuimedo> dmellado: I'm responsible?
14:13:32 <dmellado> ltomasbo: cool, I'll sync with you during this week to see overlapping work
14:13:34 <dmellado> apuimedo: you are
14:13:39 <apuimedo> dmellado: for what?
14:13:42 <dmellado> I mean, you're not, but you're marked as assignee
14:13:44 <garyloug> dmellado, which BP?
14:13:44 <dmellado> xD
14:13:52 <dmellado> https://blueprints.launchpad.net/kuryr-kubernetes/+spec/multi-vif-pods
14:13:55 <dmellado> garyloug: apuimedo ^^
14:14:09 <dmellado> garyloug: that's the one marked as partially implemented in your commit
14:14:45 <dmellado> the multi-vif in any case ;)
14:15:12 <apuimedo> dmellado: should be moved to Peng Liu or Gary Loughane
14:15:18 <apuimedo> dmellado: make it so
14:15:27 <dmellado> apuimedo: that's what I just did
14:15:30 <dmellado> no worries
14:15:46 <garyloug> Ah right I see, yea Pengs commit partially impliments. Yea Peng or I, whichever :)
14:15:57 <dmellado> garyloug: you got the prize ;)
14:16:04 <garyloug> lol
14:18:03 <dmellado> garyloug: I'm assuming you'll couple that with some tempest tests, won't you?
14:18:13 <garyloug> yep
14:18:24 <dmellado> awesome, thanks!
14:18:56 <dmellado> #action review pending rebased tests
14:19:07 <dmellado> ltomasbo: dulek apuimedo pls do take a look at those
14:19:26 <dulek> Sure!
14:19:26 <apuimedo> ok
14:19:51 <dmellado> #topic kuryr-libnetwork
14:20:16 <dmellado> There were some patches from hongbin which should be fine for now, but please do take a look if you get the chance
14:20:37 <dmellado> #topic open discussion
14:20:49 <dmellado> anything else you'd like to share? how were your holidays? xD
14:21:19 <AlexeyPerevalov_> I would like to ask about Danil's patches, regarding SRIOV.  Peng Liu has an objections there.
14:21:39 <AlexeyPerevalov_> Danil's patches weren't rebased on multi vif.
14:21:55 <dmellado> garyloug: maybe you can comment on that too
14:22:08 <apuimedo> AlexeyPerevalov_: do you know what was the nature of the objections?
14:22:17 <AlexeyPerevalov_> Do you expect these patches to be rebased on multi-vif?
14:22:22 <AlexeyPerevalov_> 1. not rebased
14:23:07 <AlexeyPerevalov_> 2. OIR, Liu proposed a way with kubernetes sriov device plugin instead of OIR.
14:24:47 <AlexeyPerevalov_> the second one requires modification of spec. It can simplify kuryr-kubernetes patch, but need improvements on sriov-device-plugin side.
14:25:07 <dmellado> AlexeyPerevalov_: I'll take a look at the patches and comment out there
14:25:17 <dmellado> in any case I'd really encourage you to sync up with garyloug and peng on the topic
14:25:33 <dmellado> if needed, we can to a bluejeans meeting to fully discuss the topic
14:26:05 <garyloug> dmellado, same I need to look at the other patches
14:26:08 <dmellado> #action (dmellado) review sriov patches, check pliu objections and set up a virtual meeting if needed
14:26:14 <dmellado> thanks garyloug
14:26:15 <garyloug> Bluejeans might be a good idea
14:26:17 <AlexeyPerevalov_> dmellado: no problem ),  yes I think special meeting regarding second point (sriov-device-plugin) would be great
14:26:37 <dmellado> sure, I'll set that up for next week, will send an email to the ML with the invite
14:27:14 <dmellado> thanks for bringing the topic AlexeyPerevalov_
14:27:32 <dmellado> btw regarding meetings and so
14:27:47 <dmellado> is there any of you (besides dulek) planning to attend Denver's PTG?
14:28:21 <dmellado> There's still a lot of time but I do plan to set up a virtual meeting too ;)
14:28:34 <AlexeyPerevalov_> I know Gary works with guys from sriov-device-plugin team, doesn't it? So maybe invite somebody from there, I told with Kural about that problem.
14:29:03 <dmellado> sure, garyloug maybe you can invite sean if you want
14:29:18 <garyloug> Yea, I work with the guys, I'll fwd to Kural
14:29:52 <dmellado> all right, anything else besides this?
14:29:54 <garyloug> dmellado, Sean has left, he works with you guys now :)
14:30:06 <dmellado> garyloug: oh, didn't know! maybe I'll have to invite him myself xD
14:30:16 <garyloug> ok :D
14:31:58 <dmellado> all right folks, so then let's call it a day and save some meeting time
14:32:09 <dmellado> garyloug: AlexeyPerevalov_ I'll send an invite, probably for next Mon ;)
14:32:11 <dmellado> thanks all!
14:32:19 <garyloug> cool, bye!
14:32:29 <AlexeyPerevalov_> bye!
14:32:31 <dmellado> #endmeeting kuryr