13:59:56 <celebdor> #startmeeting kuryr
13:59:57 <openstack> Meeting started Mon Aug 13 13:59:56 2018 UTC and is due to finish in 60 minutes.  The chair is celebdor. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:00 <openstack> The meeting name has been set to 'kuryr'
14:00:05 <celebdor> Hello and welcome to Kuryr's weekly meeting!
14:00:26 <celebdor> this week it is PTO edition since a lot of the contributors are on PTO
14:00:43 <celebdor> who is blessed with lack of PTO and is attending the meeting?
14:01:22 <garyloug_> o/
14:01:26 <AlexeyPerevalov> o/
14:02:10 <celebdor> ltomasbo: irenab: maybe here?
14:02:20 <celebdor> pliu: ?
14:05:23 <celebdor> alright then
14:05:43 <celebdor> #topic kuryr-kubernetes
14:06:12 <celebdor> #info We are practically on release time
14:06:30 <celebdor> #info apuimedo's been working on reducing test flakiness
14:06:46 <pliu> celebdor, hi
14:07:00 <celebdor> AlexeyPerevalov: you've been moving your SR-IOV work on top of pliu's multivif work
14:07:04 <celebdor> right?
14:07:26 <celebdor> shouldn't it need some devstack patch to install and configure a deviceplugin?
14:07:31 <celebdor> pliu: hi!
14:07:31 <AlexeyPerevalov> yes, and I touched his patch.
14:07:49 <AlexeyPerevalov> But there https://review.openstack.org/#/c/590662/2..3 no changes, just commit message was updated.
14:08:10 <AlexeyPerevalov> I think, it was due to I used git push gerrit ... instead of git review.
14:08:21 <celebdor> maybe
14:09:31 <AlexeyPerevalov> I used git review before this accident. But git review sometimes removed bp: field from my patches ) so I just tried w/o git review.
14:10:25 <pliu> 590662, it failed the gate, seems like a ci problem.
14:11:16 <AlexeyPerevalov> pliu: I think recheck would be helpfull here.
14:12:04 <AlexeyPerevalov> pliu, celebdor: we had sriov pod driver reference in VIFHandler, I tried to avoid it by introducing new interface in https://review.openstack.org/#/c/591352/1
14:12:45 <celebdor> pliu: it definitely looks like a ci problem
14:12:56 <celebdor> I'm trying to reduce the flakiness with the backend tests
14:13:07 <celebdor> (which IIRC are the ones that fail most often)
14:13:30 <AlexeyPerevalov> this one 591352 is not yet finished, need to rewrite OIR code. I'm doing it now.
14:13:35 <pliu> AlexeyPerevalov,I'll review it.
14:14:03 <celebdor> AlexeyPerevalov: rewrite or replace?
14:14:15 <AlexeyPerevalov> pliu: great, it touches you multivif as well.
14:14:17 <celebdor> I thought with DevicePlugin it's not OIR anymore
14:14:24 <celebdor> but it maybe is just a form of OIR
14:15:09 <AlexeyPerevalov> celebdor: replace by code which work with npwg specified sriov definition (k8s.v1.cni.cncf.io/networks: sriov-net1 ...)
14:15:42 <AlexeyPerevalov> celebdor: right
14:17:50 <celebdor> ok
14:17:55 <celebdor> thanks AlexeyPerevalov
14:18:09 <pliu> AlexeyPerevalov, my colleague is working on a document which explains the machnism of SRIOV device plugin annotate the Node. I think that may be helpful for your patch
14:18:48 <pliu> AlexeyPerevalov, I can check with him see when it will be released.
14:18:53 <celebdor> pliu: that's great
14:19:01 <celebdor> please, send it to me when it is published
14:19:06 <pliu> sure
14:19:10 <AlexeyPerevalov> pliu: great
14:19:10 <celebdor> I'm a bit out of date with that
14:19:30 <pliu> he refactor the sriov device plugin
14:19:43 <AlexeyPerevalov> I already saw npwg spec/sriov device spec
14:20:10 <pliu> so, it will not need the cni-shim and gRPC any more.
14:20:32 <AlexeyPerevalov> pliu: sounds good )
14:20:39 <celebdor> I look forwatd to gRPC as CNI calling mechanism instead of executables
14:20:54 <celebdor> so we can just keep the CNI daemon and drop the exec part
14:22:01 <pliu> code is in the branch, https://github.com/intel/sriov-network-device-plugin/tree/dev/k8s-deviceid-model
14:22:08 <celebdor> thanks pliu
14:22:33 <AlexeyPerevalov> in production we're using containerized daemon, but in dev environment I prefer just standalone runnable executable.
14:22:47 <pliu> celebdor, np
14:22:59 <celebdor> pliu: seems easy enough to add to devstack
14:23:41 <celebdor> pliu: does the dp container really need to be built? Aren't there "official" images?
14:23:55 <celebdor> or tarball releases
14:24:20 <pliu> I don't think so. But there is a dockerfile
14:24:32 <AlexeyPerevalov> pliu: now we already using sriodp from that branch.
14:25:45 <pliu> AlexeyPerevalov, cool
14:26:25 <pliu> celebdor, https://github.com/intel/sriov-network-device-plugin/tree/dev/k8s-deviceid-model/images
14:26:50 <celebdor> thanks
14:27:04 <celebdor> Anything else? Anybody?
14:30:41 <celebdor> alright then.
14:30:46 <celebdor> Thank you all for joining!
14:31:02 <celebdor> #action pliu to review AlexeyPerevalov's sr-iov rebase
14:31:05 <celebdor> #endmeeting