14:00:51 <dmellado> #startmeeting kuryr
14:00:53 <openstack> Meeting started Mon Nov  5 14:00:51 2018 UTC and is due to finish in 60 minutes.  The chair is dmellado. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:56 <openstack> The meeting name has been set to 'kuryr'
14:01:02 <dmellado> Hi folks, who's here today for the Kuryr meeting?
14:01:09 <dmellado> I'm *back*, btw xD
14:01:32 <dmellado> apuimedo: dulek could you provide a summary of these two weeks, fellas?
14:01:36 <dulek> o/
14:01:52 * dulek was out for 50% of that time. :D
14:02:12 <dulek> And I haven't really got to Gerrit email folder yet.
14:02:54 <dmellado> heh, lol, me neither tbh, I have just approved a few patches from hongbin
14:03:01 <dmellado> related to kuryr-libnetwork gates
14:03:13 <dmellado> apuimedo: you were running the meetings, shoot :D
14:04:05 <dmellado> anyways
14:04:09 <dmellado> #topic kuryr-kubernetes
14:04:56 <dmellado> Next week we'll be at the OpenStack Summit, so I'd like to highlight a few sessions that we plan to cover there
14:05:01 <dmellado> #link https://www.openstack.org/summit/berlin-2018/summit-schedule/speakers/5168
14:05:17 <dmellado> dulek and me will be around, so don't be shy and feel free to join us
14:05:33 <dulek> It'll be fun!
14:05:50 * dmellado still needs to save some time for the slides
14:05:56 <dmellado> xD
14:05:58 <dmellado> anyways
14:06:07 <dulek> So from my side I'll most likely work on the remaining sessions preparation. Please ping me if anything is needed Gerrit-wise.
14:06:14 <dmellado> dulek sure
14:06:15 <dulek> dmellado: Are you online whole week?
14:06:37 <dmellado> dulek not really I guess, but besides Wed where I'll be moving
14:06:41 <dmellado> feel free to ping me anytime
14:06:50 <dulek> dmellado: Okay, great.
14:06:55 <dmellado> there's a bank holiday in Spain on Fri, I'm not sure if you were aware of that
14:07:16 <dmellado> dulek: in any case I'll try to organize a sync session with you on Thu ;)
14:07:38 <dmellado> so, besides that, I've been resuming the work on the network policies, which now support default behavior in terms of openness and close
14:07:44 <dmellado> and labels when creating deployments
14:07:45 <dmellado> dulek: apuimedo
14:07:54 <dmellado> I do plan to tackle the unit tests with ltomasbo on another patch
14:08:06 <dmellado> so I'll mark the patches as non-wip and it'd be great if we can start to merge those
14:08:28 <dmellado> #link https://review.openstack.org/#/c/605150/
14:08:34 <dmellado> and I'd love reviews on this one as well
14:08:50 <dulek> Sure!
14:08:50 <dmellado> #link https://review.openstack.org/#/c/608616/
14:08:58 <dmellado> I'm currently writing tempest tests for these
14:09:18 <dulek> I have a few patches that only need a second +2 as well: https://review.openstack.org/#/q/owner:%22Micha%25C5%2582+Dulko+%253Cmdulko%2540redhat.com%253E%22+status:open
14:09:34 <apuimedo> sorry, I was taking the kid to school
14:09:35 <dmellado> dulek, ack, will take a look
14:09:36 <apuimedo> I'm back
14:09:56 <dmellado> no worries apuimedo, I was just asking you for a quick summary on the meetings over this two weeks
14:10:11 <apuimedo> nothing much
14:10:28 <apuimedo> there were some patches to kuryr-libnetwork
14:10:50 <apuimedo> and on the kuryr-kubernetes front we were hunting some stuff happening with LBs
14:10:59 <apuimedo> races and such
14:11:01 <dmellado> oh, our friend octavia again
14:11:22 <apuimedo> I think this time it was our handling of it
14:11:27 <apuimedo> nothing else comes to mind right now
14:11:35 <dmellado> sounds fairly ok, thanks apuimedo
14:11:38 <apuimedo> dmellado: oh, now that I think about it
14:12:08 <apuimedo> I think we should consider moving to release independent so that we can time the releases with kubernetes/openshift
14:12:31 <dmellado> apuimedo: yeah, so about that I do plan to tackle that conversation with the TC folks next week over the summit
14:12:51 <dmellado> let's see if we can try to get an agreement on that with the releases and so
14:12:54 <dmellado> so no worries
14:12:55 <apuimedo> dmellado: very well
14:13:17 <dmellado> also, gmann and dims are part of the TC folks assigned to help kuryr so we'll get to have a chat with them about that
14:13:26 <apuimedo> cause things move more there than on our deps
14:13:33 <dmellado> exactly
14:13:47 <dmellado> is erjacobs around? I'd like to ask him about his progress
14:13:50 <dmellado> doesn't look like it
14:14:08 <apuimedo> no, he works a different day each week
14:14:50 <dmellado> a different day each week?
14:14:52 <dmellado> damn
14:14:57 <dmellado> that's going to be a nightmare to get in sync with
14:15:06 <dmellado> nevermind, I'll fill some etherpad or some sort
14:15:29 <apuimedo> :-)
14:15:39 <apuimedo> I only want to see deps dropped
14:15:41 * gmann reading with sleepy eyes..
14:15:54 <dmellado> hey gmann, morning! I'll treat you to coffee soon xD
14:15:54 <apuimedo> dulek: dmellado: what's the status of the multinode tests
14:15:56 <apuimedo> ?
14:16:25 <dmellado> not sure, there's still a ton of patches that I need to review
14:16:25 <dulek> apuimedo: I've just rebased HA gate commit that implements multinode.
14:16:39 <dulek> apuimedo: I think itzikb based his commit on top of mine.
14:16:40 <dmellado> dulek: anything from itzikb?
14:16:57 <gmann> dmellado: not yet slept, night for me. :)
14:17:18 <dulek> apuimedo: And I think I've gave him advice about how to make it work, not sure if he was successful with implementing it.
14:17:30 <apuimedo> dulek: quick question
14:17:32 <dmellado> gmann: heh, then just go get some rest, we'll sync soon
14:17:36 <apuimedo> before HA
14:18:00 <apuimedo> what happens when you change the deployment image which triggers the automatic rollout
14:18:15 <apuimedo> IIRC, first it will create the new kuryr controller
14:18:19 <apuimedo> and once that one is ready
14:18:33 <apuimedo> it will go and delete the other one
14:18:51 <apuimedo> so I'm wondering how the handover works
14:18:58 <apuimedo> both in HA and non-HA scenarios
14:19:06 <dulek> apuimedo: Oh, that would be totally wrong. One of the Kubernetes Deployments guarantee is that you will have specified number of replicas.
14:19:21 <dulek> I assume for deployments it will be other way around - delete the old one, start the new one.
14:19:25 <apuimedo> dulek: from what I saw today, what happens is what I described
14:19:27 <dulek> At least if replicas=1
14:19:32 <apuimedo> when replicas=1
14:19:34 <apuimedo> :-)
14:19:54 <dulek> apuimedo: Damn, that's not really okay. I'll investigate that.
14:20:59 <apuimedo> #action dulek to investigate controller rollout
14:21:08 <dulek> apuimedo: Hey, but that would be totally wrong for any other controller as well.
14:21:22 <dulek> apuimedo: E.g. kubernetes-controller-manager is A/P.
14:21:24 <apuimedo> dulek: I assume they have ways to deal with that
14:22:44 <apuimedo> as long as they become ready and don't fsck up anything
14:22:48 <apuimedo> it will just work fine
14:23:34 <dulek> apuimedo: Okay, I'll look ito that.
14:24:25 <dmellado> all right
14:24:47 <dmellado> so besides that, dulek, we'll get to sync with yboaron also on the SRIOV stuff before the summit
14:24:48 <apuimedo> thanks dulek
14:25:03 <dmellado> as the samsung folks will be there and we'll get a chance to f2f with them
14:25:23 <dmellado> and I guess that's it from my side for now if you don't have anything more to add ;)
14:26:14 <dulek> dmellado: I think I'm pretty briefed on SR-IOV - I've reviewed their patches.
14:26:32 <dmellado> dulek: cool then, we'll sync anyway so I'll be adding that to our to-sync-list
14:26:46 <dmellado> thanks all for attending!
14:26:50 <dmellado> #endmeeting