14:00:06 <dmellado> #startmeeting kuryr
14:00:06 <openstack> Meeting started Mon Dec 10 14:00:06 2018 UTC and is due to finish in 60 minutes.  The chair is dmellado. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <openstack> The meeting name has been set to 'kuryr'
14:00:14 <dmellado> Hi folks, who's around today?
14:00:16 <dulek> o/
14:00:19 <aperevalov> o/
14:00:21 <dmellado> #chair dulek
14:00:21 <ltomasbo> o/
14:00:22 <openstack> Current chairs: dmellado dulek
14:00:26 <dmellado> #chair ltomasbo
14:00:27 <openstack> Current chairs: dmellado dulek ltomasbo
14:01:18 <dmellado> hmmm seems like we're missing a few folks around here
14:01:18 <yboaron_> o/
14:01:23 <dmellado> #chair yboaron_
14:01:24 <openstack> Current chairs: dmellado dulek ltomasbo yboaron_
14:01:34 <dmellado> celebdor_:
14:01:40 <dmellado> lazy former ptl
14:01:43 <dmellado> xD
14:01:51 <dmellado> seems like we're also missing sean
14:02:45 <dmellado> I wanted to discuss the os-vif issue around here
14:02:52 <dmellado> dulek: I've seen your email replying to him
14:02:59 <dmellado> as I was away due to bank holidays
14:03:10 <dmellado> any additional concerns that you or anyone might have with this?
14:03:30 <dulek> Ah, I haven't checked again if I've got a reply to that email…
14:03:30 <dmellado> to put up some context on the ppl around here, it seems that os-vif is basically going to change stuff and break backwards compatibility
14:03:53 <dmellado> so we have two options, IMHO
14:03:54 <dulek> Hm, nop.e
14:04:16 <dmellado> 1) Check back with the os-vif folks, which I wanted to do today on the meeting
14:04:23 <dmellado> or 2) Just go and use kuryr-lib bindings
14:04:31 <dmellado> with my personal opinion going on the latter
14:04:47 <dmellado> I will also reply to dulek's email
14:05:10 <dmellado> with my preference and so, as I would've loved to get some more quorum and discussion on this here
14:05:26 <dmellado> so for the people that are around, any concerns on 2) ?
14:05:43 <celebdor_> I'm here
14:05:52 <celebdor_> I was dropping the kid at school
14:06:14 <dulek> dmellado: Remember that besides binding it also means copying os-vif o.vo's into our code.
14:06:20 <dulek> Otherwise we're unable to read older annotations.
14:06:44 <dmellado> dulek: yeah, that's why I said I'd address that on an email, as it'd imply some stuff like that
14:07:23 <celebdor_> dulek: you're right on the older annotations
14:07:31 <dmellado> celebdor_: any additional concerns you might have on this?
14:07:48 <dmellado> TBH, after the email I was thinking about filling a blueprint
14:08:03 <dmellado> but I don't think that this will be affecting to us only
14:08:12 <dmellado> and thus wanted to raise the flag with os-vif folks and the TC
14:08:29 <dmellado> as breaking backwards compatibility is something that probably won't be allowed
14:08:55 <dulek> dmellado: Well, they say that o.vo's serialization was never the public API.
14:09:28 <dulek> From my discussion with Sean they're really willing to do changes in such a way that we can easily support.
14:09:56 <dmellado> dulek: my concern is that this might happen again in the future
14:10:06 <dmellado> and we'd be better off with something that is under our control
14:10:35 <dmellado> but I'll follow up on the email. Sean told me that he'd be attending the meeting today but obviously he couldn't xD
14:11:05 <dulek> dmellado: Yeah, I get the argument. My concern with os-vif policy on that email is "we will support serialization in the future".
14:11:38 <dulek> For us it should be - we make necessary changes now, Kuryr folks swallow that and from now on it's stable, public API.
14:11:44 <dulek> With that I'd be fine.
14:11:44 <dmellado> dulek: yeah, I was looking for some reply there, let's see
14:11:46 <dmellado> +1
14:12:01 <dmellado> otherwise we'll go for our own version
14:12:48 <dulek> Fine with me, sounds like a fair trade-off for both teams.
14:13:08 <dulek> And I know that celebdor_ is for ditching it now. ;)
14:13:30 <dmellado> so, what else? I've a few more topics for the day but I don't want to monopolize the meeting
14:13:35 <dmellado> anything else anyone? xD
14:14:22 <aperevalov> maybe me, something regarding SR-IOV again )
14:14:27 <dmellado> aperevalov: shoot! ;)
14:14:50 <celebdor_> dulek: I'm for keeping it during 15
14:14:55 <celebdor_> and ditching it for 16
14:15:04 <dmellado> celebdor_: that's DS xD
14:15:06 <celebdor_> I meant, S and Train
14:15:08 <dulek> celebdor_: You mean Stein and train?
14:15:11 <dmellado> exactly
14:15:16 <celebdor_> I only remember train
14:15:19 <celebdor_> CHoo CHoooo
14:15:40 <aperevalov> we tald about tempest tests, so now it almost done, but now I'm in vacation ), but I have some point... it's about dummy implementation...
14:15:47 <dmellado> celebdor_: https://www.youtube.com/watch?v=4k8ICZoMIJ0
14:15:49 <aperevalov> w/o sriov hw
14:16:08 <celebdor_> aperevalov: what's the minimum kernel req for that?
14:16:38 <aperevalov> celebdor_, do you mean for none hw way of testing?
14:16:45 <celebdor_> yeah
14:16:48 <celebdor_> for gates
14:17:12 <dmellado> aperevalov: so basically we want to make sure that the dummy one is something that is supported on gates hw
14:17:58 <aperevalov> unfortunately it's impossible to do it w/o hardware right now, I tald with sean about it, he did the same reseach of kernel/qemu. I filled blueprint for it.
14:18:13 <dmellado> aperevalov: do you have any link for it?
14:19:07 <aperevalov> one moment
14:19:18 <dmellado> aperevalov: if that's the case the best case would be for this would be to have third party CI for kuryr with SRIOV hardware. Back there garyloug told that intel would be willing to provide such hw setup
14:19:23 <dmellado> but we'd need to double check with him
14:20:23 <aperevalov> celebdor_, please take a look at https://blueprints.launchpad.net/kuryr-kubernetes/+spec/test-sriov-ports-without-sriov-hw
14:21:35 <aperevalov> I assumed to do some mockup which doesn't require hw, but it requires sriov binding driver modification (some special mode). I feel it's not good idea ;)
14:21:50 <dmellado> #link https://blueprints.launchpad.net/kuryr-kubernetes/+spec/test-sriov-ports-without-sriov-hw
14:22:38 <dmellado> aperevalov: I'll check with the infra folks just in case, but seems like FT won't be possible for now, yeah
14:22:53 <aperevalov> regarding Gary, and his nested, I rebased, but upper-constraints.txt still has os-vif 1.11.1 reference, need to update it to 1.12, I already updated in patch (requirements.txt) to 1.12)
14:22:54 <dmellado> #action dmellado to check with infra re: sriov hw
14:22:59 <dulek> aperevalov: We've talked at the Summit that for the first step it's fine if you'll add a "dummy" SR-IOV binding driver.
14:23:11 <dulek> aperevalov: So I'm fine with this.
14:23:37 <dmellado> dulek: yeah, until 3rd party CI is set that's the max they would be able to do
14:23:51 <dmellado> I recall speaking with AJaeger about hw anyway, so I'll recheck
14:23:58 <aperevalov> dulek, ok. Separate driver or just a configuration tweak for current one?
14:24:33 <dmellado> from my side both would work, unless the strict dulek has any more concerns xD
14:24:45 <aperevalov> ;)
14:25:17 <dulek> aperevalov: Separate, just make it inherit from the current one. :)
14:25:48 <aperevalov> ok
14:25:57 <dmellado> all right, anything else on sriov?
14:27:36 <aperevalov> I think that all for now except this one https://review.openstack.org/#/c/616504/.
14:27:36 <aperevalov> And regarding DPDK, I hope Danil will check Gary's patch in run time.
14:28:02 <dmellado> awesome, thanks for all the update aperevalov
14:28:31 <dmellado> dulek: I'm pretty sure you'd have a new topic, besides Alhambra
14:29:11 <aperevalov> we changed interface and added container_id, it was necessary for DPDK on BM, but SR-IOV binding driver was merged w/o correct rebase. Also that patch adds unit tests.
14:29:12 <dulek> dmellado: Uhm…?
14:29:29 <dmellado> dulek: meeting topic, I meant ;)
14:29:38 <dulek> aperevalov: I have it opened, will review in next round. :)
14:29:47 <dmellado> otherwise, I can go
14:29:55 <dmellado> ltomasbo: around?
14:29:57 <dulek> dmellado: Well, we were to discuss the idea of dropping support for running non-containerized Kuryr-Kubernetes?
14:30:09 <ltomasbo> dmellado, have to leave now-ish for a meeting...
14:30:09 <dmellado> yep, CI stuff was my next topic
14:30:24 <dmellado> ltomasbo: go to your meeting, we'll sync afterwards
14:30:26 <ltomasbo> dmellado, I'll be reading... and trying to answer
14:30:47 <dmellado> just wanted to mention that regarding NP, we'll make a kuryr release supporting it within this week
14:30:52 <dmellado> I'll be finishing the devref
14:31:06 <dmellado> and putting up a few more tempest tests for its experimental gate
14:31:17 <aperevalov> we're using venv for development
14:32:05 <dmellado> #topic Upstream CI
14:32:23 <dmellado> here as dulek was saying I was thinking about changing both the documentation and the gates
14:32:37 <dmellado> and set containerized and daemonized as both the preferred installation mode
14:32:44 <dmellado> and the main gates there
14:32:46 <dmellado> https://review.openstack.org/#/c/623444/
14:33:11 <dmellado> from this patch, dulek had a few concerns where we agreed to keep the lbaas and the centos gate, at least for the cycle
14:33:23 <dmellado> so has anyone strong feelings about this? xD
14:34:37 <dulek> Soooo… Who's using kuryr-kubernetes anywhere? :D
14:34:53 <dulek> And can provide us with feedback on how they run it?
14:35:07 <dulek> Because that needs to be main decision factor.
14:35:29 <dulek> If we'll be breaking someone's use case, we're the evil breaking-backwards-compatibility guys.
14:35:30 <aperevalov> dulek, our production is containerized
14:35:45 <dulek> aperevalov: That's great to hear. :)
14:36:14 <dmellado> awesome, totally glad to hear that too
14:36:43 <dmellado> in any case also I'll send an email to the ML as I wanted to hear from irena and gary
14:36:53 <dmellado> and hongbin as well if possible
14:37:14 <dmellado> in the meanwhile I'll update my patch
14:38:11 <dmellado> and I'll try to make sure I don't become an evil guy in the process, dulek xD
14:38:46 <dmellado> #topic open discussion
14:40:51 <dmellado> All right, so it looks like that's it for today
14:40:56 <dmellado> thanks for attending, folks!
14:41:00 <dmellado> #endmeeting