17:02:14 <Sukhdev> #startmeeting l2_gateway
17:02:15 <openstack> Meeting started Mon Aug 31 17:02:14 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:16 <jroll> thanks everyone
17:02:19 <openstack> The meeting name has been set to 'l2_gateway'
17:02:21 <vikas> hi sukdev
17:02:37 <Sukhdev> armax: are you here?
17:03:02 <Sukhdev> vikas: hello
17:03:57 <vikas> i think we two are here
17:04:16 <Sukhdev> Looks like everybody else is missing :-)
17:04:32 <vikas> yes :-)
17:04:34 <jatin> hi Sukhdev and Vikas
17:04:44 <vikas> hi jatin
17:04:49 <Sukhdev> I just pinged armax  - hopefully, he will join in soon
17:04:57 <Sukhdev> #topic: Agenda
17:05:13 <Sukhdev> jatin: hello
17:05:19 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/L2Gateway
17:05:30 <Sukhdev> Did you have a chance to look at the agenda?
17:05:43 <Sukhdev> I fixed it around the patches that are under review
17:05:56 <jatin> Going through it
17:06:02 <Sukhdev> #topic: Announcements
17:06:20 <Sukhdev> Neutron FF is this week -
17:07:16 <Sukhdev> this FF does not impact us directly - but, this means the Liberty release is around the corner
17:07:52 <vikas> ok
17:08:18 <Sukhdev> #topic: Release Planning for Liberty
17:08:42 <Sukhdev> I approved several patches and they got merged
17:09:05 <Sukhdev> we still have few critical ones -
17:09:23 <Sukhdev> we'll cover them in the next topic
17:09:25 <vikas> but patches for stable/kilo were failing due to oslo import error
17:10:02 <Sukhdev> vikas: yes, that is why I am pining armax - he was working on getting it fixed
17:10:24 <vikas> ok fine then
17:10:47 <Sukhdev> he has not responded - I will find him later during the day and figure out how to proceed with that
17:11:07 <vikas> ok
17:11:25 <Sukhdev> vikas: please push the patches for stable/kilo - so that it can be reviewed
17:12:03 <Sukhdev> #topic: Patches under review
17:12:20 <Sukhdev> I listed bunch of patches that require attention
17:12:35 <Sukhdev> https://review.openstack.org/#/c/187950/ - should this be abandoned?
17:12:57 <Sukhdev> shivakumar is not here - do either of you know about this?
17:13:00 <vikas> i dont have any pathes pending for stable/kilo, already 2 pathes were under review
17:13:57 <Sukhdev> vikas: yup
17:14:12 <Sukhdev> that question was in general - maruti has couple of them
17:14:24 <vikas> ok
17:14:54 <Sukhdev> vikas: this one is for you - https://review.openstack.org/#/c/194921/
17:15:21 <Sukhdev> vikas: and this one too - https://review.openstack.org/#/c/194919/
17:15:50 <vikas> yes
17:15:54 <Sukhdev> both are failing because of py27 issue - which may mean the issue is with the patch
17:16:44 <Sukhdev> vikas: is this really the stable/kilo issue or something in the patch which is making test fail?
17:16:58 <vikas> no it was failing due to oslo imoprts
17:17:29 <vikas> i think it was fixed in master
17:17:59 <vikas> same thing to be backported to stable/kilo
17:18:24 <Sukhdev> vikas: Oh I see -
17:18:47 <Sukhdev> vikas: I will follow up with armax on this
17:19:24 <Sukhdev> vikas: on this - https://review.openstack.org/#/c/208524/
17:19:54 <Sukhdev> vikas: there are two issues with it - one is being discussed with armax and rusell
17:19:55 <vikas> ok sure
17:20:09 <Sukhdev> the second one has to do with the SSL support
17:20:17 <Sukhdev> I saw your email exchange on the subject
17:20:38 <vikas> yes sukdev..we can do it as a bugfix
17:20:47 <Sukhdev> people will not deploy it without SSL support - as tcp connections are not considered secure
17:20:55 <vikas> yes
17:21:02 <Sukhdev> vikas: how big is the fix?
17:21:16 <vikas> need to investigate on that
17:21:27 <Sukhdev> shall I file a new bug for this?
17:21:36 <vikas> yes
17:21:46 <Sukhdev> vikas: can we get that in ASAP so that it can go into liberty?
17:21:58 <Sukhdev> otherwise we have a half-baked solution
17:22:25 <Sukhdev> vikas: can you discuss it with maruti?
17:22:38 <vikas> no can we document that.saying this release will suport only tcp
17:22:56 <vikas> yes i will discuss this with maruti
17:23:22 <Sukhdev> vikas: well documentation will not help - as no body will deploy unsecured solution -
17:23:33 <vikas> ok
17:23:37 <Sukhdev> vikas: it is the issue of security and usefulness
17:24:03 <Sukhdev> vikas: will all the hackers around, people are very careful about security -
17:24:28 <Sukhdev> hence, they will not use this solution - and we want as many people jump on it as possible.
17:24:41 <Sukhdev> so, this is a chicken-n-egg issue :-)
17:24:43 <vikas> yes i understood but within this week frame work. i dont think so, because i need to investigate and come up with solution so
17:25:02 <Sukhdev> vikas: we have time -
17:25:11 <Sukhdev> Neutron FF is this week -
17:25:18 <Sukhdev> but, for our repo, we have time
17:25:41 <vikas> ok then i will discuss this with maruti
17:25:46 <Sukhdev> Liberty release is in the first part of Oct - so, we have almost a month
17:26:04 <vikas> ok
17:26:38 <Sukhdev> I will file the bug - and if you can investigate to get this going - otherwise, it will be shame that we have a solution, which no body wants to use
17:27:21 <vikas> yes got it
17:27:32 <Sukhdev> #action: Sukhdev to file a bug for SSL support for OVSDB server connection and vikas to discuss with maruti for the solution
17:27:58 <Sukhdev> i assigned an action both of us
17:28:04 <vikas> atleast this patchset should get merged..since ssl support  is depending upon this patchset
17:28:49 <Sukhdev> vikas: yes, we tested this, and it works - I will push armax to resolve the issue with russell so that I can approve this for merge
17:29:02 <vikas> ok fine
17:29:11 <Sukhdev> With this I am done with my agenda items
17:29:35 <Sukhdev> jatin: you have anything to cover?
17:29:51 <jatin> not really Sukhdev
17:30:16 <Sukhdev> jatin: OK cool
17:30:24 <Sukhdev> #topic: Open Discussion
17:30:33 <Sukhdev> I am done with the the agenda items -
17:30:45 <Sukhdev> do any of you have anything you want to bring up or discuss?
17:31:08 <vikas> no i dont have any
17:31:15 <jatin> No, Sukhdev.
17:31:37 <Sukhdev> cool - then, I guess - we are done
17:31:58 <vikas> ok..thanks sukdev
17:32:04 <jatin> Thanks everyone
17:32:07 <Sukhdev> vikas: please reach out to us via email when you make progress on ssl investigation
17:32:18 <vikas> yes sure
17:32:20 <Sukhdev> thanks folks for attending today
17:32:22 <Sukhdev> bye
17:32:27 <Sukhdev> #endmeeting