16:01:35 <VW> #startmeeting Large Deployments Team
16:01:35 <openstack> Meeting started Thu Jun 22 16:01:35 2017 UTC and is due to finish in 60 minutes.  The chair is VW. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:39 <openstack> The meeting name has been set to 'large_deployments_team'
16:02:35 <VW> will hang for a bit to see if anyone is around for the meeting
16:02:48 <ad_rien_1> o/
16:03:43 <VW> hey ad_rien_1
16:03:54 <ad_rien_1> hi VW
16:04:17 <ad_rien_1> (BTW, I'm ad_rien_ from the Fog/Edge/MDC WG just in case)
16:04:30 <VW> good to know k
16:04:33 <VW> and welcome!
16:04:40 <ad_rien_1> thanks
16:04:46 <VW> for anyone else attending and lurking, I updated the meeting wiki - https://wiki.openstack.org/wiki/Meetings/LDT#Current_Work_Items
16:05:11 <VW> also, picked up a trick from another meeting I'm in regularly to have running meeting notes in an etherpad
16:05:14 <VW> #link https://etherpad.openstack.org/p/LDT_meeting_notes
16:05:25 <VW> please put your names and such in there
16:06:18 <mdorman> hey sorry, here now.
16:06:26 <VW> howdy mdorman
16:07:03 <VW> looks like a light attendance this month, but that is cool.  I'd like to circle back to the summit stuff and try to start picking one or two things to go work on
16:07:10 <VW> #topic follow up to Boston
16:08:06 <VW> There were really two main areas of work from the Forum that we can follow up on - our own meetings and the VM and bare metal sessions that johnthetubaguy ran
16:08:35 <VW> I guess we can start with ours
16:08:41 <VW> take a minute to review
16:08:54 <VW> #link https://etherpad.openstack.org/p/BOS-forum-large-deployment-team
16:10:24 <VW> The neutron bits at line 26 had a little traction while still there
16:10:40 <VW> mdorman: do you know if there are any artifacts from our conversation with the Neutron devs that Thursday
16:11:56 <VW> also - ad_rien_1 - you think you all will still be able to talk about numbers around alternatives to rabbit in August
16:13:14 <ad_rien_1> you mean in August ?
16:13:35 <ad_rien_1> (we are progressing,  you can look to the recent discussion on the dev ML)
16:13:41 * ad_rien_1 is looking for the thread..
16:14:06 <mdorman> i don’t know of any other artifacts re: neutron discussions
16:15:03 <mdorman> i know klindgren talked to kbenton and others quite a bit and we came to some conclusions about neutron scaling strategies and a theoretical way forward for implementing a cells-like approach.  there may be some ML posts, i’m not sure.
16:15:39 <VW> thanks ad_rien_1 - would love to catch up on the thread.  and yes, was just touching base on progress.  Hoping to hear more in August
16:15:41 <ad_rien_1> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118716.html
16:15:57 <VW> thanks mdorman - was trying to make sure we had a way to chase progress
16:16:15 <VW> we had a conversation at a coffee shop, so I know we didn't write much down ;)
16:16:29 <ad_rien_1> Things are progressing, slowly but we are moving forward (redhat folks are doing a big effort, that's cool
16:16:30 <ad_rien_1> )
16:16:38 <mdorman> we can check with klindgren , he might know of some specs or something that are out there.  he’s traveling this week so i’m not sure he’s on IRC much
16:17:17 <VW> no worries
16:17:29 <VW> I'll give you an action to check with him before next meeting
16:17:56 <VW> #action mdorman follow up with klindgren on the neutron scaling stratigies
16:18:22 <VW> thanks ad_rien_1 noted it the running meeting etherpad too
16:18:39 <VW> anything else from the LDT session notes we need to discuss further?
16:19:33 <ad_rien_1> I underlined whether it makes sense to try to make a global point on alternative components/approaches for the whole OpenStack ecosystem.
16:20:06 <ad_rien_1> Don't know whether it makes sense for you (maybe this is too prospective from an operator viewpoint)?
16:20:27 <ad_rien_1> I gave as an example the dragonFlow project
16:20:37 <mdorman> don’t know if there’s anything else we ned to do with teh service catalog philosophy.  it sounds like we’re mostly aligned with nova devs on that, i guess.   i think the proposal for changing how the glance endpoint is discovered/configured (that spawed the discussion) was resolved in a way that we’re happy with.  i was surprised there was not more response to my ML post about that. but i guess that means nobody disagrees with us :)
16:21:06 <ad_rien_1> (please note that I didn't make this exercice yet so …)
16:21:46 <VW> fair enough ad_rien_1.  I do think there is a lot of interest in alternatives for common components like rabbit.  The general sense I get from operators is no one is in love with it
16:21:57 <VW> as for dragonflow, that's an alternative to ML2, correct?
16:22:15 <VW> mdorman: sorry - I'll admit I missed your thread
16:22:19 <VW> can you link?
16:23:06 <ad_rien_1> VW: to be honest I'm not a neutron expert so I don't know whether DragonFlow is just a driver or a complete reimplementation of Neutron.
16:23:51 <mdorman> VW: http://lists.openstack.org/pipermail/openstack-dev/2017-May/116574.html and http://lists.openstack.org/pipermail/openstack-operators/2017-May/013391.html
16:24:01 <mdorman> IIRC, mgagne was the only responder, and he was in agreement
16:24:02 <ad_rien_1> I just underlined that point during the boston F2F meeting because I attended one more presentation from this project and the evaluations they made on Neutron (default implementation) vs their proposal looks to be rigorous enough
16:24:45 <ad_rien_1> and Results clearly demonstrated the scalability as well as better performance in comparison to Neutron
16:24:49 <mdorman> anyway, point being, i don’t think there are any needed actions on teh service catalog topic.
16:24:58 <mgagne> yes, I agree with the LDT boston work session notes regarding catalog
16:25:40 <VW> cool, thanks mdorman
16:25:45 <VW> and hello mgagne
16:25:47 <ad_rien_1> I asked you whether it make sense to try to organize a working day where people can present alternatives solutions, explain the design choices they made and that enable them to propose better performance and finally the maturity of the proposal.
16:25:55 <mgagne> o/
16:26:08 <VW> I do think activities like that make some sense ad_rien_1
16:26:16 <ad_rien_1> ok
16:26:22 <VW> not sure the best way to organize - IRC, forum sessions, etc
16:28:09 <ad_rien_1> Don't get me wrong please, but as the large scale deployment team I'm expecting that you would have been familiar with alternatives that try to deliver more performance/scalability
16:28:47 <ad_rien_1> It looks to me important (but once again I'm not an operator, just a cloud architect/researcher that try to see how OpenStack can handle large scale and geo-distributed cloud infrastructures)
16:28:59 <VW> some, but there are so many things to keep up with, we don't always catch them all
16:29:35 <ad_rien_1> yes but organizing such a working day can be a way to try to see what are the new proposals?
16:29:50 <VW> yes - I agree
16:30:23 <ad_rien_1> (please if you have other points to discuss, let me know, I do not want to waste your time ;))
16:30:41 <VW> #action VW to follow up with Ops Meetup planning team on possible options for organizing "Alternative architecture proposal sessions "
16:31:11 <VW> not a waste of time at all.  Just need to go figure out how you structure that sort of thing to benefit the most folks
16:31:22 <ad_rien_1> Ops Meetup is in Mexico, isn't it? Not sure whether this will be the best place as developpers/new contributors come either to the PTG or the summit ?
16:31:34 <VW> probably the summit
16:31:40 <VW> but the meetup team plans things for there too
16:31:44 <ad_rien_1> ok
16:31:52 <VW> basically, they look after anything that is pulling OPs folks together
16:32:47 <klindgren> hrm - super late...
16:33:11 <VW> but always welcome
16:33:15 <VW> hi klindgren
16:33:17 <ad_rien_1> Another example is related to the recent discussion regarding keystone/cockroack and I'm pretty sure there have been/are other stuffs
16:34:04 <ad_rien_1> It looks to me important to give a look at those actions, investigate pros/cons and them try to discuss with core-devs to push them (if this makes sense obviously)
16:34:08 <VW> yeah - I'm surper interested in cockroachdb since we run our control plane as VMs
16:34:23 <VW> Ok - I'll see what I can do with that then
16:34:55 <ad_rien_1> (BTW, we have started a preliminary study regarding cockroach within the FEMDC WG)
16:35:33 <ad_rien_1> VW: maybe offline you can explain me why. I do not see the link between cockroach and the fact that you are running your control plane as VMs :-P
16:35:48 <ad_rien_1> you can mail me when you will have time. Thanks
16:36:21 <VW> hey klindgren - are there any mailing list threads or follow ups from the conversation we had with the Neutron folks in Boston
16:36:38 <klindgren> not that I know of
16:37:05 <VW> simply put ad_rien_1 - since we already use VMs for our cell and api level DBs, I'm intrigued by a cloud native approach that might support auto scaling, handle node failures, etc
16:37:40 <VW> ok - klindgren - thanks.  we need to figure out how to get that stuff encapsulated into something we can follow up on
16:39:42 <VW> alright - we have beaten up the LDT session etherpad
16:39:54 <VW> want to spend a few minutes on the VM and bare metal session stuff
16:40:00 <ad_rien_1> VW ok thanks for clarifying your viewpoint
16:40:07 <VW> take a few to review the following
16:40:23 <VW> #link https://etherpad.openstack.org/p/BOS-forum-operating-vm-and-baremetal
16:43:46 <VW> so, it looks like the top contenders are on about line 345 of that
16:44:34 <VW> I haven't been able to sync up with johnthetubaguy since Boston either
16:47:36 <VW> anything in there that jumps up high on the team's radar?
16:47:46 <mdorman> yeah i mostly missed that stuff at boston, too.  i’m reviewing the etherpad
16:48:42 <VW> my home is to pick one or two that LDT can really help push forward
16:48:52 <VW> maybe even get johnthetubaguy an others in a future meeting
16:48:57 <mdorman> nothing realy jumping out to me, other than, yeah this all looks like good stuff to look into, hah
16:49:13 <VW> he's UK though, it will be August (or October) before we can do that
16:49:17 <VW> but will try
16:49:33 <mdorman> there is one item about neutron scaling, which kind of parallels our previous discussion that came out of our session
16:49:46 <VW> #action VW to get johnthetubaguy or other key folks from VM and Bare Metal group to join future LDT meetings
16:49:50 <VW> yeah - saw that mdorman
16:50:01 <VW> we'll need to see if we can bring those to convergance
16:51:57 <VW> OK - I'll also work on some mailing list follow up to all this
16:52:06 <VW> anyone have anything else?
16:52:12 <VW> #topic Other Business
16:54:12 <mdorman> none for me.  thanks as always for organizing VW
16:54:23 <VW> sure thing
16:54:33 <VW> I'll start doing a better job of promotion too
16:54:51 <VW> unless anyone else has anything, I'll give you all a few minutes back
16:55:43 <ad_rien_1> just one question, are there still important connections with the Performance team?
16:56:08 <VW> There should be.  I don't know if we have an active member in both
16:56:25 <VW> although, they have often been in our summit/forum sessions
16:56:33 <ad_rien_1> or things are rather calm
16:56:49 <ad_rien_1> ok thanks VW
16:58:15 <VW> sure thing
16:58:29 <VW> Ok - Next meeting is July 21 at 03:00 UTC
16:58:41 <VW> with that, enjoy the rest of your day, folks!
16:58:45 <VW> #endmeeting