09:00:01 <ttx> #startmeeting large_scale_sig
09:00:02 <openstack> Meeting started Wed Jan 29 09:00:01 2020 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:05 <openstack> The meeting name has been set to 'large_scale_sig'
09:00:07 <ttx> #topic Rollcall
09:00:12 <oneswig> hello
09:00:14 <belmoreira> o/
09:00:19 <ttx> Hi everyone!
09:00:24 <jiaopengju1> hi
09:00:29 <ttx> Agenda at:
09:00:33 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
09:00:46 <ttx> I reordered it a bit to give masahito time to join before we discuss oslo.metrics
09:01:21 <ttx> amorin: around?
09:01:45 <oneswig> I must leave after 30 minutes, apologies
09:01:45 <amorin> Hello
09:01:50 <amorin> I am here
09:02:00 <ttx> ok let's start then
09:02:01 <Dinesh_Bhor> Hello, Sorry for being absent for a long time.
09:02:05 <mdelavergne> Hi
09:02:11 <ttx> #topic Progress on "Documenting large scale operations" goal
09:02:14 <masahito> o/
09:02:16 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-documentation
09:02:25 <ttx> We had the following action items from last meeting(s):
09:02:36 <ttx> - Collect and add links to relevant articles around large scale openstack (if you find any) to the etherpad
09:02:46 <ttx> We had some links filed from the Discovery initiative (experimentations on edge)
09:02:53 <ttx> But otherwise not that much
09:03:04 <ttx> But then maybe it's more of a long-term action, and we should just carry it over?
09:03:16 <Dinesh_Bhor> yes i think so
09:03:20 <oneswig> I think so.  New things will turn up
09:03:31 <ttx> It's more as we find them, to remember to add those to the etherpad :)
09:03:43 <ttx> - oneswig to follow up with Scientific community to find such articles
09:03:57 <ttx> oneswig: did you mention it on the Scientific SIG meeting ?
09:03:58 <belmoreira> I added few links today. But this will be a working in progress
09:04:38 <oneswig> ttx: I did.  We have meetings in two timezones and I raised it in both.  I think people looked at the etherpad but I don't think anything more was added by them, unfortunately.
09:05:00 <ttx> OK, I propose we have a standing item in meetings, to regularly review the list we collected so far... rather than an action item
09:05:12 <oneswig> However as above I'll keep looking for useful links from scientific sig discussions going forward.
09:05:15 <ttx> since this will basically never be "done"
09:05:43 <ttx> We can curate the list and categorize it on the etherpad itself
09:06:07 <ttx> does that work for everyone?
09:06:18 <oneswig> yes
09:06:24 <Dinesh_Bhor> +1
09:06:32 <ttx> The other action was around amorin's documenting configuration defaults for large scale
09:06:33 <jiaopengju1> +1
09:06:41 <ttx> amorin: How is that going ?
09:06:56 <amorin> hey all
09:06:56 <masahito> +1
09:07:11 <amorin> I did not had enough time to work on this topic
09:07:52 <ttx> That's fine. If you need help in specific areas just tell us
09:08:48 <ttx> As I mentioned when we started this, it's ok to go slowly. Members of this group all have demanding day jobs :) The essential is to make regular progress
09:09:05 <amorin> yup
09:09:23 <ttx> Anything else on that topic?
09:09:59 <ttx> I'll take that as a 'no'
09:10:00 <ttx> #topic "Scaling within one cluster" goal
09:10:05 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-cluster-scaling
09:10:14 <ttx> We had the following action items from last meeting(s):
09:10:24 <ttx> - all post short descriptions of what happens (what breaks first) when scaling up a single cluster
09:10:31 <ttx> #link https://etherpad.openstack.org/p/scaling-stories
09:10:40 <ttx> Nobody posted anything yet ^
09:10:55 <ttx> So... Is it that you did not find the time, or that you don't have anything to say, or somethign else?
09:11:13 <ttx> (trying to see if it's still a good idea)
09:11:31 <oneswig> The investigation I have been doing has been on instrumentation, and there may be a scaling story in that.
09:11:41 <ttx> personally, I don't have much to say because I do not operate a large scale cluster myself
09:11:55 <masahito> Just I didn't have much free time to do it :-(
09:12:19 <ttx> masahito: maybe just add a link to that presentation you did in Shanghai. I think that would be a great start :)
09:12:25 <Dinesh_Bhor> didn't find the time to document. For our case it was RabbitMQ, Nova-scheduler. Will add after the meeting.
09:12:58 <masahito> ttx: ah, okay. I didn't think of it. I'll do that.
09:13:22 <oneswig> masahito: I enjoyed your presentation in Shanghai - please do :-)
09:13:23 <ttx> My hope is that once we have a few things in there, we can ask again to the openstack-discuss list and get them to add to it
09:13:37 <ttx> It's just difficult to seed the list initially
09:14:01 <ttx> We can also make sure it's a topic discussed at future Ops Meetups
09:14:59 <ttx> ok next...
09:15:02 <ttx> - masahito to produce first draft for the oslo.metric blueprint
09:15:06 <ttx> #link https://review.opendev.org/#/c/704733/
09:15:47 <masahito> yes. This is actually a draft.
09:15:55 <ttx> I propose taht between now and next meeting, we all read the review the draft and comment as necessary
09:16:18 <oneswig> Nice work, will do.
09:16:27 <ttx> so that we iterate toward a final proposal
09:16:47 <ttx> Does that sound like a good idea ?
09:16:59 <amorin> ok for me
09:17:08 <jiaopengju1> I will review it
09:17:11 <ttx> #action all to review oslo.metrics draft at https://review.opendev.org/#/c/704733/
09:17:16 <masahito> Feel free to add you comment
09:17:24 <masahito> sorry, away from keyboard
09:17:45 <ttx> - all learn more about golden signals concept
09:17:52 <ttx> #link https://landing.google.com/sre/book.html
09:18:06 <ttx> I'll admit I did not find the time to read that
09:18:25 <Dinesh_Bhor> me too
09:18:33 <oneswig> It's quite fluffy... the details could be condensed
09:19:00 <amorin> I'll try to read it also
09:19:15 <oneswig> If possible I'd like to propose a kind of show and tell about some investigation we have been doing in this area
09:19:19 <oneswig> for the next meeting
09:19:19 <ttx> Is there a specific chapter we should focus on ?
09:19:33 <ttx> sure that would be perfect
09:19:54 <oneswig> probably this bit; https://landing.google.com/sre/sre-book/chapters/monitoring-distributed-systems/#xref_monitoring_golden-signals
09:20:12 <ttx> ok, that sounds more reasonable to digest
09:20:41 <ttx> Let's read that before next meeting as preparationfor your show-and-tell
09:20:50 <oneswig> One of my colleagues has been doing some good work on using telemetry from HAproxy in Monasca.
09:21:13 <ttx> #action all learn about golden signals by reading https://landing.google.com/sre/sre-book/chapters/monitoring-distributed-systems/#xref_monitoring_golden-signals
09:21:15 <oneswig> There have been recent developments (in the last year or so) which really improve the data available about API service times
09:21:41 <ttx> #action oneswig to prepare show-and-tell about some investigation they have been doing in this area
09:22:22 <oneswig> Will do.
09:22:28 <ttx> oneswig: how much time will you need ?
09:22:55 <oneswig> Probably 15 minutes, depends on how much detail is wanted.
09:23:09 <ttx> ok so it will fit the regular meeting ok
09:23:18 <oneswig> yes, no problem.
09:23:25 <ttx> Anything else on that topic ?
09:24:17 <oneswig> not from em
09:24:18 <ttx> #topic Other topics
09:24:19 <oneswig> me
09:24:23 <ttx> Last meeting belmiro proposed a every-two-week cadence.
09:24:34 <ttx> If that still works for everyone, I will officially add the Large Scale SIG meeting so that it appears on the official meetings agenda at http://eavesdrop.openstack.org/
09:25:06 <amorin> ok for me
09:25:13 <ttx> #action ttx to add meeting to eavesdrop on a every-two-week cadence
09:25:17 <ttx> #info next meeting Feb 12, 9utc
09:25:31 <ttx> Is that ok for everyone ?
09:25:36 <Dinesh_Bhor> yes
09:25:38 <jiaopengju1> it's ok for me
09:26:05 <ttx> OK, is there anything else you wanted to discuss in this meeting?
09:26:21 <ttx> anything else we should be doing between now and next meeting?
09:27:21 <ttx> If not, I'll post a summary with all the action items we just discussed. Please try to complete them by next meeting :)
09:27:55 <ttx> and close this one
09:28:02 <ttx> oneswig: in time for your next meeting :)
09:28:07 <Dinesh_Bhor> nothing from my side
09:28:15 <oneswig> perfect, thanks :-)
09:28:35 <ttx> Thanks everyone! Talk to you all again in two weeks!
09:28:41 <jiaopengju1> thanks
09:28:51 <ttx> Anyone from teh group present at FOSDEM this weekend?
09:29:01 <Dinesh_Bhor> Thanks everyone...
09:29:15 <ttx> belmoreira, amorin oneswig maybe
09:29:43 <belmoreira> I'm not going
09:29:43 <oneswig> sorry ttx, not this time for me at fosdem
09:30:05 <ttx> OK, I'll represent :)
09:30:12 <ttx> Thanks all
09:30:14 <ttx> #endmeeting