09:00:37 <ttx> #startmeeting large_scale_sig
09:00:38 <openstack> Meeting started Wed Mar 25 09:00:37 2020 UTC and is due to finish in 60 minutes. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:39 <mdelavergne> Hi!
09:00:41 <openstack> The meeting name has been set to 'large_scale_sig'
09:00:45 <ttx> #topic Rollcall
09:00:51 <ttx> Hi! Who is here for the Large Scale SIG meeting ?
09:00:59 <ttx> mdelavergne: hi! How is it going for you ?
09:01:01 <raymonddeng> great! haha
09:01:11 <raymonddeng> i am present for the large scale sig meeting
09:01:25 <ttx> raymonddeng: welcome!
09:01:49 <mdelavergne> Everything's fine, hope it is the same for everyone here :)
09:01:58 <ttx> pinging amorin belmoreira masahito jiaopengju2
09:02:09 <masahito> hi
09:02:27 <ttx> oneswig is not in channel
09:02:35 <etp> hi
09:02:36 <belmoreira> hi, thank for ping ttx
09:02:47 <ttx> masahito: how is the situation in Japan, masahito ?
09:03:03 <masahito> Not good :-<
09:03:31 <masahito> I'm working from home everyday....
09:03:36 <ttx> ok, same here
09:04:01 <masahito> But not a lock down, so I can go out side
09:04:14 <ttx> ah, here we are under strict lockdown
09:04:18 <ttx> (France)
09:04:27 <raymonddeng> where are you guys? i'm in los angeles, ca
09:04:54 <raymonddeng> most people work remotely right now here
09:05:18 <ttx> raymonddeng: mostly Europe (belmoreira, oneswig, amorin, me) and Asia (masahito, jiaopengju2...)
09:05:33 <mdelavergne> France also
09:05:44 <ttx> ok, let's get started
09:05:49 <ttx> Our agenda for today is at:
09:05:55 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
09:06:18 <ttx> I'll reorder the topics to give amorin and oneswig some time to join
09:06:27 <ttx> #topic Large scale operations now-virtual OpenDev track
09:06:35 <ttx> #link https://etherpad.openstack.org/p/LargeScaleOps_OpenDev
09:06:45 <ttx> We had a TODO for everyone to check/comment that etherpad...
09:06:53 <ttx> belmoreira: I suspect there will be changes to it as you all work out how to run it virtually ?
09:08:07 <belmoreira> I don't have more information... I think the work done will be re-used
09:08:33 <ttx> yeah, the general idea is to start the discussion on those topics through online sessions
09:08:45 <ttx> but some tracks are more likely to be successful at that than others
09:09:05 <ttx> so in the coming weeks there will be a set of discussions to see what should be done
09:09:23 <ttx> I'd say reviewing the etherpad is still useful, in that context
09:09:45 <ttx> belmoreira: anything else on that topic ?
09:10:08 <belmoreira> no, when I have more info I will let you know
09:10:19 <ttx> #topic Progress on "Scaling within one cluster" goal
09:10:27 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-cluster-scaling
09:10:37 <ttx> We had one TODO for everyone to review new patchset of oslo.metrics spec
09:10:41 <ttx> #link https://review.opendev.org/#/c/704733/
09:11:53 <ttx> masahito: do you plan to add the metrics information schema in a new patchset ?
09:12:16 <ttx> it seems to be the only item missing at this point before approval
09:13:00 <masahito> I want, but I'm not sure when I can finish it.
09:13:30 <ttx> masahito: would you rather wait, or push for approval at the current version ?
09:13:33 <masahito> Is the actual information required to be approved?
09:13:51 <ttx> masahito: probably not, we could push for approval under the current version
09:14:12 <ttx> I think bnemec was interested in getting the code out there as soon as possible
09:14:35 <ttx> so I'd rather focus on that part than on documenting the spec
09:14:40 <masahito> Ah, okay. then please push the patch set to be approved to make things forwards.
09:15:16 <ttx> masahito: when do you think the code could be pushed ?
09:15:41 <ttx> (I can also push for repository creation if it's ready, but I suspect you ahve to check a lot of things before doing that)
09:16:29 <ttx> #action ttx to push for oslo.metric spec approval
09:16:34 <masahito> maybe until end of April? I'm a bit busy in other task right now.
09:17:09 <ttx> masahito: I can imagine. No worry, just wondering about the general timeframe. So the spec approval is not super-urgent
09:17:24 <ttx> but would be good to have in the coming weeks
09:18:00 <ttx> #info masahito thinks the oslo.metric code could be pushed by end of April at the earliest
09:18:27 <ttx> OK, otherwiose we had no recent story posted on https://etherpad.openstack.org/p/scaling-stories
09:18:41 <ttx> oneswig had a TODO to contribute a scaling story on bare metal cluster scaling, but that was not done yet
09:18:53 <ttx> So I'll push it back to next meeting
09:19:07 <ttx> #action oneswig to contribute a scaling story on bare metal cluster scaling
09:19:19 <ttx> Anything else on the "Scaling within one cluster" goal ?
09:19:56 <ttx> ok, next topic then
09:20:01 <ttx> #topic Progress on "Documenting large scale operations" goal
09:20:07 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-documentation
09:20:17 <ttx> We had two TODOs for amorin from last meeting
09:20:41 <ttx> I haven't seen anything posted, but I may have missed it
09:20:53 <ttx> In doubt Ill push back those TODOs to next meeting
09:21:07 <ttx> #action amorin to create a wiki page for large scale documentation
09:21:17 <ttx> #action amorin to propose patch against Nova doc
09:21:47 <ttx> we discussed privsep in recent meetings... note that continuing the transition to privsep has been proposed as a Victoria (next cycle) goal:
09:21:54 <ttx> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-March/013409.html
09:22:02 <ttx> Feel free to chime in on that thread to encourage this, with your operator hat on !
09:22:29 <ttx> (it's not clear for everyone that this goal would have operational benefits)
09:23:03 <ttx> I'll try to help with that community goal
09:23:22 <ttx> Anything else on "Documenting large scale operations" ?
09:23:50 <ttx> #topic Next meeting
09:24:02 <ttx> We can do next meeting in two weeks, April 8.
09:24:10 <ttx> Since Europe will switch to DST next week, we could easily move the meeting to 8 UTC (one hour earlier for Japan and China) if that helps
09:24:29 <ttx> raymonddeng, masahito: would it be better or worse for you?
09:25:11 <raymonddeng> it's about the same for me
09:26:13 <masahito> It works for me.
09:26:14 <ttx> belmoreira: any preference?
09:26:41 <ttx> (8utc would keep it at 10am for us)
09:27:51 <ttx> ok, let's try it
09:27:55 <ttx> #info next meeting: April 8, 8:00UTC
09:28:03 <ttx> I'll post the meeting change to update the meeting calendar and all.
09:28:08 <ttx> #topic Open discussion
09:28:31 <ttx> raymonddeng: was there anything specific you wanted to discuss? Any particular reason for joining the SIG?
09:28:55 <ttx> (like, are you running a large scale deployment yourself?)
09:29:45 <ttx> FWIW, the SIG has tried to avoid boiling the ocean, and that's why we tried to set reasonable, focused goals to start
09:30:27 <ttx> but the SIG obviously goes where its active members push it, so if there is anything you'd like to lead, it's pretty open :)
09:31:11 <raymonddeng> no i didn't have anything specific to discuss, i found this sig a few hours ago and was fortunate that the meeting was about to start
09:31:28 <ttx> ah! perfect timing indeed
09:31:35 <raymonddeng> i'm a university student interested in 'large scale infrastructure', doing some devops stuff at Code for America and another company and wanted to see what this sig was about see what was
09:31:54 <raymonddeng> oops, **and wanted to see what this sig was about
09:32:10 <raymonddeng> yeah very fortunate timing
09:32:20 <ttx> The general goal is to try to regroup people with common problems, so that they can work on common solutions
09:32:43 <ttx> ah, we lost raymond
09:33:10 <mdelavergne> this timing was not so fortunate :p
09:33:13 <ttx> lol
09:33:33 <ttx> Oh well, that probably means the meeting is over, unless anyone has anything more to discuss?
09:33:50 <ttx> raymonddeng: Welcome back! The general goal of SIGs is to try to regroup people with common problems, so that they can work on common solutions
09:34:19 <ttx> So here we are trying to regroup operators of large scale infrastructure (based on openstack) so that they share problems and work on solutions
09:34:55 <ttx> traditionally everyone work on solutions on their side, resulting in lots of duplication of effort
09:35:27 <ttx> and the software does not get any better in handling the problems for the next person
09:36:05 <ttx> This SIG is trying to solve that, pool resources to work on the same objectives, and ultimately improve the software
09:36:37 <ttx> It's not easy, as we all have other day jobs, but it's important :)
09:37:15 <ttx> And on those good words, I think we can close today's meeting, unless anyone else has anything to add
09:37:50 <raymonddeng> definitely very important, really impressive that you guys handle day jobs and os contributions
09:37:58 <raymonddeng> hope i can help out in some capacity!
09:38:05 <ttx> raymonddeng: I hope so! Thanks for joining
09:38:14 <ttx> Thanks everyone for attending the meeting! Stay safe!
09:38:18 <ttx> #endmeeting