08:00:04 <ttx> #startmeeting large_scale_sig
08:00:05 <openstack> Meeting started Wed Aug 26 08:00:04 2020 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:08 <openstack> The meeting name has been set to 'large_scale_sig'
08:00:10 <ttx> #topic Rollcall
08:00:16 <ttx> Who is here for the Large Scale SIG meeting ?
08:01:06 <ttx> amorin, belmoreira, tobberydberg maybe
08:01:49 <belmoreira> o/
08:02:09 <belmoreira> thanks for the ping
08:02:23 <masahito> o/
08:02:24 <tobberydberg> I'm here, but haven't been much part in the Large Scale SIG though ;-)
08:02:36 <ttx> heh
08:02:59 <ttx> Alright, let's start and see if anyone else joins
08:03:02 <ttx> Our agenda for today is at:
08:03:06 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
08:03:14 <ttx> #topic Discuss fail of first EU-US meeting
08:03:26 <ttx> As you know we recently decided to create a meeting rotation, to create a US-friendly meeting time
08:03:38 <ttx> Two weeks ago we had our first EU-US friendly meeting, but then we did not get anyone new showing up
08:03:50 <ttx> Obviously creating a new meeting in the middle of August is not optimal, but still that was disappointing
08:04:02 <ttx> We will need to make a bit more noise for the next one, and if nobody shows up again, reconsider our decision
08:04:16 <ttx> (There is no point in making it harder for APAC folks if we do not really get new members)
08:04:24 <ttx> Thoughts on that?
08:04:33 <belmoreira> +1
08:05:00 <belmoreira> there are large deployments in the US. Should we try to contact people directly?
08:05:30 <ttx> I had a few direct contacts based on https://etherpad.opendev.org/p/large-scale-sig
08:05:46 <ttx> and tried to send them direct email
08:06:17 <ttx> Beth said she can;t do IRC, the others said IRC was fine but did not show up at that first meeting
08:06:40 <ttx> But I agree, we should do personal contacts where we can
08:06:46 <ttx> in advance of the next one
08:07:09 <ttx> like people who participated actively to the opendev on large scale infra
08:07:46 <ttx> (James Penick, Erik Andersson...)
08:08:18 <ttx> If you have a personal contact that could be interested, don;t hesitate to ping them... like the week before
08:08:59 <belmoreira> sure
08:09:09 <ttx> #action all to contact US large deployment friends to invite them to next EU-US meeting
08:09:22 <ttx> ok, moving on
08:09:26 <ttx> #topic PTG/Summit plans
08:09:32 <ttx> We need to discuss if we want to do anything around the Summit and PTG in October
08:09:42 <ttx> As a reminder, our next summit will be virtual and happen on Oct 19-23, 2020
08:09:44 <amorin> hello
08:09:50 <ttx> There will be "forum sessions" there that we could leverage to get more input
08:09:52 <amorin> sorry I am late
08:09:54 <ttx> amorin: hi!
08:10:02 <mdelavergne> Hi, sorry I am late too
08:10:10 <ttx> There will also be a PTG (project teams gathering) on Oct 26-30, 2020
08:10:18 <ttx> This is more of a work event, where we could have a video meeting to discuss future SIG work if we wanted
08:10:30 <ttx> In both cases if we are interested we should engage quickly to book slots
08:10:41 <ttx> Personally I think we should definitely ask for a Forum session, for example around gathering scaling stories
08:10:54 <ttx> To act as a recruitment function but also to learn new things
08:11:10 <ttx> I'm less convinced that with the current level of activity/size of the group  we need a PTG group meeting.
08:11:28 <ttx> IRC is plenty enough to coordinate our slow work, so unless there is a particular activity we'd like to book time to synchronously work on...
08:11:36 <ttx> Thoughts?
08:11:37 <belmoreira> having a video meeting will be definitely more engaging, I think
08:12:21 <ttx> belmoreira: just for PTG or all the time?
08:12:35 <masahito> If there is chance to talk each other, the short video meeting seems to be nice.
08:12:37 <belmoreira> I was thinking for the PTG
08:12:54 <ttx> OK, so maybe a short one
08:13:12 <ttx> or two to match the two timezones
08:13:22 <amorin> how are working forum sessions, is it going to be with video meeting as well?
08:13:46 <ttx> I'm not sure yet... I assumed it would be opendev-style
08:14:03 <ttx> (opendev-the-event style)
08:14:14 <amorin> so with video on zoom, right?
08:14:20 <ttx> like a zoom meeting with a couple of moderators
08:14:25 <ttx> or meetpad
08:14:38 <ttx> right
08:14:49 <amorin> so if it is like that, maybe forum session is enough, we can meet over there and recruit new members / find new stories
08:15:19 <ttx> OK, so how about... a Forum session specifically to find new stories, a bit like that session at opendev-the-event
08:15:36 <amorin> +1
08:15:37 <belmoreira> I think it will be good for the group and it's also an opportunity to fin/interact with other people
08:15:39 <ttx> + one hour of video meeting to replace our regular meeting
08:15:47 <ttx> (at the PTG)
08:15:53 <belmoreira> +1
08:15:53 <amorin> works for me
08:16:16 <ttx> then if we identify potential new mebers in the Forum session we can follow up at the PTG
08:16:47 <ttx> OK, I'll fill the forms and file then with the required authorities
08:17:17 <ttx> I'll try to be close to our usual meeting times
08:17:32 <ttx> if those slots are still available
08:18:06 <ttx> #agreed One Forum session on scaling stories, One PTG short meeting to replace our regular meeting that week
08:18:15 <ttx> #action ttx to request Forum/PTG sessions
08:18:30 <ttx> ok, moving on to our regular topics
08:18:34 <ttx> #topic Progress on "Documenting large scale operations" goal
08:18:37 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-documentation
08:18:44 <ttx> First, osarchiver...
08:18:57 <ttx> (which was just mentioned again on openstack-discuss)
08:19:03 <ttx> What's the status of moving that upstream? I think it's stalled waiting on progress on OSops resurrection?
08:19:35 <amorin> on OVH side, we worked on applying some changes based on comments we receive on the ml
08:19:44 <amorin> we removed debian folder for example
08:19:59 <ttx> hah yes that will please zigo for sure
08:20:07 <amorin> yes
08:20:22 <amorin> so, for us it's good
08:20:35 <ttx> amorin: so next step is to make progress on resurrecting OSops
08:20:46 <amorin> yes
08:21:05 <ttx> belmoreira: we'll need to work with smcginnis to make progress on the governance side of it
08:21:26 <ttx> I might raise it on the TC channel
08:21:38 <belmoreira> great
08:21:47 <belmoreira> I'm happy to help on that
08:21:48 <ttx> #action ttx to push for OSops resurrection
08:21:56 <ttx> belmoreira: thanks
08:22:08 <ttx> #action belmoreira, ttx to push for OSops resurrection
08:22:25 <ttx> Second, we still need more config options on the Large scale configuration wiki page before we can push for a link in Nova doc
08:22:35 <ttx> amorin: do you have enough matter to work on, or should we just pause that until we have more participants working on it?
08:22:47 <amorin> yes, unfortunately I am not able to find enough time
08:22:56 <amorin> maybe we can pause that for now
08:23:03 <amorin> and stay focus on resurrecting osops?
08:23:15 <ttx> If the issue is more time than data, I'm fine carrying the work item over
08:23:30 <ttx> If you miss data to do it, then we should just pause it
08:23:38 <amorin> on the other end, we recently disccuss about rabbit binding issues on the ml
08:23:54 <amorin> and things in this topic could also be copied back to documentation
08:24:25 <ttx> amorin: your call, I can just carry over the #action, or just stop mentioning it every meeting :)
08:24:49 <amorin> ok, about nova, we can pause, we dont have enough data
08:24:58 <ttx> ok, done
08:25:36 <ttx> And finally our last workstream is around collecting metrics/billing stories
08:25:58 <ttx> Last I looked we only had OVH entry on that one
08:26:24 <ttx> belmoreira, masahito: do you think you could contribute CERN/LINE take on that?
08:26:52 <ttx> (line 36 of https://etherpad.opendev.org/p/large-scale-sig-documentation)
08:27:00 <belmoreira> yes, I can. The problem is committing when I'm going to do it.
08:27:28 <ttx> No commitment really. I just will continue to pester you for it regularly :)
08:27:44 <belmoreira> :)
08:27:54 <ttx> #action all to describe briefly how you solved metrics/billing in your deployment in https://etherpad.openstack.org/p/large-scale-sig-documentation
08:27:58 <ttx> Anything else on this topic?
08:28:23 <masahito> yes.
08:28:59 <ttx> masahito: yes you can contribute story, or yes you have something else on this topic?
08:29:59 <ttx> Assuming that was yes you can contribute story, and moving on to next topic
08:30:00 <masahito> ah, sorry. yes I can contribute story.
08:30:07 <ttx> #topic Progress on "Scaling within one cluster" goal
08:30:10 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-cluster-scaling
08:30:15 <ttx> First, update on the healthcheck/middleware ping discussion
08:30:19 <ttx> #link https://review.opendev.org/#/c/735385/
08:30:27 <ttx> I think we collectively made good progress to get it merged in oslo.messaging...
08:30:41 <ttx> I was hoping we'd have a go-ahead from sean-k-mooney or dansmith on your last reply:
08:30:45 <ttx> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-August/016697.html
08:31:18 <ttx> but I'll leave it to bnemec to get the approval timing right
08:31:55 <amorin> ok
08:31:59 <ttx> Second workstream is on oslo.metrics
08:32:03 <ttx> https://opendev.org/openstack/oslo.metrics
08:32:05 <amorin> should we ping back bnemec for this?
08:32:23 <ttx> amorin: I think he'll get to it. I think he's leaving some time for last minute objections
08:32:32 <amorin> ok
08:32:38 <amorin> so we wait for now, right?
08:32:43 <ttx> yes
08:32:46 <amorin> ack
08:33:22 <ttx> So on the oslo.metrics side, we need to make progress on two sides: try to find other users interested in running it, and improve the code base to make it more openstack-y
08:33:58 <amorin> I will ask someone at OVH if we can test this
08:34:00 <ttx> I'll try to work on adding basic tests, unless someone beats me to it
08:34:16 <ttx> so that we feel more comfortable with proposed changes
08:34:48 <ttx> masahito: the code we have in https://opendev.org/openstack/oslo.metrics is what you run at LINE currently? Or is there a difference?
08:35:40 <masahito> Basically same. But we have some improvement since I pushed the patch...
08:36:15 <ttx> masahito: ok, would be great to push it to oslo.metrics as well, when you get the chance
08:36:38 <ttx> I'd like to make a release with Victoria release
08:36:40 <masahito> I try to.
08:37:06 <ttx> #action masahito to push latest patches to oslo.metrics
08:37:22 <ttx> #action ttx to look into a basic test framework for oslo,metrics
08:37:50 <ttx> #action amorin to see if oslo.metrics could be tested at OVH
08:37:58 <ttx> Last workstream... we still need more scaling stories
08:38:00 <ttx> https://etherpad.openstack.org/p/scaling-stories
08:38:15 <ttx> we'll likely need to do a campaign to collect those, as our current outreach is not very efficient
08:38:24 <ttx> A forum session at next summit centered on that will help imho
08:38:32 <ttx> Anything else on this topic/goal?
08:39:12 <mdelavergne> not from my side
08:39:18 <ttx> #topic Next meeting
08:39:26 <ttx> Next meeting will be US-EU on Sept 9, 16utc.
08:39:42 <ttx> That's the one we'll need to make more noise about
08:39:56 <ttx> Who from this meeting will likely be able to also participate to this one?
08:40:06 <amorin> I do
08:40:22 <ttx> Thanks!
08:40:29 <ttx> Then next EU-APAC meeting will be Sept 23, 8utc.
08:40:34 <ttx> How does that sound?
08:41:02 <amorin> good
08:41:08 <belmoreira> good
08:41:10 <ttx> #info next meetings: Sep 9, 16:00UTC; Sep 23, 8:00UTC
08:41:30 <ttx> That's all I had... Any last thoughts? requests?
08:42:20 <ttx> OK then... thanks everyone!
08:42:26 <ttx> #endmeeting