15:00:48 <ttx> #startmeeting large_scale_sig
15:00:49 <openstack> Meeting started Wed May  5 15:00:48 2021 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:52 <openstack> The meeting name has been set to 'large_scale_sig'
15:00:55 <ttx> #topic Rollcall
15:00:59 <ttx> Who is here for the Large Scale SIG meeting ?
15:01:16 <belmoreira> o/
15:01:27 <mdelavergne> Hi!
15:01:39 <ttx> amorin: ping
15:01:47 <amorin> pong!
15:01:53 <imtiazc> I am
15:01:56 <amorin> (thanks)
15:02:02 <ttx> imtiazc: hi!
15:02:10 <ttx> I don't see Gene around
15:02:46 <ttx> priteau: in case you want to join us
15:02:58 <ttx> Our agenda for today is at:
15:03:02 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
15:03:02 <priteau> Good afternoon
15:03:14 <ttx> #topic OpenInfra Live show on May 20
15:03:24 <ttx> So... in two weeks we'll produce an OpenInfra.Live show
15:03:32 <ttx> Basically running our traditional video meeting but streaming it on YouTube Live, using Streamyard
15:03:43 <ttx> The title for the episode is: Upgrades in a Large Scale OpenStack infrastructure
15:03:55 <ttx> The format we discussed during PTG was to kick it off with a number of 3-5min presentations
15:04:14 <ttx> detailing how each of the guest speakers do upgrades on their large scale infrastructure, the challenges they run into, etc
15:04:26 <ttx> and then have an open discussion about those, asking questions to each other and taking questions from the YouTube chat
15:04:38 <ttx> We currently have belmoreira, amorin, mnaser signed up
15:04:48 <ttx> I reached out to Blizzard, Verizon and Box, unsuccessfully so far
15:04:57 <ttx> Also reached out to Stig, who said he could fill a seat but was not sure his deployments had a good story
15:05:05 <ttx> Anyone here interested in sharing how they do it?
15:05:40 <ttx> If not, any suggestion who else I should be reaching out to?
15:06:21 <belmoreira> maybe Bloomberg? Try contacting Chris
15:06:32 <ttx> +1 will do
15:06:46 <imtiazc> We sadly don't have a good in-place upgrade story. We brought up a separate deployment then migrated the workload. We did certain things to make the workload migration easy.
15:06:57 <imtiazc> If anyone is interested, I can talk about that.
15:07:10 <ttx> sad stories are good too!
15:07:19 <imtiazc> Sure :)
15:07:26 <belmoreira> imtiazc that's a good upgrade history!
15:07:37 <amorin> you know, our story is not amazing neither :)
15:07:42 <belmoreira> history/story :)
15:07:49 <ttx> imtiazc: I kinda like it, shows the low-tech approach / story
15:08:13 <mdelavergne> amorin just don't talk about fire? :(
15:08:28 <amorin> that's another story unfortunately :(
15:08:39 <imtiazc> Our choice of SDN provider complicated the process. So may be there are few lessons others can learn
15:08:44 <ttx> fire while upgrading would have been super extra fun
15:08:56 <belmoreira> how to upgrade a data centre?
15:08:58 <belmoreira> :)
15:09:03 <amorin> from external point of view maybe :)
15:09:20 <ttx> imtiazc: alright you're in!
15:09:38 <ttx> I'll try to get a couple more, between those I already reached to and Bloomberg / Stig
15:10:02 <ttx> 5-6 stories and guests sounds like a good number
15:10:13 <belmoreira> +1
15:10:28 <ttx> So start preparing a few slides to support your story, nothing fancy or long, just a visual aid
15:10:55 <ttx> Goal being to fit into 5-min, we can get into details with questions
15:11:00 <imtiazc> Did you say 3-5 mins per presenter?
15:11:04 <ttx> yeah
15:11:27 <ttx> like give the overall picture, and then we'll do questions, panel style
15:11:46 <amorin> ack
15:11:52 <ttx> Once I see ths lides I may be able to deduce a number of canned questions
15:11:57 <ttx> slides
15:12:16 <ttx> which I'll send in advance, but we'll also have live questions from the audience
15:12:26 <ttx> hopefully enough to fill the hour!
15:12:56 <ttx> (the goal is to do a full hour of show, so if we run dry I'll need your help in asking new questions
15:12:57 <amorin> you want us to bring the slides to you in advance?
15:13:11 <ttx> yes ideally I would combine them all in a single deck
15:13:23 <amorin> is a google slide ok for you?
15:14:03 <ttx> sure, Google slides is perfect. Worst case scenario I'll convert everything to PDF if we have a mix of formats
15:14:18 <ttx> so whatever works for you
15:14:23 <amorin> ack
15:14:32 <ttx> More generally, I think it would be good to committing to filling OpenInfra.Live schedule with future episodes of this show
15:14:46 <ttx> I call it the "Large Scale OpenStack" show, but if you have a better name suggestion, let me know
15:15:06 <ttx> I talked to the organizers and we can secure the July 1st slot (6 weeks after the May 20 episode).
15:15:21 <ttx> do y'all think we can make it?
15:15:32 <belmoreira> sounds good
15:15:40 <ttx> after that we might do a break over summer as a lot of us are Europeans with vacation plans
15:15:49 <amorin> that would replace our 2-weeks videos stream, right?
15:16:03 <ttx> yes the idea is to replace our video meeting with that
15:16:42 <ttx> and benefit from the high-value production and advertising the IOpenInfra Foundation does around openinfra.live
15:17:00 <ttx> which should be more apparent in tow weeks (we are just getting started)
15:17:13 <amorin> perfect
15:17:14 <ttx> We can also start thinking into the topic for the next one
15:17:21 <ttx> #link https://etherpad.opendev.org/p/large-scale-sig-lightning-talks
15:17:35 <ttx> Inception was a possibility\
15:18:18 <ttx> Or we could do Monitoring
15:18:51 <ttx> If we do Inception that would be main presentation / discussion, if we do Monitoring that would be more lightning talk style
15:19:11 <ttx> so maybe we should see first how the first one goes
15:19:31 <imtiazc> I can talk about what we have for monitoring or general "observability" of our OpenStack platform. How we measure SLA etc.
15:19:49 <ttx> that would be great. I know Gene wanted to talk about that too
15:20:49 <ttx> I talked with Stig about doing one around OpenStack-based supercomputers, which is a very specific facet of "large scale" but interesting
15:20:52 <amorin> we can talk about monitoring also
15:21:39 <ttx> ok, let's sleep on it and discuss next week
15:22:05 <ttx> Anything else on the "Large Scale OpenStack" show topic?
15:23:06 <ttx> ok moving on
15:23:10 <ttx> #topic Progress/Blockers
15:23:20 <ttx> * Stage 1 - Configure (amorin)
15:23:24 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/Configure
15:23:38 <amorin> nothing new here
15:24:36 <ttx> Yeah it would be good to make progress on the first questions in there... Like distros and drivers recommended at scale, but i don;t think we have a big enough sample to determine good answers for that
15:24:46 <ttx> (yet)
15:24:56 <ttx> * Stage 2 - Monitor (genekuo)
15:24:59 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/Monitor
15:25:27 <ttx> nothing new there as well
15:25:37 <ttx> * Stage 3 - Scale Up (ttx)
15:25:42 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/ScaleUp
15:26:16 <ttx> We ran out of unasnwered questions in there, so it's probably time to post new ones, if you have ideas
15:26:32 <ttx> # Stage 4/5 - Scale Out, upgrade & maintain (belmoreira)
15:26:36 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/ScaleOut
15:26:38 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/UpgradeAndMaintain
15:27:01 <belmoreira> no news. Let me know if you have ideas/topics to improve it
15:27:09 <ttx> I hope the show on upgrades will help us to write a few things on stage 5
15:27:27 <ttx> like bringing the different perspectives
15:27:34 <belmoreira> +1
15:28:20 <ttx> ok if no particular blockers let's move on
15:28:26 <ttx> #info Next meeting
15:28:30 <ttx> Our next meeting will be on IRC again, May 12.
15:28:55 <ttx> We'll likely discuss last details of the show, like deadline to send slides and final speaker list
15:29:16 <ttx> I'll emcee and coordinate between speakers
15:29:35 <ttx> #topic Open discussion
15:30:04 <ttx> any last-minute question or discussion topic?
15:30:46 <imtiazc> Anyone here using Calico for neutron network provider?
15:31:01 <amorin> nop
15:31:12 <amorin> I remember someone talking about that in our last video meeting
15:31:19 <amorin> but I dont remember who
15:31:56 <belmoreira> Bloomberg uses it
15:32:30 <imtiazc> Oh, thanks! We are going to use it. I also know that Salesforce does.
15:33:10 <belmoreira> also that's a good point. Does anyone know about Salesforce deployment?
15:33:24 <belmoreira> I don't recall any public presentation
15:33:33 <ttx> I could dig in, no idea of the size
15:33:34 <imtiazc> I have a contact at Salesforce. I can get some details.
15:33:49 <ttx> imtiazc: ++
15:33:58 <ttx> They could be a great addition to the group /shows
15:34:06 <imtiazc> They are quite big as well. Thousand node deployments in multiple data centers.
15:34:28 <ttx> ideally we'd rotate speakers enough so that it does not look like a closed club
15:34:46 <imtiazc> +1
15:35:14 <ttx> alright.. anything else?
15:35:33 <ttx> #action imtiaz to try to recruit Salesforce for the SIG
15:35:39 <ttx> :)
15:35:54 <imtiazc> I was reading a report recently which said not many enterprise customers use OpenStack. I think there are but that info is poorly publicized.
15:36:01 <imtiazc> I'll try :)
15:36:32 <ttx> I know there are, but the amount we know about is a fraction of them... and then those willing to talk publicly are a fraction of that
15:36:43 <imtiazc> Exactly.
15:36:58 <imtiazc> Oh, just though of one other topic: backup and recovery.
15:37:04 <ttx> Like distribution companies like Red Hat have a lot of customers... But we rarely see them
15:37:39 <amorin> +1 for backup and recovery
15:37:42 <ttx> and they are rarely allowed to talk freely about them either
15:38:14 <ttx> Add it to https://etherpad.opendev.org/p/large-scale-sig-lightning-talks !
15:38:20 <ttx> (worst-named etherpad ever)
15:38:46 <ttx> OK if nothing else we'll close early (I like short meetings)
15:39:24 <ttx> Reminder exceptionally we;ll do a meeting next week
15:39:38 <ttx> more for show coordination, so the speakers we have signed up
15:39:58 <ttx> it's ok if others miss it
15:40:22 <ttx> I'll send you emails anyway
15:40:26 <ttx> Have a great week
15:40:36 <ttx> #endmeeting