15:00:21 <ttx> #startmeeting large_scale_sig
15:00:21 <opendevmeet> Meeting started Wed Jun 23 15:00:21 2021 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <opendevmeet> The meeting name has been set to 'large_scale_sig'
15:00:26 <ttx> #topic Rollcall
15:00:32 <ttx> Who is here for the Large Scale SIG meeting, in our new location?
15:00:35 <genekuo> o/
15:00:36 <amorin> o/
15:00:47 <belmoreira> o/
15:00:59 <ttx> I'll ping people on #openstack-meeting-3 just in case
15:01:22 <ttx> Our agenda for today is at:
15:01:24 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
15:01:56 <ttx> #topic Next OpenInfraLive session
15:02:04 <ttx> Two weeks ago we produced a great episode, continuing our upgrade discussion
15:02:29 <ttx> The "Large Scale openStack" episodes are some of the most popular on the platform for now
15:02:39 <ttx> Our next "large scale openstack" show will be... July 15
15:02:51 <ttx> We need to decide on the topic ASAP so that we can gather guest speakers and promote the show
15:03:01 <ttx> We have three top candidates, taken from suggestions at https://etherpad.opendev.org/p/large-scale-sig-lightning-talks:
15:03:06 <ttx> - Inception: Run your OpenStack control plane on top of the infrastructure that it manages
15:03:10 <ttx> - Monitoring a large scale deployment
15:03:14 <ttx> - How OpenStack large clouds manage their spare capacity
15:03:17 <ttx> Any preference?
15:04:02 <amorin> I dont have personal preference
15:04:15 <belmoreira> personally, I'm interested in "How OpenStack large clouds manage their spare capacity" :)
15:04:35 <amorin> thats a big topic
15:04:35 <belmoreira> "Inception" it will be cool, but maybe later?
15:04:41 <genekuo> I also don't have a strong preference
15:04:57 <amorin> all of them are good candidates IMHO
15:05:16 <ttx> My only concern with this one is who would do the base presentation?
15:05:18 <amorin> Inception is maybe not *only* related to largescale
15:05:23 <ttx> In terms of format, we need to avoid the "too many presentations, no time for discussion" issue we had with upgrades
15:05:35 <ttx> So I think we should prefer a narrow topic, with one single 5-10min presentation, followed by a panel discussion between 4-5 people
15:06:02 <ttx> with "spare capacity" do we have anyone ready to do the base presentation?
15:06:02 <genekuo> Monitoring IMO is a very large topic
15:06:18 <ttx> genekuo: yeah we should probably be more specific
15:06:47 <amorin> about monitoring, we can talk, but my speaker is not available easily on 15
15:07:04 <amorin> about spare, belmiro, you were willing to talk, right?
15:07:18 <amorin> belmoreira
15:07:40 <belmoreira> I think is an interesting topic to discuss... I have a lot of questions :)
15:08:16 <ttx> belmoreira: do you think we can do the show without any leading presentation?
15:08:18 <belmoreira> amorin, would you be willing to talk?
15:08:37 <amorin> I think we have few things to say, but I know we are not the best on this topic...
15:08:47 <belmoreira> I think public clouds is even more challenging
15:08:53 <amorin> I can still ask the team and come back to you asap
15:09:15 <ttx> We can discuss who the guest speakers could be but i want to nail down the format first
15:09:31 <ttx> if we do presentation + panel, we need a presenter
15:09:31 <genekuo> I can also ask the team that manages capacity to see if they can talk
15:09:48 <ttx> alternatively we can do pure panel
15:09:58 <ttx> if we have many questions, that could work
15:10:04 <belmoreira> ttx having only one presentation may be very narrow scope. Probably people are doing different things... public/private clouds are completly different
15:10:45 <ttx> it's narrow but it's a just a trick to get people engaged
15:11:00 <ttx> or maybe it's more a presentation to introduce the topic
15:11:00 <belmoreira> ttx true!
15:11:01 <genekuo> I will prefer presentations + panels
15:11:29 <genekuo> short presentations about how currently people manages capacities first
15:11:30 <ttx> Like " the problem with excess capacity: rather than "what we do at CERN with extra capacity"
15:12:05 <genekuo> I agree with belmoreira that private/public cloud may have a completely different view to this topic
15:12:12 <ttx> genekuo: short presentations did not work well for us last time, just took too much time and not enough engagement between participants
15:13:08 <ttx> but maybe we can start the discussion by introducing the challenge we want to discuss, using a few slides
15:13:17 <ttx> that would set the stage
15:13:25 <belmoreira> a presentation stating thee problem and then the discussion about what people usually do
15:13:27 <ttx> and then we can ask the panel questions
15:13:50 <amorin> sounds like a good plan
15:13:53 <belmoreira> I think I just said the same as ttx :)
15:13:55 <genekuo> Sounds good to me
15:14:10 <ttx> belmoreira: since you find the topic interesting, I nominate you for stating what the challenge is
15:14:53 <belmoreira> nomination accepted :)
15:15:25 <ttx> Also... if people have a point to make that could really use a slide to explain, we can prepare it in advance and plug it during the show
15:15:38 <ttx> (or keep it in reserve)
15:15:51 <ttx> That makes the show a bit less like a Zoom call
15:16:07 <ttx> OK so...
15:16:28 <ttx> #agreed Topic should be "How OpenStack large clouds manage their spare capacity"
15:16:46 <ttx> #agreed Belmiro will do the initial "challenge statement" short presentation
15:17:07 <belmoreira> question: is any of you using something similar to spot instances?
15:17:08 <ttx> Beyond Belmiro, who here has a great story on that topic to share and wants to be on the show?
15:17:26 <ttx> and... who else should we invite to join?
15:17:27 <amorin> I think I will find someone, or at least something to say
15:17:39 <amorin> I just need to talk back about this with the team
15:17:39 <belmoreira> not a "great story" :) I just think it's a real problem
15:17:45 <amorin> so you can count on us
15:17:54 <ttx> I'd like us to rotate speakers if possible, to avoid making it look like a club too much
15:18:00 <amorin> agree
15:18:08 <genekuo> I can ask the team managing this part. I think they can at least provide some input to the problems
15:18:16 <ttx> Like we could have someone from CityNetwork or Binero for the public cloud side
15:18:23 <amorin> rotate the speakers, or rotate the companies?
15:18:33 <amorin> ok yes
15:18:43 <belmoreira> "CityNetwork or Binero" that would be great
15:18:49 <ttx> That could be in addition to you arnaud if you have a good story to share
15:19:04 <amorin> I can also be "spare speaker"
15:19:09 <amorin> if we have enought
15:19:10 <ttx> since the challenge is clear on public clouds, I would not mind having two
15:19:16 <ttx> \ok good
15:19:26 <amorin> Do you have any contact with fuga.cloud?
15:19:31 <ttx> no
15:19:49 <amorin> I know they are using openstack, maybe I can find a contact
15:20:00 <ttx> InMotion could be interesting, they have a "openstack-as-a-service" offering that should generate a lot of spare capacity
15:20:27 <ttx> Otherwise, i'd love to have someone from Verizon Media (like James Penick since they have a huge capacity
15:21:31 <ttx> Cloud&Heat could be fun too
15:22:00 <ttx> I'll reach out to those and ask if they want to join. Any other participant suggestion?
15:22:12 <ttx> genekuo: do you have a story to tell on that topic?
15:23:24 <genekuo> Capacity is actually manage by a separate team. I can ask if they are willing to talk
15:23:30 <ttx> #info Belmiro will participate, Arnaud is available in case we need him, Gene will ask the capacity team
15:24:10 <ttx> #info thierry to reach out to CityNetwork / Binero / InMotion/ Cloud&heat / Verizon Media
15:24:56 <ttx> belmoreira: if you do the problem statement, my added value is limited on the show, so I was wondering if you could just do the intro/outro and follow the episode script
15:25:00 <ttx> Then I can focus on triaging questions and selecting good ones... it's been hard for me to do both
15:25:15 <ttx> So I'll be around, just not "on" the show
15:25:37 <ttx> belmoreira: are you ok with leading the discussion on that one?
15:25:50 <belmoreira> That's a big challenge. i'm happy to try
15:26:01 <ttx> (We'll work on the script of questions together)
15:26:35 <ttx> #info Belmiro will emcee the show, thierry will be backstage selecting questions
15:27:05 <ttx> Alright.. anything else on that? I'll keep y'all posted on the progress in recruiting guest speakers
15:27:49 <genekuo> Sounds like a good plan to me
15:27:56 <ttx> alright then
15:27:58 <ttx> #topic Progress/Blockers
15:28:00 <ttx> * Stage 1 - Configure (amorin)
15:28:04 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/Configure
15:28:22 <amorin> I havnt been working on this topic for a while, dont have much time at the moment
15:28:58 <ttx> ++
15:29:10 <ttx> * Stage 2 - Monitor (genekuo)
15:29:15 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/Monitor
15:29:31 <genekuo> Not much update on the wiki part
15:30:01 <genekuo> Mostly working on oslo.metrics stuff
15:30:10 <ttx> no blocker?
15:30:35 <genekuo> I would like to know the gap to a 1.0.0 release
15:30:50 <genekuo> I actually put this topic in open discussion
15:31:13 <ttx> ok
15:31:26 <ttx> * Stage 3 - Scale Up (ttx)
15:31:29 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/ScaleUp
15:31:42 <ttx> no progress recently, openinfra.live has been eating my bandwidth
15:31:46 <ttx> # Stage 4/5 - Scale Out, upgrade & maintain (belmoreira)
15:31:48 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/ScaleOut
15:31:50 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG/UpgradeAndMaintain
15:32:11 <belmoreira> I will use the info from the previous shows to update it. Will try to do it for the next meeting.
15:32:26 <ttx> yeah... Was wondering if there was any insight to extract from our upgrades show that we could use
15:32:39 <ttx> alright, next topic
15:32:50 <ttx> #topic Next meetings
15:32:57 <ttx> We'll have one more IRC meeting between now and our next OpenInfra Live show
15:33:05 <ttx> So the schedule for next meetings looks like:
15:33:07 <ttx> - July 7: IRC meeting
15:33:11 <ttx> - July 15: OILive
15:33:21 <ttx> After that my proposal would be to skip the meeting on July 21
15:33:37 <ttx> then have a meeting on August 4 with whoever will be around, one on August 18 and book August 26 for the next live episode.
15:33:53 <ttx> (I booked August 26 for our next episode)
15:34:05 <ttx> How does that sound?
15:34:24 <genekuo> No problem for me
15:34:54 <ttx> #info next meetings: July 7 IRC meeting, July 15 OpenInfra Live, July 21 skip, August 4 IRC meeting
15:35:03 <amorin> august will be hard for me
15:35:10 <belmoreira> I can't join for the July 7 meeting
15:35:10 <amorin> july ok
15:35:18 <ttx> hmm
15:35:56 <ttx> belmoreira: July 7 we would have discussed lastminute prep for the OILive episode, so if you;re not around it's probably not worth it
15:35:59 <belmoreira> but I can catch up later with ttx
15:36:12 <ttx> ok, still useful to have async point
15:36:20 <ttx> a sync point I mean
15:37:16 <ttx> amorin: re: August I'm on the same boat... if we think we can't make a show on Aug 26, better push back the date
15:37:25 <ttx> amorin: when would you be back?
15:37:36 <amorin> not before september
15:37:48 <amorin> september 8 I think
15:37:50 <ttx> maybe we could do the Inception episode on Aug 26
15:37:53 <amorin> 1  will be hard also
15:37:56 <ttx> since you will sit out that one I guess
15:37:59 <amorin> yup
15:38:18 <ttx> then we can plan one around monitoring early October
15:38:30 <ttx> ok
15:38:35 <belmoreira> please keep the meeting for the 7. I have already my Wednesday afternoon blocked, but let's see... I may be able to join a little bit later
15:38:58 <ttx> #info Next OILive episode after the Jul 15 one will be Aug 26, probably around Inception
15:39:14 <ttx> #topic Open discussion
15:39:19 <ttx> Floor is yours genekuo
15:39:56 <genekuo> Yeah, I would like to know if there is any general guideline or a checklist to go to 1.0.0 release for projects
15:40:16 <genekuo> I saw in wiki page that we currently still have 2 gaps (bandit and test coverage)
15:41:15 <genekuo> Currently I've tested the basic features and confirm it working in devstack
15:41:33 <ttx> re: bandit we should enable it, and make it skip the predictable file path using "# nosec"
15:42:00 <ttx> test coverage, I have no idea how mucgh we test but it's probably minimal
15:42:12 <ttx> would be good to add more if we can
15:42:25 <ttx> but we should aim at 1.0.0 in Xena release
15:42:58 <ttx> if you think it's not going to significantly change in the near future
15:43:41 <genekuo> OK, I'll start working on bandit and test coverage
15:43:42 <ttx> in terms of general guidelines, 1.0.0 means you apply deprecation rules, backward compatibility etc
15:44:04 <ttx> so if you remove an option, you need to continue to support it as deprecated over two openstack releases, etc
15:44:28 <ttx> so it's good to be suer about the API and config options and general architecture before declaring 1.0.0
15:44:33 <ttx> sure*
15:45:22 <ttx> genekuo: you mentioned talking with another user recently... how did that go?
15:45:34 <ttx> It's generally a good test that the lib works for several use cases
15:45:53 <genekuo> They actually figured out how to test it with the half done code I proposed
15:46:15 <genekuo> Haven't got back to them to see if they have any feedback
15:46:16 <ttx> ok
15:46:30 <ttx> maybe that would be good to do before planting a 1.0.0 flag
15:46:30 <genekuo> Let me ask them if there's any point for improvement
15:46:48 <ttx> ok, does that answer your questions?
15:47:02 <genekuo> Yep, thanks a lot!
15:47:07 <ttx> Alright then... Anything else, anyone?
15:47:34 <genekuo> Another small question come up in my mind
15:48:01 <genekuo> Do we gather statistics for wiki view count?
15:49:19 <genekuo> Will be interesting to know how much people actually reach the wiki page
15:49:28 <amorin> guys, I need to run right now, see you next week!
15:49:42 <genekuo> Thanks amorin!
15:49:52 <ttx> unfortunately no
15:49:56 <ttx> no usage stats on wiki
15:50:02 <ttx> ok let's close
15:50:04 <ttx> Thanks everyone
15:50:09 <genekuo> Thanks!
15:50:10 <ttx> #endmeeting