15:01:17 <ttx> #startmeeting large_scale_sig
15:01:17 <opendevmeet> Meeting started Wed Sep  1 15:01:17 2021 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:17 <opendevmeet> The meeting name has been set to 'large_scale_sig'
15:01:20 <ttx> #topic Rollcall
15:01:22 <ttx> Who is here for the Large Scale SIG meeting?
15:01:26 <rbudden> hello
15:01:27 <ttx> genekuo: hi!
15:01:30 <belmoreira> o/
15:01:36 <genekuo> hi
15:01:39 <ttx> rbudden, belmoreira hi!
15:01:53 <ttx> amorin maybe?
15:01:53 <belmoreira> hi
15:02:13 <ttx> mdelavergne too
15:02:29 <ttx> Is everyone back from vacation?
15:03:00 <belmoreira> good to be back
15:03:19 <genekuo> not exactly from vacation, I was busy preparing to fly back to Japan and miss the notification for last meeting
15:03:27 <ttx> alright, looks like, that's everyone for today
15:03:32 <ttx> Our agenda for today is at:
15:03:34 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
15:03:41 <ttx> #topic Next OpenInfraLive session
15:04:03 <ttx> Last week we had a good session on software-defined supercomputers, thanks to oneswig for leading that
15:04:21 <ttx> It was a bit of a different spin than usual, but great to include new users
15:04:33 <ttx> Our next open slot for an episode is just before the PTG, on Oct 14, 2021
15:04:50 <ttx> sp 6 weeks from now
15:04:54 <ttx> Are you all available on that date?
15:05:18 <ttx> If that's not working we could push back to Oct 28
15:05:32 <genekuo> Currently free on Oct 14 for me
15:05:35 <belmoreira> 14 works for me
15:05:49 <ttx> OK then mark your calendars now! 14 it is
15:05:59 <ttx> We have quite a bit of time to organize, but I'd like to decide on the topic early
15:06:07 <ttx> We had two topics in the pipeline: Inception and Monitoring
15:06:13 <ttx> Any preference?
15:07:04 <ttx> Inception being: running openstack control plane on itself
15:07:16 <genekuo> From my side, I can find speaker (or me) to do both, so I don't have specific preference
15:07:25 <ttx> Monitoring being a bit more of a general question (how do you solve monitoring)
15:08:01 <ttx> I think for Monitoring it will be slightly easier to find participants
15:08:09 <ttx> since very few do Inception
15:08:31 <ttx> belmoreira: any preference?
15:08:49 <belmoreira> how about we change the inception to "OpenStack architecture in your deployment"
15:09:26 <ttx> hmm, what do you mean exactly
15:09:32 <ttx> Topic tbd
15:09:40 <ttx> err.. wrong channel
15:09:55 <genekuo> I think belmoreira is suggesting a more general topic
15:10:08 <belmoreira> inception is just a way to setup openstack (pros,cons)
15:10:20 <genekuo> Instead of focusing on inception, there may be different deployment architecture in large scale deployment
15:10:34 <belmoreira> but we can leave space for all the other user stories
15:10:42 <ttx> ah ok, yes
15:10:56 <belmoreira> containers, disk less setup, ...
15:11:20 <ttx> like "How Large Scale deployments are architected"
15:11:26 <ttx> and have a bunch of examples
15:11:34 <belmoreira> yeah, something like that
15:11:55 <ttx> With guests willing to show and tell
15:12:10 <belmoreira> inception is just one particular case
15:12:21 <ttx> Maybe focusing on the larger users for this one
15:12:43 <belmoreira> maybe something like the upgrades sessions, but now going deep into the architecture
15:12:59 <ttx> belmoreira, genekuo: I assume you both would be able to present?
15:13:46 <belmoreira> I'm interested in present
15:13:49 <ttx> rbudden: not sure your deployment would fit that discussion, but let me know
15:13:59 <genekuo> I will be available, or at least my teammate will
15:14:27 <ttx> OK, I'll build up something around that theme and start looking around for guests
15:14:41 <ttx> Will keep y'all posted at next meeting
15:14:49 <genekuo> :)
15:15:10 <ttx> #agreed theme for next episode: "OpenStack architecture in large scale deployments"
15:15:19 <ttx> #info CERn and LINE available to present
15:16:29 <ttx> alright, any question on that topic?
15:16:29 <rbudden> Our deployment is somewhat large. I work with Jonathan Mills on the NASA OpenStack clouds.
15:16:53 <rbudden> I don’t have exact specs in front of me, but we’re in the neighborhood of 3500-4000 cores
15:16:56 <ttx> rbudden: yes, I remember. If that is a topic you would be interested in presenting on, let me know
15:17:15 <rbudden> sure, if it’s helpful
15:17:22 <rbudden> we basically role our own deployment
15:17:28 <rbudden> it’s in-house Ansible CM
15:17:40 <ttx> yeah ideally we'd have a mix of approaches
15:18:17 <ttx> #info rbudden could present for NASA, using in-house Ansible CM
15:19:28 <ttx> alright moving on
15:20:21 <ttx> #topic Large Scale Journey updates
15:20:25 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG
15:20:30 <ttx> Was there any recent progress made on documenting the Large Scale Journey?
15:20:41 <belmoreira> no updates from me
15:20:45 <ttx> It feels like this has taken a backseat as we focused on OpenInfra.Live episodes...
15:20:50 <ttx> (which I think are more immediately visible and valuable)
15:21:07 <genekuo> I was busy with OpenInfra Days Asia recently
15:21:14 <genekuo> have a talk about oslo.metrics there
15:21:34 <genekuo> For the code part I'm working on functional tests
15:21:45 <ttx> I think we should still aim at gradually improving that doc, but that can be done over the long run
15:22:01 <ttx> CCreating spaces for discussions around Large Scale is imho more valuable
15:22:27 <belmoreira> +1
15:22:27 <ttx> genekuo: noted
15:22:46 <ttx> #topic Next meeting
15:22:54 <ttx> Our next scheduled IRC meeting will be Sept 15.
15:22:58 <ttx> #info next IRC meeting on Sept 15
15:23:25 <ttx> I'll have more details on the upcoming episode by then, started fishing for extra speakers etc
15:23:55 <ttx> genekuo: how is your deployment architected? You don't do Inception or Ansible iirc
15:24:07 <genekuo> We do both inception and ansible
15:24:22 <belmoreira> humm
15:24:26 <genekuo> our control plane run on top of k8s on top of our openstack
15:24:38 <genekuo> while we uses ansible to deploy the manifests
15:25:10 <belmoreira> I was not thinking how sites deploy the infrastructure (puppet, ansible, chef?, ...)
15:25:13 <ttx> ok, so that would be another combination
15:25:22 <ttx> #topic Open discussion
15:25:23 <belmoreira> but more about the architecture and why
15:26:19 <ttx> belmoreira: there is a link between the two, but I think I see where you;re going
15:26:40 <belmoreira> why they cluster rabbit or not? number of nova APIs? are they in physical nodes? why?
15:26:52 <belmoreira> my thinking was more in these lines
15:27:20 <ttx> belmoreira: maybe you could write a short paragraph describing the types of questions you'd like answered? That would help me in my speaker outreach
15:27:51 <genekuo> I could understand the direction belmoreira would like the talk to be
15:28:29 <belmoreira> let me know if it makes sense to you
15:28:35 <ttx> belmoreira: you'd still mention the inception aspect, which is a bit of a deployment thing
15:29:04 <ttx> I guess that's where I'm confused, the area between the two
15:29:22 <genekuo> There is some connection IMO
15:29:22 <belmoreira> in my view inception is a strong architecture decision, not related with the deployment tool (puppet in our case)
15:29:33 <genekuo> but belmoreira would like to focus on why
15:29:45 <genekuo> for example why we uses ansible to deploy manifest to k8s
15:29:58 <genekuo> why we choose to do inception
15:30:47 <genekuo> not sure if i understand correctly
15:31:24 <ttx> belmoreira: could you write something up that would describe what's on topic for that episode? That would be helpful to me as I do the initial outreach
15:31:53 <ttx> we could reuse it as the episode description
15:31:56 <belmoreira> ttx ok, let me try to do it
15:32:05 <genekuo> thank you
15:32:09 <ttx> thanks!
15:32:19 <ttx> #action belmoreira to draft the episode description
15:32:25 <ttx> Anything else, anyone?
15:33:13 <ttx> rbudden: anything you wanted to discuss?
15:33:24 <genekuo> nothing from my side
15:33:27 <rbudden> nothing offhand
15:33:41 <ttx> we have low attendance today because not everyone is back from vacation. Hopefully we'll have more in two weeks
15:33:44 <rbudden> i’d be interesting in picking ppl’s brains on rabbitmq setup/tradeoffs sometime
15:33:47 <rbudden> but no need for that now
15:34:30 <ttx> rbudden: did you see our video meeting on RabbitMQ scaling?
15:34:48 <rbudden> yes, I caught part of that and need to review it
15:35:09 <rbudden> I know there were some write ups being worked on as well
15:35:36 <ttx> ok then if nothing else for today, let's end early
15:35:43 <ttx> Thanks everyone!
15:35:44 <genekuo> thanks all! :)
15:35:54 <mdelavergne> Thanks!
15:35:54 <rbudden> thanks!
15:36:05 <ttx> mdelavergne: lurking I see
15:36:18 <belmoreira> thanks
15:36:23 <ttx> #endmeeting