15:01:00 <ttx> #startmeeting large_scale_sig
15:01:00 <opendevmeet> Meeting started Wed Aug 31 15:01:00 2022 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <opendevmeet> The meeting name has been set to 'large_scale_sig'
15:01:06 <ttx> #topic Rollcall
15:01:09 <mdelavergne> Hi!
15:01:12 <felixhuettner[m]> Hi
15:01:16 <ihti[m]> Hi!
15:01:19 <ttx> Welcome back!
15:01:38 <ttx> Who else is here for the Large Scale SIG meeting?
15:02:06 <ttx> pinging amorin
15:02:14 <felixhuettner[m]> that looks like a small round
15:02:32 <ttx> let me see if Belmiro is anywhere close
15:03:08 <ttx> Hmm, looks like he is not
15:04:12 <ttx> That is indeed a short crew, but let's roll it through anyway or we will never get back to a rhythm :)
15:04:30 <ttx> ihti[m]: is it your first Large Scale SIG meeting/
15:04:34 <ttx> ?
15:04:50 <ihti[m]> Yes, I am colleague of Felix :)
15:04:59 <ttx> Oh right!
15:05:12 <ttx> Well, welcome and thanks for joining
15:05:18 <ttx> Our agenda for today is at:
15:05:21 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
15:05:37 <ttx> #topic OpenInfra Live September 29 episode - Deep dive into Schwarz Gruppe
15:05:58 <ttx> First topic is the OpenInfra Live episode we'll be running on Sept 29
15:06:03 <felixhuettner[m]> we already collected some fun stories to share there
15:06:18 <felixhuettner[m]> especially about the rabbit you all know and love :)
15:06:35 <ttx> That's great! Usually Belmiro starts a thread to discuss content as we get closer to the event
15:06:54 <ttx> I'll try to make sure he starts one
15:07:01 <felixhuettner[m]> ok, sounds great
15:07:15 <ttx> felixhuettner[m]: ihti[m] : have you viewed a former Deep Dive episode to see what to expect? It's a pretty loose format
15:07:37 <felixhuettner[m]> yep, two collegues of us did also join one in the past
15:07:42 <ttx> We try to have recurring hosts (mnaser, amorin and belmiro)
15:07:48 * frickler sneaks in late
15:08:04 <ttx> right, but the deep dive is a specific format, centered on one company in particular
15:08:10 <ttx> frickler: hi!
15:08:24 <ttx> We did one on OVHcloud and one on Yahoo so far
15:08:39 <ihti[m]> Yes, have seen a couple of the deepdives in teh past so quite familier with the format
15:08:44 <felixhuettner[m]> ok, then we'll definately take a look
15:09:07 <ttx> just go to https://openinfra.dev/live/ and search for "Deep Dive"
15:09:18 <ihti[m]> Ah okay you just had 2 till now, so didn't miss any :)
15:09:28 <ttx> It's more like an open discussion between ops, only live on te Internet
15:09:46 <ttx> usually pretty popular episodes
15:10:16 <ttx> anyway, I planned to use that meeting to confirm the hosts but none of them are around
15:10:39 <ttx> so I'll follow up on the email thread we started
15:10:49 <felixhuettner[m]> ok, thanks
15:11:14 <ttx> #action ttx to confirm hosts and ask belmiro to start a content thread about Sept29 episode
15:11:45 <ttx> felixhuettner[m]: ihti[m]: do you have questions about this show, before we move on to another topic?
15:11:52 <felixhuettner[m]> not from me
15:11:56 <ihti[m]> Nope
15:12:14 <ttx> We usually join 30min in advance to have time to walk around the platform
15:12:18 <ttx> ok!
15:12:22 <ttx> #topic Status on docs website transition
15:12:36 <ttx> I pushed a few changes to clean up the generated docs website at https://docs.openstack.org/large-scale/
15:13:07 <ttx> https://review.opendev.org/c/openstack/large-scale/+/854419 is the last one
15:13:32 <felixhuettner[m]> they look a lot nicer now
15:13:33 <frickler> oh, I missed that one, will review later
15:13:38 <ttx> One that is approved and merged I will replace the old wiki pages with a redirect message
15:13:47 <ttx> pointing people to the new location
15:13:57 <frickler> +1
15:14:18 <ttx> #action ttx to replace all Large Scale SIG wiki pages with redirects to the docs (once 854419 merges)
15:14:43 <ttx> Any question or comment on that topic?
15:15:23 <ttx> alright then
15:15:24 <ttx> #topic RabbitMQ questions
15:15:45 <felixhuettner[m]> thanks, i collected a few over the last 2 month
15:16:04 <ttx> I'm not sure with amorin and mnaser and Belmiro away we will have tat many answers right now, but can't hurt to ask
15:16:09 <felixhuettner[m]> one thing is the `rabbit_transient_queues_ttl` setting which is recommended in https://docs.openstack.org/large-scale/other/rabbitmq.html#rabbit-transient-queues-ttl
15:16:40 <felixhuettner[m]> and for me that feels more like something we need to fix in oslo.messaging
15:17:09 <ttx> felixhuettner[m]: yeah that definitely feels like a workaround
15:17:10 <felixhuettner[m]> so what happens is that when a agent shuts down then the fanout queues it created are not deleted
15:17:19 <felixhuettner[m]> and they fill up until they are deleted
15:17:46 <felixhuettner[m]> the short look i had in the oslo.messaging code looked like it should actually remove them on shutdown
15:17:52 <felixhuettner[m]> but that does not seem to work reliably
15:18:46 <felixhuettner[m]> if there is no specific reason for that then i would open a bug for that, maybe we can then get rid of this recommendation
15:19:11 <ttx> yeah, that sounds like a good path to follow... It might be a tricky one to fix though
15:19:29 <ttx> but filing a bug sounds like a good start
15:19:36 <frickler> iiuc the recommendation also helps in case of unscheduled shutdown, like hardware failure
15:19:55 <frickler> but creating and possibly fixing a bug seems useful anyway
15:20:05 <felixhuettner[m]> thats a really valid point
15:20:11 <felixhuettner[m]> i did not think about that
15:20:22 <felixhuettner[m]> but then i'll go ahead and create a bug
15:20:41 <felixhuettner[m]> #action felix.huetter to create a but regarding olso.messaging not deleting fanout queues when neutron agents stop
15:20:43 <ttx> yeah not sure fixing the bug would make the recommendation invalid
15:20:53 <ttx> but that's a good open discussion to have
15:21:00 <felixhuettner[m]> aaah, cant even write my name :)
15:21:06 <ttx> we got it
15:21:30 <felixhuettner[m]> ok :)
15:21:31 <felixhuettner[m]> the other thing is the ha policies we recommend
15:21:31 <ttx> what about the other issue?
15:21:44 <felixhuettner[m]> at the moment only the normal incoming queues are made durable and HA
15:21:55 <felixhuettner[m]> however we do not do the same thing for reply queues
15:22:12 <felixhuettner[m]> but since they are also tied to the lifetime of the service using them i don't see why we should treat them differently
15:22:54 <felixhuettner[m]> (and also oslo.messaging treats them differently)
15:23:17 <ttx> that's a good question, would be good to have others opinion on it
15:23:46 <ttx> the "policy" might have been from the one contributor to that doc, and not that much shared
15:24:00 <felixhuettner[m]> i think it fits to what oslo.messaging does
15:24:08 <ttx> so reopening the case is interesting
15:24:13 <felixhuettner[m]> as long as it does not set the durable flag on these queues we can not make them ha anyway
15:24:22 <ttx> hah
15:24:45 <ttx> This one could be worth a ML thread then, if it's oslo.messaging behavior
15:25:11 <ttx> it's technically not a bug since it works as designed... just the design is questionable
15:25:20 <felixhuettner[m]> yep
15:25:24 <felixhuettner[m]> ok, then i'll send something to the ML
15:25:48 <ttx> yeah, so my recommendation would be to open a ML thread and see who gets out of the woodwork to defend the current behavior
15:25:57 <felixhuettner[m]> #action felix.huettner to raise a question on the mailinglist why reply queues are not created as durable
15:26:24 <ttx> Alright, anything else on that topic?
15:26:30 <felixhuettner[m]> nothing from me
15:27:01 <ttx> #topic Next meetings
15:27:13 <ttx> Next meeting is September 14, but I'll be in Dublin for Open Source Summit EU so I won't be able to chair it
15:27:34 <ttx> Who is available to run the meeting? We definitely need one as there might be last minute details to discuss for the Deep dive on Sept 29
15:28:04 <ttx> i could ask belmiro but if we have a volunteer present that might be a stronger bet
15:28:24 <felixhuettner[m]> i'll probably be there (unless something breaks :) )
15:28:56 <frickler> I could do it, but I don't mind if you ask belmiro or amorin first
15:29:48 <ttx> OK how about I ask them (we need them on that one anyway) and if they can't I'll take one of your generous offers to help
15:30:32 <ttx> #info September 14 - IRC meeting (ttx to ask belmiro/amorin if they can chair, or felixhuettner/frickler if they can't)
15:30:35 <felixhuettner[m]> sounds good
15:31:06 <ttx> #action ttx to ask belmiro/amorin if they can chair next meeting
15:31:13 <ttx> #info September 29 - willbe our OpenInfra Live
15:31:26 <ttx> #topic Open discussion
15:31:30 <ttx> Anything else, anyone?
15:31:41 <felixhuettner[m]> not from me
15:31:42 <mdelavergne> not from my part
15:31:45 <frickler> I have an ad for the publiccloud_sig
15:31:57 <ihti[m]> nothing from my side
15:32:02 <frickler> might be interesting for some people here, too
15:32:06 <ttx> frickler: promote away!
15:32:16 <ttx> definitely big overlap
15:32:16 <frickler> https://meetings.opendev.org/meetings/publiccloud_sig/2022/publiccloud_sig.2022-08-31-08.04.html is the meeting that happened earlier today
15:32:49 <frickler> happening every other wed at 08 UTC
15:33:08 <frickler> so EU friendly as well as NZ hopefully
15:33:33 <frickler> current hot topic is discussing how to provide standard cloud images
15:33:38 <ttx> #info Public Cloud SIG meetings every other Wednesday at 8UTC
15:34:04 <frickler> like tagged via metadata or standardized names
15:34:14 <RamonaBeermann[m]> is it in this channel?
15:34:19 <frickler> yes
15:34:20 <ttx> yes
15:34:27 <RamonaBeermann[m]> thx
15:35:06 <ttx> frickler: anything else?
15:35:17 <frickler> I think that's it from me
15:35:29 <ttx> Alright, then thanks everyone for attending
15:35:40 <ttx> #endmeeting