15:00:01 <ttx> #startmeeting large_scale_sig
15:00:01 <opendevmeet> Meeting started Wed Nov 23 15:00:01 2022 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:01 <opendevmeet> The meeting name has been set to 'large_scale_sig'
15:00:06 <ttx> #topic Rollcall
15:00:16 <ttx> Who is here for the Large Scale SIG meeting?
15:00:23 <kbarrientos[m]> o/
15:00:32 <amorin> hello
15:00:38 <ttx> Hi Kristin and Arnaud!
15:00:40 <belmoreira> o/
15:00:42 <felixhuettner[m]> o/
15:00:56 <ramona-beermann[m]> o/
15:01:34 <ttx> full crew today!
15:01:36 <ttx> Our agenda for today is at:
15:01:40 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
15:01:52 <ttx> #topic Ops Deep Dive Episode on Dec 8
15:02:06 <ttx> Alright... so on the guest front I invited Florian Leduc from Societe Generale but despite my attempts they haven't confirmed yet
15:02:20 <ttx> So yesterday I also reached out to Benjamin Fuhrmann at Ubisoft as a backup plan.
15:02:35 <ttx> I hope to get the confirmation this week... because time is running out
15:02:54 <ttx> On the host side, we have amorin and mnaser confirmed...
15:02:57 <ttx> belmoreira: can you join us?
15:03:07 <belmoreira> yes, I can join
15:03:15 <ttx> \o/
15:03:26 <ttx> they did not strap you onto a rocket yet
15:03:34 <amorin> :)
15:03:48 <ttx> We'll start a thread around content as soon as I get the guests lined up.
15:04:02 <ttx> #action ttx to confirm guest and start thread on content
15:04:15 <ttx> not much we can do until then
15:04:24 <amorin> that's an ops deep dive anyway, we dont usually have that much work to do on our side
15:04:31 <ttx> any question/comment re: openinfra.live?
15:04:37 <amorin> except starting an etherpad with few questions
15:04:55 <ttx> I feel like the pre-discussion helps though so I would rather start it sooner than later
15:05:05 <amorin> ack
15:05:25 <belmoreira> it would be a great show, with Ubisoft or Societe Generale
15:05:47 <belmoreira> s/would/will
15:05:48 <ttx> I told Ubisoft they will be next if Societe Generale gets back to us after all
15:06:09 <ttx> #topic Large Scale doc
15:06:13 <ttx> #link https://docs.openstack.org/large-scale
15:06:22 <ttx> Anything new to report here?
15:06:47 <amorin> yes
15:06:55 <amorin> sorry, no, nothing new, but
15:06:56 <ttx> I see https://review.opendev.org/c/openstack/large-scale/+/864286 landed
15:07:13 <amorin> I'd like to start a discussion /doc around the database connection
15:07:27 <amorin> fine tuning the number of connections needed per service
15:07:32 <amorin> number of green threads
15:07:37 <amorin> number of max_pool_size, etc.
15:07:38 <ttx> hmm, yeah that would be good
15:07:54 <amorin> I am currently trying to formalize this downstream
15:07:56 <ttx> iirc there is some guidance but not too much
15:08:11 <amorin> as soon as I have something I can share, I will create a patchset
15:08:20 <felixhuettner[m]> then we can compare what everyone has set and try to learn something from it :)
15:08:31 <amorin> but if you folks arlready have more than what is on the doc, that would be nice
15:08:55 <amorin> yes, I still have your numbers felixhuettner[m], from a discussion we had few weeks ago
15:09:04 <felixhuettner[m]> +1
15:09:11 <amorin> I also started a thread on mailing list, but no body answered
15:09:17 <felixhuettner[m]> i can always dig for more if you are interested
15:09:19 <amorin> except you belmoreira  :)
15:09:42 <amorin> our public endpoints are heavily used (neutron api mostly)
15:09:46 <ttx> somnetimes posting another answer puts it back on top of everyone's inboxes
15:09:54 <amorin> so we have a lot of workers to handle that
15:10:06 <amorin> but we reach the max number of connection multiple times
15:10:21 <amorin> so there is for sure some tuning to do there, and some guideline to provide
15:10:44 <amorin> or at least, some explanation on how the parameters act on the deployment
15:10:47 <ttx> definitely
15:11:01 <ttx> looking forward to your patchset
15:11:12 <ttx> anything else on that topic?
15:11:13 <amorin> yup, me too :)
15:11:13 <belmoreira> amorin, I replied to you regrading this topic. The approach that we followed was to increase the number of connections in the DB side and keep the defaults for the services.
15:11:39 <amorin> yup
15:12:31 <belmoreira> but it would be great to dive in those params
15:13:01 <ttx> ok, moving on...
15:13:03 <amorin> that's my objective, I will let you know
15:13:10 <ttx> #topic Next meetings
15:13:18 <ttx> So in two weeks we'll have our Openinfra Live episode (if I can get the guests to confirm!)
15:13:30 <ttx> After that we should probably do a break over the holidays, and be back in January
15:13:36 <ttx> Does that work for everyone?
15:13:43 <felixhuettner[m]> sounds good
15:14:00 <kbarrientos[m]> yep!
15:14:03 <belmoreira> when should we expect the next openinfra live?
15:14:14 <ttx> probably end of january or so
15:14:28 <amorin> good to me
15:14:41 <ttx> Ideally we'll have Ubisoft or Societe Generale lined up
15:14:49 <belmoreira> nice
15:15:00 <ttx> so the lengthy part (booking a guest) should be done
15:15:04 <ttx> #info OpenInfra Live on Dec 8
15:15:07 <ttx> #info Next IRC meeting on January 4
15:15:14 <ttx> #topic Open discussion
15:15:30 <ttx> There is a meetup around Large Scale OpenStack in Paris Tuesday next week, for those who are around
15:15:38 <ttx> (in Ubisoft offices)
15:15:45 <amorin> I'll be there
15:16:02 <ttx> Florian and Benjamin are speaking there so in the worst case scenario i should get one of them to sign up on that day
15:16:16 <ttx> #link https://www.meetup.com/openstack-france/events/289568019/
15:16:19 <belmoreira> have fun there
15:16:29 <ttx> amorin: great!
15:16:46 <ttx> Anything else, anyone?
15:16:55 <belmoreira> it would be great if the talks can be shared
15:17:07 <belmoreira> looks a great content for this group
15:17:30 <ttx> My talk is pretty generic intro, but yes, would be good to grab the slides for the others
15:17:34 <ttx> likely in French
15:17:45 <amorin> I think, they will try to record it
15:17:52 <ttx> fancy
15:17:55 <amorin> live stream will be hard, but record is possible IIRC
15:18:11 <belmoreira> let me know if they get published
15:18:14 <amorin> but the talks are goiing to be in french
15:18:19 <amorin> AFAIK
15:18:35 <amorin> sorry, ttx already mentionned it :)
15:18:35 <belmoreira> :) it's fine
15:18:59 <belmoreira> (I'm missing french)
15:19:11 <ttx> alright, no other topic for discussion? going once...
15:19:50 <ttx> going twice...
15:20:12 <ttx> Thanks everyone!
15:20:16 <ttx> #endmeeting