09:00:01 <ttx> #startmeeting large_scale_sig
09:00:01 <opendevmeet> Meeting started Wed Feb  8 09:00:01 2023 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:01 <opendevmeet> The meeting name has been set to 'large_scale_sig'
09:00:08 <ttx> #topic Rollcall
09:00:13 <ttx> Who is here for the Large Scale SIG meeting?
09:00:26 <june_yi> o/
09:00:38 <belmoreira> o/
09:00:41 <links> o/
09:00:43 <ttx> june_yi: welcome!
09:01:13 <ttx> Our agenda for today is at:
09:01:19 <ttx> #link https://etherpad.openstack.org/p/large-scale-sig-meeting
09:01:43 <ttx> amorin: around?
09:02:16 <ttx> felix.huettner: around?
09:02:29 <felixhuettner[m]> o/
09:03:18 <ttx> OK let's get started
09:03:43 <ttx> I see we have a couple of new people, so maybe we can do a quick round of introductions
09:04:20 <ttx> I'm Thierry Carrez, general manager for the OpenInfra Foundation and co-chair for the Large Scale SIG, trying to facilitate the discussions and sharing of experience here
09:04:36 <color_park> Hi all. I'm from Samsung sds, south Korea
09:05:10 <howard> Hi, I am working for Samsung SDS, too.
09:05:15 <ttx> color_park: great! I was looking forward to your presence
09:05:40 <june_yi> I am working on cloud development at Samsung SDS in South Korea with color_park and howard. Nice to meet you all. I'm not familiar with irc meetings, but I'll try to follow along.
09:06:18 <ttx> Maybe you can give a bit more detail on your setup at Samsung SDS, so that others on the meeting can understand what you are trying to achieve and help answer questions later in the Open discussion?
09:06:20 <belmoreira> Hello, I'm Belmiro, one of co-founders of this SIG. Currently I work at ESA, managing the ground IT infrastructure.
09:07:51 <felixhuettner[m]> Hi, I'm Felix working for the STACKIT Cloud offering
09:08:30 <amorin_> hello!
09:08:39 <color_park> samsung sds is responsible for the network and infrastructure of all companies with samsung names. We want to support their services through openstack in the near future and furthermore, we want to get the possibility as csp through openstack :)
09:08:39 <amorin_> sorry I am late, completely forgot about the new hour
09:09:35 <ttx> color_park: that is exciting. Feel free to ask our scaling experts questions as you are working through the early design choices
09:09:41 <june_yi> Samsung SDS is running a local CSP business in Korea and is preparing for expansion based on OpenStack. Multi-Region, Multi-AZ is a technical challenge for us.
09:09:45 <amorin> I am Arnaud Morin, working for OVHcloud as SRE, mostly involved in deploying and maintaining our Public Cloud offer bases on openstack
09:10:48 <ttx> ok... How about we discuss recommended options in "open discussion" at the end of the meeting? It feels like a good moment for you to engage in the Large Scale SIG
09:11:02 <ttx> I bet you have plenty of questions
09:11:20 <ttx> but let's go through the regular topics of the meeting first
09:11:26 <danpaik> sorry about that.  some kind of problem at work so i'm in now...
09:11:41 <ttx> danpaik: no problem, we are just getting started
09:11:55 <danpaik> great.  my team should have made it in here though.  thx ttx.
09:12:14 <ttx> We will discuss Samsung SDS questions in open discussion at the end of our agenda
09:12:18 <ttx> #topic Next Ops Deep Dive Episode
09:12:48 <ttx> As you probably know we run regular live webcasts featuing large scale users sharing their experience with a panel of operators
09:13:05 <ttx> So for our next one we need a proposed date and a proposed guest
09:13:19 <ttx> How about... April 13? that's avoiding Antelope release and PTG, and gives us time to find a guest
09:14:14 <belmoreira> first congrats to ttx, amorin and felixhuettner[m] for the great episode
09:14:24 <amorin> we miss you belmoreira!
09:14:35 <ttx> belmoreira amorin felix.huettner let me know if there are obvious blockers for you on that date
09:14:39 <ttx> not the same without you belmoreira ...
09:14:39 <amorin> but yes, it went fine and smoothly
09:14:44 <amorin> checking my calendar
09:15:07 <belmoreira> it was very good
09:15:09 <felixhuettner[m]> thanks
09:15:24 <felixhuettner[m]> i'm on vaccation on april 13
09:15:34 <ttx> ah.
09:15:54 <amorin> April 13 is good for me
09:15:59 <ttx> Could do April 6 instead
09:16:09 <amorin> that works for me also
09:16:24 <ttx> felix.huettner: you available for April 6?
09:16:28 <felixhuettner[m]> that is fine for me
09:16:57 <ttx> belmoreira: any preference?
09:18:25 <belmoreira> this timeslot can always clash with a major meeting that I have... It's far away for me to know if I need to attend or not.
09:18:37 <ttx> #agreed Next Large Scale OpenStack OpenInfra Live episode tentatively scheduled April 6
09:18:53 <ttx> Any suggestion who we should showcase there?
09:19:16 <amorin> should Societe general be available?
09:19:31 <ttx> ah, yes, that was in our backlog
09:19:40 <ttx> I'll contact them
09:19:50 <belmoreira> That would be great, since is a completely different use case
09:20:34 <ttx> With Samsung SDS engaging at an eearly stage with the group, I was also wondering if we could do an episode around early technical choices for a large scale deployment
09:20:52 <ttx> but the hour of the Live episode (15utc) is very inconvenient for them
09:20:54 <links> hi all, missed to introduce myself. I work in Red Hat in performance & scale team.
09:21:09 <ttx> links: oh, welcome!
09:21:18 <amorin> nice, welcome links!
09:21:26 <felixhuettner[m]> hi links
09:21:34 <ttx> so... maybe something to keep in mind for a future episode
09:21:51 <felixhuettner[m]> should we then maybe also do a live episode that is at a better time?
09:21:58 <danpaik> sure, happy to do that in a future episode from samsung sds
09:22:00 <ttx> #action ttx to reach out to Societe generale for April 6 espiode
09:22:40 <ttx> ok let's keep that in mind, it could make for an interesting perspective... like what would you choose if you started again from scratch today
09:23:00 <belmoreira> OpenInfra live being Asia time friendly
09:23:20 <belmoreira> it's a good idea for specific episodes
09:23:37 <felixhuettner[m]> and i have the feeling that this list is long
09:24:16 <ttx> danpaik: how much would the Live broadcast timing (15utc must be.. midnight your time?) be a blocker to your participation?
09:24:36 <ttx> So far we have not done episodes at another time, but I can ask
09:25:05 <amorin> something like 9 UTC
09:25:16 <amorin> that would be asia friendly, but not US friendly :(
09:25:34 <ttx> yeah one issue is that our production crew is in the US and our hosts are in Europe :)
09:25:35 <danpaik> we can do a midnight participation...
09:26:10 <danpaik> it will be optional for my team but some of us can probably attend at midnight
09:26:12 <ttx> danpaik: ok, that's great to know... we'll definitely try to do one around that theme
09:26:30 <ttx> we don't need 10 people, at most 2
09:26:40 <ttx> volunteers for midnight :)
09:27:08 <danpaik> sure we should be able to do that
09:27:20 <ttx> #info other potential guest: Samsung SDS to discuss early choices in large scale
09:27:45 <ttx> OK I think I have enough to work from.
09:27:49 <ttx> #topic Large Scale doc
09:27:56 <ttx> #link https://docs.openstack.org/large-scale
09:28:05 <ttx> This is where we try to document the learnings of the SIG
09:28:51 <ttx> it's organized as a "journey" from configuring for large scale to scaling up, scaling out, and maintaining that
09:29:21 <ttx> danpaik june_yi There might be answers to some of your questions in there already
09:29:31 <ttx> team: Anything new to report here?
09:29:35 <danpaik> ok we will review the site
09:29:45 <amorin> nothing new on my side here, but I am pretty sure we can learn from danpaik and links
09:29:56 <felixhuettner[m]> nope, nothing new from me
09:30:29 <ttx> danpaik: we are also interested in the list of things that are *not* addressed in that doc and should be... that's a good area to focus on going forward
09:30:42 <ttx> so any feedback on that will be great!
09:31:02 <danpaik> got it.  we'll focus on stuff not in the doc as well
09:31:30 <ttx> #topic Next meetings
09:31:53 <ttx> Our next meeting will be back at the US+EU time, scheduled for Feb 22 at 15utc. I won't be available to chair it though
09:32:01 <ttx> Do we have a volunteer? I'll make sure to post the reminders and let you know of progress on the Live guests
09:32:31 <ttx> I'll be around to chair our next APAC+EU meeting March 8, 9utc
09:33:12 <amorin> I can help
09:33:21 <ttx> amorin: thanks!
09:33:28 <amorin> wait , no
09:33:31 <amorin> I'll be off
09:33:41 <ttx> oops
09:33:58 <amorin> I am taking a holiday week, sorry
09:33:59 <links> I have some experience in galera/mariadb tunings at scale. Let me rethink on it if it would be a good addition to the doc.
09:34:12 <ttx> I'm a bit reluctant to skip it since now those are only happening every 4 weeks
09:34:22 <amorin> links amazing! this is one topic we dont have yet fully covered
09:35:08 <ttx> felix.huettner: belmoreira would you be around? I'm reluctant to skipping it since it comes only every 4 weeks around now
09:35:10 <belmoreira> I can't join this meeting. Have my calendar already with conflicting meetings in this time slot... :(
09:35:25 <ttx> ok sounds like we should just skip it then
09:35:35 <ttx> nobody will be around anyway
09:35:54 <felixhuettner[m]> ok i would be there :)
09:35:57 <felixhuettner[m]> but also fine for me to skip
09:36:14 <ttx> We can have a status update thread on the mailing-list to keep everyone informed on that week
09:36:59 <felixhuettner[m]> links: i'm always interested in galera tuning :D
09:37:02 <ttx> #info Feb 22 meeting skipped, will have a thread on the mailing-list instead to update status
09:37:14 <ttx> #info EU+APAC IRC meeting March 8, 9utc
09:37:31 <ttx> #topic Open discussion
09:38:16 <ttx> Question for Samsung SDS folks: are there any questions at this stage in your project that you would like to ask our resident experts?
09:38:52 <ttx> or would you like to review the documentation we already produced first? I'd recommend watching past episodes of teh Large Scale OpenStack show on OpenInfra Live too
09:38:59 <danpaik> we will prepare a set of questions for the next meeting.  we are primarily interested in using openstack at large scale across multiple regions and zones (many data centers) and haven't seen much of this yet.
09:39:22 <danpaik> we'll do some homework over the next few weeks.  thanks everyone for the warm welcome and look forward to participating in this SIG
09:39:33 <ttx> ok, so your concerns are mainly on scaling out to multiple zones/clusters/regions/AZs
09:39:43 <ttx> always a great topic :)
09:40:00 <danpaik> main concern is single control plane across multiple data centers each with a separate ceph
09:40:21 <danpaik> and how we can do that but maybe that's getting too detailed so we can discuss the problems we want to solve first
09:40:54 <danpaik> and yes you are correct in that our concerns are mainly with scaling across regions and zones, etc.
09:40:55 <ttx> details are good! I think that resonates with the stuff belmoreira was doing at CERN and amorin and felix.huettner are doing now
09:41:23 <danpaik> that's great.  collaboration is good!
09:41:46 <belmoreira> +1
09:41:47 <ttx> danpaik: it is one of the key benefits of using open infrastructure!
09:42:12 <felixhuettner[m]> yep i think we definately can share a bunch of ideas
09:42:13 <danpaik> we have been working closely with mirantis as well but have some limitations across this architecture that we want to address.
09:42:19 <felixhuettner[m]> allthough as always there will be no single solution
09:42:27 <ttx> Question for the team: do you want to do anything during the virtual PTG week of March 27?
09:42:46 <amorin> yup, each deployment is different, but some issues are still easy to avoid
09:42:58 <ttx> danpaik: the answer is very often "it depends" which is why discussing it is so useful.
09:43:14 <danpaik> felixhuettner[m], amorin, and others: we'll definitely have some fun discussions.
09:44:21 <amorin> +1
09:44:38 <felixhuettner[m]> +1
09:44:40 <ttx> Also... we will organize a Large Scale SIG forum session at the OpenInfra Summit in Vancouver, hpoinh to see some of you there!
09:44:44 <ttx> hoping*
09:45:01 <felixhuettner[m]> yep, will definately be there
09:45:23 <ttx> discussing ity in person is even better and more productive
09:45:29 <belmoreira> will try to join
09:45:44 <danpaik> will try as well
09:46:04 <amorin> unfortunately I wont be there
09:46:16 <ttx> do you think we should do something during the virtual PTG week of March 27?
09:46:21 <ttx> amorin: :(
09:46:33 <amorin> about virtual PTG, I am ok to do something if we have some topics to discuss?
09:46:42 <amorin> or maybe invite people talking with us?
09:46:48 <amorin> we did that in past IIRC
09:46:53 <ttx> we usually use the spot to recruit new SIG members
09:46:58 <amorin> I dont remember if it was a success or not
09:47:01 <ttx> but lately that was less efficient
09:47:19 <amorin> ack, so maybe we should keep only the vancouver real event
09:47:27 <amorin> which, last time in Berlin, was a great success
09:47:30 <ttx> belmoreira: you've been to a bunch, do you think it's worth our time?
09:47:38 <ttx> (virtual PTG session)
09:47:58 <ttx> yes, in -person gets plenty of new engagement
09:48:37 <belmoreira> i the Summit definitely
09:48:48 <belmoreira> in
09:49:18 <ttx> ok, how about we skip the virtual PTG end of March (focus on our Live episode and regular meetings, and plan to do am in -person session in Vancouver.
09:49:37 <amorin> +1
09:50:06 <belmoreira> Virtual PTG depends if we get people interested. It's difficult to say. At least we keep the possibility for people to ask questions and prepare the summit forum session
09:50:06 <ttx> #agreed Large Scale SIG will not do a virtual PTG session end of March, but will do an in-person session in Vancouver during the summit
09:50:36 <ttx> we can change our minds if the mood changes
09:50:44 <belmoreira> yeap
09:50:51 <ttx> Anything other topic to discuss, anyone?
09:51:28 <amorin> nop
09:52:21 <ttx> Thanks links danpaik june_yi color_park for joining us today! It's been one of the most active meetings we've had in a while!
09:52:31 <ttx> Thanks everyone for joining
09:52:41 <danpaik_mobile> Thanks for setting up the new time
09:52:57 <june_yi> +1
09:53:04 <ttx> No problem! we should have done that earlier :)
09:53:21 <ttx> #endmeeting