15:00:32 <ttx> #startmeeting large_scale_sig
15:00:32 <opendevmeet> Meeting started Wed Apr 23 15:00:32 2025 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <opendevmeet> The meeting name has been set to 'large_scale_sig'
15:00:48 <amorin> hello!
15:00:56 <ttx> amorin: high!
15:01:02 <ttx> hi!
15:01:26 <dmsimard[m]> hello o/
15:01:46 <ttx> Hi dmsimard good to see you!
15:02:10 <ttx> felix.huettner: around?
15:02:39 <ttx> Welcome to the monthly Large Scale SIG meeting...
15:02:46 <ttx> Our agenda lives at:
15:02:59 <ttx> #link https://etherpad.opendev.org/p/large-scale-sig-meeting
15:03:12 <ttx> Feel free to add topics there while we wait for stragglers
15:03:57 <ttx> #topic Next Large Scale SIG virtual meetup
15:04:49 <ttx> Unfortunately not much progress to report on that front. We were waiting for Nexgen to confirm (as we wanted an AI infrastructure episode) but they seem too busy buying GPUs right now
15:05:23 <ttx> I'm now looking at plan C, after our two main targets did not follow up
15:06:00 <ttx> Let me know if you have suggestions of who we could reach out to!
15:06:25 <ttx> Definitely want to do one before summer hits
15:07:29 <amorin> ack, I dont remember the name of the company, but they were doing baremetal with openstack
15:07:43 <amorin> dmsimard[m]: I think we talked about it once
15:07:48 <dmsimard[m]> CERN is always interesting to hear about but they already talk a lot about what they do :)
15:08:15 <amorin> yes, cern is a good idea, they do use GPU as per talks I heard about on kubecon
15:08:18 <ttx> yes and we had them several times already :) Would like to feature a recent/new user ideally
15:09:23 <ttx> I'll come up with suggestions and probably discuss it over email so that we make progress before next month meeting
15:09:27 <dmsimard[m]> agreed
15:09:52 <ttx> #action ttx to suggest plan C solutions in a ML thread ahead of next meeting
15:10:41 <ttx> but yes, if we can't convince a recent user to talk about their stuff, we'll reach out to older users, maybe one that's been growing their footprint a lot
15:11:30 <ttx> Anything else on that topic?
15:12:14 <ttx> #topic Large scale doc
15:12:15 <ttx> #link https://docs.openstack.org/large-scale
15:12:30 <ttx> Nothing to review on https://review.opendev.org/q/project:openstack/large-scale+status:open
15:12:49 <ttx> Does anyone have new doc changes cooking?
15:12:58 <amorin> I remember, it was openmetal!
15:13:04 <amorin> sorry for late answer :(
15:14:00 <ttx> OK, next topic...
15:14:04 <ttx> #topic Anything to highlight from the PTG ?
15:14:27 <ttx> Good question! I haven't been attending that many sessions so I can't tell
15:14:38 <ttx> Anything relevant in sessions you attended?
15:15:03 <dmsimard[m]> I added this topic, I also haven't been able to attend but did browse a couple etherpads after the fact
15:16:57 <dmsimard[m]> I didn't come prepared with a list but was hoping to know if there was noteworthy things to put on our radar to follow
15:17:22 <ttx> amorin: did you attend anything relevant?
15:18:02 <dmsimard[m]> I saw in keystone there is an attempt to rewrite it in rust for improved performance, for example
15:18:56 <dmsimard[m]> https://etherpad.opendev.org/p/apr2025-ptg-keystone line 99
15:19:08 <ttx> I guess taht's a good question -- would you consider that Keystone performance is such a bottleneck that you would just both feet into a Rust rewrite (and the inevitable regressions it would initially bring?)
15:19:14 <amorin> I did attend few stuff around GPU, autoscaling
15:19:17 <ttx> jump*
15:19:29 <amorin> I attented some very interesting talks about telemetry / monitoring of applications
15:19:41 <amorin> which is something we lack in OpenStack IMHO
15:20:09 <ttx> I would agree that telemetry is a bit lacking right now
15:20:45 <dmsimard[m]> @ttx, I don't personally have strong opinions and know what happened to past attempts at rewriting things in golang or rust :)
15:21:27 <dmsimard[m]> I am curious and interested in claims of 10x to 100x performance improvements, though
15:21:34 <amorin> we are trying to implement sentry inside neutron downstream, but this is still wip
15:23:19 <dmsimard[m]> We have something on the order of 100 million keystone API calls in 24h so even 10x improvement is significant
15:24:03 <ttx> dmsimard: interesting to know that at least the struggle is real (not sure that rewrite is the solution, but there is a problem to solve)
15:24:44 * dmsimard[m] nod
15:25:01 <ttx> Any other interesting insight from the PTG week?
15:26:20 <ttx> if not, moving on
15:26:23 <ttx> #topic Next meeting(s)
15:26:40 <ttx> Our next meeting is scheduled for May 28, 15utc, here as usual
15:26:45 <dmsimard[m]> I noted a challenge in ARM testing from the nova pad since Linaro has stepped away
15:27:05 <ttx> My personal goal is to have a guest and a date for our next virtual meetup by then
15:28:17 <ttx> #topic Open discussion
15:29:17 <dmsimard[m]> Any plans for operators and this SIG at this upcoming France summit ?
15:31:12 <ttx> We'd like to have something yes
15:31:57 <ttx> either a ops feedback session, or something Large-Scale-SIG specific
15:32:34 <dmsimard[m]> That would be great, let us know if we can help :)
15:34:24 <ttx> Will sure do! We should see clearer in a month
15:34:33 <ttx> Alright, anything else to discuss?
15:34:51 <dmsimard[m]> nothing from me
15:36:02 <ttx> OK then... Thanks for joining. Looks like we really need a new high-profile meetup to promote the monthly meeting and get more attendance :)
15:36:09 <ttx> #endmeeting