13:01:06 <isviridov> #startmeeting MagnetoDB
13:01:07 <openstack> Meeting started Thu Mar 13 13:01:06 2014 UTC and is due to finish in 60 minutes.  The chair is isviridov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:10 <openstack> The meeting name has been set to 'magnetodb'
13:01:19 <isviridov> Hi everybody
13:01:25 <achuprin> Hi
13:01:28 <achudnovets> hi
13:01:28 <aostapenko> Hello
13:01:30 <volmax> Hi
13:01:50 <miarmak_> hi
13:01:53 <isviridov> So let us start
13:01:57 <SpyRay> hi all
13:02:03 <isviridov> Teh agenda for today https://wiki.openstack.org/wiki/MagnetoDB/WeeklyMeetingAgenda
13:02:15 <isviridov> #topic General project status overview
13:02:34 <isviridov> So, i'm happy to see all of you here.
13:03:00 <isviridov> As you know we have released POC version and now started working on 2.0.*
13:03:28 <isviridov> The main goals for current 2.0.1 version are:
13:03:42 <isviridov> * openstack infra integration
13:03:56 <isviridov> * definition MagnetoDB API
13:04:32 <isviridov> * devstack integration
13:06:36 <isviridov> So, current version scope https://launchpad.net/magnetodb/+milestone/2.0.1
13:07:56 <isviridov> Should we proseed with next topic?
13:08:06 <aostapenko> looks reasonable
13:08:14 <miarmak_> +
13:08:20 <achudnovets> +
13:08:37 <isviridov> #topic MagnetoDB API Draft status
13:08:56 <isviridov> achudnovets, looks it your song
13:09:28 <isviridov> #link https://wiki.openstack.org/wiki/MagnetoDB/api
13:09:53 <achudnovets> there is the MagnetoDb API draft https://wiki.openstack.org/wiki/MagnetoDB/api
13:10:12 <isviridov> achudnovets, good job!
13:10:37 <isviridov> achudnovets, have you discussed it with smb from community?
13:11:22 <achudnovets> nope, I'd like to hear some comments about it
13:11:49 <isviridov> Probably the ML is better place for that
13:12:45 <aostapenko> isviridov: +1
13:13:03 <achudnovets> I agree
13:13:19 <isviridov> #action achudnovets start ML thread with API discussion
13:13:54 <isviridov> achudnovets, i've seen BP about API implementation.
13:14:14 <isviridov> Good job, I've added most pf them to 2.0.1 version scope
13:14:24 <isviridov> #link https://launchpad.net/magnetodb/+milestone/2.0.1
13:14:41 <isviridov> #topic Third party CI status
13:15:30 <isviridov> So, with MagnetoDB we need to have CI process out if openstack infra, but together with it
13:15:47 <isviridov> 1. running cassadnra integration test
13:16:00 <isviridov> 2. run devstack integration tests
13:16:23 <achudnovets> Why we need CI outside openstack infra?
13:16:39 <isviridov> #link https://blueprints.launchpad.net/magnetodb/+spec/third-party-ci
13:16:47 <aostapenko> isviridov: Why don't we run devstack integration tests in infra?
13:16:55 <isviridov> achudnovets, because of 1. and 2. )
13:17:12 <achudnovets> ok, I see, thanks :)
13:17:47 <isviridov> aostapenko, we are not a part of openstack yet. In future, when we will integrate. We will run it there.
13:18:58 <aostapenko> isviridov: I suppose we can do new gate with devstack in infra
13:20:07 <isviridov> aostapenko, not sure, that we can add our project to devstack. It can brake whole dev process.
13:20:16 <achuprin> now we have some requirements for environment
13:20:45 <achuprin> as results we need own env
13:21:15 <achuprin> which will be integrated with Infra
13:21:46 <achuprin> we hava 3 way for this
13:22:26 <achuprin> 1. Gerrit layer
13:22:44 <achuprin> 2. zuul layer
13:23:04 <achuprin> 3. Nodepool layer
13:23:26 <isviridov> Do we know what the way we go now?
13:23:31 <achuprin> some information you can find here https://www.mail-archive.com/openstack-infra@lists.openstack.org/msg01013.html
13:24:21 <achuprin> now we use Gerrit layer integration for cassandra unittests
13:24:56 <achuprin> but for devstack testing we need other way
13:25:24 <achuprin> zuul or nodepool layers integrations
13:25:40 <isviridov> achuprin, looks we need the wiki page about it.
13:26:27 <achuprin> can we discuss this offline?
13:26:58 <isviridov> Yeap, let us go to #magnetodb for discussion
13:27:01 <aostapenko> achuprin: I think all this tests can be run by different gates in infra
13:27:36 <isviridov> #action achuprin discuss with infra the best way for our CI
13:28:01 <isviridov> #action achuprin create wiki page with CI description
13:28:04 <achuprin> isviridow, wiki - ok
13:28:23 <isviridov> next topic?
13:28:26 <achudnovets> +
13:29:22 <ominakov> +
13:29:24 <isviridov> #topic Support of other database backends except Cassandra. Support of HBase
13:29:35 <volmax> +
13:30:17 <achuprin> aostapenko, yes it will be run by different gates, but for this we need specific env. (cassandra requirements for example )
13:30:31 <isviridov> We have to look at other database for MagnetoDB, not only Cassandra
13:31:22 <ikhudoshyn> do we, really?
13:31:49 <isviridov> It is common case, HBase comes together with big data processing and we have evaluate if HBase or some other DB suits
13:32:12 <isviridov> ikhudoshyn, hey man
13:32:16 <ikhudoshyn> so by 'other database' you mean hbase, right?
13:32:25 <isviridov> ) at least
13:32:28 <ikhudoshyn> isviridov, hi there
13:32:50 <isviridov> Do you have anything to share with us in that dirrection?
13:33:20 <ominakov> how magneto can interact with HBase?
13:33:45 <aostapenko> ominakov: the same way as with cassandra
13:34:06 <isviridov> ominakov, the underlying databate pluggubility by design.
13:34:18 <ikhudoshyn> are there any other candidates, apart from hbase?
13:34:18 <ikhudoshyn> 'cos with hbase i kinda got a tiny complain
13:34:42 <isviridov> ominakov, it is possible just to implement another DB support
13:34:58 <isviridov> ikhudoshyn, riak, mongodb. What do you think?
13:34:59 <ikhudoshyn> ominakov, thats the issue
13:35:30 <isviridov> ikhudoshyn, but HBase always comes with Hadoop and Big Data
13:37:02 <isviridov> I think we have to start ML thread
13:37:14 <aostapenko> isviridov: +
13:37:19 <achudnovets> +
13:37:21 <isviridov> ikhudoshyn, can you drive it?
13:38:16 <isviridov> #action isviridov ikhudoshyn start mail thread about evalution other databases as backend for MagnetoDB
13:38:35 <isviridov> #topic Devstack integration status
13:38:45 <isviridov> It is vital thing actualy
13:38:56 <isviridov> vnaboichenko, SpyRay any news?
13:39:07 <isviridov> #link https://blueprints.launchpad.net/magnetodb/+spec/devstack-integration
13:39:56 <vnaboichenko> we have done script which deploys cassandra 2.02 from tarbar with oracle jdk 1.7 and magnetodb from master
13:40:12 <vnaboichenko> we are investigating in cassandra cluster manager
13:40:13 <vnaboichenko> https://github.com/pcmanus/ccm
13:40:35 <isviridov> WOW! Looks as huge progress
13:40:39 <vnaboichenko> now looks good, we will modify scripts for set up nodes with this manager
13:41:17 <isviridov> I think we need some guide for work with it
13:41:39 <vnaboichenko> yes, i will made a wiki
13:41:45 <isviridov> Awesome!
13:42:09 <isviridov> #actio vnaboichenko devstack integration guide in OpenStack wiki
13:42:15 <isviridov> #action vnaboichenko devstack integration guide in OpenStack wiki
13:42:33 <isviridov> #topic Weekly meeting time slot
13:43:18 <isviridov> We have to think about better time for our meeting to cover US contributors.
13:43:38 <isviridov> What about 1700 UTC
13:43:44 <miarmak_> do we have maybe a table with free time slots?
13:43:48 <isviridov> Other suggestions?
13:44:18 <aostapenko> 17 is good
13:44:26 <isviridov> miarmak_, good point. We have to check free slots
13:44:30 <isviridov> I'll do so
13:44:36 <achudnovets> 1700 UTC is good for me
13:44:47 <isviridov> #action isviridov find better time slot for meeting
13:45:04 <miarmak_> isviridov: yeah, and after that take several slots and vote for them
13:45:05 <isviridov> #action isviridov start ML voting meeting time
13:45:18 <isviridov> miarmak_, yeap
13:45:25 <miarmak_> awesame)
13:45:31 <isviridov> #topic Open discussion
13:45:47 <isviridov> ikhudoshyn, how was your fly?
13:45:54 <isviridov> )
13:46:40 <isviridov> ikhudoshyn, it looks like we can count on you in PST timezome.
13:47:08 <miarmak_> is it 6.47 am now?)
13:47:26 <isviridov> miarmak_, yeap. But we have seen him
13:47:55 <isviridov> Ok, guys. Looks like we finished
13:48:15 <isviridov> Thx and see you at #magnetodb
13:48:20 <miarmak_> btw
13:48:27 <ikhudoshyn> oops, guys, had issues with connection
13:48:31 <miarmak_> i remember 1 thing about time
13:48:46 <isviridov> miarmak_, pelase
13:48:53 <miarmak_> we have time change soon in ua
13:49:09 <miarmak_> )
13:49:12 <isviridov> miarmak_, good point. I'll take it into account
13:49:18 <miarmak_> thx)
13:49:21 <isviridov> #endmeeting