09:01:23 <strigazi> #startmeeting magnum
09:01:23 <opendevmeet> Meeting started Wed Feb 23 09:01:23 2022 UTC and is due to finish in 60 minutes.  The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:23 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:24 <opendevmeet> The meeting name has been set to 'magnum'
09:01:28 <strigazi> #topic Roll Call
09:01:31 <strigazi> o/
09:01:35 <jakeyip> o/
09:01:49 <gbialas_> O/
09:01:56 <mnasiadka> o/
09:03:52 <strigazi> #topic Release final python-magnumclient for Yoga | https://review.opendev.org/c/openstack/releases/+/830241
09:04:21 <strigazi> This needs to be merged by the 25th.
09:04:49 <strigazi> I would like to ask you for some help to include 788689: Cluster config update | https://review.opendev.org/c/openstack/python-magnumclient/+/788689
09:05:46 <strigazi> I'm trying to follow it up as well
09:07:28 <strigazi> #topic Review action items
09:07:29 <jakeyip> ok I tested PS57, it was working OK but was just failing CI
09:07:53 <strigazi> change the default hyperkube to the rancher build, done: 830479: [k8s-coreos] Default hyperkube_prefix to rancher | https://review.opendev.org/c/openstack/magnum/+/830479
09:09:50 <strigazi> jakeyip: thanks, I will try to do another round of review as well.
09:10:12 <jakeyip> ok, kube_tag and master_kube_tag is only used for hyperkube and nothing else?
09:10:31 <strigazi> yes
09:12:10 <opendevreview> Spyros Trigazis proposed openstack/magnum master: [k8s-coreos] Default hyperkube_prefix to rancher  https://review.opendev.org/c/openstack/magnum/+/830479
09:13:32 <strigazi> jakeyip: here as well but of the hyperkube https://github.com/openstack/magnum/blob/master/magnum/drivers/common/templates/kubernetes/fragments/upgrade-kubernetes.sh
09:14:12 <jakeyip> I'm not super familiar with code, what about https://github.com/openstack/magnum/blob/master/magnum/drivers/common/templates/kubernetes/fragments/configure-kubernetes-minion.sh#L157
09:14:43 <strigazi> jakeyip: for fedora-coreos this is not used
09:15:31 <strigazi> see https://github.com/openstack/magnum/blob/master/magnum/drivers/common/templates/kubernetes/fragments/configure-kubernetes-minion.sh#L65
09:16:16 <strigazi> jakeyip: change magnum/api/validation.py#L259-L260 to not allow mesos as a coe option, can you push a patch?
09:16:25 <jakeyip> ok like I say I'm not super familiar, I trust you
09:16:29 <jakeyip> sure, I will do that
09:17:12 <strigazi> jakeyip: in fedora coreos, "atomic install" does not exist a
09:17:15 <strigazi> jakeyip: in fedora coreos, "atomic install" does not exist at all
09:17:24 <jakeyip> oh yeah right we used podman
09:18:20 <strigazi> #action jakeyip to change magnum/api/validation.py#L259-L260 to not allow mesos as a coe option
09:19:31 <strigazi> #action strigazi to comment on 821213: Drop mesos driver | https://review.opendev.org/c/openstack/magnum/+/821213 , 803780: Drop bay and baymodel from controllers | https://review.opendev.org/c/openstack/magnum/+/803780 , 803629: Drop bay and baymodel | https://review.opendev.org/c/openstack/python-magnumclient/+/803629
09:19:57 <strigazi> #topic Yoga release
09:20:30 <strigazi> mnasiadka: gbialas_: jakeyip: is something else we want to update for Yoga?
09:20:47 <gbialas_> Not today :)
09:21:02 <strigazi> We still have a couple of weeks
09:21:13 <mnasiadka> let me check pending patches...
09:21:51 <mnasiadka> OVN LB related patches:
09:21:51 <mnasiadka> https://review.opendev.org/c/openstack/magnum/+/764444
09:21:51 <mnasiadka> https://review.opendev.org/c/openstack/magnum/+/765309
09:21:51 <mnasiadka> https://review.opendev.org/c/openstack/magnum/+/767119
09:22:08 <mnasiadka> And a patch related to allowed_address_pairs bug in ML2/OVN - https://review.opendev.org/c/openstack/magnum/+/773923
09:22:25 <strigazi> mnasiadka: ACK
09:22:26 <mnasiadka> would be nice to get these in :)
09:22:54 <strigazi> #action strigazi to review https://review.opendev.org/c/openstack/magnum/+/764444 https://review.opendev.org/c/openstack/magnum/+/765309 https://review.opendev.org/c/openstack/magnum/+/767119 https://review.opendev.org/c/openstack/magnum/+/773923
09:23:18 <strigazi> #action jakeyip to review https://review.opendev.org/c/openstack/magnum/+/764444 https://review.opendev.org/c/openstack/magnum/+/765309 https://review.opendev.org/c/openstack/magnum/+/767119 https://review.opendev.org/c/openstack/magnum/+/773923
09:23:46 <strigazi> ( jakeyip I see you are not added in the magnum-core group yet, I will ping the ML thread)
09:24:01 <strigazi> And for Yoga,
09:24:27 <strigazi> #topic Conformance for 1.24 in Yoga
09:24:44 <strigazi> mnasiadka: gbialas_: Do you want to have a look at it?
09:25:18 <strigazi> We need to submit a patch with the result of the conformance test to have magnum certified
09:25:56 <strigazi> #link https://www.cncf.io/certification/software-conformance/
09:29:36 <strigazi> #action strigazi to follow up kubernetes conformance for Yoga https://www.cncf.io/certification/software-conformance/
09:29:46 <jakeyip> strigazi: not in hurry, but if quota fixes can be in for Yoga that'll be good too
09:30:08 <mnasiadka> strigazi: sure, we can look into that
09:30:19 <strigazi> #undo
09:30:19 <opendevmeet> Removing item from minutes: #action strigazi to follow up kubernetes conformance for Yoga https://www.cncf.io/certification/software-conformance/
09:30:26 <strigazi> #action mnasiadka to follow up kubernetes conformance for Yoga https://www.cncf.io/certification/software-conformance/
09:30:53 <strigazi> #action strigazi to review https://review.opendev.org/c/openstack/magnum/+/764254 https://review.opendev.org/c/openstack/magnum/+/764397
09:31:19 <strigazi> I think that's it for past items
09:31:28 <strigazi> #topic Open Discussion
09:31:59 <jakeyip> just off the top of my mind, is atomic something that should be deprecated?
09:32:07 <strigazi> jakeyip: yes
09:32:28 <strigazi> it's replaced by fedora-coreos
09:32:45 <strigazi> jakeyip: want to do it? similar to mesos?
09:33:25 <jakeyip> yeah I am in favour of removing code, too much legacy code gets confusing.
09:33:51 <jakeyip> might not be in time for yoga, not sure
09:33:52 <strigazi> #action jakeyip to deprecate fedora-atomic driver(s)
09:34:14 <strigazi> feel free to push a plaholder patch at least and we see
09:34:24 <jakeyip> ok
09:35:23 <strigazi> all, any other business?
09:39:26 <strigazi> let's close then, see you next week!
09:39:29 <strigazi> #endmeeting