08:59:47 <strigazi> #startmeeting magnum
08:59:47 <opendevmeet> Meeting started Wed Mar 16 08:59:47 2022 UTC and is due to finish in 60 minutes.  The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:59:47 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:59:47 <opendevmeet> The meeting name has been set to 'magnum'
08:59:52 <strigazi> #topic Roll Call
09:00:00 <jakeyip> o/
09:00:44 <strigazi> o/
09:01:11 <dale`> o/
09:01:11 <gbialas> o/
09:03:09 <strigazi> #topic Past Action Items
09:03:30 <strigazi> #link https://etherpad.opendev.org/p/magnum-weekly-meeting
09:04:22 <strigazi> jakeyip to change magnum/api/validation.py#L259-L260 to not allow mesos as a coe option
09:04:55 <strigazi> jakeyip: we have a patch for this?
09:06:22 <jakeyip> yes, merged https://review.opendev.org/c/openstack/magnum/+/830594
09:06:37 <strigazi> cool, thanks
09:07:13 <strigazi> I'm relaying the following to the next:
09:07:20 <strigazi> #action strigazi to comment on 821213: Drop mesos driver | https://review.opendev.org/c/openstack/magnum/+/821213 , 803780: Drop bay and baymodel from controllers | https://review.opendev.org/c/openstack/magnum/+/803780 , 803629: Drop bay and baymodel | https://review.opendev.org/c/openstack/python-magnumclient/+/803629
09:07:31 <strigazi> next is:
09:07:39 <strigazi> strigazi to review Octavia Patches https://review.opendev.org/c/openstack/magnum/+/764444 https://review.opendev.org/c/openstack/magnum/+/765309 https://review.opendev.org/c/openstack/magnum/+/767119 https://review.opendev.org/c/openstack/magnum/+/773923
09:08:08 <strigazi> I just finished with these three, thanks mnasiadka
09:08:32 <strigazi> I don't who is using devstack for testing, but master doesn
09:08:42 <strigazi> I don't who is using devstack for testing, but master doesn't work for me since a couple of weeks
09:08:49 <strigazi> I had to use wallaby
09:08:56 <jakeyip> master of?
09:09:26 <strigazi> jakeyip: master branch of all components including devstack
09:09:39 <jakeyip> I opened a bug with ovn-octavia-provider and patched another thing
09:09:47 <strigazi> jakeyip: I deployed with wallaby and then just bumped magnum to master
09:09:47 <jakeyip> it worked for me for ovn-octavia-provider master
09:10:14 <jakeyip> their devstack wasn't working properly
09:10:32 <strigazi> jakeyip: But for the magnum patches we can merge right?
09:10:37 <strigazi> i think it was fine
09:11:00 <jakeyip> yeah it's working for me now. a couple of rough edges. one thing I am thinking of is if we should squash those changes
09:11:34 <jakeyip> it's not really working until you have all three changes, does this warrant a squash?
09:11:39 <strigazi> we could, gbialas what do you think?
09:12:35 <strigazi> jakeyip: to not hold things we can squash in case of a cherry-pick
09:12:56 <strigazi> they're hanging for some time, so let's take them
09:13:29 <jakeyip> sure. before you merge, we might also need https://review.opendev.org/c/openstack/magnum/+/832877 else it is going to fail gate
09:13:33 <gbialas> What is the question. ?
09:13:40 <strigazi> I'll add it as an action again to make it's in by the next meeting
09:14:12 <strigazi> gbialas: to squash the three OVN patches into one
09:14:34 <strigazi> jakeyip: ack for https://review.opendev.org/c/openstack/magnum/+/832877
09:15:11 <gbialas> I think it is ok. They are covering one story, and are dependent.
09:15:38 <strigazi> #action strigazi to follow Octavia Patches https://review.opendev.org/c/openstack/magnum/+/764444 https://review.opendev.org/c/openstack/magnum/+/765309 https://review.opendev.org/c/openstack/magnum/+/767119 https://review.opendev.org/c/openstack/magnum/+/773923
09:15:46 <strigazi> gbialas: ok
09:16:22 <strigazi> #action strigazi to follow: 832877: Remove the deprecated argument tenant from RequestContext | https://review.opendev.org/c/openstack/magnum/+/832877
09:16:35 <strigazi> jakeyip: we need this in the yoga branch? ^^
09:16:59 <jakeyip> not sure I didn't test yoga
09:17:05 <strigazi> ok
09:17:27 <strigazi> next item is:
09:17:35 <strigazi> mnasiadka to follow up kubernetes conformance for Yoga https://www.cncf.io/certification/software-conformance/
09:17:58 <strigazi> I'll relay since mnasiadka didn't join today
09:18:07 <strigazi> #action mnasiadka to follow up kubernetes conformance for Yoga https://www.cncf.io/certification/software-conformance/
09:18:12 <strigazi> next:
09:18:27 <strigazi> strigazi to review https://review.opendev.org/c/openstack/magnum/+/764254 https://review.opendev.org/c/openstack/magnum/+/764397 DONE and in time for yoga
09:18:28 <mnasiadka> still need to do that, sorry - $job overtook my life :)
09:18:37 <strigazi> mnasiadka: no worries
09:18:47 <strigazi> and last one,
09:18:55 <strigazi> jakeyip to deprecate fedora-atomic driver(s)
09:19:23 <strigazi> pushed: https://review.opendev.org/c/openstack/magnum/+/833949
09:19:38 <jakeyip> I have a WIP in https://review.opendev.org/c/openstack/magnum/+/833949/1 , following feilong's and others deprecation strategy. can you let me know if that is OK I'll do reno and rest
09:19:59 <strigazi> #action strigazi, jakeyip to follow 833949: WIP: Deprecated fedora_atomic driver | https://review.opendev.org/c/openstack/magnum/+/833949
09:20:23 <strigazi> jakeyip: we can do it like that, looks good
09:20:58 <jakeyip> good
09:21:09 <strigazi> #topic Open Discussion
09:21:37 <mnasiadka> What about PTG slots? I think Magnum is not on the list of projects that will have PTG sessions ;-)
09:21:39 <strigazi> I just wanted to check with gbialas and mnasiadka if there are any news for the CAPI driver
09:22:11 <mnasiadka> I don't think so, these are other people from our company that wanted to do this - but I'm afraid they are busy with other tasks.
09:22:17 <mnasiadka> But I'll check after the meeting.
09:22:38 <strigazi> mnasiadka: cool, let us know
09:23:47 <oneswig_> hi strigazi - apologies.  mnasiadka is right - the problem is other deadlines for end of March
09:24:20 <strigazi> mnasiadka: for the PTG, I don't think another two hour slot would make a difference. If we make good progress with the weekly meetings we can do another session in the next PTG
09:24:54 <mnasiadka> strigazi: sure, fine by me :)
09:25:23 <strigazi> oneswig_: no worries, we are eager to move with it. When you manage to allocate ping us at CERN, others are for sure interested too
09:25:45 <oneswig_> thanks strigazi, will do
09:25:48 <strigazi> mnasiadka: But it's a good point, I'll send an email to tell people and remind them for the meeting
09:26:29 <strigazi> dale`: do you want to bring something up?
09:26:50 <dale`> thanks, just listening in today
09:27:03 <strigazi> cool
09:27:23 <strigazi> all, any other business
09:27:30 <strigazi> all, any other business?
09:27:36 <jakeyip> one deprecation topic, there are a few stuffs marked as deprecated and can be removed, namely overlay (not overlay2) and in-tree cinder csi. should these move ahead?
09:28:21 <strigazi> we can drop them
09:28:25 <strigazi> less is more :)
09:28:37 <jakeyip> good
09:28:55 <strigazi> #action jakeyip to drop "overlay" storage driver
09:29:05 <strigazi> #action jakeyip to drop cinder in-tree provider
09:29:54 <jakeyip> there's a question a few days earlier about admission-control that I don't have the answer to
09:30:22 <strigazi> #action strigazi to notify the ML for not having a PTG session
09:30:30 <strigazi> jakeyip: what was it?
09:30:57 <jakeyip> > dhrp | The specific problem that I have is; which feels super dumb. Is that that when using the CLI to create the template, I cannot pass a comma separated list. with the admission_control_list. This probably just a parsing issue.
09:31:31 <jakeyip> I think the issue is with label values being a comma separated list
09:31:57 <strigazi> --labes "the comma separated list" --labels kube_tag=v1.23.1 --labels ..
09:32:16 <strigazi> you can pass labels many times
09:32:58 <strigazi> Indeed the client probably parses the list incorrectly
09:33:43 <gbialas> label=value,label=value,label=value... is the way to go in cli
09:34:43 <strigazi> yes, you can split it in many --labels arguments
09:34:49 <jakeyip> that works gbialas thanks
09:35:23 <jakeyip> strigazi: one other review for attention - dropping baymodel in client  https://review.opendev.org/c/openstack/python-magnumclient/+/803629
09:35:24 <gbialas> strigazi you are right, this also works
09:35:53 <strigazi> #action strigazi to follow 803629: Drop bay and baymodel | https://review.opendev.org/c/openstack/python-magnumclient/+/803629
09:40:01 <strigazi> all, any other business?
09:43:22 <strigazi> thanks for joining everyone
09:43:27 <strigazi> #endmeeting