09:01:01 <jakeyip> #startmeeting magnum
09:01:01 <opendevmeet> Meeting started Wed Apr 27 09:01:01 2022 UTC and is due to finish in 60 minutes.  The chair is jakeyip. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:01 <opendevmeet> The meeting name has been set to 'magnum'
09:01:05 <jakeyip> #topic Roll Call
09:01:11 <strigazi> o/
09:01:15 <jakeyip> o/
09:03:04 <jakeyip> mnasiadka ?
09:03:20 <mnasiadka> o/
09:03:29 <jakeyip> Thanks for joining the meeting
09:04:16 <strigazi> btw, you don't have to loop over all topics if nothing is to be reported
09:04:22 <jakeyip> Agenda:
09:04:24 <jakeyip> #link https://etherpad.opendev.org/p/magnum-weekly-meetingn
09:05:21 <jakeyip> jakeyip to change magnum/api/validation.py#L259-L260 to not allow mesos as a coe option
09:05:27 <jakeyip> this is done
09:05:56 <gbialas> O/
09:06:03 <jakeyip> there are a few more follow up for dropping mesos drivers, any updates?
09:06:36 <strigazi> no, I will take care of them this week
09:06:43 <jakeyip> thanks
09:07:00 <jakeyip> #action strigazi to comment on 821213: Drop mesos driver | https://review.opendev.org/c/openstack/magnum/+/821213 , 803780: Drop bay and baymodel from controllers | https://review.opendev.org/c/openstack/magnum/+/803780 , 803629: Drop bay and baymodel | https://review.opendev.org/c/openstack/python-magnumclient/+/803629
09:07:22 <jakeyip> next:
09:08:17 <jakeyip> gbialas: to squash the three OVN patches into one
09:09:07 <gbialas> jakeyip: afaik mnasiadka was handling this.
09:09:44 <gbialas> I know it was my action point, but he took this :)
09:10:20 <mnasiadka> I never got to this point, so do this gbialas ASAP ;)
09:10:30 <gbialas> ok:)
09:10:42 <mnasiadka> (spent some time fixing devstack to do my task properly)
09:10:43 <jakeyip> :) thanks
09:11:07 <jakeyip> #action gbialas: to squash the three OVN patches into one https://review.opendev.org/c/openstack/magnum/+/764444 https://review.opendev.org/c/openstack/magnum/+/765309 https://review.opendev.org/c/openstack/magnum/+/767119 https://review.opendev.org/c/openstack/magnum/+/773923
09:11:11 <jakeyip> next
09:11:17 <jakeyip> mnasiadka: to follow up kubernetes conformance for Yoga https://www.cncf.io/certification/software-conformance/
09:11:46 <mnasiadka> Yes, did the deploy and tests, but then wanted to do the same on devstack (not Kolla-Ansible Yoga deployment)
09:11:57 <mnasiadka> And found myself in a very bad place :)
09:12:15 <mnasiadka> It's better now, so I'll pick it up again and finish this off properly.
09:12:46 <mnasiadka> btw - after https://review.opendev.org/c/openstack/python-keystoneclient/+/675870 landed - Magnum will probably always use public Keystone endpoint (don't know if it's a bad thing though)
09:12:59 <mnasiadka> Before that patch - it used admin endpoint (which does not exist in devstack)
09:13:23 <jakeyip> thanks, I understand devstack is a struggle, I am for the idea that we should prune / fix up the wiki aggressively
09:13:29 <strigazi> mnasiadka: (it's a bad thing)
09:13:43 <mnasiadka> strigazi: I'll propose a patch to get it configurable on our side
09:13:59 <jakeyip> will trust only work with admin endpoint?
09:14:00 <mnasiadka> our = Magnum
09:14:11 <strigazi> magnum and heat accounts are very powerful and they should talk to an admin endpoint
09:14:23 <strigazi> for devstack, it does matter much
09:14:30 <mnasiadka> strigazi: but keystone v2 does not guarantee/require an admin endpoint
09:14:36 <mnasiadka> and some deployment projects are just removing it
09:14:49 <mnasiadka> ups
09:14:49 <mnasiadka> v3
09:15:16 <strigazi> we can support both admin and public and let deployers pick what they want I guess
09:15:17 <mnasiadka> so I think we should default to admin, but make it configurable so deployment project/user can set it to internal?
09:15:23 <strigazi> yeap
09:15:24 <mnasiadka> or public, yeah
09:15:43 <mnasiadka> I'll do it as part of devstack cleanup (+docs obviously)
09:17:12 <jakeyip> #action mnasiadka to check out implications of https://review.opendev.org/c/openstack/python-keystoneclient/+/675870 and possibly endpoint type configurable
09:17:58 <jakeyip> next: CAPI driver
09:18:37 <mnasiadka> I'll nudge Stig later today asking what's the plan - and update etherpad...
09:18:38 <jakeyip> mnasiadka / gbialas any news?
09:18:55 <mnasiadka> I don't think it has much traction in our company now
09:19:19 <jakeyip> ok, let us know
09:20:06 <jakeyip> strigazi: I didn't follow CAPI topic much, do you have anything to add to that?
09:20:45 <strigazi> jakeyip: no, I have heard from many that they want to do it but due to it's intrusiveness plans are stale. Same here
09:21:12 <strigazi> we really want it but it will be a very big change
09:21:33 <jakeyip> any WIP on your side doing this?
09:22:00 <strigazi> we don't have anything, most of our focus is the move of all addons to containers
09:22:17 <strigazi> managed by a single helm chart
09:22:47 <jakeyip> ok we will revisit this
09:23:30 <jakeyip> next: propose of mnasiadka for Core
09:23:40 <strigazi> done :)
09:24:00 <mnasiadka> thanks :)
09:24:06 <jakeyip> nice, welcome mnasiadka, thanks for your great work
09:24:36 <jakeyip> next: docs update, especially wiki
09:25:11 <mnasiadka> we should remove the wiki contents - wiki.openstack.org is unmaintained and is going to be removed sooner or later
09:25:39 <strigazi> +1
09:25:51 <jakeyip> where will we put docs?
09:27:08 <strigazi> https://opendev.org/openstack/magnum/src/branch/master/doc
09:27:14 <mnasiadka> yes, that's the obvious place
09:28:29 <jakeyip> ok, as long as that is the consenses, we shall move away from wiki
09:30:01 <jakeyip> #action jakeyip move docs away from wiki into https://opendev.org/openstack/magnum/src/branch/master/doc
09:30:22 <jakeyip> I have questions about 'Compatibility Matrix'. FCOS 35 tripped a few people up
09:31:24 <jakeyip> p.s. link to compatibility matrix on wiki https://wiki.openstack.org/wiki/Magnum
09:31:55 <jakeyip> probably we should document supported fcos version? maybe also drop everything train and below?
09:33:11 <strigazi> +1
09:34:11 <jakeyip> ok so correct me if I am wrong. Yoga - fcos35, Xena - fcos31. I am going off magnum/devstack/plugin.sh
09:35:09 <jakeyip> Any other topics?
09:35:44 <strigazi> (I have to jump out thanks jakeyip for running the meeting)
09:35:57 <jakeyip> thanks strigazi for joining
09:36:39 <jakeyip> mnasiadka / gbialas anything you want to bring up?
09:37:30 <mnasiadka> gbialas is working on getting Prometheus properly working after latest chart bump (some of Kubernetes services metrics endpoints are only listening on 127.0.0.1 and unreachable)
09:38:10 <mnasiadka> and I think that's it ;-)
09:38:24 <opendevreview> Merged openstack/magnum stable/wallaby: Fix errors caused by cryptography>=35.0.0  https://review.opendev.org/c/openstack/magnum/+/839185
09:38:34 <jakeyip> ok
09:38:48 <gbialas> I am thinking of compatibility matrix for k8s tag
09:39:10 <gbialas> But I don't have nothing particular in my mind right now.
09:39:45 <jakeyip> is this the kube_tag on https://wiki.openstack.org/wiki/Magnum or something else?
09:39:51 <gbialas> Yes.
09:40:13 <jakeyip> ok. we will move it and update it :)
09:40:15 <jakeyip> I will
09:40:17 <gbialas> I think we are supportin to wide range on k8s taks
09:41:09 <gbialas> I think we are supportng to wide kube_tags versions range for one release.
09:43:24 <gbialas> I will try to come with some proposal regarding this to next meeting.
09:44:00 <jakeyip> ok. I think yoga default is 1.23
09:44:11 <jakeyip> let's put it on next week's agenda
09:44:39 <jakeyip> anything else?
09:45:00 <gbialas> Nothing from my side
09:45:14 <jakeyip> thanks for joining the meeting
09:45:16 <jakeyip> #endmeeting