09:02:02 <strigazi> #startmeeting magnum
09:02:02 <opendevmeet> Meeting started Wed May  4 09:02:02 2022 UTC and is due to finish in 60 minutes.  The chair is strigazi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:02 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:02:02 <opendevmeet> The meeting name has been set to 'magnum'
09:02:05 <strigazi> #topic Roll Call
09:02:07 <strigazi> o/
09:02:11 <jakeyip> o/
09:03:50 <gbialas> o/
09:04:18 <strigazi> Thanks for joining the meeting jakeyip gbialas
09:04:23 <strigazi> #topic announcements
09:04:27 <strigazi> Welcome mnasiadka to the core team
09:04:28 <tobias-urdin> o/
09:04:40 <jakeyip> welcome!
09:04:46 <gbialas> welcome :)
09:05:21 <strigazi> #topic Past action items
09:05:51 <strigazi> strigazi to comment on 821213: Drop mesos driver | https://review.opendev.org/c/openstack/magnum/+/821213 DONE
09:06:14 <strigazi> jakeyip: do we have a patch to not allow mesos as COE already?
09:06:28 <jakeyip> not yet
09:06:41 <jakeyip> I'll do a for docs first, then remove meso from code
09:07:08 <jakeyip> docs - https://review.opendev.org/c/openstack/magnum/+/839556
09:07:14 <strigazi> thanks, I linked your patch in the review
09:07:38 <strigazi> next is: Drop bay and baymodel from controllers
09:07:53 <strigazi> I noticed that we have already a deprecation warning in the client
09:07:59 <strigazi> maybe we drop it in this cycle?
09:08:30 <strigazi> jakeyip: ^^
09:08:39 <jakeyip> I didn't see the deprecation warning, but if there is, then yes
09:09:00 <jakeyip> I will check for deprecation warning
09:09:11 <strigazi> https://github.com/openstack/python-magnumclient/blob/d558e4a2556029ffb8c987bd1ff309d3f86dfe83/magnumclient/v1/bays_shell.py#L24
09:09:25 <jakeyip> good then
09:09:40 <strigazi> and https://github.com/openstack/python-magnumclient/blob/d558e4a2556029ffb8c987bd1ff309d3f86dfe83/magnumclient/v1/baymodels_shell.py#L23
09:09:52 <strigazi> so we move ahead with it
09:10:42 <jakeyip> ok
09:11:03 <strigazi> next is gbialas: to squash the three OVN patches into one, this is done right?
09:11:04 <opendevreview> Jake Yip proposed openstack/magnum master: Drop bay and baymodel tests  https://review.opendev.org/c/openstack/magnum/+/803779
09:11:28 <jakeyip> Yes. I was testing it, looks ok
09:11:35 <gbialas> It is done in this patch : https://review.opendev.org/c/openstack/magnum/+/839709
09:11:45 <strigazi> thanks
09:11:49 <dioguerra> nick dioguerra
09:12:08 <strigazi> let me put the two action, for this and bay* stuff
09:12:48 <strigazi> #action jakeyip, strigazi to follow bay/baymodel patches
09:13:22 <strigazi> #action jakeyip, strigazi to follow mesos removal (docs and block mesos as COE)
09:13:46 <strigazi> #action jakeyip, mnasiadka, strigazi to follow 839709: Add support for choosing Octavia provider | https://review.opendev.org/c/openstack/magnum/+/839709
09:14:22 <strigazi> since mnasiadka is not here we can relay his action items
09:14:32 <strigazi> #action mnasiadka: to follow up kubernetes conformance for Yoga https://www.cncf.io/certification/software-conformance/
09:14:41 <strigazi> #action mnasiadka to check out implications of https://review.opendev.org/c/openstack/python-keystoneclient/+/675870 and possibly endpoint type configurable
09:14:55 <strigazi> next:
09:15:20 <strigazi> CAPI driver, gbialas, do you want to mention something?
09:15:58 <gbialas> Unfortunately, no.
09:16:33 <strigazi> thanks, no worries
09:17:37 <strigazi> next is: move away from wiki, jakeyip you brought this up I think
09:18:31 <jakeyip> yeap I haven't done much
09:19:01 <strigazi> #action jakeyip to follow removal of magnum wiki
09:19:18 <strigazi> #action gbialas, mnasiadka to follow CAPI driver
09:19:33 <strigazi> last one, gbialas: supportng to wide kube_tags versions range for one release
09:20:10 <strigazi> gbialas: do you want to mention something? Is there something specific to do?
09:20:20 <strigazi> like make sure conformance passes for a single release?
09:20:38 <strigazi> single release of Openstack, many k8s
09:21:19 <jakeyip> I'm also curious how we decide max min like what we have in wiki
09:23:26 <jakeyip> strigazi: any ideas
09:23:42 <strigazi> I think the wiki was updated for what we know it's working, there wasn't a specific aim before that
09:24:32 <strigazi> I think three releases is reasonable
09:24:59 <jakeyip> ok
09:25:07 <strigazi> the load can high when k8s drops a lot of things
09:25:27 <strigazi> eg to be prepared for 1.22 is not easy
09:26:44 <strigazi> we can check with gbialas in the next meeting again, I guess he wants to follow that
09:26:51 <gbialas> Yes.
09:27:01 <gbialas> Sorry, I was distracted, for a moment.
09:27:20 <gbialas> We can discuss this next week.
09:27:24 <strigazi> ok
09:27:30 <strigazi> we can move it first
09:27:41 <strigazi> let's move to:
09:27:48 <strigazi> #topic open discussion
09:28:21 <strigazi> Anyone wants to bring something up?
09:29:39 <jakeyip> on topic of wiki - anything on https://wiki.openstack.org/wiki/Magnum that needs to be kept? I was thinking keeping 'Resources', 'IRC and IRC Meetings' and 'Users'
09:30:21 <jakeyip> we also might keep 'Compatibility Matrix' for a while, until we move it
09:30:29 <jakeyip> others are kind of stale, stale is bad
09:30:45 <jakeyip> what is everyone's opinions
09:31:16 <strigazi> jakeyip: Ι would point wiki to docs.openstack.org/magnum
09:31:36 <strigazi> this is the place that shoyld be up to date
09:32:51 <jakeyip> meaning keep nothing except for a documentation link?
09:32:54 <strigazi> also the project readme should point to doo/magnum and maybe the corresponding file from docs https://opendev.org/openstack/magnum/src/branch/master/doc/source/index.rst
09:33:08 <strigazi> jakeyip: IMO yes
09:33:21 <jakeyip> aggressive, I like it
09:33:58 <strigazi> the readme is also imporant because ppl may land on github.com/openstack/magnum
09:34:15 <strigazi> or opendev.org/o/magnum
09:36:02 <jakeyip> sorry I might not be understanding this part completely
09:36:07 <jakeyip> this readme? https://opendev.org/openstack/magnum/src/branch/master/README.rst
09:37:00 <strigazi> yes
09:37:20 <jakeyip> ok
09:39:14 <strigazi> Anything else to discuss?
09:39:56 <jakeyip> nothing else from me
09:41:46 <strigazi> Thanks! Let's end the meeting then. See you next week
09:41:52 <strigazi> #endmeeting