09:04:18 <jakeyip> #startmeeting magnum
09:04:18 <opendevmeet> Meeting started Wed May 11 09:04:18 2022 UTC and is due to finish in 60 minutes.  The chair is jakeyip. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:04:18 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:04:18 <opendevmeet> The meeting name has been set to 'magnum'
09:04:33 <jakeyip> #topic Roll Call
09:04:37 <jakeyip> o/
09:04:52 <strigazi> o/
09:06:11 <jakeyip> Thanks for joining the meeting strigazi
09:06:24 <jakeyip> #topic Past action items
09:07:49 <jakeyip> Drop mesos docs https://review.opendev.org/c/openstack/magnum/+/839556 , strigazi to comment
09:08:47 <strigazi> DONE, just now
09:09:20 <jakeyip> ok next is "Drop bay and baymodel from controllers". there is a couple of patches
09:09:49 <jakeyip> first in magnum code https://review.opendev.org/c/openstack/magnum/+/803779 - this never passed zuul.
09:09:55 <strigazi> Are we taking them now in  the end?
09:10:42 <jakeyip> I wonder if Diogo is still interested in working on this? or should we take over
09:10:54 <jakeyip> sorry I don't understand, can you clarify
09:11:09 <strigazi> I mean, we can merge this in the cycle right?
09:11:32 <jakeyip> this meaning mesos?
09:12:08 <strigazi> for bay/baymodel
09:13:17 <jakeyip> yes
09:13:29 <strigazi> cool
09:14:07 <strigazi> I left  comment in the patch
09:14:56 <jakeyip> ok, there's another one - https://review.opendev.org/c/openstack/magnum/+/803780 - this one diogo marked as WIP
09:15:26 <strigazi> same comment
09:15:59 <jakeyip> same topic, on the client side - https://review.opendev.org/c/openstack/python-magnumclient/+/803629
09:17:10 <strigazi> commented
09:17:48 <jakeyip> should I add this as action strigazi ?
09:17:54 <strigazi> sure
09:18:23 <jakeyip> #action jakeyip strigazi follow up with diogo on bay and baymodel patches
09:19:30 <jakeyip> next - "Add support for choosing Octavia provider" | https://review.opendev.org/c/openstack/magnum/+/839709
09:20:00 <strigazi> approved
09:20:08 <jakeyip> thanks
09:20:24 <jakeyip> mnasiadka isn't around so we'll keep his items
09:20:33 <jakeyip> #action mnasiadka: to follow up kubernetes conformance for Yoga https://www.cncf.io/certification/software-conformance/
09:20:39 <jakeyip> #action mnasiadka to check out implications of https://review.opendev.org/c/openstack/python-keystoneclient/+/675870 and possibly endpoint type configurable
09:20:47 <jakeyip> #action gbialas, mnasiadka to follow CAPI driver
09:22:16 <jakeyip> next something new - "Adapt Cinder CSI to upstream manifest" | https://review.opendev.org/c/openstack/magnum/+/833354
09:23:30 <jakeyip> was hoping to ask mnasiadka if they want to push this, I'm not too familar with this, strigazi you know what to do?
09:24:31 <strigazi> better to move with Mohammed's proposal
09:24:49 <strigazi> but this is the issue with managing manifest in code
09:25:15 <strigazi> hence the much bigger idea to move all this to a meta helmchart containing everything
09:25:37 <jakeyip> yeah agree. do we ever have an action item tracking it?
09:25:47 <strigazi> I don't think so
09:26:50 <jakeyip> ok it's a big thing and I don't know where to start. let's have this discussion when more people are around, or at PTG
09:26:55 <jakeyip> what do you think strigazi ?
09:27:31 <strigazi> sounds good
09:28:31 <opendevreview> Merged openstack/magnum master: Drop mesos documentation  https://review.opendev.org/c/openstack/magnum/+/839556
09:29:22 <jakeyip> ok, still on previous items. for wiki I cleaned up https://wiki.openstack.org/wiki/Magnum. I left the table there until I have some time to move it to magnum src
09:29:37 <jakeyip> any comments?
09:30:14 <strigazi> no, counds good
09:30:27 <strigazi> s/counds/sounds/
09:30:51 <jakeyip> ok I think that's it for past action items. anything I missed out?
09:31:38 <strigazi> I think that was all
09:31:41 <jakeyip> I would like a topic for New Reviews that I need help with
09:31:56 <strigazi> sure
09:32:08 <jakeyip> #topic New Reviews
09:32:20 <jakeyip> below are some in magnumclient
09:32:29 <jakeyip> first - 'Drop lower-constraints.txt and its testing' | https://review.opendev.org/c/openstack/python-magnumclient/+/840078
09:34:36 <strigazi> done
09:34:48 <strigazi> I mean, approved
09:35:11 <jakeyip> thanks
09:35:29 <jakeyip> next - 'Remove translation sections from setup.cfg' | https://review.opendev.org/c/openstack/python-magnumclient/+/750281
09:36:10 <strigazi> approved
09:36:14 <jakeyip> I think this is done everywhere so should be fine
09:36:17 <jakeyip> thanks
09:36:50 <jakeyip> next up is reviews in magnum-ui
09:37:09 <jakeyip> Fixed Unit test for magnum-ui | https://review.opendev.org/c/openstack/magnum-ui/+/835963
09:37:30 <jakeyip> how do we test this? or if Zuul passes it's generally ok?
09:39:12 <strigazi> I think zuul is good enough for this
09:40:20 <jakeyip> ok. good to hear. I'll +2 that and rebase the lower-constraint patch in the same repo https://review.opendev.org/c/openstack/magnum-ui/+/840077
09:40:48 <strigazi> cool
09:40:53 <jakeyip> that's all for reviews, thanks
09:41:12 <jakeyip> any reviews you want to bring up?
09:41:20 <jakeyip> strigazi ^
09:41:46 <strigazi> I'm good
09:42:03 <jakeyip> #topic Open Discussion
09:42:33 <jakeyip> there's something from storyboard
09:42:56 <jakeyip> K8s 1.24+ : Remove dockershim kubelet options  | https://storyboard.openstack.org/#!/story/2010028
09:43:05 <jakeyip> strigazi: have you tried k8s 1.24?
09:43:16 <strigazi> no
09:43:31 <strigazi> has he proposed a change?
09:43:57 <jakeyip> I don't think so
09:44:17 <strigazi> Maybe we tell the person who open the propose one :)
09:44:25 <strigazi> Maybe we tell the person who open the story to propose one :)
09:44:29 <opendevreview> Merged openstack/python-magnumclient master: Drop lower-constraints.txt and its testing  https://review.opendev.org/c/openstack/python-magnumclient/+/840078
09:44:30 <jakeyip> ok team work :)
09:44:31 <opendevreview> Merged openstack/python-magnumclient master: Remove translation sections from setup.cfg  https://review.opendev.org/c/openstack/python-magnumclient/+/750281
09:45:17 <jakeyip> another story I don't understand | https://storyboard.openstack.org/#!/story/2010023
09:45:38 <jakeyip> have you seen this?
09:46:12 <strigazi> no, first time I see it
09:46:27 <strigazi> the issue I mean. The story I have seen
09:46:53 <jakeyip> ok I just wanted to check, I can go digging if I find some time
09:47:11 <jakeyip> that's all from me
09:47:46 <jakeyip> anything you want to discuss?
09:48:17 <strigazi> I'm good, thank you for chairing Jake!
09:48:49 <jakeyip> you're welcome. Thanks! see you next week!
09:48:51 <jakeyip> #endmeeting