09:00:51 <jakeyip> #startmeeting magnum
09:00:51 <opendevmeet> Meeting started Wed Jun 12 09:00:51 2024 UTC and is due to finish in 60 minutes.  The chair is jakeyip. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:51 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:51 <opendevmeet> The meeting name has been set to 'magnum'
09:00:56 <jakeyip> #link https://etherpad.opendev.org/p/magnum-weekly-meeting
09:01:02 <jakeyip> Please put your topics into to Agenda
09:01:06 <jakeyip> #topic Roll Call
09:01:08 <jakeyip> o/
09:01:22 <dalees> o/
09:02:31 <jakeyip> let's wait a couple of minutes
09:04:22 <jakeyip> dalees: have merged some of the magnum-ui reviews last couple of weeks; if there's anything outstanding feel free to add to agenda
09:05:06 <jakeyip> I will do 919449 shortly :)
09:05:23 <dalees> thanks jakeyip, I need to revisit most of the others to refresh myself on them and make sure they're review ready
09:06:26 <jakeyip> ok, let's go on to topics for now
09:06:38 <jakeyip> #topic v1.28 support with heat driver
09:07:19 <jakeyip> link https://review.opendev.org/c/openstack/magnum/+/919560
09:07:29 <jakeyip> #link https://review.opendev.org/c/openstack/magnum/+/919560
09:08:30 <jakeyip> #link https://review.opendev.org/c/openstack/magnum/+/920725
09:08:41 <jakeyip> the second one is a change to test CI
09:09:21 <jakeyip> I still cannot get it working, seems like just bumping the occm verion fails
09:11:10 <jakeyip> bumping just occm - https://review.opendev.org/c/openstack/magnum/+/920725/3
09:11:25 <dalees> :(
09:11:51 <dalees> I'm trying to read the zuul logs, but they're large...
09:12:07 <jakeyip> this one https://zuul.opendev.org/t/openstack/build/52d1056a97044146ad27631876a7baad/log/controller/logs/magnum-nodes/kubernetes/pods/kube-system/openstack-cloud-controller-manager-x6sf5
09:12:51 <jakeyip> occm fails at  `openstack.go:477] Failed to list neutron extensions: Get "https://158.69.76.92:9696/networking/v2.0/extensions": dial tcp 158.69.76.92:9696: connect: no route to host`
09:14:18 <jakeyip> it seems like error connecting to neutron?
09:15:19 <jakeyip> my hunch is that maybe the pods never could connect to neutron, but it was ok as there was nothing doing that
09:15:29 <jakeyip> but newer occm now does connect, and so fails
09:15:42 <jakeyip> but I have yet to identify a commit in occm
09:16:02 <dalees> hm, dont' know. But yeah 9696 is neutron
09:16:37 <jakeyip> I can't replicate this locally, or in our cloud
09:16:57 <jakeyip> I'm guessing if it's infra, it will affect clusters spun up by capi too, not isolated to heat driver
09:18:24 <jakeyip> I was hoping to grab mnasiadka attention too, so we can dump some info like the cluster template in the logs
09:20:29 <jakeyip> let me know if you have any ideas
09:21:21 <jakeyip> kind of depressing because I just want to hit this target for D and it's just stuck.
09:21:28 <jakeyip> want to get it over with so we can go on to capi
09:22:23 <dalees> I've not done much debugging with Zuul; it's really hard if it doesn't happen locally.
09:23:05 <jakeyip> that's ok, I keep pluggin away
09:23:09 <jakeyip> off to happier topics
09:23:12 <jakeyip> #topic capi
09:23:30 <jakeyip> I am unsure how we go on from here, wrt magnum-capi-helm-charts
09:24:58 <jakeyip> do we build a chart and push to a registry? do we do it like stackhpc and rely on github pages?
09:25:32 <dalees> do we have the code into opendev?
09:25:52 <jakeyip> not yet
09:25:58 <dalees> yeah, push it to an oci registry IMO
09:26:22 <jakeyip> ok we can work on that then
09:26:23 <dalees> requires less infrastructure, as there should already be an oci registry somewhere we can use
09:26:59 <jakeyip> #agreed package magnum-capi-helm-charts and push to registry
09:27:04 <jakeyip> #action find oci registry
09:27:15 <jakeyip> #action package magnum-capi-helm-charts
09:27:45 <jakeyip> I will hit infra people up to progress this
09:28:11 <dalees> the other option would be to use the same as openstack-helm which appears to be https://tarballs.opendev.org/openstack/openstack-helm
09:28:42 <dalees> but i'd still prefer oci registry, if there is one available
09:28:51 <jakeyip> hm right
09:31:09 <jakeyip> can you help with packaging when the repo is synced into opendev?
09:32:35 <jakeyip> do you have patches on it? how do you handle release?
09:32:54 <dalees> yeah, i should be able to help
09:33:53 <dalees> we have our own local copy of the repo yes, and we tag it and push to our OCI registry, then refer to these in Magnum Templates.
09:34:30 <dalees> we've got several customisations in the helm charts, which lets us keep Magnum codebase a bit cleaner from our own stuff.
09:36:19 <jakeyip> ok I think we have a clearer path now with some TODOs, thanks for the tips
09:36:29 <jakeyip> I don't have much else
09:37:09 <jakeyip> #topic open discussion
09:37:41 <jakeyip> anything from anyone?
09:37:57 <dalees> for the helm chart repo, upstream(stackhpc) tags with semver, and we add `+catalystcloud1` etc. Helm complains a bit, but deals with it okay.
09:38:12 <dalees> nothing else from me
09:39:27 <jakeyip> I see, good idea, I shall replicate that :)
09:39:50 <jakeyip> cool let's end the meeting
09:39:52 <jakeyip> #endmeeting