09:00:04 <dalees> #startmeeting magnum
09:00:04 <opendevmeet> Meeting started Wed May 14 09:00:04 2025 UTC and is due to finish in 60 minutes.  The chair is dalees. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:04 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:04 <opendevmeet> The meeting name has been set to 'magnum'
09:00:11 <dalees> #topic Roll Call
09:00:26 <dalees> o/
09:01:53 <dalees> as per topic, meeting agenda is at https://etherpad.opendev.org/p/magnum-weekly-meeting
09:03:13 <dalees> courtesy ping: mnasiadka  jakeyip
09:06:53 <jakeyip> o/
09:08:35 <dalees> hi jakeyip
09:08:42 <dalees> #topic CI stability
09:09:05 <dalees> I think the most pressing topic is CI failures, it appears that magnum isnt' running happily in CI any longer.
09:09:27 <dalees> so we consistently see 24 failures in the output, with 503 internal server error reported.
09:09:49 <dalees> jakeyip: did you have a chance to look into this? I'm having a closer look now.
09:10:38 <jakeyip> no
09:12:28 <jrosser> i was attempting (failing) to fix server error with cluster templates here https://review.opendev.org/c/openstack/magnum/+/948167
09:12:29 <dalees> hmm, it looks like magnum-api doesn't start, uwsgi complains it can't find the wsgi script: https://857602a3728ec786b09a-b4998686e736196b5d74af7a908c113b.ssl.cf1.rackcdn.com/openstack/c8035124770744558d66315502b2df59/controller/logs/screen-magnum-api.txt
09:12:49 <jrosser> the anisble modules ci for magnum is also broken
09:14:11 <dalees> this patchset does pass, so perhaps these wsgi are needed. I need to have a closer look (and that patchset needs release notes): https://review.opendev.org/c/openstack/magnum/+/949110
09:14:51 <dalees> jrosser: can you link to the ansible modules CI?
09:15:50 <jrosser> dalees: example here https://review.opendev.org/c/openstack/ansible-collections-openstack/+/944121
09:16:08 <jrosser> it might be helpful to run that job for magnum changes to catch these errors
09:17:40 <jrosser> it is just accident that contributing to one of the neutron related modules runs the magnum job, and thats broken
09:18:45 <dalees> i wonder if that's a related failure, if the wsgi startup is no longer working. I can't see any useful logs from that zuul job
09:19:22 <mnasiadka> pbr stopped generating wsgi scripts, so we need to move to the module
09:19:25 <mnasiadka> check the related openstack-discuss thread
09:19:45 <mnasiadka> I can have a look next week
09:20:28 <mnasiadka> Actually... we have a patch: https://review.opendev.org/c/openstack/magnum/+/949110
09:22:03 <mnasiadka> I can add the reno there (if no one else wants to) and we can get that merged
09:24:11 <dalees> ah, so pbr changed behaviour. thanks mnasiadka
09:25:06 <jakeyip> ah ok I can do reno
09:25:22 <dalees> yeah we need to land that patch before anything else can, then.
09:25:34 <jakeyip> yeap
09:26:06 <jakeyip> shall we go to next topic?
09:26:08 <dalees> are there deployer implications for that change that need to be in these release notes? will deployments need to be updated to use a new wsgi file?
09:26:59 <dalees> yeah, we can move on and continue the discussion in that patchset. i'll give it a minute in case there are other comments on this.
09:27:56 <dalees> #topic change meeting timing
09:28:20 <dalees> who's topic was this? I moved it from agenda from a week or two ago
09:28:26 <jakeyip> yeah that's from me.
09:28:39 <dalees> what is the proposal?
09:29:23 <jakeyip> I am finding it hard to do Wed evening. I wonder if we can move this either to Tue / Thurs evening or some other time
09:29:55 <jakeyip> there is the matter of scheduling conflict for Wed evening, and also by evening I'm pretty zoned out already sometimes. not sure about you dalees
09:30:16 <dalees> I think I can do Tuesday just as easily.
09:30:19 <jakeyip> when I saw evening of cos it's EU morning :P
09:30:33 <dalees> jakeyip: yeah, timing is hard.
09:31:14 <dalees> I'd also propose making it every 2 weeks, as sometimes we have little to discuss here and every week evenings *is* harder.
09:32:41 <jakeyip> I am ok with once every two weeks too.
09:33:09 <dalees> on a related topic, and to add more variables John Garbutt mentioned having a meeting for azimuth (in the helm charts repo): https://github.com/azimuth-cloud/capi-helm-charts/issues/454#issuecomment-2863798429
09:34:08 <dalees> I feel like the helm charts could be discussed here also, as I'm not keen on additional evening meetings. But I don't want to sideline The Other Driver.
09:35:09 <mnasiadka> As long as it's sort of the same time of the day for Europe - it can be any day
09:35:27 <mnasiadka> We could do every two weeks as well, although I'm not that active in Magnum as I should be - so I'll shut up :)
09:35:58 <jakeyip> 0900 UTC is 0500 for Canada :P so maybe that's why vexxhost doesn't come to this meeting
09:36:37 <mnasiadka> well, we will not be able to have a meeting for everybody, unless we do two different meetings
09:36:52 <mnasiadka> and async discussion can take place at any time, although it doesn't take place :)
09:37:19 <dalees> yes, can only really cover 2 of EMEA, APAC and US East.
09:37:54 <jakeyip> I mean that we can change without worrying about vexxhost people cos the current timing is not suitable for them anyway
09:38:28 <dalees> well let's propose a change of day to Tuesday and the same 0900UTC. I think earlier is better for jakeyip and I, but worse for EU/UK?
09:39:30 <dalees> moving to every 2 weeks (biweekly) opens a space to ask mnaser if an additional time is helpful. But I agree async chat is still possible and sync meetings may not be needed there.
09:40:06 <dalees> (the additional day could be in APAC and US working hours, if it were needed)
09:40:44 <dalees> any further thoughts? you get an opinion too mnasiadka
09:40:59 <jakeyip> jrosser too?
09:41:14 <dalees> of course!
09:42:04 <dalees> currently meetings are 10am in UK tz
09:42:10 <jrosser> UK times are good for me
09:42:29 <mnasiadka> https://www.worldtimebuddy.com/?pl=1&lid=3081368,2158177,2193733,2643743&h=3081368&hf=0
09:43:49 <mnasiadka> If I got locations correctly :)
09:44:42 <jakeyip> need to change day to Tue too :P
09:44:43 <dalees> yep, also compare with 6 months out, for the other DST options. 10pm is less fun than 9pm: https://www.worldtimebuddy.com/?pl=1&lid=3081368,2158177,2193733,2643743&h=3081368&date=11/11/2025%7C3&hf=0
09:47:23 <dalees> is one hour earlier at 8am UTC objectionable to anyone?
09:47:54 <jakeyip> ok for me
09:47:56 <dalees> ah 8am UK
09:48:07 <dalees> in their winter
09:48:25 <mnasiadka> they'll survive ;-)
09:48:27 <dalees> ok for poland, 9am.
09:48:36 <mnasiadka> right jrosser ?
09:50:56 <dalees> so the proposal is currently: every 2nd Tuesday, 8am UTC.
09:51:40 <jakeyip> +1
09:52:33 <jrosser> 8 am is doable for me
09:52:41 <jrosser> just :)
09:54:15 <mnasiadka> +1
09:54:59 <dalees> Ok, let's make the first two weeks from now, 27th May?
09:55:07 <jakeyip> ok
09:55:27 <dalees> #action Dale to change meeting time and post to mailing list.
09:55:44 <dalees> #topic AZ patch for capi driver
09:56:00 <dalees> last topic; jakeyip, yours?
09:56:30 <jakeyip> yeah
09:57:21 <dalees> we use anti-affinity instead of AZs for control plane nodes, but I can see the use case for AZ
09:57:33 <jakeyip> we have this. just wondering if you or stackhpc needs this, I forgot about it but happy to work on it if people wants it
09:58:48 <dalees> I support including it as others will want it, and one day CatalystCloud will too. For now we won't use it.
09:59:08 <jakeyip> ok
09:59:52 <jakeyip> on that topic, anti-affinity won't make it go to a separate AZ / failure domain right? just different hypervisors?
10:00:04 <dalees> correct
10:01:11 <jakeyip> ok I will work on this, gives us a way forward for what pawel mention - different nodegroups in different az
10:01:13 <dalees> we have multiple regions, but not multiple AZs within the region.
10:01:34 <jakeyip> I am done with this
10:01:51 <dalees> then we can close; any other topics
10:01:55 <jakeyip> I want to go back to the patch for wsgi , got a quetion for mnasiadka
10:01:59 <dalees> #topic Open discussion
10:02:35 <jakeyip> AFAICT, this only modifies devstack behaviour but doesn't remove any functionality ?
10:02:43 <jakeyip> is reno nedeed in that case?
10:03:58 <jakeyip> dalees: over time I think you can close if you want
10:04:27 <dalees> I'm just looking up how we call the wsgi with uwsgi outside devstack.
10:04:38 <jakeyip> ok
10:05:08 <dalees> we use `uwsgi --wsgi-file=/var/lib/openstack/bin/magnum-api-wsgi`
10:05:22 <dalees> so that needs to change, right?
10:05:56 <dalees> as this patchset removes that installed file (because pbr no longer does it!)
10:06:04 <dalees> so we need a reno for operators somewhere
10:06:53 <jakeyip> ah I missed that we removed that entry_point
10:08:08 <dalees> #endmeeting