15:00:47 <bswartz> #startmeeting manila
15:00:50 <openstack> Meeting started Thu Sep  5 15:00:47 2013 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:54 <openstack> The meeting name has been set to 'manila'
15:01:10 <vbellur> bswartz: hello
15:01:13 <bswartz> good morning everyone
15:01:17 <lpabon> hi
15:01:18 <vikiland> hi
15:01:19 <vbelokon> hi
15:01:23 <vponomaryov> hi
15:01:24 <shamail> good morning
15:01:25 <yportnova_> hi
15:01:36 <bswartz> wow lots of people here today
15:02:14 <bswartz> sorry if I'm disorganized, I'm travelling today
15:02:24 <bswartz> #link https://wiki.openstack.org/wiki/ManilaMeetings
15:03:01 <bswartz> for those of you who weren't here last week, we have engineers working on the code finally
15:03:30 <bswartz> vbelokon has volunteed to give us an update on development progress
15:03:48 <bswartz> #topic development progress
15:03:54 <vbelokon> bswartz: ok, let me present short report
15:04:37 <vbelokon> DevStack - Supporting Manila in DevStack was implemented. It's in testing now. Link to Git: [https://github.com/119Vik/devstack] (master branch)
15:05:04 <vbelokon> bswartz: Could you please provide repository to push Manila-DevStack code (requirements - target repo + allowed access)?
15:05:08 <bswartz> #link https://github.com/119Vik/devstack
15:05:24 <bswartz> vbelokon: sure
15:05:45 <vbelokon> ok next
15:05:57 <vbelokon> Attributes "Cinder" was renamed to "Manila" in many places in the Manila project. And we are working on unit-tests of Manila now.
15:06:08 <vbelokon> First "smoke testing" of Manila service was performed. Bugs and issues were found. QA are in-progress. Tempest. Preparing of positive and negative tests are in-progress. Functionality for Tempest (Manila Manager) is ready.
15:06:34 <vbelokon> Several questions from QA team:
15:06:36 <vbelokon> 1) We have some stuff from Cinder as quotas for users and etc. Do we need to keep it in Manila or should we remove?
15:07:17 <bswartz> vbelokon: we want to keep quota support
15:07:20 <vbelokon> 2) Current tempest in repo http://github.com/bswartz/tempest in branch "manila" is grizzly tempest. Our tempest is based on latest havana tempest, so, should we completely replace it or make branch like "manila/havana"?
15:07:31 <bswartz> it wouldn't surprise me if there are bugs in the quota code however
15:07:36 <vbelokon> bswartz: ok, thanks, we will keep quota
15:08:23 <vponomaryov> as for tempest - it is in fast change period, so was not commited yet to repo
15:09:03 <vponomaryov> addition to question 2)
15:09:10 * KenD should probably make a new repo 'manila/icehouse
15:09:23 <bswartz> vbelokon: will it be hard to merge the manila/temptest changes with recent havana changes?
15:09:42 <lpabon> if we copy code from Cinder, does that mean Manila will start diverging?  Will someone keep the common code up to date?  Is there a plan to have a common base?
15:10:00 <vbelokon> let's ask vponomaryov
15:10:13 <vbelokon> abput tempest
15:10:15 <bswartz> KenD: I'd rather wait until we've got the code in stackforge before worrying about icehouse
15:10:35 <vponomaryov> no, it is not hard to merge, but it is really different, it has modified structure
15:10:52 <bswartz> lpabon: that's a concern, yes. Ideally we will move common stuff into oslo, but that's not on the critical path for us
15:11:07 <lpabon> bswartz: cool
15:11:37 <KenD> msg/ <kend> bswartz: good with that
15:12:15 <vbelokon> bswartz: about tempest - I think it's better to merge with Havana
15:12:16 <esker> hello
15:12:26 <vikiland> рш
15:12:28 <vikiland> hi
15:12:29 <bswartz> vbelokon: you mentioned finding some bugs already
15:12:50 <bswartz> can we file them in LP?
15:12:55 <vikiland> yeah it's related to rename process
15:13:14 <vbelokon> yes we can, but it's better to publish them in LP a bit latter
15:13:28 <vbelokon> now a lot of minor issues
15:13:46 <vbelokon> later when we have a stable project all bugs we will publish in LP
15:14:22 <bswartz> vbelokon: now that you've been working on the code for a bit, how soon do you expect we can complete the first 2 BPs?
15:14:23 <vbelokon> so during next week we are planning:
15:14:40 <vbelokon> bswartz: in one weel
15:14:42 <vbelokon> bswartz: in one week
15:14:57 <vbelokon> our plan is:
15:15:00 <vbelokon> - NFS/CIFS servers configuration and supporting
15:15:02 <vbelokon> - rename / refactoring / cleanup / bug fix of manila-clinet
15:15:04 <vbelokon> - tempest tests
15:15:06 <vbelokon> - bug fixing of manila
15:15:21 <bswartz> that sounds great
15:15:47 <bswartz> I think we need to get the code into stackforge before we can start pushing our tempest and devstack changes upstream
15:15:57 <bswartz> any problem keeping those changes in github for a wihle?
15:16:06 <vbelokon> so, that's is my short report from our side :)
15:16:29 <vikiland> тщ
15:16:30 <vikiland> no
15:16:38 <bswartz> okay
15:16:55 <bswartz> #action make a shared devstack repo available
15:17:17 <bswartz> #topic open floor
15:17:41 <yportnova_> bswartz, api question
15:17:44 <bswartz> anyone else here want to share anything new?
15:17:48 <vikiland> should we  test manila with netapp shares ?
15:17:55 <esker> Who will be in attendance at the Design Summit in Hong Kong?
15:18:01 <bswartz> lpabon: will you be available to contribute soon?
15:18:06 <vbellur> bswartz: we have shortlisted one more candidate for Manila
15:18:19 <vbellur> esker: I will be around
15:18:23 <yportnova_> We have 2 versions of api. Shares are extensions to existing api. Leave v1 of api? Move shares api from contrib to v1?
15:18:36 <shamail> esker: I will probably be attending
15:18:50 <bswartz> vikiland: testing the netapp-specific backends is a low priority
15:18:56 <lpabon> bswartz: I would like to get more familiar with the code and the blueprints.  Is there a wiki page which has the blueprints or should I search for them
15:19:12 <bswartz> vikiland: I'd more interested in having a stable project and reaching incubation status
15:19:21 <esker> Okay, perhaps bswartz has already mentioned, but we'd like to plan on a design summit session (or some other gathering) to discuss / plan in person.
15:19:28 <vikiland> bswartz: got it.
15:19:35 <bswartz> lpabon: https://launchpad.net/manila/
15:20:04 <vbellur> esker: sounds good
15:20:08 <bswartz> yportnova_: we can take this opportunity to reset the API version as we remove the blocks stuff
15:20:11 <shamail> Q: Have there been anymore discussions around network plumbing or auto-mounting in the guest?
15:20:21 <bswartz> We should only have a v1 API
15:20:25 <lpabon> bswartz: nice, thanks.  I hope that by next week I will be cought up on the design and proposed tasks to be able to start contributing
15:20:48 <yportnova_> bswartz: good, I will do it
15:21:03 <yportnova_> what about default port for api?
15:21:36 <bswartz> esker: thanks for reminging us, I plan to hold at least 1 un-conference session in HK on Manila. It would be nice to meet people face to face, and perhaps we'll have enough time to do some real planning work
15:22:05 <bswartz> shamail: no we've been focusing on short term goals for the last month. the plumbing design will come back into focus soon though
15:22:25 <bswartz> shamail: feel free to create some BPs -- I will be doing the same
15:23:08 <shamail> Thanks.  I was also thinking about some potential user mapping related items but I am not certain where to push out "general thoughts"
15:23:47 <bswartz> yportnova_: I'm not sure how default ports are selected. It doesn't matter to me, but we shoud follow the process that other openstack projects do if possible
15:23:52 <shamail> I think you just answered my second q in your reply.  I should look into BP submissions.
15:24:36 <vikiland> bswartz: so we'll leave it as is
15:25:12 <bswartz> shamail: LP and the openstack wiki are both good options
15:25:25 <vikiland> bswartz: we've already selected port for testing and we'll change it later if U'll need
15:25:33 <bswartz> BPs go on LP and you can link to a more detailed functional spec on the openstack wiki
15:25:45 <shamail> thanks.
15:25:46 <yportnova_> bswartz: I will check how ports for projects are selected
15:26:16 <bswartz> yportnova_: I think the most important concern is just that we don't conflict with anything else in openstack
15:26:31 <bswartz> beyond that it shouldn't matter
15:27:08 <yportnova_> as vikiland wrote, we have temporary port for testing
15:27:48 <bswartz> any other topics for today?
15:28:00 <vbellur> nothing else from me
15:28:11 <bswartz> if not I'll go work on the 1 action item and plan to see you all next week here
15:28:25 <lpabon> excellent
15:28:26 <vikiland> no questions
15:28:28 <vbelokon> bswartz: thanks
15:28:29 <bswartz> I'm optimisitic that we might be able to go into stackforce in another week or 2
15:28:29 <shamail> take care everyone!
15:28:38 <bswartz> stackforge*
15:28:46 <vbellur> thanks everyone, ttyl!
15:28:53 <bswartz> #endmeeting