15:00:12 <bswartz> #startmeeting manila
15:00:13 <openstack> Meeting started Thu Jun 19 15:00:12 2014 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:17 <openstack> The meeting name has been set to 'manila'
15:00:25 <bswartz> hello all
15:00:36 <scottda> hi
15:00:37 <vponomaryov> hi
15:01:14 <ameade> hey
15:01:19 <cknight> Hi
15:01:26 <xyang1> hi
15:01:31 <rraja> hi
15:01:34 <yportnova> hi
15:01:38 <bswartz> okay!
15:01:47 <bswartz> #link https://wiki.openstack.org/wiki/Manila/Meetings
15:01:57 <rushil> Hi
15:02:00 <bswartz> the agenda is short
15:02:03 <dustins> hello!
15:02:24 <bswartz> we start with dev status
15:02:28 <bswartz> #topic dev status
15:02:33 <vponomaryov> Dev status:
15:02:39 <vponomaryov> 1) All unittests now use module 'mock', dependency on 'mox' was removed.
15:02:40 <bswartz> and you all can yell at me for not doing reviews :-(
15:02:52 <vponomaryov> 2) Share server details and dependencies for it
15:03:00 <vponomaryov> bp: #link https://blueprints.launchpad.net/manila/+spec/implement-backend-details-in-drivers
15:03:00 <vponomaryov> gerrit:
15:03:00 <vponomaryov> #link https://review.openstack.org/100915
15:03:00 <vponomaryov> #link https://review.openstack.org/100536
15:03:12 <vponomaryov> 3) Manila's docs
15:03:12 <vponomaryov> bp: #link https://blueprints.launchpad.net/manila/+spec/manila-documentation
15:03:12 <vponomaryov> status: Client side was updated. Server side is ready for review/merge:
15:03:12 <vponomaryov> gerrit: #link https://review.openstack.org/98462
15:03:27 <vponomaryov> 4) CI job updates "openstack-infra/config" project
15:03:27 <vponomaryov> gerrit:
15:03:27 <vponomaryov> 4.1) #link https://review.openstack.org/97747
15:03:27 <vponomaryov> 4.2) #link https://review.openstack.org/99933
15:03:41 <tbarron> hi
15:03:45 <vponomaryov> TODO:
15:03:45 <vponomaryov> a) Finish 'details' chain of commits (2);
15:03:45 <vponomaryov> b) After merge of manila's docs update (3) - set CI job "gate-manila-docs" as votable;
15:03:45 <vponomaryov> c) Update ci scripts in manila's repo after merge of fix to tempest's jobs (4.1);
15:03:45 <vponomaryov> d) After merge of devstack job commit (4.2) to config project - enable its votability if it is OK;
15:04:09 <bswartz> thanks vponomaryov
15:04:24 <vponomaryov> that's all
15:04:58 <bswartz> we need to get things merged -- I've been slow this last week because I've had another high priority thing to work on
15:05:04 <bswartz> I will get to reviews by tomorrow
15:05:16 <bswartz> any questions about the above?
15:05:40 <bswartz> oh and before I forget
15:05:49 <bswartz> #topic manila core team
15:05:49 <csaba> hi
15:06:00 <nileshb> Hi Ben
15:06:04 <bswartz> welcome xyang1 to manila core
15:06:13 <xyang1> thanks!
15:06:14 <bswartz> the announcement went out earlier this week
15:06:40 <yportnova> Congrats xyang1!
15:06:54 <nileshb> Congrats xyang1
15:06:55 <bswartz> more reviewers helps spread the review load around
15:07:09 <xyang1> thanks everyone!
15:07:25 <dustins> xyang1: congratulations!
15:07:26 <bswartz> and more core team members means that we can follow the correct procedure and not +2/A our own changes
15:07:36 <bswartz> vponomaryov: I'm looking at you
15:08:31 <bswartz> anyone else who wants to join the core team, make sure you're doing lots of reviews and contributing where you can
15:08:34 <deepakcs> xyang1, congrats
15:08:47 <bswartz> okay next topic
15:08:55 <bswartz> #topic Source level debugging in IDEs
15:09:04 <bswartz> cknight: you're up
15:09:08 <cknight> OK
15:09:17 <cknight> I want to enable source-level debugging in Manila.
15:09:25 <cknight> Code changes are required to add the debugger connection call and to prevent event let from greening the thread library.
15:09:34 <cknight> There is precedent from Keystone and Glance, and I am adapting those earlier commits as closely as possible to Manila.
15:09:50 <cknight> I can set breakpoints in any of the three Manila processes.
15:10:19 <cknight> We're doing more testing today before sharing more widely.  Any questions as to why or how we're doing this?
15:10:21 <bswartz> so first question: does anyone besides cknight actually use an IDE to debug manila already?
15:10:43 <bswartz> I'm curious to know if there are alternate solutions to this in existence
15:10:43 <dustins> bswartz: I most likely will when I get into the thick of it
15:10:50 <ameade> i'd like to
15:11:03 <cknight> dustins: let's see if we can step through the test code as well
15:11:13 <dustins> cknight: agreed
15:11:18 <ameade> i know there are folks who do it outside of an IDE but that is much more cumbersome
15:11:27 <rushil> ameade: +1
15:11:45 <ameade> should cknight make a blueprint for this?
15:11:47 <dustins> I like my IDE to be my one stop shop for all things dev, including debugging
15:11:48 <cknight> Debugging is faster in an IDE, and learning the code is also faster since you can inspect everything at runtime.
15:12:02 <bswartz> okay it sounds like nobody currently does this, and I think it's safe to say everyone would like to be able to I'd like to persue this approach
15:12:10 <bswartz> #link http://tropicaldevel.wordpress.com/2013/01/24/debugging-openstack-with-pycharm-and-pydevd/
15:12:56 <cknight> I'm testing the changes in PyCharm, but it should also work in Eclipse/PyDev.
15:13:20 <bswartz> cknight please create a BP and submit the changes against that when they are ready
15:13:25 <ameade> what's our blueprint process, still just through launchpad?
15:13:34 <bswartz> ameade: yes still LP
15:13:38 <cknight> Will do
15:13:39 <deepakcs> bswartz, I don't use IDE, but would like to start using it, if enuf documentation is available on how to make the most of it, esp debugging
15:14:07 <bswartz> deepakcs: the top 2 I'm aware of are PyCharm, and Eclipse (PyDev)
15:14:35 <bswartz> Eclipse is free and PyCharm is not, fwiw
15:14:38 <deepakcs> cknight, so when u debug, are u in a source-only setup or devstack like setup ?
15:14:55 <cknight> Devstack, but can step through source.
15:14:59 * deepakcs thought that Eclipse is very resource hungry/bulky
15:15:14 * bswartz loves Eclipse
15:15:27 <deepakcs> cknight, so it would be great if you can provide steps in a wikipage on how to use devstack in a IDE w/ debugging
15:15:41 <cknight> bswartz: then you can test the solution in Eclipse
15:15:47 <cknight> deepakcs:  yes
15:15:52 <deepakcs> cknight, cool
15:16:04 <vbellur> fwiw, pycharm provides free licenses to open source projects - we might be able to get from the openstack pool or get it separately for manila too
15:16:54 <bswartz> vbellur: good to know
15:17:18 <cknight> Anything else on this topic?
15:17:36 <bswartz> cknight: I don't think you'll see any resistence to this change
15:17:43 <bswartz> mostly just people asking how to make it work
15:17:51 <cknight> Cool, thanks.  Glad to help everyone do it.
15:18:19 <bswartz> #topic open dicussion
15:18:28 <bswartz> okay that was the last thing on the agenda
15:18:31 <bswartz> anyone have anything else?
15:18:42 <scottda> Are there plans to move blueprints from launchpad to gerrit?
15:19:01 <bswartz> scottda: I don't have any
15:19:03 <vponomaryov> scottda: you mean manila-specs?
15:19:10 <scottda> yes, manila-specs
15:19:11 <bswartz> if someone sees a good reason to we could start doing it that way
15:19:28 <scottda> OK, just checking. Aside from the fact that it requires work, it seems like a good thing.
15:20:02 <scottda> It would allow feedback on blueprints at a more detailed level. And it seems to be the way the rest of Openstack is going.
15:20:05 <bswartz> scottda: I see the advantages, but it's also a heavier process -- I'd rather not fix something that isn't broken
15:20:20 <scottda> Sure, not a big deal. I was just curious.
15:20:25 <vponomaryov> scottda: We don't have so much Blueprints for now, I think it is for nearest future
15:20:38 <vponomaryov> it is NOT for nearest future
15:21:01 <scottda> ok
15:21:25 <bswartz> anyone feel strongly about moving to manila-specs instead of the current Launchpad process for BPs?
15:21:56 <bswartz> if not....
15:21:58 <xyang1> bswartz: It's nice to have, but not required for now
15:22:06 <deepakcs> xyang1, +1
15:22:12 <scottda> +1
15:22:21 <scottda> Just something to keep in mind for the future, that's all.
15:22:38 <ameade> also, just fyi for everyone, openstack has a PyCharm license for anyone who is a contributor
15:22:41 <xyang1> scottda: agreed
15:22:44 <bswartz> #agreed manila will continue to use LP for BPs for the foreseeable future
15:23:24 <bswartz> ameade: you may get questions from people on how to access those licenses
15:23:34 <ameade> they need to contact apmelton
15:23:48 <nileshb> I don't think we need to go for specs at this point of time
15:23:59 <ameade> nileshb: +1
15:24:02 <bswartz> is PyCharm open source?
15:24:09 <nileshb> blueprints should be sufficient
15:24:13 <apmelton> bswartz: there's a community edition
15:24:18 <apmelton> bswartz: we have a pro license though
15:24:30 <rushil> bswartz: I don't think so
15:24:38 <bswartz> yeah I get that it's free as in beer for us, but is it also open source?
15:24:44 <ameade> nope
15:24:59 <apmelton> yes https://github.com/JetBrains/intellij-community/tree/master/python
15:25:14 <ameade> oh nice
15:25:26 <bswartz> oh, so PyCharm is made by the same people that make IntelliJ?
15:25:42 <bswartz> that's something I didn't know, but isn't surprising
15:25:43 <dustins> bswartz: Yup, JetBrains if memory serves
15:25:46 <ameade> apmelton: perhaps it's that time of year where you should email the mailing list saying u have the license lol
15:26:23 <apmelton> ameade: I think I'll be renewing the license in august, so I will likely do it then
15:26:27 <bswartz> okay anything else from anyone?
15:26:39 <bswartz> otherwise I think we can wrap up
15:27:11 <bswartz> okay
15:27:12 <bswartz> thanks all
15:27:17 <xyang1> thanks
15:27:17 <vponomaryov> thanks
15:27:18 <deepakcs> bye
15:27:18 <dustins> thanks!
15:27:23 <bswartz> #endmeeting