15:00:07 <bswartz> #startmeeting manila
15:00:08 <openstack> Meeting started Thu Jun 26 15:00:07 2014 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <openstack> The meeting name has been set to 'manila'
15:00:19 <cknight> Hi, everyone
15:00:19 <bswartz> hello
15:00:22 <ameade> o/
15:00:55 <bswartz> wow not many people here today
15:01:01 <vponomaryov> hello
15:01:04 <rraja> hi
15:01:15 <bswartz> xyang?
15:01:16 <csaba> hi
15:01:19 <vbellur> hello
15:01:35 <yportnova> hi
15:01:40 <xyang1> hi
15:01:47 <bswartz> hey!
15:01:52 <bswartz> okay
15:02:03 <deepakcs> hi all
15:02:27 <bswartz> xyang1: do you have any updates on the status of the EMC driver?
15:02:38 <bswartz> it's been some time since we discussed it
15:02:51 <xyang1> bswartz: still waiting for legal:(
15:03:10 <bswartz> xyang1: is there a date when we can expect an answer by?
15:03:11 <xyang1> bswartz: when are you going to submit incubation request?
15:03:27 <bswartz> xyang1: real soon now -- there are no blockers
15:03:38 <tbarron> hi
15:03:41 <bswartz> in fact waiting for the EMC driver is the biggest thing holding us back
15:03:54 <bswartz> although it won't actually hold us back
15:04:18 <xyang1> bswartz: so we initially thought since manila is new, it can be handled differently from cinder, however, we still have to go thru the whole process
15:04:34 <bswartz> can you give us an idea?
15:04:42 <bswartz> another week or 2? months?
15:04:54 <xyang1> bswartz: another month, probably
15:05:15 <bswartz> could you commit to a date? like end of july?
15:05:18 <xyang1> bswartz: are you actually waiting for EMC driver before making incubation request?
15:05:20 <bswartz> or is that not possible
15:05:50 <bswartz> xyang1: whether we wait or not depends on how long we have to wait
15:05:51 <xyang1> bswartz: Let me check with legal and get back to you on that
15:05:55 <bswartz> okay thanks
15:06:08 <bswartz> I think we would be okay without it, but we would be better with it
15:06:15 <bswartz> that's the current thinking
15:06:22 <bswartz> okay onto agenda items
15:06:26 <bswartz> #link https://wiki.openstack.org/wiki/Manila/Meetings
15:06:36 <bswartz> #topic dev status
15:06:45 <vponomaryov> Dev status:
15:06:55 <vponomaryov> 1) Share server details
15:06:55 <vponomaryov> bp: #link https://blueprints.launchpad.net/manila/+spec/implement-backend-details-in-drivers
15:06:55 <vponomaryov> Generic driver was updated.
15:06:55 <vponomaryov> Cmode driver update: #link https://review.openstack.org/98069
15:06:55 <vponomaryov> Driver manager update: #link https://review.openstack.org/102463
15:07:10 <vponomaryov> 2) Tempest jobs
15:07:10 <vponomaryov> bp: #link https://blueprints.launchpad.net/manila/+spec/multibackend-installation-tempest-job
15:07:10 <vponomaryov> update of ci scripts: #link https://review.openstack.org/102770
15:07:32 <vponomaryov> 3) Migrate from oslo-rpc to oslo.messaging
15:07:33 <vponomaryov> bp: #link https://blueprints.launchpad.net/manila/+spec/oslo-messaging
15:07:33 <vponomaryov> gerrit: #link https://review.openstack.org/#/c/101586/
15:07:33 <vponomaryov> status: ready for review
15:07:55 <vponomaryov> thats the main
15:08:08 <bswartz> vponomaryov: is there anything that urgently needs review?
15:08:18 <bswartz> I've been spending a bunch of time on reviews, trying to get to them all
15:08:57 <vponomaryov> bswartz: https://review.openstack.org/102791 - this is blocker for multibackend job
15:09:21 <bswartz> vponomaryov: it has 2 -1s
15:09:37 <bswartz> I'll weigh in though
15:09:37 <vponomaryov> bswartz: yes, will update after meeting
15:09:41 <bswartz> k ty
15:09:47 <bswartz> any questions on that stuff?
15:10:00 <deepakcs> bswartz, yeah 1
15:10:23 <deepakcs> vponomaryov, did u face or see any issue with multi-backend without the lock present ?
15:10:43 <deepakcs> vponomaryov, asking because, I am trying to understand what the exact problem is.. DB redudant entries or something else ?
15:11:23 <vponomaryov> deepakcs: its just proper behaviour with shared resources
15:11:59 <deepakcs> vponomaryov, ok! I will go thru ur patch set2 and provide reviews
15:12:26 <bswartz> okay cool
15:12:43 <bswartz> #topic Manila test suite not in tempest
15:12:51 <bswartz> so I'm not sure what the issue is here
15:13:06 <bswartz> manila test are not in tempest because they can't be in tempest
15:13:11 <bswartz> tests*
15:13:12 <ameade> so we were confused about where the canonical tempest tests live for manila
15:13:15 <ameade> but just found this contrib/tempest/README.rst
15:13:41 <ameade> noticed that the gate just copies these files into tempest
15:13:45 <bswartz> #link https://github.com/stackforge/manila/blob/master/contrib/tempest/README.rst
15:13:55 <ameade> is there a better way? how do those tests stay up to date?
15:13:55 <vponomaryov> ameade: bswartz is right we have no right to push our tests to tempest without incubation
15:14:03 <ameade> yeah that makes sense
15:14:10 <bswartz> ameade: this is because we're not incubated yet
15:14:19 <ameade> but we need to update the wiki then
15:14:20 <bswartz> does keeping the tests in contrib create any actual problems?
15:14:35 <ameade> #link https://wiki.openstack.org/wiki/Manila_Overview
15:14:44 <vponomaryov> ameade: actually, tests for manila in manila's repo is much more cooler, than in different repo
15:14:53 <ameade> it was just confusing bucause there are links and manila branches in a bunch of repos
15:14:55 <bswartz> ameade:  gah! that page is obsolete
15:15:06 <bswartz> I will delete that wiki page
15:15:19 <ameade> i completely understand why we are doing it the way we are
15:15:40 <bswartz> but there does need to be a pointer to the right place for tests somewhere in the developer docs
15:15:47 <ameade> most def
15:15:55 <dustins> Agreed, it was a little confusing for a newbie like me
15:15:59 <cknight> So what is the process by which we run the functional tests here?
15:16:09 <dustins> I thought I had done something wrong :)
15:16:19 <bswartz> who wants to own updating the docs
15:16:33 * bswartz looks around for volunteers
15:16:39 * ameade hides
15:16:56 <vponomaryov> cknight: tempest
15:17:42 <deepakcs> bswartz, I can own it.. but i haven't used tempest myself ;)
15:17:51 <cknight> dustins: do you have what you need to run the manila tests correctly today?
15:18:03 <ameade> so in order to add tests, one would make do the copy, make changes, and somehow copy their things back over and commit in manila?
15:18:04 <dustins> bswartz: I can do that as well, just got to get the mountain of other stuff done first
15:18:05 <bswartz> #action deepakcs update the developer docs with instructions on where to find tests and how to run them
15:18:16 <dustins> cknight: It's starting to look that way
15:18:22 <deepakcs> bswartz, sure..
15:18:40 <bswartz> dustins: if you want to help out deepakcs that would be great
15:18:47 <bswartz> just as long as it gets done
15:18:54 <bswartz> docs are not my strong point
15:18:58 <vponomaryov> ameade: it depends on your development process
15:18:59 <bswartz> :-(
15:19:07 <deepakcs> bswartz, BTW since we are talking abt docs.. I uploaded "Setting up devstack+Manila on F20" doc @
15:19:16 <vponomaryov> ameade; you can use mounted share for dir with tests
15:19:16 <deepakcs> #link https://wiki.openstack.org/w/index.php?title=Manila/docs/Setting_up_DevStack_with_Manila_on_Fedora_20
15:19:18 <dustins> bswartz: deepakcs: Sounds good, I've got some background with tempest so we can collaborate on this
15:19:31 <bswartz> deepakcs: thanks!
15:19:32 <deepakcs> dustins, sure, i will ping u my email ID in pvt
15:19:48 <ameade> vponomaryov: if we had a manila branch in a tempest repo this would be trivial, but then we have the issue of keeping tempest up to date
15:19:56 <dustins> deepakcs: sounds good
15:20:27 <bswartz> ameade: we used to do it that way, but the repo was hosted under github.com/bswartz which looked kind of lame
15:20:36 <vponomaryov> ameade: it is up-to-date
15:21:09 <ameade> vponomaryov: yeah the current way we do it will always be on tempest master in the gate right?
15:21:11 <vponomaryov> ameade: all manila's tempest tests are running with each gerrit change with latest tempest
15:21:17 <bswartz> and there was the issue of rebasing that branch all the time
15:21:26 <vponomaryov> ameade: tempest has only tempest now
15:21:32 <ameade> bswartz: yeah thats what i mean by up to date
15:21:33 <vponomaryov> ameade: and will has
15:21:50 <vponomaryov> ameade: s/tempest/master/ branch I meant
15:22:25 <bswartz> vponomaryov: what is our procedure for fixing ourselves when tempest introduces a change that breaks our tests?
15:22:53 <bswartz> wouldn't our gate become blocked?
15:23:05 <vponomaryov> bswartz: tempest jobs are non-votable
15:23:20 <vponomaryov> bswartz: if compatibility lost - just fix it
15:23:23 <bswartz> okay there's my answer
15:23:28 <bswartz> sound good everyone?
15:23:32 <ameade> when can we make them vote?
15:23:48 <vponomaryov> ameade: anytime
15:23:52 <bswartz> ameade: probably safer to leave them non voting until post incubation
15:24:00 <bswartz> but we could do it earlier too
15:24:12 <vponomaryov> bswartz: +1
15:24:14 <ameade> as long as folks dont ignore them
15:24:34 <bswartz> I look at those results, usually
15:24:40 <ameade> kk lets just carry on, we can revisit this stuff if it becomes a problem
15:24:42 * bswartz reminds himself to look at them always
15:25:00 <bswartz> #topic open discussion
15:25:08 <ameade> deepakcs, dustins : make sure the docs show the workflow of adding a test
15:25:08 <bswartz> okay anything else
15:25:31 <dustins> ameade: wilco!
15:25:40 <bswartz> bobf: you here by any chance?
15:26:39 <deepakcs> ameade, sure, will try.. :)
15:26:55 <ameade> I get unittest errors when doing ./run_tests.sh on current master..could someone with an environment just try that real quick?
15:27:03 <deepakcs> ameade, bswartz I will shoot Qs on the list with manila tag.. if something is unclear or unknown to me. Hope to get answers :)
15:27:19 <bswartz> okay cool
15:27:24 <bswartz> we all read the ML I think
15:28:07 <vponomaryov> ameade: use tox -epy27
15:28:23 <bswartz> okay if anyone can help ameade continue the discussion in #openstack-manila
15:28:25 <ameade> yeah i only get 2 errors with tox and those are race conditions
15:28:28 <bswartz> I think we're done here
15:28:30 <ameade> i get 13 with run_tests.sh
15:28:35 <deepakcs> bswartz, http://lists.openstack.org/pipermail/openstack-dev/2014-June/038753.html - no answers got :)
15:28:38 <ameade> but they should both be clean >.<
15:29:14 <vponomaryov> ameade: dependencies, environment, could be any reason
15:29:23 <ameade> yeah could be
15:29:38 <vponomaryov> ameade: gate is the example of its real status
15:29:56 <xyang1> deepakcs: why can't we get that resolved in this meeting?:)
15:29:57 <bswartz> deepakcs: I don't see that message in my folder -- I will check my filters
15:30:03 <ameade> well it works fine if i roll back by a few commits
15:30:20 <deepakcs> xyang1, i am fine
15:30:30 <vponomaryov> ameade: you mean commits from master?
15:30:34 <deepakcs> bswartz, oh.. did i use a wrong tag ?
15:30:46 <ameade> vponomaryov: yeah
15:30:54 <xyang1> It should be stats to be consistent with get_share_stats
15:31:27 <vponomaryov> ameade: I know the answer!
15:31:32 <deepakcs> xyang1, i agree.. my Q was whether we do that across all drivers in 1 patch or do it selectively as we hit them ?
15:31:45 <xyang1> with regard to docstring, I agree it shouldn't be volume group
15:31:57 <vponomaryov> ameade: new dependencies, after applying new commits, just remove old .tox dir
15:32:12 <xyang1> deepakcs: I suggest you open another bug to fix all drivers?
15:32:18 <vponomaryov> ameade: than tox -epy27 will recreate it with proper deps
15:32:40 <deepakcs> xyang1, we can .. but in that patch for glusterfs driver, do we change s/status/stats or not ?
15:33:03 <bswartz> deepakcs: this is a mystery
15:33:06 <deepakcs> xyang1, and also what do u think on updating the docstring which is copied from lvm.py!
15:33:19 <xyang1> deepakcs: I don't see why not.  we change it there first because that is where we found it
15:33:34 <xyang1> deepakcs: then change other places.  we can do it incrementally
15:33:41 <deepakcs> bswartz, mystery of what ?
15:33:52 <bswartz> deepakcs: the ML and my mailbox
15:33:53 <deepakcs> xyang1, i am fine, i just wanted to make sure others agree :)
15:33:56 <xyang1> deepakcs: docstring should be changed in glusterfs driver
15:34:24 <deepakcs> xyang1, ok, then say so in the review comemnts, so that next patchset will fix it :)
15:34:48 <deepakcs> bswartz, np, u can reply now that i shared the archive link
15:35:10 <xyang1> deepakcs: so fix the issues in glusterfs in this patch, and have another patch fix everything else.  that's my suggestion
15:35:32 <deepakcs> xyang1, I am fine.. pls put that in your review comments
15:35:58 <xyang1> deepakcs: sure
15:36:31 * deepakcs requesting all Manila folks to provide review comments on https://wiki.openstack.org/wiki/Manila/docs/Setting_up_DevStack_with_Manila_on_Fedora_20
15:36:32 <bswartz> okay I'll sort out the ML problem later
15:37:03 <deepakcs> vponomaryov, do u want to discuss the lock issue here or we are fine on it ?
15:37:06 <bswartz> deepakcs I think I agree with xyang1
15:37:19 <deepakcs> bswartz, cool
15:37:21 <vponomaryov> deepakcs: No, everything is fine
15:37:36 <bswartz> okay
15:37:43 <bswartz> anything else before we wrap up?
15:38:04 <bswartz> thanks all for helpful discussions today
15:38:16 <vponomaryov> thanks
15:38:18 <deepakcs> bye
15:38:18 <rraja> thanks
15:38:23 <bswartz> #endmeeting