15:00:19 <bswartz> #startmeeting manila
15:00:20 <openstack> Meeting started Thu Oct  2 15:00:19 2014 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:22 <rushil> \o
15:00:25 <openstack> The meeting name has been set to 'manila'
15:00:39 <bswartz> good morning/afternoon/evening !
15:00:42 <tbarron> hi
15:00:44 <scottda> hi
15:00:47 <vponomaryov> Hello
15:00:49 <csaba> hi
15:00:57 <xyang1> hi
15:00:59 <jasonsb> hi (i'm new)
15:01:02 <bswartz> so I don't have much of an agenda today
15:01:12 <bswartz> jasonsb: welcome!
15:01:19 <jasonsb> thank you
15:01:47 <bswartz> does anyone have something they want added to the agenda?
15:01:52 <bswartz> any topics to discuss?
15:01:59 <bswartz> if not this will be a short meeting
15:02:03 <bswartz> not that that's a bad thing
15:02:03 <jasonsb> (hoping to contribute to project esp for HDS equipment)
15:02:12 <bswartz> Hitachi?
15:02:18 <jasonsb> yessir
15:02:22 <bswartz> awesome
15:02:29 <bswartz> I'll get your contact info after the meeting
15:03:02 <bswartz> okay so real quick dev status update
15:03:03 <jasonsb> (snds gd)
15:03:07 <bswartz> #topic dev status
15:03:14 <vponomaryov> Dev status for last week:
15:03:21 <vponomaryov> 1) Added more filters for list API
15:03:25 <vponomaryov> server BP: #link https://blueprints.launchpad.net/manila/+spec/improve-share-list-filtering
15:03:29 <vponomaryov> server gerrit: #link https://review.openstack.org/#/c/125094/
15:03:33 <vponomaryov> client BP: #link https://blueprints.launchpad.net/python-manilaclient/+spec/improve-share-list-filtering
15:03:38 <vponomaryov> client gerrit: #link https://review.openstack.org/#/c/124982/
15:03:38 <vponomaryov> status: ready for review
15:03:47 <vponomaryov> 2) Modified Horizon with added share-server page in admin tab
15:03:47 <vponomaryov> status: work in progress
15:03:47 <vponomaryov> change: #link https://github.com/NetApp/horizon/pull/2
15:04:07 <vponomaryov> Also several minor changes to docs
15:04:13 <vponomaryov> thats the main
15:04:19 <bswartz> thanks vponomaryov!
15:04:42 <bswartz> so there's no bugs against RC2 that I know about
15:04:50 <bswartz> so with any luck there won't be a RC3
15:04:51 <vponomaryov> But there are a couple of open items
15:04:59 <bswartz> ?
15:05:02 <vponomaryov> Manilaclient has no realese candidate.
15:05:07 <vponomaryov> Manilaclient does not have "kilo" dev cycle.
15:05:39 <vponomaryov> manilaclient depends on server state, so we should make releases for it too
15:05:41 <bswartz> yeah clients don't get RCs
15:05:55 <bswartz> they just get releases
15:06:04 <xyang1> are there any pending client side changes for Juno?
15:06:06 <vponomaryov> any release is Ok
15:06:08 <bswartz> check how cinder does it: http://git.openstack.org/cgit/openstack/python-cinderclient
15:06:24 <bswartz> xyang1: there were all kinds of changes
15:06:33 <bswartz> I will tag a version I suppose
15:06:38 <xyang1> bswartz: are they all merged?
15:06:49 <bswartz> but the release management on the client is way simpler
15:07:00 <bswartz> I'm not aware of anything that's waiting
15:07:20 <bswartz> https://review.openstack.org/#/q/manilaclient+status:open,n,z
15:07:29 <bswartz> these are all kilo targetted
15:08:03 <vponomaryov> bswartz: so, lets make juno release and change version to kilo
15:08:10 <bswartz> okay will do
15:08:23 <bswartz> #action bswartz will release juno version of python-manilaclient
15:08:58 <bswartz> so please keep testing with RC2
15:09:15 <bswartz> this is our last chance to find any bugs and fix them before we have a public release
15:09:41 <vponomaryov> bswartz: no one denied back-ports
15:09:44 <bswartz> the master branch is now open for kilo changes but please hold off on merging a ton of stuff
15:10:10 <bswartz> there's no hurry to merge for kilo-1
15:10:28 <bswartz> in a week or two we'll get to merging the backlog if kilo-targeted changes
15:11:00 <bswartz> #topic open discussion
15:11:19 <bswartz> so I'll give one more chance to ask questions or raise new topics
15:11:32 <vponomaryov> bswartz: some summit news?
15:11:45 <bswartz> I don't have any summit news -- and that concerns me
15:12:00 <bswartz> I need to get with ttx and find out about how much time we'll get at the design summit
15:12:03 <jasonsb> i would like to meet up with everybody
15:12:08 <jasonsb> i'll be there
15:12:14 <bswartz> jasonsb: you'll be in paris?
15:12:21 <jasonsb> yes
15:12:24 <bswartz> great!
15:12:27 <jasonsb> just booked it all
15:12:30 <bswartz> many of us will be there
15:13:02 <bswartz> and this project will get some time/space for discussing designs for kilo
15:13:07 <bswartz> just don't know how much yet
15:13:34 <bswartz> #action bswartz get details about the design summit so we can finalize plans
15:14:05 <bswartz> okay it sounds like that's it
15:14:14 <bswartz> we have a bunch of topics for paris
15:14:29 <bswartz> so I'm sure we'll have to prioritize it all and pick the stuff that's most interesting
15:14:38 <bswartz> no matter how much time we get
15:14:56 <bswartz> okay that's it
15:15:03 <bswartz> thanks all
15:15:13 <vponomaryov> thanks
15:15:16 <bswartz> shortest meeting in a long time!
15:15:17 <xyang1> thank
15:15:18 <rushil> thanjs
15:15:22 <rushil> *thanks
15:15:29 <jasonsb> thanks and nice to meet
15:15:32 <bswartz> #endmeeting