15:00:03 <bswartz> #startmeeting manila
15:00:04 <openstack> Meeting started Thu Jul 16 15:00:03 2015 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <openstack> The meeting name has been set to 'manila'
15:00:11 <bswartz> hello all
15:00:17 <vponomaryov> hi
15:00:30 <cknight> Hi
15:00:33 <u_glide> hi
15:00:37 <ganso_> hello
15:00:37 <csaba> hi
15:00:41 <rraja> hi
15:00:56 <bswartz> #agenda https://wiki.openstack.org/wiki/Manila/Meetings
15:01:07 <bswartz> looks like short agenda again
15:01:07 <xyang3> hi
15:01:36 <bswartz> I know it's vacation season and many people are in and out of the office
15:01:45 <cFouts> hi
15:01:46 <bswartz> #topic Midcycle Meetup
15:02:06 <bswartz> so the meetup is 2 weeks away!
15:02:08 <lpabon> o/
15:02:37 <bswartz> I haven't heard from anyone who can travel so I'm assuming that it will be another mostly-remote midcycle meetup
15:02:43 <bswartz> #link https://etherpad.openstack.org/p/manila-liberty-midcycle-meetup
15:02:51 <markstur> hi
15:02:55 <bswartz> I would still like to know who is joining remotely
15:03:00 <bswartz> please add your names to the etherpad
15:03:15 <bswartz> and I'm also looking for more topic proposals
15:03:35 <xyang3> bswartz: can you add meeting start and end time there also
15:03:38 <bswartz> there is plenty to talk about with all of the features we're currently working on, but I suspect not enough to fill up 2 days
15:03:42 <bswartz> xyang3: good idea
15:05:06 <bswartz> I was thinking 1300-2100 UTC
15:05:17 <bswartz> which is the same we did for the winter meetup
15:05:46 <bswartz> we could shorten that time if there aren't enough agenda topics
15:06:16 <bswartz> I've added the stuff I think it's important to talk about, but those topics probably only fill half the time
15:07:21 <bswartz> by next week I'll want to have scheduled times for each topic so if there aren't any new topic proposals I'll just make each day shorter
15:07:48 <bswartz> markstur: I just realized those times are really bad for you
15:07:56 <markstur> bswartz, It's OK
15:08:05 <markstur> I can just get up early 2 days
15:08:10 <bswartz> okay
15:08:21 <markstur> I think that worked well last time.  Better than going so late that people drop off
15:08:35 <bswartz> okay so that's all I have on the midcycle
15:08:38 <markstur> Actually last time. Nobody showed up for the late sessions
15:08:44 <bswartz> please sign up if you're attending -- I'll send an ML post too
15:08:53 <bswartz> #action bswartz to send ML reminder about midcycle etherpad
15:09:16 <bswartz> #topic Python 3 support
15:09:29 <bswartz> so people have asked me when we're going to support python 3
15:09:46 <bswartz> the rest of openstack seems to be making significant progress
15:10:07 <vponomaryov> bswartz: yeah, we should add py3 unit tests job first
15:10:09 <bswartz> Most other projects have a gate-python34 job
15:10:33 <bswartz> any reason we can't just add gate-manila-python34? are there known bugs?
15:10:34 <lpabon> cool
15:10:50 <vponomaryov> bswartz: we can
15:10:51 <lpabon> most likely we won't know until we try
15:11:03 <vponomaryov> bswartz: sure, as non-voting until stabilization
15:11:10 <u_glide> lpabon:  +1
15:11:13 <xyang3> +1
15:11:26 <bswartz> any volunteers to add the job?
15:11:39 * lpabon hears crickets
15:11:52 <bswartz> lpabon: you didn't wait long enough!
15:11:58 <lpabon> lol
15:11:59 <lpabon> :-D
15:12:00 <bswartz> lol
15:12:04 <vponomaryov> bswartz: it is easy, I can do it
15:12:07 <bswartz> okay well it shouldn't be too hard
15:12:30 <bswartz> just needs to be nonvoting initially
15:12:45 <bswartz> and after we have the job someone will need to file bugs for any detected issues
15:13:21 <bswartz> I know we spend some effort ensuring py3 compatibility even though we don't actively test it
15:13:41 <bswartz> my opinion is that we don't need to be leaders in py3 support, but we don't want to get too far behind the rest of openstack in that area
15:13:51 <bswartz> incidentally I feel the same way about ipv6 support
15:14:28 <bswartz> the lack of ipv6 support in openstack is a travesty, but I don't think this team's job is to go out and fix everything required to make it work
15:14:40 <bswartz> we should just make sure manila supports ipv6
15:15:21 <bswartz> #topic open discussion
15:15:29 <bswartz> that's all I had for today
15:15:37 <bswartz> anyone have something else they want to discuss
15:15:39 <bswartz> ?
15:15:40 <xyang3> bswartz: VNX CI started to report
15:15:50 <bswartz> xyang3: :D
15:15:56 <xyang3> bswartz: although there are still lots of failures
15:15:59 <bswartz> cool
15:16:13 <xyang3> bswartz: do you want us to turn it off until the failures are fixed
15:16:23 <xyang3> bswartz: otherwise it looks ugly
15:16:36 <bswartz> yes that reminds me I still owe several of you a 1on1 discussion about CI status
15:16:43 <bswartz> expect emails in the next week
15:16:51 <bswartz> xyang3: up to you
15:17:01 <xyang3> bswartz: ok, CI for Isilon is in progress
15:17:11 <bswartz> if it has a good chance of succeeding, leave it on -- if it's going to fail for sure, maybe turn off reporting
15:17:23 <bswartz> HP CI seems to have dropped off the radar
15:17:24 <xyang3> ok
15:17:28 <bswartz> it was reporting and now it's not
15:17:29 <markstur> Yes
15:17:47 <markstur> We had network changes and a lot of instability so it's not reporting.
15:17:51 <markstur> Should be back though.
15:18:05 <bswartz> markstur: that's cool -- HP is still well ahead of the deadlines
15:18:29 <bswartz> thanks xyang3, markstur
15:18:31 <markstur> Yeah. I went thru what xyang was saying about whether to turn it off
15:18:32 <xyang3> bswartz: we should talk about required features at the mid cycle?  I don't think we settle it down yet
15:18:44 <markstur> It actually is easier to track when it is on.  There is that nice report.
15:18:47 <bswartz> xyang3: please add a proposal
15:18:53 <xyang3> ok
15:19:16 <xyang3> bswartz: that affects CI as well, so we know what tests are required and what can be skipped
15:20:00 <bswartz> yes it's something we should decide for sure
15:20:35 <bswartz> and by "we" I mean I don't want to dictate the minimum feature list, I want the community to agree
15:21:18 <bswartz> xyang3: are there any features in particular you have questions about?
15:21:33 <xyang3> bswartz: like readonly
15:21:43 <xyang3> bswartz: I know Isilon doesn't have it yet
15:21:48 <bswartz> the most common question I get is whether snapshots are required, and I find it really hard to imagine allowing manila without snapshots
15:21:56 <ganso_> #link https://etherpad.openstack.org/p/manila-minimum-driver-requirements
15:22:03 <bswartz> xyang3: I had assumed it was required, but that's worth a discussion
15:22:58 <xyang3> bswartz: I think if a feature is required, we should list that in wiki shortly after the summit
15:23:13 <markstur> It seems a lot of drivers have "limitations"
15:23:14 <xyang3> bswartz: I'm saying it is late to add a requirement now for liberty
15:23:32 <vponomaryov> xyang3: why wiki? I guess it is better to have "doc" describing it
15:23:48 <xyang3> vponomaryov: some sort of official doc
15:23:57 <markstur> I think at least some of those should become "capabilities" so we can just have a way to deal with what features to expect
15:24:01 <xyang3> early on
15:24:19 <bswartz> ganso_: thanks for the link
15:24:37 <bswartz> the plan for minimum features is to get them into the official developer docs
15:25:22 <bswartz> minimum features have been informal for a long time
15:25:38 <ganso_> I thought shrink share was optional...
15:25:44 <bswartz> having the list in the manila repo (which is where the dev docs are) will help I think
15:25:45 <xyang3> ganso_: +1
15:26:06 <vponomaryov> xyang3: about requirement for RO - generic driver supports only RW for CIFS
15:26:27 <vponomaryov> xyang3: so, I guess, we should require only RW
15:26:30 <xyang3> vponomaryov: ok, so that can't be required then
15:26:57 <xyang3> vponomaryov: ok.  I thought that is tested in tempest
15:27:14 <lpabon> yeah i agree that this should not only be a doc but also part of some ci
15:27:24 <bswartz> I'd like to require read-only support
15:27:47 <ganso_> bswartz: but generic driver cannot do it for CIFS
15:27:50 <bswartz> but if there's a good reason it can't be implemented in certain cases then we have to find a way to communicate to the end user whether a share can support RO or not
15:27:56 <markstur> But I think it varies by protocol access-type...
15:28:09 <bswartz> ganso_: it cannot do it currently, but that doesn't mean it can never be done
15:28:45 <bswartz> it would be simpler to find a way to make it work in all cases and then say it's just a required feature
15:28:50 <bswartz> optional features are always more messy
15:28:51 <markstur> I think we should look into reporting capabilities so a share type can get the behavior it expects, but we don't have to pull a driver because it is different
15:28:56 <xyang3> bswart: so we need to have Liberty minimum requirements vs min requirements for the next release
15:29:12 <markstur> Agree with the messy comment
15:29:14 <bswartz> I agree
15:29:35 <bswartz> just because we intend to make a new feature required doesn't mean everyone has to implement it immediately -- there can be some time delay
15:31:14 <bswartz> although the deadlines for when new features will be required is also something that needs to be agreed upon and clearly communicated
15:31:34 <xyang3> bswartz: +1
15:31:57 <bswartz> alright if there's nothing else we can end early today
15:32:01 <vponomaryov> bswartz: maybe we should use some tagging for drivers?
15:32:13 <bswartz> vponomaryov: tagging for what features are supported?
15:32:19 <vponomaryov> bswartz: yes
15:32:29 <vponomaryov> bswartz: by features or group of features
15:32:34 <vponomaryov> bswartz: all-required
15:32:37 <bswartz> if we agree features should be optional, then yes
15:32:39 <vponomaryov> bswartz: incubating
15:32:41 <vponomaryov> etc
15:32:41 <markstur> vponomaryov, Good idea. Some master feature matrix at least
15:32:49 <bswartz> oh I see what you mean
15:33:37 <vponomaryov> all new drivers that does not have CI will have "incubating" or "sand-box" tag
15:33:44 <vponomaryov> s/does/do/
15:33:58 <markstur> After the deadline plan.  Next we'd need a what to do with drivers that "can't" comply
15:34:00 <bswartz> yeah, the way I'd like to see it done, is that compliance with a new feature should be covered by tempest tests, and the group of tempest tests should be skippable as long as the feature is optional
15:34:20 <markstur> I think tags sound better than moving them to stackforge
15:34:32 <xyang3> stackforge?
15:34:34 <markstur> or to unofficial repos
15:34:34 <bswartz> once a feature becomes required it should no longer be skippable and backends that can't pass those tests need to do something
15:34:44 <vponomaryov> markstur: there is no requirement to something new in stackforgeanymore, AFAIK
15:34:59 <vponomaryov> to * have *
15:35:09 <bswartz> last I head, the plan was to delete stackforge and move everything to openstack namespace
15:35:09 <markstur> I mean if a driver cannot do snapshots.  Do we remove it.  Where will it go.
15:35:31 <markstur> It'll go somewher unofficial (let's say github)
15:35:32 <bswartz> markstur: that's not our problem
15:35:33 <xyang3> bswartz: really?  then we'll have thousands of projects
15:35:47 <markstur> Unless we have a way to tag it "sand-box", etc...
15:36:02 <bswartz> xyang3: it what I see discussed in TC/infra meetings
15:36:14 <xyang3> bswartz: wow
15:36:31 <bswartz> markstur: deleted drivers remain in the git history -- and they can be released any number of ways for users that want them
15:36:47 <vponomaryov> xyang3: our manila-image-elements project appeared in "openstack" namespace at once
15:37:25 <bswartz> I don't think this team should have an opinion on how drivers are released if they're not part of upstream -- personally I think out-of-tree drivers are harmless but should not be encouraged
15:37:36 <xyang3> vponomaryov: that is still a manila sub project.  I'm not sure what happens to all the projects in general
15:38:06 <vponomaryov> xyang3: it is there because of reason bswartz described
15:38:26 <vponomaryov> xyang3: not because of manila is master-project
15:39:03 <bswartz> for those interested in the stackforge/openstack thing read the TC meeting minutes -- it has to do with the "big tent" concept and because infra is annoyed at having to rename projects from stackforge to openstack periodically
15:39:44 <bswartz> renaming projects is highly disruptive and serves no purpose other than to draw a boundary between an in-crowd and an out-crowd
15:40:11 <xyang3> bswartz: I'm just wondering if we can find a place to host a summit any more in the future, to fit in thousands of projects
15:40:27 <markstur> Vegas
15:40:37 <xyang3> markstur :)
15:40:53 <bswartz> I don't think that suddenly every project in the openstack namespace gets time at the summit -- that's managed separately
15:41:12 <bswartz> this is just limited to the naming of the repos
15:41:13 <xyang3> bswartz: ok, let's see
15:41:29 <bswartz> okay we're pretty off-topic now
15:41:41 <bswartz> thanks everyone I think we're done
15:41:46 <markstur> FYI -- I'm out-of-office tomorrow and next week.
15:41:54 <markstur> I'll try to stay in touch to follow-up on reviews, but not sure how well that will work.
15:41:59 <bswartz> #endmeeting