15:00:14 <bswartz> #startmeeting manila
15:00:15 <openstack> Meeting started Thu Jan 21 15:00:14 2016 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:18 <openstack> The meeting name has been set to 'manila'
15:00:20 <bswartz> hello all
15:00:21 <cknight> Hi
15:00:23 <ganso> hello
15:00:24 <dustins> \o
15:00:26 <vponomaryov> hello
15:00:29 <markstur_> hi
15:01:06 <bswartz> hmmm not many people here
15:01:09 <tingwang> o/
15:01:18 <bswartz> toabctl told me he won't be here
15:01:23 <bswartz> xyang isn't around
15:01:39 <bswartz> #topic announcements
15:01:47 <tingwang> Hello, everyone. This is my first time attending manila meeting.I'm a newcomer.
15:01:52 <aovchinnikov> hi
15:01:57 <Zhongjun_> hi
15:01:58 <cknight> tingwang: welcome!
15:01:59 <csaba> hey
15:02:02 <dustins> tingwang: Welcome!
15:02:04 <bswartz> so the M-2 milestone is today, and we have not merged everything we wanted to, not even close
15:02:05 <tingwang> Thank you
15:02:14 <bswartz> tingwang: hello, and welcome
15:02:25 <cknight> bswartz: kinda hard to merge things fast when the gate doesn't work
15:02:29 <tbarron> hi
15:02:37 <tingwang> I'm happy to see you.
15:02:51 <bswartz> regarding M-2, there are several things in the gate I'm hoping to get in before the tag, but the whether they do or not, I will tag the milestone this afternoon
15:03:15 <bswartz> cknight: the gate is less bad today than previous days this week it seems
15:03:25 <bswartz> but anything is possible
15:03:56 <vponomaryov> bswartz: devstack starteg taking about 50 minutes ((
15:04:11 <bswartz> the main things I wanted to call attention to are the LVM driver https://blueprints.launchpad.net/manila/+spec/lvm-driver https://review.openstack.org/#/c/232970/
15:04:58 <bswartz> and the share access control interface changes https://blueprints.launchpad.net/manila/+spec/new-share-access-driver-interface https://review.openstack.org/#/c/245126/
15:05:03 <cknight> LVM driver looks pretty good.  It'd be great if others could also try running it.
15:05:21 <cknight> I got it going pretty easily.
15:05:30 <bswartz> these both continue to be urgent
15:05:47 <dustins> cknight: I'll make a point to give it a shot on my machines here
15:05:48 <bswartz> there is some discussion around the second
15:06:04 <bswartz> vponomaryov: are you joking about devstack?
15:06:14 <vponomaryov> bswartz: no
15:06:25 <bswartz> vponomaryov: how does any gate job pass?
15:06:35 <vponomaryov> bswartz: it is about failed ones
15:06:47 <bswartz> is it random?
15:06:54 <vponomaryov> bswartz: kind of
15:07:00 <bswartz> okay
15:07:21 <bswartz> there are 6 changes with workflow +1 currently
15:07:27 <bswartz> we'll see what gets through by this afternoon
15:08:04 <bswartz> #agenda https://wiki.openstack.org/wiki/Manila/Meetings
15:08:12 <bswartz> #topic Update_access backwards compatibility approach discussion
15:08:16 <bswartz> ganso: you're up
15:08:40 <ganso> #link  https://review.openstack.org/#/c/245126/
15:09:14 <ganso> currently, tempest tests are testing V1 and V2 the same way
15:09:19 <ganso> because API has not changed
15:09:34 <ganso> but in that patch, it currently changes some DB fields
15:09:44 <ganso> it removes "state" field from Access table
15:09:55 <ganso> and adds "access_rules_status" to Share Instance table
15:10:19 <ganso> which causes API requests to retrieve rules to not return a value
15:10:28 <ganso> this affects V1 and V2 microversioned up to 2.8
15:11:00 <bswartz> so if the tempest tests were done correctly, they would be failing, right?
15:11:09 <ganso> so, behavior of V1 and V2-up-to-2.8 should be maintained, and not borken
15:11:14 <ganso> s/borken/broken
15:11:21 <ganso> bswartz: yes
15:11:23 <tpsilva> they are
15:11:38 <ganso> tpsilva: in that change, it currently is not
15:11:56 <ganso> because they are not testing V1 appropriately
15:12:00 <ganso> they are testing V2 2.9
15:12:19 <bswartz> right
15:12:20 <ganso> so I have 2 proposals
15:12:28 <ganso> proposal 1: creating a property "state" in access model that derives share access_rule_status. Map "out_of_sync" to "new", "active" to "active", "error" to "error". Downside is that whenever an user adds a new access rule, all rules change to "new" and then back to "active".
15:12:34 <ganso> proposal 2: do not remove fields, keep old behavior and new one. For each new request, an access rule is added to DB with status "new", if API call succeeds, state is changed to "active". If it fails changes to "error". Behavior is closer to original. Downside is managing when one access rule fixes the other, or are added in a group, but API access_allow
15:12:34 <ganso> allows only for one access_rule to be added at a time.
15:13:12 <ganso> proposal 2 seems to have best results maintaining V1 behavior
15:13:40 <bswartz> I prefer proposal 1
15:13:58 <bswartz> why do we care about preserving the V1 behaviour, other than not breaking existing clients?
15:14:20 <bswartz> the old behaviour was confusing and not something we should continue IMO
15:15:10 <bswartz> the only reason to spend extra effort making the old API behaviour exactly correct would be if there were cases where clients depended on the states being expressed exactly as they used to be
15:15:21 <bswartz> and I seriously doubt any logic depends on the values in those fields
15:15:23 <gouthamr> ganso: which causes API requests to retrieve rules to not return a value.. .I didn't really understand this part. We're removing a field, why would we not be able to retrieve rules?
15:15:41 <bswartz> as long as we provide some value which is vaguely accurate, I think clients will be fine
15:15:59 <cknight> Proposal 1 is closer to what's happening on the backend.  All rules are passed down to the driver to re-apply, so a brief time in the New state seems OK.
15:16:10 <ganso> gouthamr: we are able to retrieve rules, but the field "state" from table Access is not present anymore.
15:16:36 <bswartz> gouthamr: access state used to be stored per-rule -- we're chaging it to be per-share-instance
15:16:40 <markstur_> Test scripts that set a rule and test its status will be broken
15:16:41 <ganso> cknight: there is also the case where if one rule fails, all rules change to error at the same time
15:16:57 <markstur_> Production scripts?
15:17:05 <bswartz> ganso: that's close enough to the truth that I wouldn't expect breakage
15:17:15 <ganso> markstur_: if they test individual rules they will not. If they test the whole list, or multiple items in the list, they will.
15:17:29 <bswartz> I would expect people to be confused, but the fix is simple -- upgrade to new client
15:18:36 <dustins> As long as that's clearly documented, I'm alright with that
15:19:18 <ganso> dustins: would this affect only Mitaka docs?
15:19:40 <bswartz> ganso: I think this calls for a release note
15:19:41 <ganso> dustins: document that "if using V1 client, or V2 pre-2.9, the following behavior will be shown:"
15:19:48 <dustins> bswartz: +1
15:19:50 <bswartz> ganso: +1
15:20:00 <dustins> ganso: Exactly, yes
15:20:06 <gouthamr> ganso: +1, standard deprecation.. like the others we've done so far.
15:20:18 <ganso> great then
15:20:26 <ganso> does everybody agree with proposal 1 or should we vote?
15:20:46 <bswartz> I favor proposal 1
15:20:48 <bswartz> any opposed?
15:20:52 <markstur_> I think my concern was addressed
15:21:35 <vponomaryov> ok with both
15:21:50 <bswartz> btw just to add some more background, the driver interface part of this change is the new interface that all the existing drivers need to implement in M-3, so it's urgent that that part of this change merges asap
15:22:02 <bswartz> this was discussed at midcycle last week
15:22:36 <bswartz> so we can tinker with the API part of the change later if needed, but some flavor of the change needs to go in
15:22:53 <bswartz> that's why I'm in favor of a cheap and easy solution
15:23:24 <bswartz> okay I think we're agreed
15:23:50 <bswartz> #agreed we will go with ganso's first proposal for share access rule states
15:23:50 <ganso> ok
15:24:03 <bswartz> #topic Exposing the Data Service to drivers
15:24:09 <bswartz> ganso: you're up again
15:24:49 <ganso> markstur_ and I were talking yesterday about exposing some basic functionality of Data Service to drivers, possibly through a helper
15:25:18 <ganso> the manager would take care of RPC calls, handle results, callbacks
15:25:29 <ganso> my main concern is this #link https://review.openstack.org/#/c/259917/
15:25:34 <ganso> I posted a comment
15:25:43 <ganso> we briefly discussed this at the midcycle
15:25:44 <bswartz> ganso: would the manager run the copy code itself, or deal with sending RPCs to the actual data copy service?
15:25:59 <ganso> the copy code would be offloaded to the data service
15:26:04 <ganso> no copy would be performed in the manager
15:26:26 <ganso> but there are 2 things very important here
15:26:41 <ganso> 1) drivers are not experimental, if driver change is in, it is in for Mitaka release
15:26:47 <ganso> 2) Migration and Data Service still are
15:27:00 <ganso> so agreeing this, we need to make Migration and Data Service not experimental anymore
15:27:26 <ganso> that ^, if a driver merges and uses Data Service
15:27:28 <bswartz> ganso: I agree, but there is another option
15:28:02 <bswartz> the data copy service does not need to be experimental -- it has no REST API
15:28:20 <ganso> bswartz: right, good point
15:28:24 <bswartz> the migration APIs can continue to be experimental even as we fully support the data copy service
15:28:35 <ganso> right now we don't have plans to expose Data Service functions through API, only internally to drivers through helper
15:29:47 <cknight> ganso: Thanks for pointing this out.  I don't think drivers should be doing a full data copy themselves.  But using the data copy service would make the share-from-snapshot asynchronous from the driver's perspective.  How would state changes be handled?
15:30:03 <bswartz> there is precedent for managers to send RPCs, so allowing the manager to send an RPC to the data copy service doesn't seem like a bad thing
15:30:18 <bswartz> however we should discuss what the actual RPC for data copying looks like
15:30:36 <bswartz> it has to be asynchronous to some degree, and it will require DB state
15:31:24 <ganso> cknight: share status would remain in "creating", callback function would change it to "available". This is something we still need to design, drivers are not allowed to touch DB, manager needs to do it, but in this case, manager would need to know what to do. This would be a simple share model update.
15:32:13 <cknight> ganso: OK.  It does open possibilities for more drivers to support interesting workflows, albeit more slowly.
15:32:48 <bswartz> I'm referring to how the data copy service tracks its own work
15:33:13 <ganso> bswartz: yes, this is a problem since we don't have the Jobs table
15:33:14 <bswartz> ideally the data copy service should be able to survive restarts and reboots
15:33:25 <ganso> bswartz: that as well...
15:33:44 <ganso> it is not resilient, fault tolerant
15:33:51 <bswartz> if we don't add those features then the data copy service will end up being highly unreliable in production
15:34:27 <bswartz> as simple copy_jobs table would solve a lot of problems
15:34:35 <bswartz> s/as/a/
15:34:38 <ganso> bswartz: but either that, or a driver in production bottlenecking the manila-share service copying 1TB of data
15:34:45 <cknight> bswartz: At a minimum, it seems we're agreed drivers shouldn't be doing full host-based data copy operations themselves, right?
15:35:06 <ganso> cknight: +1
15:35:07 <bswartz> cknight: I'm not sure I'd go that far
15:35:21 <bswartz> cknight: ideally they would not, but in the short term we may need to tolerate it
15:35:43 <bswartz> once we have a working reliable data copy service, then I think we should enforce that kind of rule
15:35:46 <markstur_> leveraging data service would be preferred
15:36:04 <bswartz> but until we do, I don't want to prevent drivers from doing what needs to be done
15:36:06 <cknight> bswartz: It's a scaling nightmare for any driver.  Why would a driver author choose to do that?
15:36:24 <markstur_> I don't see why it is "highly unreliable"
15:36:25 <bswartz> in any case we will be no worse off than cinder, which does immense amounts of data copying on the cinder control nodes
15:37:24 <markstur_> Seems we're going the right direction
15:37:36 <bswartz> markstur_: if all the data copy jobs simply fail when I restart the manila-data-copy service then people who use them will have to design workarounds like retry mechanisms
15:37:57 <bswartz> I'd rather that the retry mechanism lives inside the copy services so its users can assuming reliable operation
15:38:05 <bswartz> s/assuming/assume/
15:38:10 <markstur_> bswartz, Makes sense.
15:38:58 * bswartz shakes his fist at zuul
15:39:22 <bswartz> zuul just restarted all the manila gate jobs
15:39:28 <markstur_> The ghostbusters Zuul or the other one?
15:39:40 <markstur_> Oh.
15:39:49 <bswartz> markstur_: it's the same zuul
15:40:01 <dustins> The one not causing dimensional mischief :P
15:40:15 <cknight> bswartz: :-)
15:40:22 <bswartz> dustins: that's a matter of perspective
15:40:47 <dustins> :)
15:40:59 <bswartz> okay so did we answer your question ganso?
15:41:41 <ganso> bswartz: so decision is that we prefer the driver does the copy, in Mitaka. And we will work for an improved data service to be released in N, right?
15:42:07 <bswartz> ganso: any reason we can't get the data copy service fully working in M?
15:42:29 <bswartz> is there not enough manpower to get it done?
15:42:47 <ganso> bswartz: I am not sure we can do it in time, if the driver needs it, the driver will also need to update
15:42:58 <bswartz> I don't prefer that the driver does the copy, but it seems to be the only option in the short term
15:43:10 <cknight> bswartz: If that's the will of the community, fine.  I think the patch in question does Huawei customers, and by extension Manila, a disservice by introducing a huge performance bottleneck in what should be a quick workflow.
15:43:19 <ganso> bswartz: It is better than rushing it
15:43:51 <ganso> bswartz: *could be better
15:44:06 <bswartz> cknight: I think that can be worked around by documenting that, for the huawei driver at least, m-shr needs to on a node with data-copying horsepower
15:44:20 <bswartz> it's really a deployment question
15:44:47 <bswartz> right now we don't have flexbility to split the m-shr and m-dat functions onto different nodes, and in the future, we will
15:44:55 <ganso> end users don't understand that, Cloud providers may even choose to disable snapshot functionality on a Huawei backend
15:45:57 <cknight> ganso: +1  I would.
15:46:03 <bswartz> I actually hope that we can learn something about data copying by allowing some people to try it and let us know how it goes at production scale
15:46:29 <cknight> bswartz: The migration facility should accomplish that.
15:46:56 <bswartz> yes but I'm hearing we might not have that production ready in time for Mitaka
15:47:15 <ganso> bswartz: we can try
15:47:35 <ganso> maybe create an alternative Huawei patches and by the end of M-3 we merge one or the other
15:47:44 <bswartz> Mitaka will hopefully give users an improved migration experience, but maybe not a fully scalable data copying engine
15:47:44 <ganso> s/patches/patch
15:48:26 <ganso> if nobody uses Data Service and Migration is still experimental in Mitaka, then nothing is affected
15:49:19 <bswartz> okay I wanted to move onto the next topic
15:49:43 <bswartz> #topic Snapshot manage/unmanage
15:50:03 <bswartz> I was hoping xyang would suggest this as a midcycle topic so we could have discussed it last week
15:50:24 <bswartz> since she isn't here, I just wanted to point it out
15:50:44 <bswartz> https://review.openstack.org/#/c/249542
15:51:15 <bswartz> this is a feature we discussed back in liberty
15:52:09 <bswartz> it's an extension to the manage/unmanage share feature to allow handling of snapshots as well
15:52:29 <bswartz> I hope we can make this feature part of mitaka too
15:52:50 <bswartz> since xyang isn't here I guess we don't need to say anything else unless there are questions about it
15:52:51 <cknight> In principle, this seems like a useful feature, although it had its detractors on the Cinder side.  I'd like to understand how this will work with snapshots of replicated shares.
15:53:19 <bswartz> cknight: well you can manage a replicated share can you?
15:53:37 <bswartz> perhaps you can unmanage one
15:53:49 <bswartz> but only if there are no snapshots
15:54:26 <cknight> bswartz: I'm merely pointing out that merging this feature now adds more technical debt with feature interoperability.
15:54:27 <gouthamr> bswartz: you could, but the replication isn't initiated up by manila though.. so it wouldn't know about any existing replicas..
15:55:35 <bswartz> gouthamr: I'm referring to managing an share and using a share_type with replication=True
15:56:18 <bswartz> for that to succeed, the driver would need a TON of code to find and validate the existing replicas
15:56:46 <cknight> bswartz: Rather than merging yet another feature, I'd prefer to see us make the ones we already have work together, including share manage/unmanage.
15:56:50 <bswartz> fortunately the driver is free to simply fail in that case
15:57:01 <dustins> cknight: +1
15:58:03 <ganso> cknight: +1
15:58:07 <bswartz> cknight: I don't see how this makes things any worse -- manage/unmanage is an optional feature
15:58:49 <bswartz> drivers that choose to implement it can do so and add value in that use case
15:58:53 <dustins> As a side note, is there a place where I can see the required and optional features for a driver?
15:59:03 <bswartz> dustins: yes!
15:59:09 <cknight> dustins: Yes, there's a doc in devref for that.
15:59:24 <bswartz> okay we're out of time
15:59:29 <vponomaryov> http://docs.openstack.org/developer/manila/devref/driver_requirements.html
15:59:31 <bswartz> no time for open discussion even
15:59:35 <dustins> vponomaryov: Thanks!
15:59:55 <bswartz> continue the snapshot manage/unmanage discussion in the gerrit review
16:00:03 <bswartz> thanks all
16:00:05 <cknight> bswartz: ok
16:00:15 <bswartz> #endmeeting