15:00:15 <bswartz> #startmeeting manila
15:00:21 <openstack> Meeting started Thu Sep 22 15:00:15 2016 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:25 <openstack> The meeting name has been set to 'manila'
15:00:29 <bswartz> hello all
15:00:29 <gouthamr> hello o/
15:00:30 <cknight> Hi
15:00:30 <ganso> hello
15:00:31 <vponomaryov> Hello
15:00:31 <tovchinnikova> \\//
15:00:32 <tbarron> hi
15:00:34 <jseiler_> hi
15:00:34 <aovchinnikov> hi
15:00:37 <dustins> hey-o
15:00:38 <dustins> \o
15:00:41 <zhonghua> hello
15:00:46 <markstur_> hi
15:00:49 <bswartz> #agenda https://wiki.openstack.org/wiki/Manila/Meetings
15:00:56 <zhongjun_> hi
15:01:31 <bswartz> #topic Specs process
15:01:39 <bswartz> #link https://review.openstack.org/#/c/374883
15:02:06 <bswartz> I had hoped to have the above proposal ready earlier in the week so you all would have have time to review it before today
15:02:13 <xyang2> hi
15:02:33 <bswartz> however various debugging took all my time and I didn't get to write it until this morning
15:02:54 <bswartz> so I don't expect anyone to have read it yet
15:03:14 <gouthamr> you'll be surprised :)
15:03:15 <bswartz> the proposal is based on conversations I've had with the core reviewer team
15:03:21 <cknight> gouthamr: +1
15:04:03 <bswartz> people should provide feedback using gerrit, but I'll briefly outline what the proposal is
15:04:33 <bswartz> we introduced specs in newton, but didn't have any process around them, and ultimately they were not too valuable
15:04:58 <bswartz> also during newton the team got overloaded with too much new stuff and we failed to focus on the important stuff until it was too late
15:05:12 <bswartz> so I'm trying to fix that for future releases, and that document outlines my plan
15:05:22 <mkoderer> hello
15:06:17 <bswartz> In particular I regret all of the time that was spent on features which didn't get much/any review attention
15:07:15 <bswartz> in particular, the snapshot semantics stuff from tpsilva/cknight, the share backup proposal from zhongjun_, and the driver-private-share-data API from xyang, amoung others
15:07:42 <vponomaryov> user messages?
15:08:07 <bswartz> vponomaryov: yeah that was another failure
15:08:56 <bswartz> I should also mention that while I'd like to start a new process for Ocata and later, the Ocata release will be special due to how short it is
15:09:27 <bswartz> so this proposal will probably benefit us more for Pike/Queens/R...
15:09:40 <vkmc> o/
15:11:08 <bswartz> anyways please provide feedback on the proposal through gerrit and if we need to discuss it more next week we can
15:11:20 <bswartz> any questions before we move on?
15:11:53 <bswartz> #topic Ocata Design Summit
15:12:01 <bswartz> #link https://etherpad.openstack.org/p/manila-ocata-design-summit-topics
15:12:20 <bswartz> So I created this etherpad last week, and nobody has proposed anything yet
15:12:49 <bswartz> Because of the shortness of the Ocata release, my personal preference is to focus on retiring technical debt
15:13:12 <bswartz> however due to the failures of the Newton release we have a substantial number of "almost done" features which may be worth of consideration
15:14:27 <bswartz> for the design summit, we have 2 fishbowls and 4 working sessions, same as Austin
15:15:04 <bswartz> there are more conflicts with Cinder than ever before though
15:15:42 <ganso> bswartz: has the sessions schedule been published?
15:15:43 <bswartz> I know ttx tried to avoid conflicts, but the schedule is getting more complex
15:16:14 <bswartz> ganso: drafts have gone out -- I'm not sure if a public announcement has been made
15:18:54 <tbarron> ganso: https://docs.google.com/spreadsheets/d/1TQ-RSlbiBBEclkonIbfUP7R1ExZSJylF1uiEKV2G_Cw/pubhtml?gid=1107826458&single=true
15:19:05 <bswartz> anyways, if you have a topic you really want to discuss in Barcelona, please get it up on etherpad so we can start voting next week
15:19:10 <ganso> tbarron: thanks!
15:19:26 <bswartz> tbarron: ty
15:20:04 <xyang2> bswartz: for new drivers, do we still have the same deadline?  merge date is Ocata-3?  when does the driver need to be submitted?
15:20:48 <bswartz> xyang2: that's a good question
15:20:57 <bswartz> #topic new driver deadline
15:21:28 <bswartz> xyang2: I think we should avoid deciding on the specific deadline until after we agree on our specs process/deadlines
15:21:42 <xyang2> ok
15:21:58 <bswartz> however I'd be in favor of keeping it more or less the same -- maybe a bit earlier for Ocata just because of the short release
15:22:23 <xyang2> bswartz: I got questions on that because we do have a new driver coming in Ocata
15:22:36 <bswartz> #link https://releases.openstack.org/ocata/schedule.html
15:23:09 <bswartz> so if we were to keep the deadline at feature freeze minus 3 weeks, that would put us at Jan 02
15:23:31 <bswartz> and due to holidays, those last 3 weeks are going to be a mess
15:24:15 <xyang2> bswartz: ok, thanks
15:24:39 <bswartz> I need to find out when holidays fall this year and who will be affected when
15:25:12 <bswartz> possibly we can keep it the same, or possibly we might want new drivers before christmas, to account for the holiday time for reviewers
15:25:28 <vponomaryov> bswartz: +1 before christmas
15:25:46 <zhongjun_> Is there still have FFE?
15:25:51 <markstur_> vponomaryov, which christmas?
15:26:11 <vponomaryov> markstur_: the erliest
15:26:17 <vponomaryov> ))
15:26:25 <bswartz> when is orthodox christmas this year?
15:26:40 <bswartz> does it move around like the chinese new year does?
15:26:50 <ganso> bswartz:  Thursday, January 7
15:26:55 <ganso> bswartz: ^ according to google
15:27:24 <bswartz> looks like chinese new year is kind enough to fall after feature freeze this year
15:27:26 <ganso> bswartz: wait, maybe it should be 2017
15:27:47 <ganso> bswartz: scratch that, should be Saturday, January 7
15:28:27 <xyang2> bswartz: right around that time
15:28:30 <bswartz> xyang2: how do you feel about making the deadline feature freeze minus 5 weeks?
15:28:32 <ganso> bswartz: according to google, chinese new year isSaturday, January 28
15:28:46 <bswartz> that would put us at Dec 19 -- before the holidays in the US
15:28:51 <xyang2> bswartz: fine with me.  I'd like it earlier
15:29:00 <bswartz> earlier than Dec 19?
15:29:19 <xyang2> bswartz: Dec 19 is good
15:29:26 <bswartz> anyone opposed?
15:30:26 <bswartz> #agreed driver proposal deadline Dec 19
15:30:47 <bswartz> after we figure out the specs deadline stuff I'll send out a ML announcement with all the dates
15:31:33 <bswartz> and we can also push a change to the schedule repo so people can find the deadlines using google (I've gotten complaints that the ML posts are hard to google)
15:31:40 <bswartz> #topic open discussion
15:31:42 <xyang2> bswartz: you don't have problem with a CoprHD Manila driver, right?  It's already in Cinder
15:31:56 <ganso> my vacation starts on Monday September 26th and I return on October 15th. I will try to show up in the weekly meetings whenever possible.
15:32:24 <bswartz> ganso: enjoy your vacation!
15:32:36 <bswartz> it's a great time to take off, as long as no critical bugs pop up before release
15:32:40 <dustins> I got an email from the docs folks asking for volunteers for testing the Installation Documentation for Manila
15:32:45 <ganso> bswartz: thanks
15:33:00 <bswartz> dustins: we've had people in the channel who couldn't get it to work
15:33:19 <bswartz> are they the testers or is the request for testing coming because they can't get it to work?
15:33:23 <gouthamr> dustins: yay
15:33:27 <tbarron> we need some admin-oriented doc for lvm driver :)
15:33:33 <dustins> Yeah, they're coming down on the projects and asking folks to have a good look at all docs, but especially the Installation Doc
15:33:47 <bswartz> tbarron: is it not in the config guide yet?
15:33:51 <gouthamr> dustins: i was hoping to do the reverse.. ask if we can get volunteers to test it..
15:34:09 <dustins> They're asking projects to check the documentation for their respective projects
15:34:15 * tbarron checks, maybe his info is stale
15:34:24 <bswartz> yes this is a good time to update all the config ref docs for the stuff that changed in newton
15:34:26 * dustins still gets the docs liaison emails
15:34:48 <gouthamr> dustins: but needed this update to merge https://review.openstack.org/#/c/359491/
15:34:54 <gouthamr> #plug: ^ please review
15:34:58 <bswartz> and to review the docs in general for accuracy
15:35:16 <dustins> Yes, all of that needs to happen
15:35:36 <bswartz> gouthamr: should be #shamelessplug lol
15:35:43 <dustins> I know there's a lot, we're all super busy with our own things, but it really needs to be done
15:35:44 <gouthamr> :P
15:35:59 <dustins> Just to save ourselves from heartbreak and headache in the future
15:36:15 <markstur_> gouthamr changes his name to shameless
15:36:22 <gouthamr> now's a good time for a docblitz
15:36:34 <gouthamr> markstur_: lol..
15:37:05 <bswartz> alright anything else?
15:37:09 <tbarron> i'll pull shameless's patch and re-read to see if my concerns are addressed.  I was concerned that we keep pointinig newbies to the generic driver, like sending red ridiing hood into the woods.
15:37:18 <markstur_> lol
15:37:22 <bswartz> I think we're done early
15:37:25 <dustins> I might make an etherpad with all of the docs we have and then call for volunteers
15:37:26 <vkmc> yes! I wanted to get your feedback wrt some feature that has been in my mind
15:37:41 <bswartz> vkmc: like what?
15:37:42 <vkmc> considering I'm just giving my first steps on Manila, I'd appreciate your comments
15:37:43 <gouthamr> dustins: shameless +1
15:38:09 <vkmc> so... this started with a bug in the ui
15:38:34 <gouthamr> #link https://review.openstack.org/#/c/372805/
15:38:38 <vkmc> basically we are displaying all protocols on the create share modal without checking if it's deployed in the control plane
15:39:06 <vkmc> from there, I noticed that there is no direct way to get which protocols are enabled
15:39:29 <bswartz> I've heard this complaint before
15:39:30 <vkmc> we have a setting in manila.conf, but that's it
15:39:44 <vkmc> so... for now I proposed a workaround for this from the ui side
15:39:46 <vkmc> #link https://review.openstack.org/#/c/372805/
15:39:58 <bswartz> we need a new API to expose the list, and the question is what that should look like
15:40:04 <vkmc> but I was thinking this should be better fixed by implementing a capabilities endpoint for Manila
15:40:07 <vkmc> as we have in other projects
15:40:10 <vkmc> yeah
15:40:11 <bswartz> it probably makes sense for it to be a per-share-type thing
15:40:14 <gouthamr> any reason we can't use scheduler-stats
15:40:15 <gouthamr> ?
15:40:26 <bswartz> -1 for capabilities endpoint
15:40:30 <gouthamr> it gives you a list of pool capabilities
15:40:36 <vkmc> I could work on a spec for it, and later discuss it...  but preferred to get your input on if this is a good idea or not
15:40:42 <bswartz> gouthamr: admin only
15:41:02 <vkmc> bswartz, why the -1 for capabilities endpoint?
15:41:24 <bswartz> vkmc: in Manila we expose such things on the share types
15:41:43 <bswartz> so the logical approach would be for each share type to have a list of supported protocols
15:41:45 <xyang2> vkmc, bswartz: this is similar to this one in cinder: https://blueprints.launchpad.net/cinder/+spec/discovering-system-capabilities
15:41:59 <bswartz> however, doing do in a way that's backwards compatible could be tough
15:42:01 <gouthamr> xyang2: +1
15:42:03 <vkmc> xyang2, yeah, exactly what I was looking :)
15:42:14 <vkmc> bswartz, I see... yeah
15:42:19 <tbarron> vkmc: one question is whether the approach taken in  https://review.openstack.org/#/c/372805/ would be acceptable as a short-term fix (before you add unit tests, etc.) - though of course we'd work on an API longer term
15:42:37 <vkmc> indeed, thanks tbarron
15:42:47 <bswartz> xyang2: I haven't followed that discussion in cinder, but I definitely have my opinions
15:43:10 <tbarron> vkmc: as customers need a fix real soon, and we might have a bit of discussion on the right way to go for ocata, or for pike, or ..;\
15:43:25 <xyang2> vkmc: bswartz: the patch https://review.openstack.org/#/c/350310/  is on hold to get some cross project consensus on the api
15:43:38 <tbarron> xyang2: exactly
15:44:11 <tbarron> I think we may need a near term and a medium term approach unless the medium term solution can be accelearated
15:44:12 <gouthamr> the author proposed to write a spec on the API-WG..
15:44:15 <bswartz> xyang2: cinder created a real mess when they added a whole new feature which was "turned off" by default
15:44:18 <tbarron> accelerated
15:44:20 <vkmc> yeah... if we probably want to check how this turns out to be for Cinder
15:44:37 <xyang2> bswartz: blame cinder for everything:)
15:44:51 <bswartz> xyang2: cinder is an easy target :-)
15:44:57 <xyang2> :)
15:45:08 <gouthamr> karate chops with cinder blocks
15:45:15 <cknight> xyang2: not blame, just learn from them what works and what fails miserably
15:45:23 <vkmc> haha gouthamr++
15:45:27 <ganso> gouthamr: it is super effective! :P
15:45:45 <xyang2> cknight: that's ok.  cinder in turn blames nova:)
15:45:46 <vkmc> something like... "what would Cinder do?" driven development
15:45:50 <markstur_> new topic? cinder bashing
15:45:53 <dustins> cknight: Yes, learn from what worked and what did not, let's not throw our block storage buddies under the bus
15:45:55 <cknight> xyang2: :-) exactly
15:46:17 <bswartz> okay I think that's sufficient cinder bashing
15:46:27 <bswartz> vkmc: we do need a spec for this
15:46:30 <vkmc> ok, so... would you like me to work on some spec...
15:46:32 <vkmc> I was going to say that
15:46:33 <vkmc> :D
15:46:36 <gouthamr> vkmc: +1
15:46:57 <bswartz> again my preference is for something akin to our share-type public extra specs
15:47:02 <vkmc> and we can later discuss it next meeting (or another... as we see fit... we have other priorities now for sure :)
15:47:10 <bswartz> however backwards compatibility will be hard
15:47:17 <vkmc> yeah :/ that's my main concern bswartz
15:47:38 <bswartz> also there will be upgrade issues
15:47:58 <tbarron> bswartz: vkmc it would be good for people to look at the existing review to see if it's DOA or whether a short-term fix is OK too
15:48:00 <bswartz> when you upgrade from newton to ocata, how will manila figure out what protocols to enable for each share type
15:48:01 <bswartz> ?
15:48:42 <vponomaryov> protocols are enabled via config and it will not be changed
15:48:43 <tbarron> #link https://review.openstack.org/#/c/372805/
15:48:49 <gouthamr> i think we can deprecate the horizon config option safely..
15:48:59 <bswartz> vkmc: if you'll be in barcelona that would be a good design summit topic
15:49:18 <vkmc> bswartz, I will be there yes, and I would like to discuss it then!
15:49:26 <bswartz> put something on the etherpad then
15:49:38 <bswartz> anything else before we end the meeting?
15:49:48 <zhongjun_> I have one
15:49:49 <vkmc> vponomaryov, agree, I'm proposing to add a way to retrieve which protocols are enabled
15:49:56 <vkmc> bswartz, will do, thanks
15:50:02 <zhongjun_> Could you please pay attention to enable IPv6 feature?
15:50:02 <zhongjun_> link:http://osdir.com/ml/openstack-dev/2016-09/msg01487.html
15:50:02 <zhongjun_> spec link: https://review.openstack.org/#/c/362786/
15:50:33 <zhongjun_> Thanks all
15:50:39 <gouthamr> zhongjun_: sure..
15:50:46 <bswartz> zhongjun_: yes I think ipv6 would be a good thing to focus on in ocata
15:51:03 <bswartz> it feels small enough to fix the small release yet will offer large value
15:51:15 <cknight> zhongjun_: please add that to the etherpad
15:51:28 <bswartz> zhongjun_: will you be in barcelona?
15:51:36 <zhongjun_> bswartz, cknight: ok, I will add it later
15:51:46 <bswartz> cknight: the etherpad is for summit topics -- we should omit stuff if key people can't attend
15:51:54 <zhongjun_> bswartz: I am not sure
15:51:56 <bswartz> and cover those items in another venue
15:52:55 <bswartz> okay, well if there's a chance you'll be there I suggest proposing it on the etherpad zhongjun_
15:53:40 <zhongjun_> bswartz: ok
15:54:25 <bswartz> okay thanks everyone
15:54:31 <bswartz> talk to you next week
15:54:41 <bswartz> #endmeeting