15:00:38 <bswartz> #startmeeting manila
15:00:39 <openstack> Meeting started Thu Apr 13 15:00:38 2017 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <openstack> The meeting name has been set to 'manila'
15:00:45 <bswartz> hello all
15:00:50 <dustins> \o
15:00:53 <markstur> hi
15:00:53 <tbarron> hi
15:00:55 <ganso> hello
15:00:56 <xyang2> hi
15:00:58 <bswartz> #agenda https://wiki.openstack.org/wiki/Manila/Meetings
15:00:59 <vponomaryov> hello
15:01:02 <gouthamr> hello o/
15:01:27 <tommylikehu> hello from cell phone..
15:01:31 <bswartz> #topic announcements
15:01:36 <toabctl> hi
15:01:46 <bswartz> today is the Pike-1 milestone
15:01:49 <Zhongjun__> hi
15:01:53 <bswartz> I'll be pushing tags this afternoon
15:02:04 <jungleboyj> o/
15:02:12 <bswartz> also spec freeze is tonight at 23:59 UTC
15:02:26 <bswartz> more about specs in a moment
15:02:32 <jprovazn> hi
15:02:58 <bswartz> #topic Spec Freeze
15:03:09 <bswartz> #link https://etherpad.openstack.org/p/manila-pike-spec-review-focus
15:03:32 <bswartz> thanks to those who signed up to review specs
15:03:44 <bswartz> I've seen a lot of reviews
15:04:18 <bswartz> I was out of town the last 3 days and I've been focusing mostly on 2 specs
15:04:37 <xyang2> bswartz: 23:59 UTC = 6:59PM EST right?
15:04:40 <bswartz> I'd like to review all the unmerged specs and discuss if any of them should be punted or given more time
15:04:50 <bswartz> xyang2:  that sounds about right
15:05:35 <bswartz> first up, share_groups quota resource
15:05:39 <bswartz> #link https://review.openstack.org/#/c/452270/
15:06:13 <bswartz> are we waiting on anything to workflow this one?
15:07:30 <gouthamr> nope, did it
15:07:30 <bswartz> next up, ceilometer integration
15:07:30 <bswartz> #link https://review.openstack.org/445441
15:07:31 <bswartz> I'll do the honors
15:07:36 <bswartz> share type quotas
15:07:37 <bswartz> #link https://review.openstack.org/#/c/447021/
15:08:03 <gouthamr> xyang2 recommended some changes
15:08:07 <bswartz> xyang: any reason you +1 instead of +2?
15:08:20 <xyang2> share type quotas?
15:08:29 <bswartz> yes
15:08:43 <gouthamr> vponomaryov: can you add the bp in the commit message?
15:09:02 <vponomaryov> gouthamr: "if you need to upload another patch set."
15:09:05 <xyang2> just suggest add a blueprint reference, no big deal
15:09:09 <vponomaryov> gouthamr: there is no other need
15:09:18 <bswartz> yeah I don't really care about bp in the commit
15:09:22 <bswartz> it's a specs repo
15:09:32 <gouthamr> well ,it shows up on launchpad if you do
15:09:46 <bswartz> next is openstack client support
15:09:50 <bswartz> #link https://review.openstack.org/#/c/395775/
15:09:52 <tbarron> I'm for the idea but don't think OSC is ready for us yet, for reasons given in the review.
15:10:06 <gouthamr> +1
15:10:19 <bswartz> is Mauricio Lima here?
15:10:24 <bswartz> what is IRC nick?
15:11:02 <gouthamr> mlima
15:11:04 <gouthamr> not here
15:11:28 <bswartz> does anyone think we could work this into Pike given more time or are we all in favor of pushing to Queens?
15:11:48 <vponomaryov> I am for pushing it to Q
15:11:51 <gouthamr> +1
15:11:58 <tbarron> +1
15:12:01 <bswartz> yeah I get the sense people want to push it
15:12:10 <bswartz> I'm looking for a motion to not push it
15:12:14 <ganso> I am not sure mlima is going to be working on it
15:12:24 <bswartz> so we can hear arguments in favor of keeping it in Pike
15:12:25 <markstur> it would be nice to see someone prototype it, but don't know if anyone has signed up for that
15:12:47 <markstur> the microversion issue might push it to Q anyway
15:13:00 <tbarron> markstur: +1
15:13:19 <bswartz> okay so I'll put a note on this spec explaining that we won't merge it in pike
15:13:30 <xyang2> there's no update on the patch since Dec. 15 last year
15:14:02 <bswartz> oh good point
15:14:04 <gouthamr> ganso, was mlima part of your group at hitachi? i see he did the manila integration for kolla..
15:14:10 <bswartz> I don't know why I didn't notice the history
15:14:42 <bswartz> yeah with no current implementer this doesn't stand a chance
15:14:55 <bswartz> next up, ensure share
15:15:00 <bswartz> #link https://review.openstack.org/#/c/446494/
15:15:08 <ganso> gouthamr: yes, but slightly separate group. That group suffered the same fate as mine, AFAIK
15:15:09 <vponomaryov> more time
15:15:13 <vponomaryov> for ensure share
15:15:24 <gouthamr> ganso: :(
15:15:34 <tommylikehu> vponomaryov:  so push the deadline for that one?
15:15:38 <bswartz> I've seen the issues I raised get addressed in this spec
15:15:53 <ganso> vponomaryov: why more time?
15:15:56 <vponomaryov> tommylikehu: you do not want to give more time for it? )
15:15:57 <bswartz> but it could probably use some more clarifications so we're all happy with it
15:16:00 <ganso> bswartz: I personally think that one is ok
15:16:02 <Zhongjun__> Currently, ensure share don't have big problem
15:16:24 <bswartz> well I hope we can all agree that we don't want to throw this on out of pike
15:16:27 <tommylikehu> vponomaryov:  I do
15:16:35 * jungleboyj sighs ... So much good talent gone from the community.
15:16:43 <gouthamr> jungleboyj: ++
15:16:57 <tommylikehu> jungleboyj:  they will be back
15:17:09 <vponomaryov> tommylikehu: are you going to sponsor them? )
15:17:15 * jungleboyj likes tommylikehu 's attitude.
15:17:20 <tommylikehu> vponomaryov:  try to help
15:17:29 <bswartz> it's a good feature to implement, and it's mostly a question of whether we want to approve the spec today or grant an extension for some time to get the spec in better shape before we merge
15:17:33 <jungleboyj> Good.  I have been trying to do the same.
15:17:53 <tommylikehu> jungleboyj:  you always:)
15:18:04 <bswartz> is anyone against granting an extension for this spec, or against the proposal altogether?
15:18:07 <ganso> bswartz: there are 2 specs regarding ensure_share
15:18:16 <markstur> extension sounds good
15:18:19 <ganso> bswartz: one part LGTM, the other needs more work
15:18:20 <bswartz> ganso: that's another good point
15:18:31 <ganso> bswartz: are we ok with merging only one of them in pike if that's the case?
15:18:32 <Zhongjun__> yes https://review.openstack.org/#/c/453553
15:18:35 <gouthamr> can we look at this one with code?
15:18:45 <bswartz> the idea this spec originally contained was split into 2 specs based on earlier review feedback
15:18:57 <ganso> gouthamr: what do you mean? require the code to merge the spec?
15:19:33 <markstur> a "go-straight-to-code" card?
15:19:52 <tbarron> Is this a situation where we are all OK with making the commitment to review and shepherd the work but we think the design may still need some changes?
15:19:56 <ganso> markstur: :O
15:20:04 <gouthamr> ganso: no, it seems like a difficult feature to completely express in the spec.. maybe things will make more sense with code to look at. so, take the this spec-merging easy until we start seeing code that works..
15:20:06 <tbarron> vponomaryov: ^^
15:20:28 <bswartz> gouthamr: I don't see any point waiting for the code -- the spec can express the idea clearly enough
15:20:42 <tbarron> bswartz: +1
15:20:44 <bswartz> if the code that follows the spec is not what we want, we still have the option to say no to that
15:20:54 <Zhongjun__> bswartz: +1
15:20:56 <ganso> gouthamr: we still can merge the spec and not merge the code if we are not happy with the code
15:20:57 <vponomaryov> tbarron: I, personnaly, would like to give time for both ensure-share related specs, infinite share and "like"-tiltering
15:21:15 <gouthamr> i agree with vponomaryov...
15:21:22 <tbarron> vponomaryov: but I was asking your *reason* for this one :D
15:21:44 <markstur> tiltering?
15:21:51 <bswartz> okay so lets' consider the group of specs
15:21:54 <gouthamr> we'll help tinker these specs into a reasonable state in review.
15:22:00 <vponomaryov> tbarron: no final agreement from my side, but idea is good in general
15:22:25 <tbarron> vponomaryov: ack.  So I agree that this one could have some more time.
15:22:26 <bswartz> vponomaryov: you're referring to https://review.openstack.org/#/c/452097/ and https://review.openstack.org/#/c/453553/ ?
15:22:30 <vponomaryov> markstur: yeahs, fingers tend to do misclicks )
15:22:41 <bswartz> why is infinite shares related to the other 2?
15:22:44 <Zhongjun__> you guys are so nice today :D
15:22:47 <jungleboyj> tiltering sounds more fun than filtering
15:23:02 * gouthamr thought he meant tinkering
15:23:02 <vponomaryov> bswartz: I refered 4 specs, and those 2 are from them, yes
15:23:05 <markstur> yep. good word.
15:23:22 <tbarron> it's not related to the ensure share specs; he's just in favor of adding more time to it too
15:23:23 * jungleboyj adds it to my lexicon
15:23:31 <bswartz> vponomaryov: oh also https://review.openstack.org/#/c/447775/
15:23:44 <markstur> jungleboyj: +1 use it wisely
15:23:49 <tbarron> so let's talk about the other two not-ensure-share-specs separately
15:24:00 <vponomaryov> tbarron: ^_^
15:24:00 <bswartz> okay well for now let's just consider the the first 2
15:24:04 <ganso> tbarron: +1
15:24:10 <vponomaryov> tbarron: you are looking directly to the core
15:24:14 <vponomaryov> )
15:24:16 <bswartz> https://review.openstack.org/#/c/447775/ and https://review.openstack.org/453553
15:24:44 <tbarron> I'm -1 on this until cinder & manila align on REST api and client cli.
15:24:45 <tbarron> The hard part of this is probably more social than technical.
15:24:45 <tbarron> Propose extending deadline on this one to match cinder's spec deadline
15:24:47 <bswartz> should we give these 2 specs another week to work out remaining issues?
15:25:03 <tbarron> ^^^ 447775 is going to take more than  one week
15:25:04 <bswartz> tbarron: please let's focus on these 2 for a moment
15:25:39 <tbarron> bswartz: sorry, got confused by your citing 447775, I was for focus myself
15:25:39 <xyang2> Cinder's spec freeze is Pike-2
15:25:41 <bswartz> tbarron: wait is your cinder comment related to these 2 specs? I'm not following I guess
15:25:58 <tbarron> bswartz: 447775 is not an ensure share spec
15:26:09 * bswartz headdesk
15:26:11 <gouthamr> bswartz: 453553 and 446494 you mean? (ensure share, update share)
15:26:13 <bswartz> tbarron: thank you
15:26:15 <tbarron> but yes, let's go there in a minute
15:26:25 * ganso is no longer confused
15:26:35 <bswartz> that was just a copypasta error on my part
15:26:50 <ganso> bswartz: hmmm copypasta
15:26:50 <bswartz> https://review.openstack.org/446494 and https://review.openstack.org/453553
15:27:02 <gouthamr> ganso: too bad, what about 4467736
15:27:08 <markstur> jungleboyj: You'll want to add copypasta to your lexicon/menu as well
15:27:27 <jungleboyj> markstur:  Yes!
15:27:35 <ganso> gouthamr: is that gerrit ID ok? doesn't work here
15:27:37 <bswartz> I'll blame spicy for that
15:27:47 * gouthamr hahahaha
15:27:56 <tbarron> couple weeks more on the two ensure-share specs is fine with me
15:28:00 <bswartz> okay so there's no relation to cinder for these 2 specs right?
15:28:04 <tbarron> ack
15:28:07 <bswartz> why more than 1 more week?
15:28:21 <tbarron> bswartz: one week is fine with me too :D
15:28:58 <bswartz> everyone okay with granting 1 week extension on these 2? any argue for more time or throw them out to queens?
15:29:09 <vponomaryov> I am ok for having deadline for specs that are related to CInder equal to Cinder's deadline and one week for other not related
15:29:25 <bswartz> vponomaryov: we'll cover those other 2 in a moment
15:29:43 <bswartz> I want to cover these in priority order and ensure_share is pretty high priority for me
15:30:00 <Zhongjun__> bswartz: thanks
15:30:07 <bswartz> I have a feeling 1 week should be enough to get these 2 wrapped up
15:30:30 <bswartz> #agreed 1 week extension for ensure share spec and enhance update spec
15:30:36 <bswartz> next up, infinite shares
15:30:43 <bswartz> #link https://review.openstack.org/452097
15:30:54 * bswartz checks he didn't make another paste error
15:30:59 <vponomaryov> requires more eyes
15:31:05 <tbarron> I'm -1 on this because we don't have a common idea/goal for what infinite shares should be.
15:31:19 <tbarron> more detailed argument in the spec review
15:31:19 <bswartz> tbarron: it was discussed in austin IIRC
15:31:23 <Zhongjun__> this spec sounds like requires more dicusstion
15:31:31 * tbarron stands by his observation
15:31:31 <bswartz> but I haven't personally reviewed this one
15:31:40 <markstur> i think there are scheduler issues
15:31:52 <markstur> not sure if they were addressed since yesterday
15:31:59 <tbarron> but the various ideas have a common thread, tracking actual share usage.
15:32:05 <tbarron> that's the first problem to solve
15:32:17 <bswartz> let me ask a higher level question -- why focus on this feature in pike? we've known about the use case since before newton
15:32:19 <markstur> how do we place non-infinite shares correctly after infinite shares are placed?
15:32:29 <tbarron> and we're not going to solve it in a week, it was pretty much a last-minute addon to this spec
15:33:03 <bswartz> markstur: IIRC in austin the idea was to treat infinite-sized shares as a completely separate thing -- different quota logic and different scheduler logic
15:33:36 <vponomaryov> иыцфкеяЖ сгккуте ызус зкщзщыуы фгещвуеусешщт ща ф ышяу
15:33:39 <markstur> the scheduler part might be easier to work out in code review
15:33:43 <tbarron> vponomaryov: exactly
15:33:43 <jungleboyj> Who!
15:33:47 <markstur> vponomaryov: Now that is a a typo!
15:33:47 <jungleboyj> Whoa!
15:33:50 <vponomaryov> bswartz: current spec proposes autodetection of a size
15:33:57 <bswartz> our options here are to push it to queens or decide to do more review focus on it and give it some more time
15:34:02 <ganso> sorry my ukranian is a little rusty
15:34:16 <jungleboyj> j/me is laughing
15:34:17 <vponomaryov> markstur: now, it is typo of language switching ))
15:34:56 <vponomaryov> ganso: it is not ukrainian, it is just letters under english ones
15:35:04 <markstur> vponomaryov: Yes. I like to see that once in a while. I pretend you are cursing.
15:35:15 <vponomaryov> or blessing
15:35:18 <vponomaryov> who knows )
15:35:22 <tommylikehu> is looking
15:35:28 <gouthamr> google always knows
15:35:29 <xyang2> markstur: right, he can curse us but we won't understand:)
15:36:02 <vponomaryov> so, one week to "infinite" share before we decide its schedule?
15:36:03 <tommylikehu> I think we should get back to our topic
15:36:09 <bswartz> I like the infinite share idea at a high level but I'm not sure it's worth spending time on right now
15:36:09 <tbarron> it seemed to me that every reviewer had a different idea of what an infinite share should be
15:37:16 <markstur> yes. making size optional has been wanted for a while -- but what that means exactly is now hitting reality
15:37:28 <xyang2> I agree we need more time reviewing this.  It's complicated
15:37:49 <bswartz> xyang2: we need more time, but do we do that during pike or during queens?
15:38:07 <vponomaryov> bswartz: decide in a week
15:38:15 <xyang2> bswartz: it doesn't sound like we can decide in a week
15:38:16 <bswartz> I guess we could give it 1 more week, and then reconsider next week
15:38:35 <bswartz> we could postpone the decision to punt if people really do want to give this a chance in pike
15:38:53 <tommylikehu> +1
15:38:57 <Zhongjun__> bswartz:  +1
15:39:01 <bswartz> okay
15:39:07 <vponomaryov> +1
15:39:26 <bswartz> #agreed reconsider infinite shares spec next week for pike inclusion
15:39:47 <bswartz> last up, Filter (tilter?) things out providing flexible way to API
15:39:54 <bswartz> #link https://review.openstack.org/#/c/447775/
15:40:06 <tbarron> this is the one coupled with tommylikehu's cinder proposal
15:40:14 <tbarron> in the last cycle tommylikehu did an awesome job working with the cinder community to get their snapshot-rollback proposal aligned with our revert-to-snapshot spec
15:40:28 <tbarron> I'd like to see a similar alignment on this one
15:40:32 <bswartz> so vponomaryov like this, but others don't, and there is interaction with the cinder version which won't be resolved until ....
15:41:00 <vponomaryov> bswartz: other don't like absense of compatibility with Cinder
15:41:01 <tommylikehu> tbarron:  thanks
15:41:04 <bswartz> June 7th, 88 weeks from now
15:41:06 <Zhongjun__> because I change it as vponomaryov's method.
15:41:09 <bswartz> 8* weeks
15:41:14 <vponomaryov> bswartz: mostly, not considering small concerns )
15:41:23 <Zhongjun__> :)
15:41:39 <vponomaryov> how many weeks? ))
15:41:53 <gouthamr> 88
15:42:03 <bswartz> are some poeple suggesting we leave this open until the cinder issues are sorted out?
15:42:06 <xyang2> the one in Cinder will be built upon griffith's generic filter spec
15:42:12 <vponomaryov> 8 - is infinite value flipped for 90 degrees )
15:42:16 <tbarron> Do we really want to end up with two very different CLI and REST api for essentially the same kind of thing?
15:42:18 <bswartz> do we need a cross-project effort to synchronize the 2 specs?
15:42:37 <tbarron> And then, when we *do* go to OSC ...
15:42:43 <bswartz> 88 mph is the speed you need to travel to go back in time and not miss the spec merge deadline
15:43:01 <tommylikehu> I reckon cinder will not agree to have the new filter argument while keep the exsiting ones
15:43:12 <xyang2> do we also want generic filter in manila?
15:43:23 <tommylikehu> xyang2:  that's the point
15:43:26 <vponomaryov> xyang2: we haven't discussed it before
15:43:36 <gouthamr> would tommylikehu like to propose it to manila
15:43:36 <jungleboyj> tommylikehu:  Great Scott!  That was brilliant!
15:43:42 <tbarron> xyang2: my question is, do we have any good reason for not aligning the two projects?
15:43:47 <Zhongjun__> Could we discuss it now?
15:43:57 <xyang2> https://review.openstack.org/#/c/441516/
15:44:11 <xyang2> tbarron: aligning the two is of course good
15:44:23 <bswartz> my opinion is that it's a good idea to synchronize with other projects in areas like this where there's no a strong reason to do our own thing
15:44:37 <tommylikehu> gouthamr:  I think  I can if we would like to
15:44:40 <gouthamr> that spec is still not cognizant of "like" filtering for select fields
15:44:49 <bswartz> however for the same reason I don't see why we would want to be leading here, why not follow after others have done the initial hard work?
15:45:08 <tbarron> gouthamr: and yesterday's cinder meeting said that it would become so, with tommylikehu's help
15:45:11 <markstur> following cinder example?  Is this still the manila meeting?
15:45:21 <xyang2> :)
15:45:23 <gouthamr> tommylikehu: if you can roll it into a spec on our end, i would support it
15:45:32 <tbarron> markstur: I'm not saying just do what cinder does, I'm saying *lead*
15:45:46 <bswartz> and if our intent is to follow what cinder does, then why not postpone the whole effort until queens so we can see what happens in cinder?
15:45:56 <tbarron> do the right thing for openstack
15:45:57 <tommylikehu> gouthamr:  a new spec and both two involoved?
15:46:02 <bswartz> interested parties could contribute to the cinder spec review
15:46:10 <vponomaryov> bswartz: why follow? do right thing should be our goal
15:46:21 <tommylikehu> vponomaryov: lol
15:46:26 <bswartz> vponomaryov: we have to pick our battles
15:46:45 <bswartz> I'd rather lead in areas where we're likely to have the best ideas or unique circumstances
15:46:51 <xyang2> we usually blame cinder for bad decisions:)
15:46:59 <bswartz> REST API filtering is a rather boring technical problem IMO
15:47:04 <tbarron> bswartz: would you have a problem with interested parties participating in the cinder review and then posting a manila implementation if we agree to that?
15:47:09 <ganso> xyang2: that's our oldest tradition :)
15:47:13 <gouthamr> tommylikehu: ``manila list --filters name=xyz`` ``manila list --filters name=~xyz``
15:47:17 <xyang2> ganso: :)
15:47:39 <tommylikehu> gouthamr:  vponomaryov  doesn't like it
15:47:46 <gouthamr> may i ask why?
15:47:54 <bswartz> tbarron: I like that approach except why hurry to do it in pike? why not copy the implementation in queens after it has a bit a soak time?
15:47:59 <gouthamr> anyway, we can discuss that in review...
15:48:03 * tbarron wants to keep the manila people involved and participating, but not just talking among themselves.
15:48:24 <vponomaryov> tbarron: soooo communicative person )))
15:48:38 <tommylikehu> tbarron that's your goal, we are a big family
15:48:42 * jungleboyj likes tbarron speaking his mind!
15:49:15 <tbarron> bswartz: that's what I actually proposed first (waiting till queens) but I realized that with Zhongjun__ and tommylikehu both working on the same problem we have a chance to align here.
15:49:51 <vponomaryov> tbarron: it does not answer question why we want it in P
15:49:59 <bswartz> okay
15:50:12 <bswartz> so the proposal is to just not have a manila spec and follow the cinder spec
15:50:20 <tbarron> vponomaryov: because it motivates people to keep working on the right design
15:50:30 <bswartz> treat the cinder spec as if it were a crossproject spec
15:50:48 <tbarron> bswartz: the sqlalchemy part will have to be different though
15:50:50 <bswartz> that raises the question of why this wasn't a crossproject spec to begin with
15:51:02 <bswartz> don't we have a cross project specs process?
15:51:07 <tbarron> it's the REST and client & ui that should converge
15:51:33 <gouthamr> generic and "LIKE" filtering has come up in api-wg in the past... we haven't had someone take on that effort...
15:51:38 * tbarron isn't sure that it has historically been terribly effective
15:51:50 <bswartz> tbarron: that argues for a mini-spec that references the cinder spec and only describes the manila-specific differences in the implementation
15:52:00 <tbarron> bswartz: +1
15:52:10 <bswartz> tbarron: I'm glad you said it not me
15:52:13 <xyang2> I don't know the status but I don't know if there's a lot going on in cross-project specs: https://review.openstack.org/#/q/status:open+openstack/openstack-specs
15:52:16 <bswartz> ;-)
15:52:23 <gouthamr> from cinder_specs import generic_filtering_for_the_win
15:52:29 <bswartz> I would have been less diplomatic
15:52:49 <jungleboyj> :-)
15:52:52 <vponomaryov> gouthamr: generic tiltering )
15:53:00 <tommylikehu> maybe we should start from refactor our sqlalchemy apis
15:53:02 <jungleboyj> vponomaryov:  ++
15:53:04 <bswartz> okay so how about this
15:53:07 <gouthamr> yes, pylint would have caught that
15:53:34 <bswartz> let's modify our spec to refer to the cinder spec for the parts that we want to be in common, and only include the manila specific detail in our own spec
15:53:42 <gouthamr> tommylikehu: ++ that's also been spoken about here in the past
15:54:16 <tommylikehu> gouthamr:  and the conclusion?
15:54:21 <bswartz> let's try to merge that in the next week, then it's up to tommylikehu and Zhongjun__ to implement it in pike if they wish or wait until queens
15:54:40 <bswartz> we'll use both specs as a reference for the reason
15:54:50 <bswartz> we'll use both specs as a reference for the feature
15:55:26 <gouthamr> reasonable future
15:55:27 <tbarron> +1 from me
15:55:32 <tommylikehu> bswartz:  great
15:55:37 <Zhongjun__> bswartz:  sure, I'd like to implement it in pike
15:55:45 <gouthamr> +1
15:55:50 <gouthamr> thanks Zhongjun__
15:55:50 <bswartz> anyone interested in influencing the design of the REST/CLI portions of the design should provide feedback to the cinder spec
15:56:22 <bswartz> this means we have 4 specs with extension until next week
15:56:37 <bswartz> all of them owned by Zhongjun__
15:57:01 <bswartz> I hope you can find the time to get them all updated Zhongjun__!
15:57:09 <bswartz> and unfortunately we used all our time
15:57:13 <bswartz> tbarron you had some agenda items
15:57:29 <tbarron> I'll just mention them in #openstack-manila in a moment
15:57:30 <tommylikehu> move to manila channel..
15:57:31 <bswartz> any of them need urgent attention today?
15:57:35 <Zhongjun__> bswartz: ok, I alway update them
15:57:58 <bswartz> okay for the record before we close the meeting
15:58:09 <bswartz> Spec Validation
15:58:14 <bswartz> #link https://review.openstack.org/456398
15:58:20 <bswartz> Add blockdiag diagram family capability to manila specs
15:58:24 <bswartz> #link https://review.openstack.org/456404
15:58:34 <bswartz> Stop Translating Log messages
15:58:38 <bswartz> #link https://review.openstack.org/#/c/452189
15:58:43 <bswartz> #topic open discussion
15:59:03 <bswartz> if the above 3 need discussion we can do it in the manila channel, or next week
15:59:08 <bswartz> anything else before we wrap up this meeting?
15:59:50 <bswartz> okay thanks all
15:59:58 <bswartz> #endmeeting