15:00:40 <bswartz> #startmeeting manila
15:00:41 <openstack> Meeting started Thu May 18 15:00:40 2017 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:45 <openstack> The meeting name has been set to 'manila'
15:00:48 <bswartz> hello all
15:00:52 <gouthamr> hello o/
15:00:52 <vponomaryov> hello
15:00:54 <toabctl> hi
15:01:11 <ganso> hello
15:01:29 <bswartz> tbarron markstur xyang2 cknight: courtesy ping
15:01:30 <cknight> Hi
15:01:37 <markstur> hi
15:01:38 <zhongjun> Hi
15:01:48 * bswartz remembers that tbarron is out on vacation...
15:01:54 <jungleboyj> o/
15:02:25 <bswartz> welcome back from summit everyone
15:02:26 <xyang2> hi
15:02:34 <bswartz> I hope you all enjoyed boston
15:02:38 * jungleboyj is still recovering
15:02:45 <bswartz> especially you xyang2
15:02:57 <xyang2> bswartz: short travel:)
15:03:07 <vkmc> o/
15:03:10 <vkmc> hey hey
15:03:30 <markstur> xyang2: hosting a summit must be a lot of work
15:03:35 <bswartz> so I only have one topic on the agenda today, and it's an urgent one
15:03:40 <bswartz> #agenda https://wiki.openstack.org/wiki/Manila/Meetings
15:03:44 <xyang2> markstur: right:)
15:03:48 <jungleboyj> markstur:  Not for xyang2  , she can do it all!
15:03:58 <bswartz> #topic PTG involvement
15:04:03 <bswartz> #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/116921.html
15:04:04 <xyang2> jungleboyj: I'll just take all the credit:)
15:04:10 <bswartz> so I don't know how many of you saw my ML thread
15:04:31 <bswartz> only got 2 responses on the list
15:04:39 <bswartz> if you haven't seen it please read it now
15:04:55 <bswartz> we need to decide about the denver PTG today
15:05:13 <bswartz> diablo_rojo is impatient to hear our response
15:05:19 <tommylikehu> Will manila cancel the next ptg?
15:05:53 <bswartz> tommylikehu: it's up to the community
15:06:51 <bswartz> as I said in my ML post, I lean toward making the Manila PTG a virtual event, and not requiring travel to Denver
15:06:53 <diablo_rojo> bswartz, not impatient but eager :)
15:07:02 <markstur> virtual is better for me, but I don't want that to get in the way of those that can meet live
15:07:14 <bswartz> diablo_rojo: I was exaggerating for effect :-)
15:07:20 <markstur> careful what you say diablo_rojo is listening
15:07:27 <diablo_rojo> markstur, :)
15:07:27 <markstur> :)
15:07:34 <diablo_rojo> easier to listen when my name is mentioned
15:07:48 <bswartz> yeah I knew she was in the channel and I wanted her to get the ping
15:08:11 <bswartz> so the big downside to doing a virtual PTG is the timezone issue
15:08:28 <tommylikehu> bswartz:  has any other project already lead the way to have a virtual one?
15:08:40 <ganso> it seems the biggest problem for this next (PTG + Summit) combo is the Summit, not the PTG
15:09:18 <bswartz> in past events we chose to hold them from UTC 1200-2000
15:09:34 <diablo_rojo> If it helps- we will have TSP for the PTG again and will continue to have it for the Summit/Forum as well.
15:10:03 <bswartz> during those the most affected team member was markstur, but he was able to wake up early for those 2 days
15:10:12 <zhongjun> Virtual is also better for me, Meybe we have less chance to go out in the next half year
15:10:33 * dustins sneaks in to the back of the classroom and takes a seat
15:10:43 <bswartz> however I worry that people in Asia/Pacific would be completely unable to attend due to that being the middle of the night for them
15:11:37 <xyang1> everyone still here?
15:11:45 <bswartz> diablo_rojo: some manila team members attempted to use TSP for Atlanta and all got turned down IIRC
15:11:46 <zhongjun> Yes
15:12:02 <ganso> yes
15:12:28 <bswartz> I'm not sure if manila is viewed as a "less important" project or if people just got unlucky in the lottery
15:12:46 <dustins> Or both :(
15:12:58 <bswartz> TSP is great but I don't think we should rely on it as a community because it's hit or miss
15:13:26 <vponomaryov> only /me doesn't know what is TSP?
15:13:34 <tommylikehu> vpo
15:13:45 <xyang1> I assume that means travel support program
15:13:54 <vponomaryov> ooooh
15:14:00 <zhongjun> What is TSP
15:14:02 <diablo_rojo> bswartz, :/  We tried to give TSP first to PTLs and then we balanced the numbers based on registration for individual projects, so if there were a lot of Manila people registered, we gave them less priority.
15:14:09 <vponomaryov> xyang1: ty )
15:14:12 <diablo_rojo> zhongjun, Travel Support Program
15:14:13 <jungleboyj> vponomaryov:  Yes, the travel support program from the foundation
15:14:16 <bswartz> so I'm particularly intersted to hear from zhongjun and tommylikehu
15:14:22 <jungleboyj> For those who can't get company funding.
15:14:44 <bswartz> if we held a virtual event and kept the times we have in the past (UTC 1200-2000) would you be able to attend or would that make it impossible?
15:15:18 <tommylikehu> zhongjun and I are both not sure whether we could get the chance to go aboard
15:15:26 <bswartz> we of course could discuss a different time slot that favored Asia/Pacific, but then the European members would have problems
15:15:46 <bswartz> there is no way to do a virtual event that works for the whole world
15:16:12 <zhongjun> We have less chance to go aboard
15:16:27 <vkmc> we could try to do some sort of time slots pick and see in which slot the majority can make it
15:16:31 <vkmc> it's far from ideal... but...
15:16:34 <bswartz> okay so if we join the physical PTG in Denver then you might be excluded anyways?
15:16:51 <bswartz> vkmc: we will cross the bridge when we get to it
15:16:54 <tommylikehu> maybe
15:17:15 <vkmc> if we do the physical ptg and people cannot get funding to attend, is the same as if we cannot find time slots for virtual ptg
15:17:54 <bswartz> okay
15:17:55 <ganso> vkmc: yea it will end up being the same as virtual
15:18:19 <tommylikehu> we could do the physical ptg and set up the webex as what we did in atlanta
15:18:24 <vponomaryov> why not consider virtual as plan B?
15:18:33 <bswartz> so is there anyone that prefers the Denver PTG over a virtual event?
15:18:34 <vkmc> the only difference is that with the virtual ptg we can have recordings of the sessions in an easier way as if we do a physical ptg
15:19:07 <bswartz> tommylikehu: yes if we did go to Denver we'd setup a conference to try to help remote attendees join (and also to record the sessions)
15:19:27 <bswartz> but recordings of physical meetings tend to miss a lot of the details
15:19:38 <bswartz> recordings of virtual meetings capture everything
15:19:38 <vkmc> ^ that
15:20:07 <tommylikehu> bswartz:  that make sense
15:20:23 <bswartz> not that I think anybody really watches 16 hours of us talking
15:20:53 <bswartz> still there have been cases where we wanted to go back and listed to select parts of a recording if we forgot what was discussed
15:21:15 <vponomaryov> just need someone volunteering to be stenographers ))
15:21:27 <bswartz> so I'm still waiting to hear from someone who prefers a physical meeting over a virtual meeting
15:21:38 <bswartz> if nobody does, then I think our decision is easy
15:22:09 <bswartz> the benefits of not having to fight for time at the PTG are pretty big, because those of us who want to do crossproject stuff can do it and not be stressed out in denver
15:22:35 <markstur> denver is a no-stress zone
15:22:40 <bswartz> and we can meet face to face in sydney and drink whatever kind of beer they have in Australia
15:22:45 <dustins> I like a physical meeting because it allows us to talk with other contributors in other projects that are in the same place
15:22:56 <tommylikehu> sydney?
15:23:02 <dustins> But, on the other hand, they can just join our virtual meeting
15:23:02 <tommylikehu> next summit?
15:23:05 <jungleboyj> markstur:  :-)
15:23:40 <zhongjun> We'd like to attend physical meeting if our company allows us to do it:)
15:23:43 <ganso> bswartz: ok, this is the part that I don't understand completely. How does choosing the PTG to be virtual or physical relate to us doing an "official" Manila Forum at Sydney?
15:24:26 <diablo_rojo> bswartz, you shouldn't have the same scheduling conflicts as with Atlanta.
15:25:01 <vkmc> dustins, agree with that... it's harder though, people won't join a virtual meeting as easy as they go into a room... it's less casual
15:25:04 <bswartz> ganso: it doesn't -- I'm just saying that it's likely some of us will be in sydney due to all the customers and salespeople and loose budgets that go along with those things
15:25:07 <diablo_rojo> Not sure if you saw ttx 's email to the dev list today but we are working on a new organization and are listening to feedback on optimizing the layout.
15:25:37 <tommylikehu> I think different company has different strategies, for our company, huawei  would rather give us the chance the attend the ptg not the summit.
15:25:38 <bswartz> diablo_rojo: link?
15:25:42 <dustins> vkmc: Yeah, I find it easier to stay focused when we're all together in a room
15:26:35 <vponomaryov> bswartz: "salespeople" point is related mostly to manager positions, so, I think, you are minority in this case having it as an argument
15:26:40 <bswartz> okay so I'm hearing a few votes in favor of physical PTG
15:26:47 <diablo_rojo> bswartz, http://lists.openstack.org/pipermail/openstack-dev/2017-May/116971.html
15:26:50 <bswartz> vponomaryov: perhaps
15:27:19 <bswartz> diablo_rojo: ty
15:27:26 <vponomaryov> bswartz: physical presence on PTC is really interesting from other devs presence
15:27:28 <xyang1> diablo_rojo: so that means cinder's PTG meeting time in Denver will be shorter than in Atlanta?
15:28:20 <jungleboyj> xyang1:  That is the major scheduling conflict.  :-(
15:28:41 <bswartz> cinder didn't even use their whole time in Atlanta -- the 3rd day was slow and ended before lunch
15:29:06 <jungleboyj> bswartz:  We were just that efficient.  ;-)
15:29:11 <diablo_rojo> xyang1, the idea was to have the conflict teams in different parts of the week so Manila M&T with a little spillover into W if needed and Cinder be W-F
15:29:13 <bswartz> I want to get to the point where we can vote on this today
15:29:23 <tommylikehu> it looks like the real decision here is which one should we use as a manila ptg, summit or real ptg.
15:29:24 <bswartz> but I want to get all the opinion and facts out in the open first
15:29:56 <dustins> tommylikehu: I know that my management won't be too happy about sending everyone but Manila folks to the PTG and then the Manila folks to the summit
15:29:57 <bswartz> jungleboyj: I think you're joking but that's actually an important point
15:30:24 <jungleboyj> bswartz:  Only a little joking.  We were able to tear through stuff there.
15:30:41 <bswartz> dustins: summit attendence wouldn't be required by this community
15:30:58 <bswartz> but the foundation seems to have this idea that devs should also attend summits
15:31:25 <vponomaryov> "should"? ))
15:31:34 <dustins> So long as there are PTGs, I don't think I'll ever be at a summit unless I'm presenting :(
15:31:58 <dustins> So if we don't do the physical PTGs, I'd likely never get to see anyone in the community face-to-face
15:32:01 <tommylikehu> dustins: +1
15:32:19 <vkmc> that's a good point dustins
15:33:07 <dustins> Since there's no point in my going to the PTG if no Manila folks are there, and I won't go to the summits because it's hard to justify for engineers
15:33:17 <vponomaryov> bswartz: especially considering place where will be next summit. Manila team will gain more participating om PTG, IMHO
15:33:28 <bswartz> vponomaryov: that was the source of my discontentment after Atlanta PTG
15:33:40 <ganso> dustins: unless we create an actual need for us to go to the summit, like doing official Manila Forum sessions there, like in design summit, no?
15:33:40 <dustins> Yeah, there's a 0% chance that I get to go to Sydney in the fall :)
15:34:02 <dustins> It'd be very difficult to justify
15:34:03 <tommylikehu> dustins:  prepare for a persentation
15:34:12 <jungleboyj> :-)
15:34:17 <bswartz> the foundation is sending signals that we're expected to attend all 4 events each year and I think it's unrealistic for most of us
15:34:20 <gouthamr> ganso: yes, but unless you attend the PTG in person, you don't get the free ATC pass to the summit :P
15:34:35 <bswartz> so I'm trying to figure out what is realistic
15:34:37 <ganso> gouthamr: oh right, forgot about that
15:34:40 <jungleboyj> gouthamr:  Good point.
15:34:47 <dustins> But the ATC pass only covers a small amount of the total travel expense for a Summit
15:34:53 <vponomaryov> gouthamr: pass much cheaper than attendance of summit
15:35:17 <bswartz> vponomaryov: not anymore -- have you seen how high they raised the price to attend summit?
15:35:25 <gouthamr> true... but having to pay that much is probably more reason to not go to summit :(
15:35:31 <tommylikehu> bswartz:  how much
15:35:44 <ganso> tommylikehu: $1200 dollars
15:35:50 <bswartz> IIRC Boston was $1200
15:35:55 <zhongjun> Wow
15:35:56 <gouthamr> where you meet real users and operators and hear more war stories than you do on irc channels or mailing lists
15:36:03 <vponomaryov> bswartz: it is cheaper anyway
15:36:35 <gouthamr> i really wish the PTG was right before summit or right after it so we didn't have this problem at all
15:36:45 <bswartz> okay so what if we ignore sydney and fast forward to vancouver
15:36:52 <gouthamr> the only problem then would be a looong hiatus from home
15:37:13 <bswartz> are those of you who think you can't attend summits also thinking vancouver will be impossible?
15:37:14 <ttx> and frankly, if they don't want to come, they just should not :)
15:37:50 <ttx> the Foundation is not focring anyone
15:38:03 <dustins> bswartz: It's distinctly possible, I'll have to ask my management chain to see
15:38:32 <ganso> bswartz: I guess for those that could not attend Boston, why would they be able to attend Vancouver?
15:38:46 <ttx> I mean, if a team prefers to skip the PTG, it's OK too
15:38:52 <bswartz> so it's possible that maybe sydney is a special case where people won't be able to attend, but afterwards the summit could be a viable choice
15:39:05 <dustins> Yeah, I wasn't able to go to Boston because I'd gone to Atlanta
15:39:17 <bswartz> ttx: what if a team wants to get space at the summit to conduct a PTG-like event for just that team?
15:39:25 <gouthamr> hey, unless the one after is in Berlin :)
15:39:25 <gouthamr> or someplace
15:39:45 <bswartz> gouthamr: Berlin is a cheap flight I'm sure
15:39:46 <ttx> bswartz: we had hacking rooms in Boston, I expect them to still be around in next events
15:40:11 <ganso> bswartz: I still think PTG + Vancouver will not be viable for most people, unless speakers and TSP, but we cannot depend on those
15:40:11 <bswartz> ttx: yes I checked those out -- but is something more formal a possibility?
15:40:29 <gouthamr> ttx: what are the chances we can get the ATC discount if we didn't have a physical meeting at the PTG?
15:40:35 <ttx> bswartz: depend wh
15:40:37 <ttx> err
15:40:42 <ttx> depends what you mean by "formal"
15:40:55 <bswartz> I feel like if the summit has no formal place for teams to meet up, then we're being pushed to go to the PTG or to hold a virtual event
15:41:00 <ttx> gouthamr: low. The idea is to keep it cheap for people going to 4 events per year
15:41:03 <bswartz> ttx: I mean a reserved room
15:41:18 <ttx> (and then push money to the travel support program)
15:41:25 <gouthamr> oh.. didn't think of it that way..
15:41:39 <ttx> bswartz: you could reserve the hacking rooms in Boston.
15:41:51 <bswartz> ttx: okay good to know
15:42:03 <ttx> was in emails, but yeah, was easy to miss
15:43:23 <ttx> bswartz: the Forum is definitely encouraging people to talk to each other rather than encouraging holing up in a hacking room with your team, yes
15:43:33 <zhongjun> Is there a chance that openstack organization will pay all travel money for someone who want to attend PTG?
15:43:33 <ttx> since te latter can be done in cheaper venues and locations
15:43:56 <tommylikehu> zhongjun: only you get the lucky
15:44:19 <zhongjun> tommylikehu: I wish
15:44:30 <bswartz> okay so our decision is complicated because what we decide for Queens might be different from Rocky
15:44:37 <ttx> zhongjun: we have a travel support program. At PTGs the travel support program prioritizes PTLs first, then asks them to give us an idea of who is necessary for discussions
15:44:38 <bswartz> but we need to decide on Queens today
15:44:52 <smcginnis> zhongjun: A little out of date: https://wiki.openstack.org/wiki/Travel_Support_Program
15:45:02 <ttx> in Atlanta we could fund travel for ~20people
15:45:20 <bswartz> so I'll open up a vote and we'll see where people stand
15:45:26 <vponomaryov> amount of PTLs is bigger than 20
15:45:44 <ttx> vponomaryov: thankfully most of them had support from their employer
15:45:51 <zhongjun> thx,smcginnis:thanks
15:45:52 <vkmc> sounds like.. ptgs are more focused per team event, summits are more cross-project diverse-profiles event
15:45:59 <diablo_rojo> vponomaryov, true, but not all projects go and not all need our help :)
15:46:22 <bswartz> #startvote Should Manila attend the PTG in Denver or hold a virtual PTG for Queens? denver, virtual
15:46:23 <openstack> Begin voting on: Should Manila attend the PTG in Denver or hold a virtual PTG for Queens? Valid vote options are denver, virtual.
15:46:24 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:46:37 <ganso> #vote virtual
15:46:38 <vponomaryov> #vote denver
15:46:43 <vkmc> #vote virtual
15:46:43 <xyang1> #vote virtual
15:46:49 <gouthamr> #vote denver
15:46:55 <tommylikehu> #vote denver
15:46:59 <bswartz> #vote virtual
15:47:06 <dustins> #vote denver
15:47:08 <xyang1> vponomaryov: are you going to Denver?
15:47:12 <zhongjun> #vote virtual
15:47:35 <xyang1> vponomaryov: I thought you will start a new adventure by then
15:47:35 <bswartz> too bad tbarron isn't here and I don't know his vote
15:47:44 <tommylikehu> xyang1: same question
15:47:58 <vponomaryov> xyang1: so, I should not vote because of it?
15:47:59 <markstur> #vote virtual
15:48:04 <bswartz> 30 more seconds for voting
15:48:05 * markstur was disctracted sorry
15:48:18 <xyang1> vponomaryov: you have all the right to vote!
15:48:18 <gouthamr> xyang1: his new adventure may be an openstack project and he might come hang with his old friends
15:48:28 <xyang1> :)
15:48:37 <bswartz> #endvote
15:48:38 <openstack> Voted on "Should Manila attend the PTG in Denver or hold a virtual PTG for Queens?" Results are
15:48:39 <openstack> denver (4): vponomaryov, dustins, tommylikehu, gouthamr
15:48:40 <openstack> virtual (6): bswartz, markstur, ganso, xyang1, zhongjun, vkmc
15:48:56 <bswartz> hmm not as clear cut a result as I hoped for
15:49:03 <xyang1> vponomaryov: and looking forward to seeing you in Denver
15:49:14 <markstur> I'd like to assume tbarron would vote denver
15:49:19 <smcginnis> bswartz: If you slice it by cores (and PTL), that probably needs to have more weight.
15:49:24 <markstur> and yes it is not clear
15:50:03 <markstur> @smcginnis what's my weight got to do with it?
15:50:09 <gouthamr> :'D
15:50:11 <smcginnis> Hah
15:50:11 <ganso> smcginnis: that would reduce 2 voters for each option, the result would end up being the same
15:50:46 <vponomaryov> ganso: consider cknight and tbarron
15:50:47 <bswartz> well there's slight edge for virtual, so I think we should follow the will of the people
15:50:48 <smcginnis> ganso: Well, just saying if half the cores and the PTL are not able or unwilling to go in person, that's important.
15:51:00 <bswartz> if you slice it by core team members it's still in favor of virtual
15:51:38 <bswartz> so we will plan a virtual event for queens
15:51:47 <bswartz> some of us will likely end up in denver for other reasons
15:51:56 <bswartz> and we can reassess for Rocky what we'd like to do
15:52:39 <tommylikehu> smcginnis:  how about cinder teams:)
15:52:45 <bswartz> diablo_rojo, ttx: thanks for your willingness to accomodate us in Denver but it appears it won't be necessary
15:53:03 <ttx> bswartz: That's fine! Moar space for others :)
15:53:04 <smcginnis> tommylikehu: Cinder will be in Denver for sure.
15:53:20 <bswartz> so the next decisions we'll need to make are which week we'll do our virtual PTG and which timeslot
15:53:22 <diablo_rojo> bswartz, no problem :)
15:53:31 <bswartz> but that doesn't need to happen today
15:53:51 <bswartz> for the record:
15:53:55 <bswartz> #agreed Manila Queens PTG will be virtual
15:54:02 <bswartz> #topic open discussion
15:54:03 <markstur> and "viral"
15:54:08 <bswartz> anything else today?
15:54:15 <gouthamr> bswartz diablo_rojo: i attended a couple project onboarding sessions. i think that's a great thing to formalize! :) can we try that in Sydney (i can attend virtually :P)
15:54:30 <gouthamr> ^^ manila onboarding i mean.. we didn't have one in Boston
15:55:06 <bswartz> I didn't manage to attend any of those onboarding sessions but I'm certainly curious about them
15:55:08 <xyang1> jungleboyj, smcginnis: the cinder on-boarding is great!
15:55:19 <jungleboyj> gouthamr:  That did seem to be popular.
15:55:24 <jungleboyj> xyang1:  Thank you!
15:55:26 <gouthamr> see, all the cool kids had it :)
15:55:26 <diablo_rojo> gouthamr, I imagine we will do the signup for those in a similar way- smaller projects that need more new devs get first dibs and then when I open it up to everyone else its first come first serve
15:55:32 <smcginnis> xyang1: +1
15:55:42 <diablo_rojo> They did seem to go over well which made me very happy :)
15:55:52 <gouthamr> diablo_rojo: :) thanks! we're small-ish and we're always welcoming..
15:55:58 <smcginnis> Some more than others, but I think there were some very useful ones.
15:56:48 <bswartz> gouthamr: did any of the projects have hazing rituals for newcomers?
15:56:57 <xyang1> :)
15:57:00 <gouthamr> but we're also kinda scary for new developers... too much esoteric tribal knowledge that only a few possess...
15:57:11 <dustins> gouthamr: +1
15:57:20 <xyang1> bswartz: maybe we should start that in manila:)
15:57:36 <ganso> gouthamr: starting with "DHSS", right? xD
15:57:36 <bswartz> xyang1: I assumed they did that in nova already....
15:57:39 <gouthamr> hahaha
15:57:40 <dustins> I've got a new QE on Manila and I'm trying to distill the last three years of knowledge in a single document :D
15:57:57 <gouthamr> dustins: you're a hero
15:57:58 <ganso> vponomaryov: and 24-hour rules :P
15:58:04 <dustins> consequently hi raissa :)
15:58:18 <raissa> do/
15:58:21 <bswartz> okay I think we can wrap up this meeting
15:58:22 <raissa> *o/
15:58:30 <gouthamr> hey raissa... welcome!
15:58:36 <raissa> thnaks :)
15:58:42 <bswartz> thanks all for helping me make this decision
15:59:03 <bswartz> #endmeeting